No se encuentran recursos de mapeo en el idioma seleccionado.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar un grupo de VRRP en el modo de equilibrio de carga

Ejemplo para configurar un grupo de VRRP en el modo de equilibrio de carga

Descripción general del equilibrio de carga de VRRP

En el modo de equilibrio de carga, varios dispositivos transmiten tráfico de servicio simultáneamente. Por lo tanto, el modo de equilibrio de carga requiere dos o más routers virtuales. Cada router virtual contiene un router Master y varios Backups, y el Master en cada router virtual puede ser diferente.

El modo de equilibrio de carga difiere del modo activo/standby de las siguientes maneras:
  • Se deben crear múltiples grupos VRRP, y el Master en cada grupo VRRP puede ser diferente.
  • Un dispositivo VRRP puede unir múltiples grupos VRRP y tiene diferentes prioridades en diferentes grupos VRRP.

Notas de configuración

  • En V200R003 y versiones anteriores, VRRP se puede configurar solo en la interfaz VLANIF.

    En V200R005 y versiones posteriores, VRRP se puede configurar en la interfaz VLANIF y en la interfaz Ethernet de capa 3.

    Para un switch modular en V200R006 y versiones posteriores, VRRP se puede configurar en la interfaz VLANIF, interfaz Ethernet de capa 3, subinterfaz de terminación Dot1q y subinterfaz de terminación QinQ.

    Para un switch fijo en V200R009 y versiones posteriores, VRRP se puede configurar en la interfaz VLANIF, interfaz Ethernet de capa 3 y subinterfaz.

  • Asegúrese de que cada dispositivo del mismo grupo VRRP esté configurado con el mismo VRID.
  • Los grupos VRRP deben usar diferentes direcciones IP virtuales. La dirección IP virtual de un grupo VRRP debe estar en el mismo segmento de red que la dirección IP de la interfaz donde está configurado el grupo VRRP.

  • A lo siguiente se describen los Modelos de productos y versiones aplicables.
    Tabla 10-3  Modelos de productos y versiones aplicables

    Producto

    Modelo del Producto

    Versión del software

    S2300

    S2320EI

    V200R011C10, V200R012C00

    S3300

    S3300EI

    V100R006C05

    S3300HI

    V200R001C00

    S5300

    S5320LI

    V200R010C00, V200R011C10, V200R012C00

    S5320SI

    V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5300EI

    V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5300HI

    V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5310EI

    V200R002C00, V200R003C00, V200R005(C00&C02)

    S5320EI

    V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5320HI

    V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5330SI

    V200R011C10, V200R012C00

    S6300

    S6300EI

    V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S6320EI

    V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S6320SI

    V200R011C10, V200R012C00

    S6320HI

    V200R012C00

    S9300

    S9303, S9306 y S9312

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S9300

    S9310

    V200R010C00, V200R011C10, V200R012C00

    S9300X

    S9310X

    V200R010C00, V200R011C10, V200R012C00

    S9300E

    S9303E, S9306E y S9312E

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    NOTA:
    Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de redes

En Figura 10-3, HostA y HostC son dual-homed a SwitchA y SwitchB a través del switch. Para reducir la carga de tráfico de datos en SwitchA, HostA utiliza SwitchA como el gateway predeterminado para conectarse a Internet, y SwitchB funciona como el gateway de reserva. HostC usa SwitchB como el gateway predeterminado para conectarse a Internet, y SwitchA funciona como gateway de reserva. Esto implementa el equilibrio de carga.

NOTA:

En este escenario, para evitar bucles, asegúrese de que todas las interfaces conectadas tengan STP deshabilitado y las interfaces conectadas se eliminen de la VLAN 1. Si STP está habilitado y las interfaces VLANIF de switches se usan para construir una red de anillo de Capa 3, una interfaz en la red va a ser bloqueado. Como resultado, los servicios de Capa 3 en la red no pueden ejecutarse normalmente.

Figura 10-3  Diagrama de redes para configurar un grupo VRRP en modo de equilibrio de carga

Hoja de ruta de configuración

Un grupo VRRP en modo de equilibrio de carga se usa para implementar el equilibrio de carga. La hoja de ruta de la configuración es la siguiente:

  1. Asigne una dirección IP a cada interfaz y configure un protocolo de enrutamiento para garantizar la conectividad de la red.
  2. Cree los grupos 1 y 2 de VRRP en SwitchA y SwitchB. En el grupo 1 de VRRP, configure SwitchA como Master y SwitchB como Backup. En el grupo 2 de VRRP, configure SwitchB como el Master y SwitchA como el Backup.

Procedimiento

  1. Configure los dispositivos para garantizar la conectividad de la red.

    # Asigne una dirección IP a cada interfaz. SwitchA se usa como un ejemplo. Las configuraciones de SwitchB y SwitchC son similares a la configuración de SwitchA, y no se mencionan aquí. Para más detalles, vea los archivos de configuración.

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan batch 100 300 500
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type trunk
    [SwitchA-GigabitEthernet1/0/1] port trunk allow-pass vlan 300
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type trunk
    [SwitchA-GigabitEthernet1/0/2] port trunk allow-pass vlan 100 500
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] ip address 10.1.10.1 24
    [SwitchA-Vlanif100] quit
    [SwitchA] interface vlanif 500
    [SwitchA-Vlanif500] ip address 10.1.50.1 24
    [SwitchA-Vlanif500] quit
    [SwitchA] interface vlanif 300
    [SwitchA-Vlanif300] ip address 192.168.1.1 24
    [SwitchA-Vlanif300] quit

    # Configure el reenvío de Capa 2 en el switch.

    <Quidway> system-view
    [Quidway] sysname Switch
    [Switch] vlan batch 100 500
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type trunk
    [Switch-GigabitEthernet1/0/1] port trunk allow-pass vlan 100 500
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type trunk
    [Switch-GigabitEthernet1/0/2] port trunk allow-pass vlan 100 500
    [Switch-GigabitEthernet1/0/2] quit
    

    # Configure OSPF en SwitchA, SwitchB, y SwitchC. SwitchA se usa como un ejemplo. Las configuraciones de SwitchB y SwitchC son similares a la configuración de SwitchA, y no se mencionan aquí. Para más detalles, vea los archivos de configuración.

    [SwitchA] ospf 1
    [SwitchA-ospf-1] area 0
    [SwitchA-ospf-1-area-0.0.0.0] network 10.1.10.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] network 10.1.50.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] quit
    [SwitchA-ospf-1] quit

  2. Configure un grupo VRRP.

    # Configure el grupo 1 de VRRP en SwitchA y SwitchB, establezca la prioridad de SwitchA a 120 y el retardo de preferencia en 20 segundos y establezca la prioridad predeterminada para SwitchB.

    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] vrrp vrid 1 virtual-ip 10.1.10.111
    [SwitchA-Vlanif100] vrrp vrid 1 priority 120                 //La prioridad predeterminada de un dispositivo en un grupo VRRP es 100. Cambie la prioridad del master para que sea más alta que Backup.
    [SwitchA-Vlanif100] vrrp vrid 1 preempt-mode timer delay 20  //Un dispositivo en un grupo VRRP usa prioridad inmediata por defecto. Cambie la demora de preferencia de Master para evitar interrupciones de servicio en una red inestable donde los dispositivos en el grupo VRRP se adelantan como Master.
    [SwitchA-Vlanif100] quit
    [SwitchB] interface vlanif 100
    [SwitchB-Vlanif100] vrrp vrid 1 virtual-ip 10.1.10.111
    [SwitchB-Vlanif100] quit

    # Configure el grupo 2 de VRRP en SwitchA y SwitchB, configure la prioridad de SwitchB a 120 y el retardo de preferencia en 20 segundos, y configure la prioridad predeterminada para SwitchA.

    [SwitchB] interface vlanif 500
    [SwitchB-Vlanif500] vrrp vrid 2 virtual-ip 10.1.50.111
    [SwitchB-Vlanif500] vrrp vrid 2 priority 120                 //La prioridad predeterminada de un dispositivo en un grupo VRRP es 100. Cambie la prioridad de Master para que sea más alta que Backup.
    [SwitchB-Vlanif500] vrrp vrid 2 preempt-mode timer delay 20  //Un dispositivo en un grupo VRRP usa prioridad inmediata por defecto. Cambie la demora de preferencia de Master para evitar interrupciones de servicio en una red inestable donde los dispositivos en el grupo VRRP se adelantan como Master.
    [SwitchB-Vlanif500] quit
    [SwitchA] interface vlanif 500
    [SwitchA-Vlanif500] vrrp vrid 2 virtual-ip 10.1.50.111
    [SwitchA-Vlanif500] quit
    

  3. Verifique la configuración.

    # Una vez completada la configuración, ejecute el comando display vrrp en SwitchA. Pueden ver que SwitchA es el Master en el grupo 1 de VRRP y el Backup en el grupo 2 de VRRP.

    [SwitchA] display vrrp
      Vlanif100 | Virtual Router 1
        State : Master
        Virtual IP : 10.1.10.111
        Master IP : 10.1.10.1
        PriorityRun : 120
        PriorityConfig : 120                                                        
        MasterPriority : 120                                                        
        Preempt : YES   Delay Time : 20 s
        TimerRun : 1 s
        TimerConfig : 1 s
        Auth type : NONE                                                            
        Virtual MAC : 0000-5e00-0101                                                
        Check TTL : YES                                                             
        Config type : normal-vrrp                                                   
        Backup-forward : disabled
        Create time : 2012-01-12 20:15:46
        Last change time : 2012-01-12 20:15:46
    
      Vlanif500 | Virtual Router 2
        State : Backup
        Virtual IP : 10.1.50.111
        Master IP : 10.1.50.2
        PriorityRun : 100
        PriorityConfig : 100                                                        
        MasterPriority : 120                                                        
        Preempt : YES   Delay Time : 0 s
        TimerRun : 1 s
        TimerConfig : 1 s
        Auth type : NONE                                                            
        Virtual MAC : 0000-5e00-0102                                                
        Check TTL : YES                                                             
        Config type : normal-vrrp                                                   
        Backup-forward : disabled
        Create time : 2012-01-12 20:15:46
        Last change time : 2012-01-12 20:15:46

    # Una vez completada la configuración, ejecute el comando display vrrp en SwitchB. Pueden ver que SwitchB es el Backup en el grupo 1 de VRRP y el Master en el grupo 2 de VRRP.

    [SwitchB] display vrrp
      Vlanif100 | Virtual Router 1
        State : Backup
        Virtual IP : 10.1.10.111
        Master IP : 10.1.10.1
        PriorityRun : 100
        PriorityConfig : 100                                                        
        MasterPriority : 120                                                        
        Preempt : YES   Delay Time : 0 s
        TimerRun : 1 s
        TimerConfig : 1 s
        Auth type : NONE                                                            
        Virtual MAC : 0000-5e00-0101                                                
        Check TTL : YES                                                             
        Config type : normal-vrrp                                                   
        Backup-forward : disabled
        Create time : 2012-01-12 20:15:46
        Last change time : 2012-01-12 20:15:46
    
      Vlanif500 | Virtual Router 2
        State : Master
        Virtual IP : 10.1.50.111
        Master IP : 10.1.50.2
        PriorityRun : 120
        PriorityConfig : 120                                                        
        MasterPriority : 120                                                        
        Preempt : YES   Delay Time : 20 s
        TimerRun : 1 s
        TimerConfig : 1 s
        Auth type : NONE                                                            
        Virtual MAC : 0000-5e00-0102                                                
        Check TTL : YES                                                             
        Config type : normal-vrrp                                                   
        Backup-forward : disabled
        Create time : 2012-01-12 20:15:46
        Last change time : 2012-01-12 20:15:46

Archivos de configuración

  • El archivo de configuración de SwitchA

    #
    sysname SwitchA
    #
    vlan batch 100 300 500
    #
    interface Vlanif100
     ip address 10.1.10.1 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.10.111
     vrrp vrid 1 priority 120
     vrrp vrid 1 preempt-mode timer delay 20
    #
    interface Vlanif300
     ip address 192.168.1.1 255.255.255.0
    #
    interface Vlanif500
     ip address 10.1.50.1 255.255.255.0
     vrrp vrid 2 virtual-ip 10.1.50.111
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 100 500
    #
    ospf 1
     area 0.0.0.0
      network 10.1.10.0 0.0.0.255
      network 10.1.50.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
    #
    return
  • El archivo de configuración de SwitchB

    #
    sysname SwitchB
    #
    vlan batch 100 200 500
    #
    interface Vlanif100
     ip address 10.1.10.2 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.10.111
    #
    interface Vlanif200
     ip address 192.168.2.1 255.255.255.0
    #
    interface Vlanif500
     ip address 10.1.50.2 255.255.255.0
     vrrp vrid 2 virtual-ip 10.1.50.111
     vrrp vrid 2 priority 120
     vrrp vrid 2 preempt-mode timer delay 20
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 100 500
    #
    ospf 1
     area 0.0.0.0
      network 10.1.10.0 0.0.0.255
      network 10.1.50.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    return
  • El archivo de configuración de SwitchC

    #
    sysname SwitchC
    #
    vlan batch 200 300 400
    #
    interface Vlanif200
     ip address 192.168.2.2 255.255.255.0
    #
    interface Vlanif300
     ip address 192.168.1.2 255.255.255.0
    #
    interface Vlanif400
     ip address 172.16.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    ospf 1
     area 0.0.0.0
      network 172.16.1.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    return
    
  • Archivo de configuración del switch

    #
    sysname Switch
    #
    vlan batch 100 500
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100 500
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 100 500
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15489

Descargas: 129

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente