No se encuentran recursos de mapeo en el idioma seleccionado.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar la asociación entre VRRP y BFD para implementar una conmutación rápida activa/standby

Ejemplo para configurar la asociación entre VRRP y BFD para implementar una conmutación rápida activa/standby

Descripción general de la asociación entre VRRP y BFD

Un grupo de VRRP envía y recibe paquetes de anuncios de VRRP para determinar los estados maestros y de reserva, implementando redundancia. Si los enlaces conectados a un grupo VRRP fallan, los paquetes de anuncio de VRRP no pueden enviarse para su negociación. Backup cambiará al Master después de un período de tres veces mayor que el intervalo durante el cual se envían los paquetes de anuncio de VRRP. Durante el período de conmutación, el tráfico del servicio aún se envía al dispositivo Master original, y va a causar la pérdida de tráfico de usuario.

BFD puede detectar rápidamente la conectividad de enlaces y rutas en la red. La asociación entre VRRP y BFD implementa una conmutación activa/standby rápida dentro de 1 segundo. Se establece una sesión BFD entre Master y Backup y está vinculada a un grupo VRRP. BFD detecta fallas del grupo VRRP. Cuando ocurre una falla, BFD notifica al grupo VRRP que se está realizando una conmutación activa/standby, reduciendo en gran medida el tiempo de interrupción del servicio.

Notas de configuración

  • En V200R003 y versiones anteriores, VRRP se puede configurar solo en la interfaz VLANIF.

    En V200R005 y versiones posteriores, VRRP se puede configurar en la interfaz VLANIF y en la interfaz Ethernet de capa 3.

    Para un switch modular en V200R006 y versiones posteriores, VRRP se puede configurar en la interfaz VLANIF, interfaz Ethernet de capa 3, subinterfaz de terminación Dot1q y subinterfaz de terminación QinQ.

    Para un switch fijo en V200R009 y versiones posteriores, VRRP se puede configurar en la interfaz VLANIF, interfaz Ethernet de capa 3 y subinterfaz.

  • Asegúrese de que cada dispositivo del mismo grupo VRRP esté configurado con el mismo VRID.
  • Los grupos VRRP deben usar diferentes direcciones IP virtuales. La dirección IP virtual de un grupo VRRP debe estar en el mismo segmento de red que la dirección IP de la interfaz donde está configurado el grupo VRRP.

  • Múltiples grupos VRRP pueden vigilar una sesión BFD, y un grupo VRRP puede vigilar un máximo de ocho sesiones BFD simultáneamente.

  • A lo siguiente se describen los Modelos de productos y versiones aplicables.
    Tabla 10-4   Modelos de productos y versiones aplicables

    Producto

    Modelo del Producto

    Versión del software

    S3300

    S3300EI

    V100R006C05

    S3300HI

    V200R001C00

    S5300

    S5320SI

    V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5300EI

    V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5300HI

    V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5310EI

    V200R002C00, V200R003C00, V200R005(C00&C02)

    S5320EI

    V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5320HI

    V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5330SI

    V200R011C10, V200R012C00

    S6300

    S6300EI

    V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S6320EI

    V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S6320SI

    V200R011C10, V200R012C00

    S6320HI

    V200R012C00

    S9300

    S9303, S9306 y S9312

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S9300

    S9310

    V200R010C00, V200R011C10, V200R012C00

    S9300X

    S9310X

    V200R010C00, V200R011C10, V200R012C00

    S9300E

    S9303E, S9306E y S9312E

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    NOTA:
    Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de redes

En Figura 10-4, hosts en a LAN son dual-homed a SwitchA y SwitchB a través del switch. Un grupo VRRP se establece en SwitchA y SwitchB, y SwitchA es el Master.

Cuando SwitchA o un enlace entre SwitchA y SwitchB es defectuoso, los paquetes VRRP se envían después de que se completa la negociación de VRRP. Para acelerar las conmutaciones de enlace, despliegue una sesión BFD en el enlace y asocie el grupo VRRP con la sesión BFD. Cuando la interfaz en el principal o el enlace falla, la sesión BFD detecta rápidamente la falla y notifica al grupo VRRP de la falla. Después de recibir la notificación, el grupo VRRP realiza una conmutación rápida activa/standby. Backup se convierte en Master y se hace cargo del tráfico. Esto reduce el impacto de la falla en la transmisión del servicio.

NOTA:

En este escenario, para evitar bucles, asegúrese de que todas las interfaces conectadas tengan STP deshabilitado y las interfaces conectadas se eliminen de la VLAN 1. Si STP está habilitado y las interfaces VLANIF de switches se usan para construir una red de anillo de Capa 3, una interfaz en la red va a ser bloqueado. Como resultado, los servicios de Capa 3 en la red no pueden ejecutarse normalmente.

Figura 10-4  Asociación entre VRRP y BFD para implementar una conmutación rápida activa/standby

Hoja de ruta de configuración

La asociación entre VRRP y BFD se usa para implementar una conmutación rápida activa/standby. La hoja de ruta de la configuración es la siguiente:

  1. Asigne una dirección IP a cada interfaz y configure un protocolo de enrutamiento para garantizar la conectividad de la red.
  2. Configure un grupo VRRP en SwitchA y SwitchB. SwitchA funciona como Master, su prioridad es 120 y el retraso de prioridad es 20s. SwitchB funciona como Backup usando la prioridad predeterminada a realizar el gateway de reserva principal.
  3. Configure una sesión BFD estática en SwitchA y SwitchB para vigilar el enlace del grupo VRRP.
  4. Asocie la configuración entre BFD y VRRP en SwitchB. Cuando el enlace es defectuoso, se puede realizar una conmutación activa/standby rápidamente.

Procedimiento

  1. Configure los dispositivos para garantizar la conectividad de la red.

    # Asigne una dirección IP a cada interfaz. SwitchA se usa como un ejemplo. La configuración de SwitchB es similar a la de SwitchA.

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan 100
    [SwitchA-vlan100] quit
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port hybrid pvid vlan 100
    [SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 100
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] ip address 10.1.1.1 24
    [SwitchA-Vlanif100] quit

    # Configure el reenvío de Capa 2 en el switch.

    <Quidway> system-view
    [Quidway] sysname Switch
    [Switch] vlan 100
    [Switch-vlan100] quit
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port hybrid pvid vlan 100
    [Switch-GigabitEthernet1/0/1] port hybrid untagged vlan 100
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port hybrid pvid vlan 100
    [Switch-GigabitEthernet1/0/2] port hybrid untagged vlan 100
    [Switch-GigabitEthernet1/0/2] quit
    

    # Configure OSPF entre SwitchA y SwitchB. SwitchA se usa como un ejemplo. La configuración de SwitchB es similar a la de SwitchA.

    [SwitchA] ospf 1
    [SwitchA-ospf-1] area 0
    [SwitchA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] quit
    [SwitchA-ospf-1] quit

  2. Configure un grupo VRRP.

    # Configure el grupo 1 de VRRP en SwitchA, y establezca la prioridad de SwitchA a 120 y el retardo de preferencia en 20 segundos.

    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] vrrp vrid 1 virtual-ip 10.1.1.3
    [SwitchA-Vlanif100] vrrp vrid 1 priority 120                 //La prioridad predeterminada de un dispositivo en un grupo VRRP es 100. Cambie la prioridad de Mater para que sea más alta que Backup.
    [SwitchA-Vlanif100] vrrp vrid 1 preempt-mode timer delay 20  //Un dispositivo en un grupo VRRP usa prioridad inmediata por defecto. Cambie la demora de preferencia de Master para evitar interrupciones de servicio en una red inestable donde los dispositivos en el grupo VRRP se adelantan como Master.
    [SwitchA-Vlanif100] quit

    # Configure el grupo 1 de VRRP en SwitchB. SwitchB usa el valor predeterminado 100.

    [SwitchB] interface vlanif 100
    [SwitchB-Vlanif100] vrrp vrid 1 virtual-ip 10.1.1.3
    [SwitchB-Vlanif100] quit

  3. Configure una sesión de BFD estática.

    # Cree una sesión BFD en SwitchA.

    [SwitchA] bfd
    [SwitchA-bfd] quit
    [SwitchA] bfd atob bind peer-ip 10.1.1.2 interface vlanif 100 //Configure una sesión BFD estática para vigilar el enlace del grupo VRRP.
    [SwitchA-bfd-session-atob] discriminator local 1 //Configure el discriminador local de la sesión BFD. El discriminador local en SwitchA debe ser el mismo que el discriminador remoto en SwitchB.
    [SwitchA-bfd-session-atob] discriminator remote 2 //Configure el discriminador remoto de la sesión BFD. El discriminador remoto en SwitchA debe ser el mismo que el discriminador local en SwitchB.
    [SwitchA-bfd-session-atob] min-rx-interval 100 //Configure el intervalo mínimo para recibir paquetes BFD.
    [SwitchA-bfd-session-atob] min-tx-interval 100 //Configure el intervalo mínimo para enviar paquetes BFD.
    [SwitchA-bfd-session-atob] commit //Confirme la sesión de BFD para que la configuración se ponga en vigor.
    [SwitchA-bfd-session-atob] quit
    

    # Cree una sesión BFD en SwitchB.

    [SwitchB] bfd
    [SwitchB-bfd] quit
    [SwitchB] bfd btoa bind peer-ip 10.1.1.1 interface vlanif 100
    [SwitchB-bfd-session-btoa] discriminator local 2
    [SwitchB-bfd-session-btoa] discriminator remote 1
    [SwitchB-bfd-session-btoa] min-rx-interval 100
    [SwitchB-bfd-session-btoa] min-tx-interval 100
    [SwitchB-bfd-session-btoa] commit
    [SwitchB-bfd-session-btoa] quit
    

    Ejecute el comando display bfd session en SwitchA y SwitchB. Pueden ver que la sesión de BFD es Up. La visualización en SwitchA se usa como un ejemplo.

    [SwitchA] display bfd session all
    --------------------------------------------------------------------------------
    Local Remote PeerIpAddr      State     Type        InterfaceName                
    --------------------------------------------------------------------------------
    1     2      10.1.1.2      Up        S_IP_IF     Vlanif100         
    --------------------------------------------------------------------------------
         Total UP/DOWN Session Number : 1/0       

  4. Asocie la configuración entre BFD y VRRP.

    # Configure la asociación entre VRRP y BFD en Switch. Cuando la sesión BFD se convierte en Down, la prioridad de SwitchB aumenta en 40.

    [SwitchB] interface vlanif 100
    [SwitchB-Vlanif100] vrrp vrid 1 track bfd-session 2 increased 40 //El valor 2 indica el discriminador local.
    [SwitchB-Vlanif100] quit

  5. Verifique la configuración

    # Una vez completada la configuración, ejecute el comando display vrrp en SwitchA y SwitchB. SwitchA es el dispositivo Master, SwitchB es el Backup, y el BFD asociado la sesión está en estado Up.

    [SwitchA] display vrrp
      Vlanif100 | Virtual Router 1
        State : Master
        Virtual IP : 10.1.1.3
        Master IP : 10.1.1.1
        PriorityRun : 120
        PriorityConfig : 120
        MasterPriority : 120
        Preempt : YES   Delay Time : 20 s
        TimerRun : 1 s
        TimerConfig : 1 s
        Auth type : NONE
        Virtual MAC : 0000-5e00-0101
        Check TTL : YES
        Config type : normal-vrrp
        Backup-forward : disabled
        Create time : 2012-01-12 20:15:46
        Last change time : 2012-01-12 20:15:46
    [SwitchB] display vrrp
      Vlanif100 | Virtual Router 1
        State : Backup
        Virtual IP : 10.1.1.3
        Master IP : 10.1.1.1
        PriorityRun : 100
        PriorityConfig : 100
        MasterPriority : 120
        Preempt : YES   Delay Time : 0 s
        TimerRun : 1 s
        TimerConfig : 1 s
        Auth type : NONE
        Virtual MAC : 0000-5e00-0101
        Check TTL : YES
        Config type : normal-vrrp
        Backup-forward : disabled
        Track BFD : 2  Priority increased : 40
        BFD-session state : UP
        Create time : 2012-01-12 20:15:46
       Last change time : 2012-01-12 20:15:46

    # Ejecute el comando de shutdown en GE1/0/1 de SwitchA para simular un error de enlace. A continuación, ejecute el comando display vrrp enSwitchA y SwitchB. Pueden ver que SwitchA está en el estado de Initialize, SwitchB se convierte en Master , y la sesión de BFD asociada se convierte en Down.

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] shutdown
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] display vrrp
      Vlanif100 | Virtual Router 1
        State : Initialize
        Virtual IP : 10.1.1.3
        Master IP : 0.0.0.0
        PriorityRun : 120
        PriorityConfig : 120
        MasterPriority : 0
        Preempt : YES   Delay Time : 20 s
        TimerRun : 1 s
        TimerConfig : 1 s
        Auth type : NONE
        Virtual MAC : 0000-5e00-0101
        Check TTL : YES
        Config type : normal-vrrp
        Backup-forward : disabled
        Create time : 2012-01-12 20:15:46
        Last change time : 2012-01-12 20:15:46
    [SwitchB] display vrrp
      Vlanif100 | Virtual Router 1
        State : Master
        Virtual IP : 10.1.1.3
        Master IP : 10.1.1.2
        PriorityRun : 140
        PriorityConfig : 100
        MasterPriority : 140
        Preempt : YES   Delay Time : 0 s
        TimerRun : 1 s
        TimerConfig : 1 s
        Auth type : NONE
        Virtual MAC : 0000-5e00-0101
        Check TTL : YES
        Config type : normal-vrrp
        Backup-forward : disabled
        Track BFD : 2  Priority increased : 40
        BFD-session state : DOWN
        Create time : 2012-01-12 20:15:46
       Last change time : 2012-01-12 20:15:46

    # Ejecute el comando undo shutdown en GE1/0/1 de SwitchA.

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] undo shutdown
    [SwitchA-GigabitEthernet1/0/1] quit

    # Después de 20 segundos, ejecute el comando display vrrp en SwitchA y SwitchB. Pueden ver que SwitchA se restaura como Master, SwitchB se restaura como Backup, y la sesión de BFD asociada está en estado Up.

    [SwitchA] display vrrp
      Vlanif100 | Virtual Router 1
        State : Master
        Virtual IP : 10.1.1.3
        Master IP : 10.1.1.1
        PriorityRun : 120
        PriorityConfig : 120
        MasterPriority : 120
        Preempt : YES   Delay Time : 20 s
        TimerRun : 1 s
        TimerConfig : 1 s
        Auth type : NONE
        Virtual MAC : 0000-5e00-0101
        Check TTL : YES
        Config type : normal-vrrp
        Backup-forward : disabled
        Create time : 2012-01-12 20:15:46
        Last change time : 2012-01-12 20:15:46
    [SwitchB] display vrrp
      Vlanif100 | Virtual Router 1
        State : Backup
        Virtual IP : 10.1.1.3
        Master IP : 10.1.1.1
        PriorityRun : 100
        PriorityConfig : 100
        MasterPriority : 120
        Preempt : YES   Delay Time : 0 s
        TimerRun : 1 s
        TimerConfig : 1 s
        Auth type : NONE
        Virtual MAC : 0000-5e00-0101
        Check TTL : YES
        Config type : normal-vrrp
        Backup-forward : disabled
        Track BFD : 2  Priority increased : 40
        BFD-session state : UP
        Create time : 2012-01-12 20:15:46
        Last change time : 2012-01-12 20:15:46

Archivos de configuración

  • El archivo de configuración de SwitchA

    #
    sysname SwitchA
    #
    vlan batch 100
    #
    bfd
    #
    interface Vlanif100
     ip address 10.1.1.1 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.1.3
     vrrp vrid 1 priority 120
     vrrp vrid 1 preempt-mode timer delay 20
    #
    interface GigabitEthernet1/0/1
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #  
    bfd atob bind peer-ip 10.1.1.2 interface Vlanif100
     discriminator local 1
     discriminator remote 2
     min-tx-interval 100
     min-rx-interval 100
     commit  
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    return
  • El archivo de configuración de SwitchB

    #
    sysname SwitchB
    #
    vlan batch 100
    #
    bfd
    #
    interface Vlanif100
     ip address 10.1.1.2 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.1.3
     vrrp vrid 1 track bfd-session 2 increased 40
    #
    interface GigabitEthernet1/0/1
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    bfd btoa bind peer-ip 10.1.1.1 interface Vlanif100
     discriminator local 2
     discriminator remote 1
     min-tx-interval 100
     min-rx-interval 100
     commit
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    return
  • Archivo de configuración del switch

    #
    sysname Switch
    #
    vlan batch 100
    #
    interface GigabitEthernet1/0/1
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    interface GigabitEthernet1/0/2
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15384

Descargas: 127

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente