No se encuentran recursos de mapeo en el idioma seleccionado.

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar VRRP para garantizar la transmisión de datos de multidifusión confiable

Ejemplo para configurar VRRP para garantizar la transmisión de datos de multidifusión confiable

Descripción general de VRRP

En general, todos los hosts en el mismo segmento de red tienen la misma ruta predeterminada con la dirección de gateway como la dirección del siguiente salto. Los hosts utilizan el enrutamiento predeterminado para enviar paquetes a gateway y el gateway reenvía los paquetes a otros segmentos de red. Cuando el gateway falla, los hosts con el mismo enrutamiento predeterminado no pueden comunicarse con redes externas. La configuración de gateways de salida múltiples es un método común utilizado para mejorar la confiabilidad del sistema. Sin embargo, la selección de enrutamiento entre los gateways se convierte en un problema.

VRRP resuelve el problema. VRRP virtualiza múltiples dispositivos de enrutamiento en un router virtual sin cambiar la red y utiliza la dirección IP del router virtual como la dirección de gateway predeterminado para implementar el gateway de reserva. Cuando el gateway falla, VRRP selecciona un gateway para transmitir el tráfico del servicio para garantizar una comunicación confiable.

Notas de configuración

  • Los grupos VRRP deben usar diferentes direcciones IP virtuales. La dirección IP virtual de un grupo VRRP debe estar en el mismo segmento de red que la dirección IP de la interfaz donde está configurado el grupo VRRP.
  • Asegúrese de que cada dispositivo del mismo grupo VRRP esté configurado con el mismo VRID.
  • En V200R003C00 y versiones anteriores, solo la interfaz VLANIF admite VRRP. En V200R005C00 y versiones posteriores, las interfaces VLANIF y Layer 3 Ethernet son compatibles con VRRP.
  • A continuación se describen los Modelos de productos y versiones aplicables.
    Tabla 10-6  Modelos de productos y versiones aplicables

    Producto

    Modelo del producto

    Versión del software

    S3300

    S3300EI

    V100R006C05

    S3300HI

    V200R001C00

    S5300

    S5320SI

    V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5330SI

    V200R011C10, V200R012C00

    S5300EI

    V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5310EI

    V200R002C00, V200R003C00, V200R005(C00&C02)

    S5320EI

    V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5300HI

    V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5320HI

    V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S6300

    S6300EI

    V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S6320EI

    V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S6320SI

    V200R011C10, V200R012C00

    S6320HI

    V200R012C00

    S9300

    S9303, S9306 y S9312

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S9300

    S9310

    V200R010C00, V200R011C10, V200R012C00

    S9300X

    S9310X

    V200R010C00, V200R011C10, V200R012C00

    S9300E

    S9303E, S9306E y S9312E

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    NOTA:
    Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de redes

Como se muestra en Figura 10-6, SwitchA y SwitchB son gateways de salida de la red del campus; SwitchC y SwitchD son switches de core. El origen de multidifusión se conecta a la red del campus a través de un router. Los nodos clave en la red funcionan en modo de redundancia para mejorar la confiabilidad de la red, y los gateways de salida y los switches de core están completamente conectados para implementar la redundancia de enlace. Los gateways de salida y los switches de core deben configurarse para admitir que los datos de multidifusión se transmitan confiablemente a la red de vínculo descendente.

NOTA:

En este escenario, para evitar bucles, asegúrese de que todas las interfaces conectadas tengan STP deshabilitado y las interfaces conectadas se eliminen de la VLAN 1. Si STP está habilitado y las interfaces VLANIF de switches se usan para construir una red de anillo de Capa 3, una interfaz en la red va a ser bloqueado. Como resultado, los servicios de Capa 3 en la red no pueden ejecutarse normalmente.

Figura 10-6  Transmisión de datos de multidifusión a través de una red VRRP
Dispositivo Interfaz VLAN Dirección IP de la interfaz VLANIF Dispositivo Interfaz VLAN Dirección IP de la interfaz VLANIF
SwitchA GE1/0/0 VLAN 100 10.1.1.1/24 SwitchC GE1/0/0 VLAN 400 10.1.6.1/24
Eth-trunk 1 (con interfaces de miembro GE2/0/1, GE2/0/2 y GE2/0/3) VLAN 100, VLAN 200 Sin interfaz VLANIF 200 Eth-trunk 1 (con interfaces de miembro GE2/0/1, GE2/0/2 y GE2/0/3) VLAN 400, VLAN 500 Sin interfaz VLANIF 500
GE3/0/1 VLAN 301 10.1.2.1/24 GE3/0/1 VLAN 301 10.1.2.2/24
GE3/0/2 VLAN 302 10.1.3.1/24 GE3/0/2 VLAN 304 10.1.5.2/24
SwitchB GE1/0/0 VLAN 100 10.1.1.2/24 SwitchD GE1/0/0 VLAN 400 10.1.6.2/24
Eth-trunk 1 (con interfaces de miembro GE2/0/1, GE2/0/2 y GE2/0/3) VLAN 100, VLAN 200 Sin interfaz VLANIF 200 Eth-trunk 1 (con interfaces de miembro GE2/0/1, GE2/0/2 y GE2/0/3) VLAN 400, VLAN 500 Sin interfaz VLANIF 500
GE3/0/1 VLAN 303 10.1.4.1/24 GE3/0/1 VLAN 303 10.1.4.2/24
GE3/0/2 VLAN 304 10.1.5.1/24 GE3/0/2 VLAN 302 10.1.3.2/24

Hoja de ruta de configuración

Para garantizar la confiabilidad de transmisión de datos de multidifusión, configure el Protocolo de redundancia de enrutador virtual (VRRP) y la Detección de reenvío bidireccional (BFD) en los gateways de salida y los switches de core. Para garantizar el reenvío normal de multidifusión, configure un protocolo de multidifusión en los gateways de salida y los switches de core.

  1. Configure grupos de agregación de enlaces entre SwitchA y SwitchB, y entre SwitchC y SwitchD para garantizar un intercambio rápido y confiable de paquetes VRRP.
  2. Cree VLAN en los switches y agregue sus interfaces a las VLAN respectivas. Configure las direcciones IP para las interfaces VLANIF correspondientes para hacer que los segmentos de red local sean accesibles.
  3. Configure el protocolo Abrir la ruta más corta primero (OSPF) en los switches para garantizar los enrutamientos accesibles entre ellos. Los enrutamientos de OSPF equilibran la carga del tráfico de unidifusión entre los gateways de salida y los switches de core para reducir cargas de enlaces que transmiten datos de multidifusión y unidifusión simultáneamente.
  4. Configure un grupo de VRRP entre SwitchA y SwitchB y un grupo de VRRP entre SwitchC y SwitchD para asegurar el envío confiable de multidifusión. Los grupos VRRP implementan el equilibrio de carga para el tráfico de unidifusión para reducir las cargas de enlaces que transmiten datos de multidifusión y unidifusión simultáneamente.
  5. Configure un protocolo de multidifusión en los switches para garantizar el reenvío normal de datos de multidifusión.
  6. Configure BFD para OSPF y BFD para PIM en los switches para admitir que los switches detecten rápidamente fallas de enlace, realizando una rápida convergencia de enrutamiento de unidifusión y multidifusión.

Procedimiento

  1. Configure grupos de agregación de enlaces en los switches.

    # Cree Eth-Trunks y agregar interfaces de miembros a Eth-Trunks en el gateway de salida del campus y los dispositivos de core.

    <SwitchA> system-view
    [SwitchA] interface Eth-Trunk1     //Cree Eth-Trunk1 y enlace las interfaces de miembro GE2/0/1 a GE2/0/3.
    [SwitchA-Eth-Trunk1] trunkport gigabitethernet 2/0/1 to 2/0/3
    [SwitchA-Eth-Trunk1] quit
    
    <SwitchB> system-view
    [SwitchB] interface Eth-Trunk1     //Cree Eth-Trunk1 y enlace las interfaces de miembro GE2/0/1 a GE2/0/3.
    [SwitchB-Eth-Trunk1] trunkport gigabitethernet 2/0/1 to 2/0/3
    [SwitchB-Eth-Trunk1] quit
    
    <SwitchC> system-view
    [SwitchC] interface Eth-Trunk1     //Cree Eth-Trunk1 y enlace las interfaces de miembro GE2/0/1 a GE2/0/3.
    [SwitchC-Eth-Trunk1] trunkport gigabitethernet 2/0/1 to 2/0/3
    [SwitchC-Eth-Trunk1] quit
    
    <SwitchD> system-view
    [SwitchD] interface Eth-Trunk1     //Cree Eth-Trunk1 y enlace las interfaces de miembro GE2/0/1 a GE2/0/3.
    [SwitchD-Eth-Trunk1] trunkport gigabitethernet 2/0/1 to 2/0/3
    [SwitchD-Eth-Trunk1] quit
    

    Por defecto, un Eth-Trunk funciona en modo de equilibrio de carga manual, y todas las interfaces activas cargan el tráfico de equilibrio.

  2. Cree VLAN, agregue interfaces a las VLAN respectivas y configure las direcciones IP para las interfaces VLANIF correspondientes.

    1. Cree VLAN y agregue interfaces a las VLAN en el gateway de salida y en los dispositivos de core. Las configuraciones en SwitchB, SwitchC y SwitchD son similares a la configuración en SwitchA, y no se mencionan aquí.

      [SwitchA] vlan batch 100 200 301 302
      [SwitchA] interface gigabitethernet 1/0/0
      [SwitchA-GigabitEthernet1/0/0] port link-type trunk     //Establezca el tipo de enlace de la interfaz en Trunk, que no es el tipo de enlace predeterminado.
      [SwitchA-GigabitEthernet1/0/0] port trunk allow-pass vlan 100
      [SwitchA-GigabitEthernet1/0/0] quit
      [SwitchA] interface gigabitethernet 3/0/1
      [SwitchA-GigabitEthernet3/0/1] port link-type trunk     //Establezca el tipo de enlace de la interfaz en Trunk, que no es el tipo de enlace predeterminado.
      [SwitchA-GigabitEthernet3/0/1] port trunk allow-pass vlan 301
      [SwitchA-GigabitEthernet3/0/1] quit
      [SwitchA] interface gigabitethernet 3/0/2
      [SwitchA-GigabitEthernet3/0/2] port link-type trunk     //Establezca el tipo de enlace de la interfaz en Trunk, que no es el tipo de enlace predeterminado.
      [SwitchA-GigabitEthernet3/0/2] port trunk allow-pass vlan 302
      [SwitchA-GigabitEthernet3/0/2] quit
      [SwitchA] interface eth-trunk 1
      [SwitchA-Eth-Trunk1] port link-type trunk     //Establezca el tipo de enlace de la interfaz en Trunk, que no es el tipo de enlace predeterminado.
      [SwitchA-Eth-Trunk1] port trunk allow-pass vlan 100 200
      [SwitchA-Eth-Trunk1] quit
    2. Configure las direcciones IP para las interfaces de Capa 3 en el gateway de salida del campus y los dispositivos de core. Las configuraciones en SwitchB, SwitchC y SwitchD son similares a la configuración en SwitchA, y no se mencionan aquí.

      [SwitchA] interface vlanif 100     //Cree VLANIF100.
      [SwitchA-Vlanif100] ip address 10.1.1.1 24
      [SwitchA-Vlanif100] quit
      [SwitchA] interface vlanif 301     //Cree VLANIF301.
      [SwitchA-Vlanif301] ip address 10.1.2.1 24
      [SwitchA-Vlanif301] quit
      [SwitchA] interface vlanif 302     //Cree VLANIF302.
      [SwitchA-Vlanif302] ip address 10.1.3.1 24
      [SwitchA-Vlanif302] quit
      [SwitchA] interface loopback 1     //Cree LoopBack1.
      [SwitchA-LoopBack1] ip address 10.10.1.1 32
      [SwitchA-LoopBack1] quit
  3. Configure OSPF.

    # Habilite OSPF en el gateway de salida del campus y dispositivos de core, agregue los dispositivos al Area 0 y anuncie segmentos de red locales en el Area 0. Las configuraciones en SwitchB, SwitchC y SwitchD son similares a la configuración en SwitchA, y no se mencionan aquí .

    [SwitchA] ospf
    [SwitchA-ospf-1] area 0
    [SwitchA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255     //Especifique que la interfaz que ejecuta OSPF es la que está conectada al segmento de red 10.1.1.0 y que la interfaz pertenece al Area 0.
    [SwitchA-ospf-1-area-0.0.0.0] network 10.1.2.0 0.0.0.255     //Especifique que la interfaz que ejecuta OSPF es la que está conectada al segmento de red 10.1.2.0 y que la interfaz pertenece al Area 0.
    [SwitchA-ospf-1-area-0.0.0.0] network 10.1.3.0 0.0.0.255     //Especifique que la interfaz que ejecuta OSPF es la que está conectada al segmento de red 10.1.3.0 y que la interfaz pertenece al Area 0.
    [SwitchA-ospf-1-area-0.0.0.0] network 10.10.1.1 0.0.0.0     //Especifique que la interfaz que ejecuta OSPF es la que está conectada al segmento de red 10.10.1.1 y que la interfaz pertenece al Area 0.
    [SwitchA-ospf-1-area-0.0.0.0] quit
    [SwitchA-ospf-1] quit
  4. Configure los grupos de VRRP.

    1. Cree el grupo 1 de VRRP en los dispositivos SwitchA y SwitchB de gateway de salida de campus. Establezca la prioridad de SwitchA en 120 y la demora de prioridad en 20 segundos. Conserve la prioridad predeterminada de SwitchB. Por lo tanto, SwitchA se convierte en el dispositivo principal y SwitchB se convierte en el dispositivo de reserva del grupo 1 de VRRP.

      # Configure SwitchA.

      [SwitchA] interface vlanif 100
      [SwitchA-Vlanif100] vrrp vrid 1 virtual-ip 10.1.1.253     //Cree el grupo VRRP 1 en VLANIF100 y configure la dirección IP virtual del grupo VRRP en 10.1.1.253.
      [SwitchA-Vlanif100] vrrp vrid 1 priority 120     //Establezca la prioridad de VLANIF100 en el grupo 1 en 120 de VRRP.
      [SwitchA-Vlanif100] vrrp vrid 1 preempt-mode timer delay 20     //Establezca el retraso de prioridad de VLANIF100 en el grupo VRRP 1 en 20 segundos.
      [SwitchA-Vlanif100] quit

      # Configure SwitchB.

      [SwitchB] interface vlanif 100
      [SwitchB-Vlanif100] vrrp vrid 1 virtual-ip 10.1.1.253     //Cree el grupo VRRP 1 en VLANIF100 y configure la dirección IP virtual del grupo VRRP en 10.1.1.253.
      [SwitchB-Vlanif100] quit
    2. Cree el grupo 2 de VRRP en los dispositivos SwitchA y SwitchB de gateway de salida de campus. Establezca la prioridad de SwitchB en 120 y la demora de prioridad en 20 segundos. Conserve la prioridad predeterminada de SwitchA. Por lo tanto, SwitchB se convierte en el dispositivo principal y SwitchA se convierte en el dispositivo de reserva del grupo 1 de VRRP.

      # Configure SwitchA.

      [SwitchA] interface vlanif 100
      [SwitchA-Vlanif100] vrrp vrid 2 virtual-ip 10.1.1.254     //Cree el grupo VRRP 2 en VLANIF100 y configure la dirección IP virtual del grupo VRRP en 10.1.1.254.
      [SwitchA-Vlanif100] quit

      # Configure SwitchB.

      [SwitchB] interface vlanif 100
      [SwitchB-Vlanif100] vrrp vrid 2 virtual-ip 10.1.1.254     //Cree el grupo VRRP 2 en VLANIF100 y configure la dirección IP virtual del grupo VRRP en 10.1.1.254.
      [SwitchB-Vlanif100] vrrp vrid 2 priority 120     //Establezca la prioridad de VLANIF100 en el grupo 2 en 120 de VRRP.
      [SwitchB-Vlanif100] vrrp vrid 2 preempt-mode timer delay 20     //Establezca el retraso de preferencia de VLANIF100 en el grupo VRRP 2 en 20 segundos.
      [SwitchB-Vlanif100] quit

    Las configuraciones en SwitchC y SwitchD son similares a las configuraciones en SwitchA y SwitchB, y no se mencionan aquí.

  5. Configure un protocolo de multidifusión.

    1. Habilite el enrutamiento de multidifusión en el gateway de salida del campus y los dispositivos de core, y habilite PIM-SM en sus interfaces de Capa 3. Habilite IGMP en las interfaces del lado de usuario de los dispositivos de core.

      # Configure SwitchA.

      [SwitchA] multicast routing-enable     //Habilite el enrutamiento de multidifusión globalmente.
      [SwitchA] interface vlanif 100
      [SwitchA-Vlanif100] pim sm     //Habilite PIM-SM en VLANIF100.
      [SwitchA-Vlanif100] quit
      [SwitchA] interface vlanif 301
      [SwitchA-Vlanif301] pim sm     //Habilite PIM-SM en VLANIF301.
      [SwitchA-Vlanif301] quit
      [SwitchA] interface vlanif 302
      [SwitchA-Vlanif302] pim sm     //Habilite PIM-SM en VLANIF302.
      [SwitchA-Vlanif302] quit
      [SwitchA] interface loopback 1
      [SwitchA-LoopBack1] pim sm     //Habilite PIM-SM en LoopBack1.
      [SwitchA-LoopBack1] quit

      # Configure SwitchB.

      [SwitchB] multicast routing-enable     //Habilite el enrutamiento de multidifusión globalmente.
      [SwitchB] interface vlanif 100
      [SwitchB-Vlanif100] pim sm     //Habilite PIM-SM en VLANIF100.
      [SwitchB-Vlanif100] quit
      [SwitchB] interface vlanif 303
      [SwitchB-Vlanif303] pim sm     //Habilite PIM-SM en VLANIF303.
      [SwitchB-Vlanif303] quit
      [SwitchB] interface vlanif 304
      [SwitchB-Vlanif304] pim sm     // Habilite PIM-SM en VLANIF304.
      [SwitchB-Vlanif304] quit
      [SwitchB] interface loopback 1
      [SwitchB-LoopBack1] pim sm     //Habilite PIM-SM en LoopBack1.
      [SwitchB-LoopBack1] quit

      # Configure SwitchC.

      [SwitchC] multicast routing-enable     //Habilite el enrutamiento de multidifusión globalmente.
      [SwitchC] interface vlanif 400
      [SwitchC-Vlanif400] pim sm     //Habilite PIM-SM en VLANIF400.
      [SwitchC-Vlanif400] igmp enable     //Habilite PIM-SM en VLANIF400.
      [SwitchC-Vlanif400] quit
      [SwitchC] interface vlanif 301
      [SwitchC-Vlanif301] pim sm     //Habilite PIM-SM en VLANIF301.
      [SwitchC-Vlanif301] quit
      [SwitchC] interface vlanif 304
      [SwitchC-Vlanif304] pim sm     //Habilite PIM-SM en VLANIF304.
      [SwitchC-Vlanif304] quit
      [SwitchC] interface loopback 1
      [SwitchC-LoopBack1] pim sm     //Habilite PIM-SM en LoopBack1.
      [SwitchC-LoopBack1] quit

      # Configure SwitchD.

      [SwitchD] multicast routing-enable     //Habilite el enrutamiento de multidifusión globalmente.
      [SwitchD] interface vlanif 400
      [SwitchD-Vlanif400] pim sm     //Habilite PIM-SM en VLANIF400.
      [SwitchD-Vlanif400] igmp enable     //Habilite IGMP en VLANIF400.
      [SwitchD-Vlanif400] quit
      [SwitchD] interface vlanif 302
      [SwitchD-Vlanif302] pim sm     //Habilite PIM-SM en VLANIF302.
      [SwitchD-Vlanif302] quit
      [SwitchD] interface vlanif 303
      [SwitchD-Vlanif303] pim sm     //Habilite PIM-SM en VLANIF303.
      [SwitchD-Vlanif303] quit
      [SwitchD] interface loopback 1
      [SwitchD-LoopBack1] pim sm     //Habilite PIM-SM en LoopBack1.
      [SwitchD-LoopBack1] quit
    2. Configure la función RP dinámica en los dispositivos de core SwitchC y SwitchD que agregan tráfico de multidifusión.

      # Configure Loopback1 de SwitchC como C-BSR y C-RP.

      [SwitchC] pim
      [SwitchC-pim] c-bsr loopback 1     //Configure Loopback1 como una interfaz C-BSR.
      [SwitchC-pim] c-rp loopback 1     //Configure Loopback1 como una interfaz C-RP.
      [SwitchC-pim] quit

      # Configure Loopback1 de SwitchD como C-BSR y C-RP.

      [SwitchD] pim
      [SwitchD-pim] c-bsr loopback 1     //Configure Loopback1 como una interfaz C-BSR.
      [SwitchD-pim] c-rp loopback 1     //Configure Loopback1 como una interfaz C-RP.
      [SwitchD-pim] quit
  6. Configure BFD.

    1. Habilite BFD global en el gateway de salida del campus y los dispositivos de core. BFD global debe estar habilitado antes de configurar BFD para OSPF y BFD para PIM. Las configuraciones en SwitchB, SwitchC y SwitchD son similares a la configuración en SwitchA, y no se mencionan aquí.

      [SwitchA] bfd     //Habilita BFD globalmente.
      [SwitchA-bfd] quit
      
    2. Habilite BFD para OSPF en el gateway de salida del campus y los dispositivos de core. Las configuraciones en SwitchB, SwitchC y SwitchD son similares a la configuración en SwitchA, y no se mencionan aquí.

      [SwitchA] interface vlanif 100
      [SwitchA-Vlanif100] ospf bfd enable     //Habilite BFD para OSPF en VLANIF100.
      [SwitchA-Vlanif100] quit
      [SwitchA] interface vlanif 301
      [SwitchA-Vlanif301] ospf bfd enable     //Habilite BFD para OSPF en VLANIF301.
      [SwitchA-Vlanif301] quit
      [SwitchA] interface vlanif 302
      [SwitchA-Vlanif302] ospf bfd enable     //Habilite BFD para OSPF en VLANIF302.
      [SwitchA-Vlanif302] quit
    3. Habilite BFD para PIM en el gateway de salida del campus y los dispositivos de core. Las configuraciones en SwitchB, SwitchC y SwitchD son similares a la configuración en SwitchA, y no se mencionan aquí.

      [SwitchA] interface vlanif 100
      [SwitchA-Vlanif100] pim bfd enable     //Habilite BFD para PIM en VLANIF100.
      [SwitchA-Vlanif100] quit
      [SwitchA] interface vlanif 301
      [SwitchA-Vlanif301] pim bfd enable     //Habilite BFD para PIM en VLANIF301.
      [SwitchA-Vlanif301] quit
      [SwitchA] interface vlanif 302
      [SwitchA-Vlanif302] pim bfd enable     //Habilite BFD para PIM en VLANIF302.
      [SwitchA-Vlanif302] quit
  7. Verifique la configuración.

    • Verifique la configuración de la agregación de enlaces.

      # Ejecute el comando display eth-trunk 1 en SwitchA. La información anterior muestra que Eth-Trunk 1 contiene tres interfaces de miembros: GigabitEthernet2/0/1, GigabitEthernet2/0/2, y GigabitEthernet2/0/3. Los estados de todas las interfaces de miembros son Up.

      [SwitchA] display eth-trunk 1
      Eth-Trunk1's state information is: 
      WorkingMode: NORMAL          Hash arithmetic: According to SIP-XOR-DIP
      Least Active-linknumber: 1     Max Bandwidth-affected-linknumber: 8
      Operate status: up             Number Of Up Ports In Trunk: 3 
      --------------------------------------------------------------------------------
      PortName                           Status       Weight
      GigabitEthernet2/0/1               Up           1
      GigabitEthernet2/0/2               Up           1
      GigabitEthernet2/0/3               Up           1
      

      Las muestras de comando display eth-trunk 1 en SwitchB, SwitchC y SwitchD son similares a la muestra de comando en SwitchA.

    • Verifique la configuración de VRRP.

      # Ejecute el comando display vrrp en SwitchA. El resultado del comando muestra que SwitchA es Master en el grupo 1 de VRRP y Backup en el grupo 2 de VRRP.

      [SwitchA] display vrrp
      Vlanif100 | Virtual Router 1
          State : Master
          Virtual IP : 10.1.1.253
          Master IP : 10.1.1.1
          PriorityRun : 120
          PriorityConfig : 120
          MasterPriority : 120
          Preempt : YES   Delay Time : 20 s
          TimerRun : 1 s
          TimerConfig : 1 s
          Auth type : NONE
          Virtual MAC : 0000-5e00-0101
          Check TTL : YES
          Config type : normal-vrrp
          Backup-forward : disabled
          Create time : 2012-12-31 10:34:23 UTC-08:00
          Last change time : 2012-12-31 10:34:26 UTC-08:00
      
        Vlanif100 | Virtual Router 2
          State : Backup
          Virtual IP : 10.1.1.254
          Master IP : 10.1.1.2
          PriorityRun : 100
          PriorityConfig : 100
          MasterPriority : 120
          Preempt : YES   Delay Time : 0 s
          TimerRun : 1 s
          TimerConfig : 1 s
          Auth type : NONE
          Virtual MAC : 0000-5e00-0102
          Check TTL : YES
          Config type : normal-vrrp
          Backup-forward : disabled
          Create time : 2012-12-31 10:35:39 UTC-08:00
          Last change time : 2012-12-31 10:35:43 UTC-08:00
      

      # Ejecute el comando display vrrp en SwitchB. El resultado del comando muestra que SwitchB es Backup en el grupo 1 de VRRP y Master en el grupo 2 de VRRP.

      [SwitchB] display vrrp
      Vlanif100 | Virtual Router 1
          State : Backup
          Virtual IP : 10.1.1.253
          Master IP : 10.1.1.1
          PriorityRun : 100
          PriorityConfig : 100
          MasterPriority : 120
          Preempt : YES   Delay Time : 0 s
          TimerRun : 1 s
          TimerConfig : 1 s
          Auth type : NONE
          Virtual MAC : 0000-5e00-0101
          Check TTL : YES
          Config type : normal-vrrp
          Backup-forward : disabled
          Create time : 2012-12-31 10:34:23 UTC-08:00
          Last change time : 2012-12-31 10:34:26 UTC-08:00
      
        Vlanif100 | Virtual Router 2
          State : Master
          Virtual IP : 10.1.1.254
          Master IP : 10.1.1.2
          PriorityRun : 120
          PriorityConfig : 120
          MasterPriority : 120
          Preempt : YES   Delay Time : 20 s
          TimerRun : 1 s
          TimerConfig : 1 s
          Auth type : NONE
          Virtual MAC : 0000-5e00-0102
          Check TTL : YES
          Config type : normal-vrrp
          Backup-forward : disabled
          Create time : 2012-12-31 10:35:39 UTC-08:00
          Last change time : 2012-12-31 10:35:43 UTC-08:00
      

      Las muestras del comando display vrrp en SwitchC y SwitchD son similares a las muestras de comando en SwitchA y SwitchB.

    • Verifique la configuración de OSPF.

      # Ejecute el comando display ip routing-table en SwitchA. El resultado del comando muestra que hay dos enrutamientos de IP a 10.1.6.0/24, que implementan el equilibrio de carga del tráfico de unidifusión.

      [SwitchA] display ip routing-table
      Route Flags: R - relay, D - download to fib
      ------------------------------------------------------------------------------
      Routing Tables: Public
               Destinations : 15       Routes : 18       
      
      Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
      
             10.1.1.0/24  Direct  0    0           D   10.1.1.1        Vlanif100
             10.1.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif100
           10.1.1.253/32  Direct  0    0           D   127.0.0.1       Vlanif100
           10.1.1.254/32  Direct  0    0           D   127.0.0.1       Vlanif100
             10.1.2.0/24  Direct  0    0           D   10.1.2.1        Vlanif301
             10.1.2.1/32  Direct  0    0           D   127.0.0.1       Vlanif301
             10.1.3.0/24  Direct  0    0           D   10.1.3.1        Vlanif302
             10.1.3.1/32  Direct  0    0           D   127.0.0.1       Vlanif302
             10.1.4.0/24  OSPF    10   2           D   10.1.3.2        Vlanif302
             10.1.5.0/24  OSPF    10   2           D   10.1.2.2        Vlanif301
           10.1.6.0/24  OSPF    10   2           D   10.1.2.2        Vlanif301
                          OSPF    10   2           D   10.1.3.2        Vlanif302
           10.1.6.253/32  OSPF    10   2           D   10.1.2.2        Vlanif301
                          OSPF    10   2           D   10.1.3.2        Vlanif302
           10.1.6.254/32  OSPF    10   2           D   10.1.3.2        Vlanif302
                          OSPF    10   2           D   10.1.2.2        Vlanif301
            127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
            127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
      

      Las muestras del comando display ip routing-table en SwitchB, SwitchC y SwitchD son similares a la muestra del comando en SwitchA.

    • Verifique la configuración de PIM-SM.

      El origen de multidifusión 10.100.1.1 envía datos de multidifusión al grupo 225.0.0.10, y los hosts de usuario se han unido al grupo 225.0.0.10.

      # Ejecute el comando display pim routing-table en SwitchB y SwitchD. El resultado del comando muestra que las entradas de enrutamiento PIM se han creado para el grupo 225.0.0.10.

      NOTA:

      SwitchB y SwitchD implementan el enrutamiento de multidifusión de la siguiente manera:

      • De acuerdo con las reglas dinámicas de elección de RP, las interfaces C-RP tienen la misma máscara de dirección IP, prioridad y resultado de cálculo hash, la interfaz C-RP con una dirección IP más grande se convierte en RP. Por lo tanto, Loopback1 de SwitchD se convierte en la interfaz RP.
      • De acuerdo con las reglas de Reenvío de ruta inversa (RPF), si dos enrutamientos óptimos de costo igual están disponibles en la tabla de enrutamiento IP, la que tiene una dirección de siguiente salto más grande se selecciona como el enrutamiento RPF. Por lo tanto, SwitchD selecciona el enrutamiento con la dirección 10.1.5.1 de siguiente salto como el enrutamiento RPF al segmento de red de destino 10.1.1.0/24.
      [SwitchB] display pim routing-table
      VPN-Instance: public net
       Total 0 (*, G) entry; 1 (S, G) entry
       
       (10.100.1.1, 225.0.0.10)
           RP: 10.4.4.4
           Protocol: pim-sm, Flag: SPT ACT
           UpTime: 00:00:42
           Upstream interface: Vlanif100
               Upstream neighbor: 10.1.1.3
               RPF prime neighbor: 10.1.1.3
           Downstream interface(s) information:
           Total number of downstreams: 1
               1: Vlanif303
                   Protocol: pim-sm, UpTime: 00:00:42, Expires:-
      
      [SwitchD] display pim routing-table
      VPN-Instance: public net
       Total 0 (*, G) entry; 1 (S, G) entry
       
       (10.100.1.1, 225.0.0.10)
           RP: 10.4.4.4
           Protocol: pim-sm, Flag: SPT ACT
           UpTime: 00:00:42
           Upstream interface: Vlanif303
               Upstream neighbor: 10.1.4.1
               RPF prime neighbor: 10.1.4.1
           Downstream interface(s) information:
           Total number of downstreams: 1
               1: Vlanif400
                   Protocol: pim-sm, UpTime: 00:00:42, Expires:-
      
    • Verifique la configuración de BFD.

      # Ejecute el comando display ospf bfd session all en SwitchA. El resultado del comando muestra que las sesiones OSFF BFD se han configurado correctamente.

      [SwitchA] display ospf bfd session all
      OSPF Process 1 with Router ID 10.10.1.1
      
        Area 0.0.0.0 interface 10.1.1.1(Vlanif100)'s BFD Sessions
      
       NeighborId:10.2.2.2          AreaId:0.0.0.0          Interface: Vlanif100
       BFDState:up                 rx    :1000             tx       :1000
       Multiplier:3                BFD Local Dis:8196      LocalIpAdd:10.1.1.1
       RemoteIpAdd:10.1.1.2         Diagnostic Info:No diagnostic information
      
        Area 0.0.0.0 interface 10.1.1.1(Vlanif100)'s BFD Sessions
      
       NeighborId:5.5.5.5          AreaId:0.0.0.0          Interface: Vlanif100
       BFDState:up                 rx    :1000             tx       :1000
       Multiplier:4                BFD Local Dis:8195      LocalIpAdd:10.1.1.1
       RemoteIpAdd:10.1.1.3         Diagnostic Info:No diagnostic information
      
        Area 0.0.0.0 interface 10.1.2.1(Vlanif301)'s BFD Sessions
      
       NeighborId:10.3.3.3          AreaId:0.0.0.0          Interface: Vlanif301
       BFDState:up                 rx    :1000              tx       :1000
       Multiplier:3                BFD Local Dis:8194      LocalIpAdd:10.1.1.1
       RemoteIpAdd:10.1.2.2         Diagnostic Info:No diagnostic information
      
        Area 0.0.0.0 interface 10.1.3.1(Vlanif302)'s BFD Sessions
      
       NeighborId:10.4.4.4          AreaId:0.0.0.0          Interface: Vlanif302
       BFDState:up                 rx    :1000              tx       :1000
       Multiplier:3                BFD Local Dis:8193      LocalIpAdd:10.1.1.1
       RemoteIpAdd:10.1.3.2         Diagnostic Info:No diagnostic information

      La muestra del comando display ospf bfd session all en SwitchB, SwitchC y SwitchD son similares a la muestra del comando en SwitchA.

      # Ejecute el comando display pim bfd session en SwitchA. El resultado del comando muestra que las sesiones de PIM BFD se han configurado correctamente.

      [SwitchA] display pim bfd session
      VPN-Instance: public net
      Total 4 BFD session Created
       
      Vlanif100 (10.1.1.1): Total 2 BFD session Created
       
      Neighbor     ActTx(ms)     ActRx(ms)     ActMulti     Local/Remote     State
      10.1.1.2     1000           1000           3            8192/8192       Up
      10.1.1.3     1000           1000           3            8191/8191       Up
       
      Vlanif301 (10.1.2.1): Total 1 BFD session Created
       
      Neighbor     ActTx(ms)     ActRx(ms)     ActMulti     Local/Remote     State
      10.1.2.2     1000           1000           3            8193/8193       Up
       
      Vlanif302 (10.1.3.1): Total 1 BFD session Created
       
      Neighbor     ActTx(ms)     ActRx(ms)     ActMulti     Local/Remote     State
      10.1.3.2     1000           1000           3            8194/8194       Up

      Las muestras del comando display pim bfd session en SwitchB, SwitchC y SwitchD son similares a la muestra del comando en SwitchA.

Archivos de configuración

  • El archivo de configuración del gateway de salida del campus de SwitchA

    #
    sysname SwitchA
    # 
    vlan batch 100 200 301 to 302
    #
    multicast routing-enable
    #
    bfd
    #
    interface Vlanif100
     ip address 10.1.1.1 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.1.253
     vrrp vrid 1 priority 120
     vrrp vrid 1 preempt-mode timer delay 20
     vrrp vrid 2 virtual-ip 10.1.1.254
     pim sm
     pim bfd enable
     ospf bfd enable
    #
    interface Vlanif301
     ip address 10.1.2.1 255.255.255.0
     pim sm
     pim bfd enable
     ospf bfd enable
    #
    interface Vlanif302
     ip address 10.1.3.1 255.255.255.0
     pim sm
     pim bfd enable
     ospf bfd enable
    #
    interface Eth-Trunk1
     port link-type trunk
     port trunk allow-pass vlan 100 200
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet2/0/1
     eth-trunk 1
    #
    interface GigabitEthernet2/0/2
     eth-trunk 1
    #
    interface GigabitEthernet2/0/3
     eth-trunk 1
    #
    interface GigabitEthernet3/0/1
     port link-type trunk
     port trunk allow-pass vlan 301
    #
    interface GigabitEthernet3/0/2
     port link-type trunk
     port trunk allow-pass vlan 302
    #
    interface LoopBack1
     ip address 10.10.1.1 255.255.255.255
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.1.2.0 0.0.0.255
      network 10.1.3.0 0.0.0.255
      network 10.10.1.1 0.0.0.0
    #
    return
  • El archivo de configuración del gateway de salida del campus de SwitchB

    #
    sysname SwitchB
    # 
    vlan batch 100 200 303 to 304
    #
    multicast routing-enable
    #
    bfd
    #
    interface Vlanif100
     ip address 10.1.1.2 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.1.253
     vrrp vrid 2 virtual-ip 10.1.1.254
     vrrp vrid 2 priority 120
     vrrp vrid 2 preempt-mode timer delay 20
     pim sm
     pim bfd enable
     ospf bfd enable
    #
    interface Vlanif303
     ip address 10.1.4.1 255.255.255.0
     pim sm
     pim bfd enable
     ospf bfd enable
    #
    interface Vlanif304
     ip address 10.1.5.1 255.255.255.0
     pim sm
     pim bfd enable
     ospf bfd enable
    #
    interface Eth-Trunk1
     port link-type trunk
     port trunk allow-pass vlan 100 200
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet2/0/1
     eth-trunk 1
    #
    interface GigabitEthernet2/0/2
     eth-trunk 1
    #
    interface GigabitEthernet2/0/3
     eth-trunk 1
    #
    interface GigabitEthernet3/0/1
     port link-type trunk
     port trunk allow-pass vlan 303
    #
    interface GigabitEthernet3/0/2
     port link-type trunk
     port trunk allow-pass vlan 304
    #
    interface LoopBack1
     ip address 10.2.2.2 255.255.255.255
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.1.4.0 0.0.0.255
      network 10.1.5.0 0.0.0.255
      network 10.2.2.2 0.0.0.0
    #
    return
  • El archivo de configuración del dispositivo de core de SwitchC

    #
    sysname SwitchC
    # 
    vlan batch 301 304 400 500
    #
    multicast routing-enable
    #
    bfd
    #
    interface Vlanif301
     ip address 10.1.2.2 255.255.255.0
     pim sm
     pim bfd enable
     ospf bfd enable
    #
    interface Vlanif304
     ip address 10.1.5.2 255.255.255.0
     pim sm
     pim bfd enable
     ospf bfd enable
    #
    interface Vlanif400
     ip address 10.1.6.1 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.6.253
     vrrp vrid 1 priority 120
     vrrp vrid 1 preempt-mode timer delay 20
     vrrp vrid 2 virtual-ip 10.1.6.254
     pim sm
     pim bfd enable
     igmp enable
     ospf bfd enable
    #
    interface Eth-Trunk1
     port link-type trunk
     port trunk allow-pass vlan 400 500
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 400
     stp disable
    #
    interface GigabitEthernet2/0/1
     eth-trunk 1
    #
    interface GigabitEthernet2/0/2
     eth-trunk 1
    #
    interface GigabitEthernet2/0/3
     eth-trunk 1
    #
    interface GigabitEthernet3/0/1
     port link-type trunk
     port trunk allow-pass vlan 301
    #
    interface GigabitEthernet3/0/2
     port link-type trunk
     port trunk allow-pass vlan 304
    #
    interface LoopBack1
     ip address 10.3.3.3 255.255.255.255
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 10.1.2.0 0.0.0.255
      network 10.1.5.0 0.0.0.255
      network 10.1.6.0 0.0.0.255
      network 10.3.3.3 0.0.0.0
    #
    pim
     c-bsr LoopBack1
     c-rp LoopBack1
    #
    return
  • El archivo de configuración del dispositivo de core de SwitchD

    #
    sysname SwitchD
    # 
    vlan batch 302 to 303 400 500
    #
    multicast routing-enable
    #
    bfd
    #
    interface Vlanif302
     ip address 10.1.3.2 255.255.255.0
     pim sm
     pim bfd enable
     ospf bfd enable
    #
    interface Vlanif303
     ip address 10.1.4.2 255.255.255.0
     pim sm
     pim bfd enable
     ospf bfd enable
    #
    interface Vlanif400
     ip address 10.1.6.2 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.6.253
     vrrp vrid 2 virtual-ip 10.1.6.254
     vrrp vrid 2 priority 120
     vrrp vrid 2 preempt-mode timer delay 20
     pim sm
     pim bfd enable
     igmp enable
     ospf bfd enable
    #
    interface Eth-Trunk1
     port link-type trunk
     port trunk allow-pass vlan 400 500
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 400
     stp disable
    #
    interface GigabitEthernet2/0/1
     eth-trunk 1
    #
    interface GigabitEthernet2/0/2
     eth-trunk 1
    #
    interface GigabitEthernet2/0/3
     eth-trunk 1
    #
    interface GigabitEthernet3/0/1
     port link-type trunk
     port trunk allow-pass vlan 303
    #
    interface GigabitEthernet3/0/2
     port link-type trunk
     port trunk allow-pass vlan 302
    #
    interface LoopBack1
     ip address 10.4.4.4 255.255.255.255
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 10.1.3.0 0.0.0.255
      network 10.1.4.0 0.0.0.255
      network 10.1.6.0 0.0.0.255
      network 10.4.4.4 0.0.0.0
    #
    pim
     c-bsr LoopBack1
     c-rp LoopBack1
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15729

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente