No se encuentran recursos de mapeo en el idioma seleccionado.

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar la autenticación para usuarios de inicio de sesión de telnet (autenticación local de AAA)

Ejemplo para configurar la autenticación para usuarios de inicio de sesión de telnet (autenticación local de AAA)

Descripción general de la autenticación local de AAA

Los usuarios se autentican localmente a través de AAA. Para iniciar sesión en un dispositivo, el usuario debe introducir el nombre de usuario y la contraseña correcta. La información del usuario está configurada en el dispositivo local. No es necesario desplegar un servidor de autenticación en la red. Por lo tanto, la autenticación local de AAA es rápida y económica. Sin embargo, la cantidad de información de usuario que se puede almacenar depende de la capacidad del hardware del dispositivo.

Notas de configuración

Tabla 11-1  Productos y versiones aplicables

Modelo del producto

Versión del software

Switches fijos de la serie S

V100R006C05 y versiones posteriores

Switches modulares de la serie S

V200R001C00 y versiones posteriores

NOTA:
Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de redes

Como se muestra en Figura 11-1, el administrador debe administrar el dispositivo de forma remota de manera simplificada y segura. Los requisitos específicos son los siguientes:

  1. El administrador debe introducir el nombre de usuario y la contraseña correcta para iniciar sesión en el dispositivo a través de Telnet.
  2. Después de iniciar sesión en el dispositivo a través de Telnet, el administrador puede ejecutar los comandos en los niveles 0-3.
Figura 11-1  Configuración de la autenticación para usuarios de inicio de sesión de telnet (autenticación local de AAA)

Hoja de ruta de configuración

  1. Habilite el servicio Telnet.
  2. Defina el método de autenticación para usuarios de inicio de sesión de telnet a AAA.
  3. Configure la autenticación local de AAA, incluyendo la creación de un usuario local, estableciendo el tipo de acceso de usuario a telnet y estableciendo el nivel de usuario a 15.

Procedimiento

  1. Configure las interfaces y asigne direcciones IP.

    <Quidway> system-view
    [Quidway] sysname Switch
    [Switch] vlan batch 10
    [Switch] interface vlanif 10
    [Switch-Vlanif10] ip address 10.1.2.10 24
    [Switch-Vlanif10] quit
    [Switch] interface gigabitethernet1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type access
    [Switch-GigabitEthernet1/0/1] port default vlan 10
    [Switch-GigabitEthernet1/0/1] quit

  2. Habilite el servidor Telnet.

    [Switch] telnet server enable

  3. Defina el método de autenticación para la interfaz de usuario VTY a AAA.

    [Switch] user-interface maximum-vty 15  //Establezca la cantidad máxima de usos de inicio de sesión de VTY a 15 (El rango de valores varía de acuerdo con las versiones y los modelos del producto). De forma predeterminada, la cantidad máxima de usuarios de Telnet es de 5.
    [Switch] user-interface vty 0 14  //Introduzca la vista del usuario VTY 0-14.
    [Switch-ui-vty0-14] authentication-mode aaa  //Establezca el método de autenticación para la vista de usuario VTY a AAA.
    [Switch-ui-vty0-14] protocol inbound telnet  //Configure la interfaz de usuario VTY para admitir Telnet. De forma predeterminada, los switches en V200R006 y versiones anteriores son compatibles con Telnet, y los switches en V200R007 y versiones posteriores admiten SSH.
    [Switch-ui-vty0-14] quit

  4. Configure la autenticación local de AAA.

    [Switch] aaa
    [Switch-aaa] local-user user1 password irreversible-cipher Huawei@1234  //Cree el usuario local user1 y establezca la contraseña. La contraseña se muestra en el texto de cifrado en el archivo de configuración, así que recuerde la contraseña. Si olvida la contraseña, ejecute este comando nuevamente para reconfigurar la contraseña (el comando es local-user user-name password cipher password en V200R002 y versiones anteriores).
    [Switch-aaa] local-user user1 service-type telnet  //Establezca el tipo de acceso de user1 a Telnet. El usuario puede iniciar sesión únicamente a través de Telnet (de forma predeterminada, los usuarios pueden iniciar sesión a través de cualquier método en versiones anteriores a V200R007 y no pueden iniciar sesión a través de ningún método en V200R007 y versiones posteriores).
    [Switch-aaa] local-user user1 privilege level 15  //Establezca el nivel de usuario de user1 a 15. El usuario puede usar los comandos de nivel 3 y niveles inferiores.
    Warning: This operation may affect online users, are you sure to change the user privilege level ?[Y/N] y
    [Switch-aaa] quit
    NOTA:

    Cuando el nombre de usuario introducido no contiene un nombre de dominio, el dispositivo autentica al usuario a través del dominio administrativo predeterminado default_admin. De forma predeterminada, el dominio administrativo predeterminado utiliza el esquema de autenticación default y el esquema de contabilidad default.

    • Esquema de autenticación default: local authentication
    • Esquema de contabilidad default: non-accounting

  5. Verifique la configuración.

    Elija Start > Run en su computadora e introduzca cmd para abrir la ventana cmd. Ejecute el comando telnet e introduzca el nombre de usuario user1 y la contraseña Huawei@1234 para iniciar sesión en el dispositivo a través de Telnet.

    C:\Documents and Settings\Administrator> telnet 10.1.2.10
    Username:user1
    Password:***********
    <Switch>//El administrador inicia sesión con éxito.

Archivos de configuración

Archivo de configuración de Switch

#
sysname Switch
#
vlan batch 10
#
telnet server enable
#
aaa      
 local-user user1 password irreversible-cipher %^%#.)P`(ahmeXKljES$}IC%OdjjC$m)cA#}T(8z4*ZK!_Z+GSo<7C*O8WO,!rt;%^%#     
 local-user user1 privilege level 15       
 local-user user1 service-type telnet         
# 
interface Vlanif10 
 ip address 10.1.2.10 255.255.255.0     
# 
interface GigabitEthernet1/0/1         
 port link-type access           
 port default vlan 10 
#
user-interface maximum-vty 15     
user-interface vty 0 14    
 authentication-mode aaa    
 protocol inbound telnet
#
return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15765

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente