No se encuentran recursos de mapeo en el idioma seleccionado.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar la autenticación para usuarios de inicio de sesión de telnet (autenticación RADIUS)

Ejemplo para configurar la autenticación para usuarios de inicio de sesión de telnet (autenticación RADIUS)

Descripción general de la autenticación RADIUS

Cuando se implementa un servidor de autenticación RADIUS en una red, los usuarios pueden autenticarse a través de RADIUS. La información del usuario es creada y mantenida por el servidor de autenticación RADIUS. Un usuario puede iniciar sesión correctamente en el dispositivo sólo cuando el nombre de usuario y la contraseña introducida son los mismos que los configurados en el servidor RADIUS. Generalmente, la autenticación RADIUS está configurada en la red que requiere alta seguridad, por ejemplo, las redes de operadores financieros, gubernamentales y de telecomunicaciones.

Notas de configuración

Tabla 11-2  Productos y versiones aplicables

Modelo del producto

Versión del software

Switches fijos de la serie S

V100R006C05 y versiones posteriores

Switches modulares de la serie S

V200R001C00 y versiones posteriores

NOTA:
Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de redes

Como se muestra en Figura 11-2, un servidor RADIUS es implementado en una red. El administrador se autentica a través de RADIUS y telnet al dispositivo para administrarlo de forma remota. Los requisitos específicos son los siguientes:

  1. El administrador debe introducir el nombre de usuario y la contraseña correcta para iniciar sesión en el dispositivo a través de Telnet.
  2. Después de iniciar sesión en el dispositivo a través de Telnet, el administrador puede ejecutar los comandos en los niveles 0-15.
Figura 11-2  Configuración de la autenticación para usuarios de inicio de sesión de telnet (autenticación RADIUS)

Hoja de ruta de configuración

  1. Habilite el servicio Telnet.
  2. Defina el método de autenticación para usuarios de inicio de sesión de telnet a AAA.
  3. Configure la autenticación RADIUS, incluida la creación de una plantilla de servidor RADIUS, un esquema de autenticación AAA y un esquema de servicio, y la aplicación de los esquemas a un dominio.
  4. Configure el dominio al que pertenece el administrador como dominio administrativo predeterminado para que el administrador no tenga que introducir el nombre de dominio al iniciar sesión.
NOTA:

Este ejemplo sólo proporciona las configuraciones del dispositivo. Asegúrese de que los parámetros requeridos se han configurado en el servidor RADIUS, por ejemplo, la dirección IP del dispositivo, la clave compartida y el usuario que crea.

Procedimiento

  1. Configure las interfaces y asigne direcciones IP.

    <Quidway> system-view
    [Quidway] sysname Switch
    [Switch] vlan batch 10 20
    [Switch] interface vlanif 10
    [Switch-Vlanif10] ip address 10.1.2.10 24
    [Switch-Vlanif10] quit
    [Switch] interface vlanif 20
    [Switch-Vlanif20] ip address 10.1.6.10 24
    [Switch-Vlanif20] quit
    [Switch] interface gigabitethernet1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type access
    [Switch-GigabitEthernet1/0/1] port default vlan 10
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type access
    [Switch-GigabitEthernet1/0/2] port default vlan 20
    [Switch-GigabitEthernet1/0/2] quit

  2. Habilite el servidor Telnet.

    [Switch] telnet server enable
    

  3. Defina el método de autenticación para la interfaz de usuario VTY a AAA.

    [Switch] user-interface maximum-vty 15  //Establezca la cantidad máxima de usos de inicio de sesión de VTY a 15 (El rango de valores varía de acuerdo con las versiones y los modelos del producto). De forma predeterminada, la cantidad máxima de usuarios de Telnet es de 5.
    [Switch] user-interface vty 0 14  //Introduzca la vista del usuario VTY 0-14.
    [Switch-ui-vty0-14] authentication-mode aaa  //Establezca el método de autenticación para la vista de usuario VTY a AAA.
    [Switch-ui-vty0-14] protocol inbound telnet  //Configure la interfaz de usuario VTY para admitir Telnet. De forma predeterminada, los switches en V200R006 y versiones anteriores son compatibles con Telnet, y los switches en V200R007 y versiones posteriores admiten SSH.
    [Switch-ui-vty0-14] quit

  4. Configure la autenticación RADIUS.

    # Configure la plantilla de servidor RADIUS para implementar la comunicación entre el dispositivo y el servidor RADIUS.

    [Switch] radius-server template 1
    [Switch-radius-1] radius-server authentication 10.1.6.6 1812  //Especifique la dirección IP y el número de puerto del servidor de autenticación RADIUS.
    [Switch-radius-1] radius-server shared-key cipher Hello@1234  //Especifique la clave compartida del servidor RADIUS, que debe ser la misma que la configurada en el servidor RADIUS.
    [Switch-radius-1] quit
    NOTA:

    Si el servidor RADIUS no acepta los nombres de usuario que contienen nombres de dominio, ejecute el comando undo radius-server user-name domain-included en el dispositivo para que los paquetes enviados desde el dispositivo al servidor RADIUS no contengan nombres de dominio.

    # Configure un esquema de autenticación AAA y configure el modo de autenticación a RADIUS.

    [Switch] aaa
    [Switch-aaa] authentication-scheme sch1
    [Switch-aaa-authen-sch1] authentication-mode radius
    [Switch-aaa-authen-sch1] quit

    # Configure un esquema de servicio y configure el nivel de usuario a 15.

    [Switch-aaa] service-scheme sch1
    [Switch-aaa-service-sch1] admin-user privilege level 15
    [Switch-aaa-service-sch1] quit

    # Aplique el esquema de autenticación AAA, la plantilla de servidor RADIUS y el esquema de servicio al dominio.

    [Switch-aaa] domain huawei.com
    [Switch-aaa-domain-huawei.com] authentication-scheme sch1
    [Switch-aaa-domain-huawei.com] radius-server 1
    [Switch-aaa-domain-huawei.com] service-scheme sch1
    [Switch-aaa-domain-huawei.com] quit
    [Switch-aaa] quit

  5. Configure el dominio al que pertenece el administrador como dominio administrativo predeterminado para que el administrador no tenga que introducir el nombre de dominio al iniciar sesión en el dispositivo a través de Telnet.

    [Switch] domain huawei.com admin
    

  6. Verifique la configuración.

    # Ejecute el comando test-aaa en el dispositivo para probar si el administrador puede pasar la autenticación.

    [Switch] test-aaa user1 Huawei@1234 radius-template 1

    # Elija Start > Run en su computadora donde se ejecuta el sistema operativo Windows e introduzca cmd para abrir la ventana cmd. Ejecute el comando telnet e introduzca el nombre de usuario user1 y la contraseña Huawei@1234 para iniciar sesión en el dispositivo a través de Telnet.

    C:\Documents and Settings\Administrator> telnet 10.1.2.10
    Username:user1
    Password:***********
    <Switch>//El administrador inicia sesión con éxito.

Archivos de configuración

Archivo de configuración de Switch

#
sysname Switch
#
vlan batch 10 20
#
domain huawei.com admin 
#
telnet server enable
#
radius-server template 1                                                        
 radius-server shared-key cipher %^%#Zh-H!i<+2RUI,E4_q<''+[14Fmj4@>Aa0pM0H}@D%^%#
 radius-server authentication 10.1.6.6 1812 weight 80                           
#
aaa
 authentication-scheme sch1    
  authentication-mode radius  
 service-scheme sch1             
  admin-user privilege level 15
 domain huawei.com            
  authentication-scheme sch1     
  service-scheme sch1 
  radius-server 1      
# 
interface Vlanif10 
 ip address 10.1.2.10 255.255.255.0     
# 
interface Vlanif20 
 ip address 10.1.6.10 255.255.255.0     
# 
interface GigabitEthernet1/0/1         
 port link-type access           
 port default vlan 10 
#
interface GigabitEthernet1/0/2         
 port link-type access           
 port default vlan 20 
#
user-interface maximum-vty 15  
user-interface vty 0 14          
 authentication-mode aaa          
 protocol inbound telnet
#
return

Contenido relacionado

Herramienta de consulta de atributos de AAA

Esta herramienta muestra detalles sobre los atributos de AAA en los switches. No es necesario registrar una cuenta de Huawei antes de utilizar esta herramienta.

AAA Attribute Query Tool

Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15571

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente