No se encuentran recursos de mapeo en el idioma seleccionado.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar la autenticación para usuarios de inicio de sesión de telnet (autenticación HWTACACS y local)

Ejemplo para configurar la autenticación para usuarios de inicio de sesión de telnet (autenticación HWTACACS y local)

Descripción general de autenticación HWTACACS y local

Cuando se despliega un servidor de autenticación HWTACACS en una red, los usuarios pueden autenticarse a través de HWTACACS. La información del usuario es creada y mantenida por el servidor de autenticación HWTACACS. Un usuario puede iniciar sesión correctamente en el dispositivo sólo cuando el nombre de usuario y la contraseña introducidas son los mismos que los configurados en el servidor HWTACACS. Comparado con RADIUS, HWTACACS es más confiable en la transmisión y en la encriptación, y es más conveniente para el control de seguridad. Generalmente, la autenticación HWTACACS está configurada en la red que requiere alta seguridad, por ejemplo, las redes de operadores financieros, gubernamentales y de telecomunicaciones.

Tanto la autenticación HWTACACS como la autenticación local se configuran en un dispositivo, cuando el servidor HWTACACS no responde, el dispositivo realiza la autenticación local. Si sólo se configura la autenticación HWTACACS, los usuarios fallan en la autenticación cuando el dispositivo no se puede conectar al servidor HWTACACS.

Notas de configuración

Tabla 11-6  Productos y versiones aplicables

Modelo del producto

Versión del software

Switches fijos de la serie S

V100R006C05 y versiones posteriores

Switches modulares de la serie S

V200R001C00 y versiones posteriores

NOTA:
Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de redes

Como se muestra en Figura 11-22, un servidor HWTACACS se implementa en una red y el administrador hace Telnet al dispositivo para administrarlo de manera remota. Los requisitos específicos son los siguientes:

  1. El administrador debe introducir el nombre de usuario y la contraseña correcta para iniciar sesión en el dispositivo a través de Telnet.
  2. El dispositivo realiza primero la autenticación HWTACACS para el administrador. Si el servidor HWTACACS no responde, el dispositivo realiza la autenticación local.
  3. Después de iniciar sesión en el dispositivo a través de Telnet, el administrador puede ejecutar los comandos en los niveles 0-15.
Figura 11-22  Configuración de la autenticación para usuarios de inicio de sesión de telnet (autenticación HWTACACS y local)

Hoja de ruta de configuración

  1. Habilite el servicio Telnet.
  2. Defina el método de autenticación para usuarios de inicio de sesión de telnet a AAA.
  3. Configure la autenticación local de AAA, incluyendo la creación de un usuario local, estableciendo el tipo de acceso de usuario a telnet y estableciendo el nivel de usuario a 15.
  4. Configure la autenticación HWTACACS, incluyendo la creación de una plantilla de servidor HWTACACS, un esquema de autenticación AAA y un esquema de servicio, y la aplicación de los esquemas a un dominio.
NOTA:

Este ejemplo sólo proporciona las configuraciones del dispositivo. Asegúrese de que los parámetros requeridos se han configurado en el servidor HWTACACS, por ejemplo, la dirección IP del dispositivo, la clave compartida y la información del usuario.

Procedimiento

  1. Configure las interfaces y asigne direcciones IP.

    <Quidway> system-view
    [Quidway] sysname Switch
    [Switch] vlan batch 10 20
    [Switch] interface vlanif 10
    [Switch-Vlanif10] ip address 10.1.2.10 24
    [Switch-Vlanif10] quit
    [Switch] interface vlanif 20
    [Switch-Vlanif20] ip address 10.1.6.10 24
    [Switch-Vlanif20] quit
    [Switch] interface gigabitethernet1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type access
    [Switch-GigabitEthernet1/0/1] port default vlan 10
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type access
    [Switch-GigabitEthernet1/0/2] port default vlan 20
    [Switch-GigabitEthernet1/0/2] quit

  2. Habilite el servidor Telnet.

    [Switch] telnet server enable
    

  3. Defina el método de autenticación para la interfaz de usuario VTY a AAA.

    [Switch] user-interface maximum-vty 15  //Establezca la cantidad máxima de usos de inicio de sesión de VTY a 15 (El rango de valores varía de acuerdo con las versiones y los modelos del producto). De forma predeterminada, la cantidad máxima de usuarios de Telnet es de 5.
    [Switch] user-interface vty 0 14  //Introduzca la vista del usuario VTY 0-14.
    [Switch-ui-vty0-14] authentication-mode aaa  //Establezca el método de autenticación para la vista de usuario VTY a AAA.
    [Switch-ui-vty0-14] protocol inbound telnet  //Configure la interfaz de usuario VTY para admitir Telnet. De forma predeterminada, los switches en V200R006 y versiones anteriores son compatibles con Telnet, y los switches en V200R007 y versiones posteriores admiten SSH.
    [Switch-ui-vty0-14] quit

  4. Configure la autenticación local de AAA.

    [Switch] aaa
    [Switch-aaa] local-user user1@huawei.com password irreversible-cipher Huawei@1234  //Cree el usuario local user1@huawei.com y establezca la contraseña. La contraseña se muestra en el texto de cifrado en el archivo de configuración, así que recuerde la contraseña. Si olvida la contraseña, ejecute este comando nuevamente para reconfigurar la contraseña  (el comando es local-user user-name password cipher password en V200R002 y versiones anteriores).
    [Switch-aaa] local-user user1@huawei.com service-type telnet  //Establezca el tipo de acceso de user1@huawei.com a Telnet. El usuario puede iniciar sesión únicamente a través de Telnet  (de forma predeterminada, los usuarios pueden iniciar sesión a través de cualquier método en versiones anteriores a V200R007 y no pueden iniciar sesión a través de ningún método en V200R007 y versiones posteriores).
    [Switch-aaa] local-user user1@huawei.com privilege level 15  //Establezca el nivel de usuario de user1@huawei.com a 15. El usuario puede usar los comandos de nivel 15 y niveles inferiores.
    [Switch-aaa] quit

  5. Configure la autenticación HWTACACS.

    # Configure una plantilla de servidor HWTACACS para implementar la comunicación entre el dispositivo y el servidor HWTACACS.

    [Switch] hwtacacs-server template 1
    [Switch-hwtacacs-1] hwtacacs-server authentication 10.1.6.6 49  //Especifique la dirección IP y el número de puerto del servidor de autenticación HWTACACS.
    [Switch-hwtacacs-1] hwtacacs-server shared-key cipher Hello@1234  //Especifique la clave compartida del servidor HWTACACS, que debe ser la misma que la configurada en el servidor HWTACACS.
    [Switch-hwtacacs-1] quit

    # Configure un esquema de autenticación AAA, establezca los métodos de autenticación a HWTACACS y autenticación local.

    [Switch] aaa
    [Switch-aaa] authentication-scheme sch1
    [Switch-aaa-authen-sch1] authentication-mode hwtacacs local
    [Switch-aaa-authen-sch1] quit

    # Configure un esquema de servicio y configure el nivel de usuario a 15.

    [Switch-aaa] service-scheme sch1
    [Switch-aaa-service-sch1] admin-user privilege level 15
    [Switch-aaa-service-sch1] quit

    # Aplique el esquema de autenticación AAA, la plantilla de servidor HWTACACS y el esquema de servicio al dominio.

    [Switch-aaa] domain huawei.com
    [Switch-aaa-domain-huawei.com] authentication-scheme sch1
    [Switch-aaa-domain-huawei.com] hwtacacs-server 1
    [Switch-aaa-domain-huawei.com] service-scheme sch1
    [Switch-aaa-domain-huawei.com] quit
    [Switch-aaa] quit

  6. Verifique la configuración.

    # Elija Start > Run en su computadora donde se ejecuta el sistema operativo Windows e introduzca cmd para abrir la ventana cmd. Ejecute el comando telnet e introduzca el nombre de usuario user1@huawei.com y la contraseña Huawei@1234 para iniciar sesión en el dispositivo a través de Telnet.

    C:\Documents and Settings\Administrator> telnet 10.1.2.10
    Username:user1@huawei.com
    Password:***********
    <Switch>//El administrador inicia sesión con éxito.

    # Apague la interfaz conectada al servidor de autenticación HWTACACS, para desconectar el dispositivo del servidor HWTACACS. Elija Start > Run en su computadora e introduzca cmd para abrir la ventana cmd. Ejecute el comando telnet e introduzca el nombre de usuario user1@huawei.com y la contraseña Huawei@1234 para iniciar sesión en el dispositivo a través de Telnet. Puede iniciar sesión correctamente en el dispositivo, lo que indica que el dispositivo realiza la autenticación local cuando el servidor HWTACACS no responde.

Archivos de configuración

Archivo de configuración de Switch

#
sysname Switch
#
vlan batch 10 20
#
telnet server enable
#
hwtacacs-server template 1                                                      
 hwtacacs-server authentication 10.1.6.6                                   
 hwtacacs-server shared-key cipher %^%#q(P3<qAXm=Pq).G8bgq@"sbFOf%0k%umgQJ3#MF3%^%#
#
aaa
 authentication-scheme sch1    
  authentication-mode hwtacacs local
 service-scheme sch1             
  admin-user privilege level 15
 domain huawei.com                                                              
  authentication-scheme sch1                                                    
  service-scheme sch1                                                           
  hwtacacs-server 1 
 local-user user1@huawei.com password irreversible-cipher %^%#+bxGT|w}~J-FHdDG"R8"($BX%XF/R1uba0UwL0).&r"Z#zbz*2G1$%6)Rd/V%^%#
 local-user user1@huawei.com privilege level 15       
 local-user user1@huawei.com service-type telnet 
# 
interface Vlanif10 
 ip address 10.1.2.10 255.255.255.0     
# 
interface Vlanif20 
 ip address 10.1.6.10 255.255.255.0     
# 
interface GigabitEthernet1/0/1         
 port link-type access           
 port default vlan 10 
#
interface GigabitEthernet1/0/2         
 port link-type access           
 port default vlan 20 
#
user-interface maximum-vty 15  
user-interface vty 0 14          
 authentication-mode aaa          
 protocol inbound telnet
#
return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15469

Descargas: 129

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente