No se encuentran recursos de mapeo en el idioma seleccionado.

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar la autenticación de dirección MAC para controlar el acceso del usuario

Ejemplo para configurar la autenticación de dirección MAC para controlar el acceso del usuario

Descripción general de la autenticación de dirección MAC

Como uno de los modos de autenticación NAC, la autenticación de dirección MAC controla los derechos de acceso a la red de un usuario en función de la interfaz del usuario y la dirección MAC. El usuario no debe instalar ningún software de cliente. La autenticación de dirección MAC garantiza la seguridad de las intranets empresariales.

En la autenticación de dirección MAC, el software del cliente no debe instalarse en los terminales del usuario, pero las direcciones MAC deben estar registradas en los servidores, lo que resulta en una administración compleja. Otros dos métodos de autenticación NAC tienen sus ventajas y desventajas: La autenticación 802.1X garantiza una alta seguridad, pero se requiere que el software del cliente 802.1X se instale en los terminales del usuario, lo que causa una implementación inflexible de la red. La autenticación Portal tampoco requiere la instalación del software del cliente y proporciona una implementación flexible, pero tiene poca seguridad.

La autenticación de dirección MAC se aplica para acceder a escenarios de autenticación de terminales tontos, como impresoras y máquinas de fax.

Notas de configuración

Este ejemplo se aplica a todos los switches de la serie S.

NOTA:
Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de redes

Como se muestra Figura 11-30, los terminales en un departamento de control de acceso físico de una compañía están conectados a la red interna de la compañía a través del Switch. El acceso no autorizado a la red interna puede dañar el sistema de servicio de la empresa y provocar la fuga de la información clave. Por lo tanto, el administrador requiere que el Switch controle los derechos de acceso a la red de los usuarios para garantizar la seguridad de la red interna.

Debido a que terminales tontos (como impresoras) en el departamento de control de acceso físico no pueden tener instalado el cliente de autenticación, la autenticación de dirección MAC debe configurarse en el Switch. Las direcciones MAC de los terminales se utilizan como información del usuario y se envían al servidor RADIUS para su autenticación. Cuando los usuarios se conectan a la red, no se requiere autenticación.

Figura 11-30  Diagrama de redes para configurar la autenticación de dirección MAC

Hoja de ruta de configuración

La hoja de ruta de configuración es la siguiente:

  1. Configure las interconexiones de red.
  2. Configure AAA en el Switch para implementar autenticación de identidad en los usuarios de acceso a través del servidor RADIUS. La configuración incluye configurar una plantilla de servidor RADIUS, un esquema AAA y un dominio de autenticación, y enlazar la plantilla de servidor RADIUS y el esquema AAA con el dominio de autenticación.
  3. Configure la autenticación de dirección MAC para que el Switch pueda controlar los derechos de acceso a la red de los terminales tontos en el departamento de control de acceso físico. La configuración incluye:
    1. Configure un perfil de acceso MAC.
    2. Configure un perfil de autenticación.
    3. Habilite la autenticación de dirección MAC en una interfaz.
NOTA:
  • Antes de realizar operaciones en este ejemplo, asegúrese de que los terminales de acceso de usuario y el servidor puedan comunicarse.

  • Este ejemplo solo proporciona la configuración del Switch. Las configuraciones del LAN Switch y el servidor no se proporcionan aquí.

Procedimiento

  1. Cree las VLAN y configure las VLAN permitidas por las interfaces para que los paquetes puedan reenviarse.

    # Cree VLAN 10 y VLAN 20.

    <Quidway> system-view
    [Quidway] sysname Switch
    [Switch] vlan batch 10 20

    # Configure GE1/0/1 conectando el Switch a los usuarios como una interfaz de acceso y agregue la interfaz a la VLAN 10.

    [Switch] interface gigabitethernet1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type access
    [Switch-GigabitEthernet1/0/1] port default vlan 10 
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface vlanif 10
    [Switch-Vlanif10] ip address 192.168.1.10 24
    [Switch-Vlanif10] quit

    # Configure GE1/0/2 conectando el Switch al servidor RADIUS como una interfaz de acceso y agregue la interfaz a la VLAN 20.

    [Switch] interface gigabitethernet1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type access
    [Switch-GigabitEthernet1/0/2] port default vlan 20 
    [Switch-GigabitEthernet1/0/2] quit
    [Switch] interface vlanif 20
    [Switch-Vlanif20] ip address 192.168.2.10 24
    [Switch-Vlanif20] quit

  2. Configure AAA.

    # Cree y configure la plantilla de servidor RADIUS rd1.

    [Switch] radius-server template rd1
    [Switch-radius-rd1] radius-server authentication 192.168.2.30 1812
    [Switch-radius-rd1] radius-server shared-key cipher Huawei@2012
    [Switch-radius-rd1] quit

    # Cree el esquema de autenticación AAA abc y establezca el modo de autenticación a RADIUS.

    [Switch] aaa
    [Switch-aaa] authentication-scheme abc
    [Switch-aaa-authen-abc] authentication-mode radius
    [Switch-aaa-authen-abc] quit

    # Cree un dominio de autenticación huawei.com, y enlace el esquema de autenticación AAA abc y la plantilla de servidor RADIUS rd1 con el dominio.

    [Switch-aaa] domain huawei.com
    [Switch-aaa-domain-huawei.com] authentication-scheme abc
    [Switch-aaa-domain-huawei.com] radius-server rd1
    [Switch-aaa-domain-huawei.com] quit
    [Switch-aaa] quit

    # Compruebe si un usuario puede pasar la autenticación RADIUS. La prueba del usuario test y la contraseña Huawei2012 se han configurado en el servidor RADIUS.

    [Switch] test-aaa test Huawei2012 radius-template rd1
    Info: Account test succeed.

  3. Configure la autenticación de dirección MAC.

    # Establezca el modo NAC al unificado.
    [Switch] authentication unified-mode
    NOTA:
    • Por defecto, se usa el modo unificado.
    • Después de cambiar el modo NAC del común al unificado, guarde la configuración y reinicie el dispositivo para que la configuración surta efecto.

    # Configure el perfil de acceso MAC m1.

    NOTA:

    En un perfil de acceso MAC, se usa una dirección MAC sin guiones (-) como nombre de usuario y contraseña para la autenticación de dirección MAC. Asegúrese de que los formatos del nombre de usuario y la contraseña para la autenticación de dirección MAC configurados en el servidor RADIUS sean los mismos que los configurados en el dispositivo de acceso.

    [Switch] mac-access-profile name m1
    [Switch-mac-access-profile-m1] quit

    # Configure el perfil de autenticación p1, enlace el perfil de acceso MAC m1 con el perfil de autenticación, especifique el dominio huawei.com como el dominio de autenticación forzada en el perfil de autenticación, establezca el modo de acceso de usuario a multi-authen, y establezca el número máximo de los usuarios de acceso a 100.

    [Switch] authentication-profile name p1
    [Switch-authen-profile-p1] mac-access-profile m1
    [Switch-authen-profile-p1] access-domain huawei.com force
    [Switch-authen-profile-p1] authentication mode multi-authen max-user 100
    [Switch-authen-profile-p1] quit

    # Enlace el perfil de autenticación p1 a GE1/0/1 y habilite la autenticación de dirección MAC en la interfaz.

    [Switch] interface gigabitethernet1/0/1
    [Switch-GigabitEthernet1/0/1] authentication-profile p1
    [Switch-GigabitEthernet1/0/1] quit

    # (Recomendado) Configure la dirección IP de origen y la dirección MAC de origen para los paquetes de detección fuera de línea en una VLAN especificada. Se le recomienda configurar la dirección IP del gateway de usuario y su dirección MAC correspondiente como la dirección IP de origen y la dirección MAC de origen de los paquetes de detección fuera de línea.

    [Switch] access-user arp-detect vlan 10 ip-address 192.168.1.10 mac-address 2222-1111-1234

  4. Verifique la configuración.

    1. Después de que un usuario inicie un terminal, el dispositivo obtiene automáticamente la dirección MAC del terminal de usuario como nombre de usuario y contraseña para la autenticación.
    2. Los usuarios pueden acceder a la red después de ser autenticados con éxito.
    3. Después de que los usuarios se conecten, puede ejecutar el comando display access-user access-type mac-authen en el dispositivo para ver información sobre los usuarios de autenticación de dirección MAC en línea.

Archivos de configuración

Archivo de configuración del Switch

#
sysname Switch
#
vlan batch 10 20
#
authentication-profile name p1
 mac-access-profile m1
 authentication mode multi-authen max-user 100
 access-domain huawei.com force
#
access-user arp-detect vlan 10 ip-address 192.168.1.10 mac-address 2222-1111-1234
#
radius-server template rd1
 radius-server shared-key cipher %#%#4*SO-2u,Q.\1C~%[eiB77N/^2wME;6t%6U@qAJ9:%#%#
 radius-server authentication 192.168.2.30 1812 weight 80
#
mac-access-profile name m1
#
aaa
 authentication-scheme abc
  authentication-mode radius
 domain huawei.com
  authentication-scheme abc
  radius-server rd1
#
interface GigabitEthernet1/0/1
 port link-type access
 port default vlan 10
 authentication-profile p1
#
interface GigabitEthernet1/0/2
 port link-type access
 port default vlan 20
#
interface Vlanif10
 ip address 192.168.1.10 255.255.255.0
#
interface Vlanif20
 ip address 192.168.2.10 255.255.255.0
#
return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15785

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente