No se encuentran recursos de mapeo en el idioma seleccionado.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar la autenticación de dirección MAC para controlar el acceso del usuario

Ejemplo para configurar la autenticación de dirección MAC para controlar el acceso del usuario

Descripción general de la autenticación de dirección MAC

Como uno de los modos de autenticación NAC, la autenticación de dirección MAC controla los derechos de acceso a la red de un usuario en función de la interfaz del usuario y la dirección MAC. El usuario no debe instalar ningún software de cliente. La autenticación de dirección MAC garantiza la seguridad de las intranets empresariales.

En la autenticación de dirección MAC, el software del cliente no debe instalarse en los terminales del usuario, pero las direcciones MAC deben estar registradas en los servidores, lo que resulta en una administración compleja. Otros dos métodos de autenticación NAC tienen sus ventajas y desventajas: La autenticación 802.1X garantiza una alta seguridad, pero se requiere que el software del cliente 802.1X se instale en los terminales del usuario, lo que causa una implementación inflexible de la red. La autenticación Portal tampoco requiere la instalación del software del cliente y proporciona una implementación flexible, pero tiene poca seguridad.

La autenticación de dirección MAC se aplica para acceder a escenarios de autenticación de terminales tontos, como impresoras y máquinas de fax.

Notas de configuración

Este ejemplo se aplica a todos los switches de la serie S.

NOTA:
Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de redes

Como se muestra Figura 11-37, los terminales en el departamento de control de acceso físico están conectados a la red interna de la compañía a través de Switch. El acceso no autorizado a la red interna puede dañar el sistema de servicio de la empresa y provocar la fuga de información clave. Por lo tanto, el administrador requiere que Switch debe controlar los derechos de acceso a la red de los usuarios para garantizar la seguridad de la red interna.

Figura 11-37  Configuración de la autenticación de dirección MAC para controlar el acceso del usuario

Hoja de ruta de configuración

La hoja de ruta de configuración es la siguiente:

  1. Cree y configure una plantilla de servidor RADIUS, un esquema AAA y un dominio de autenticación. Enlace la plantilla de servidor RADIUS y el esquema AAA al dominio de autenticación para que Switch pueda autenticar a los usuarios de acceso a través del servidor RADIUS.
  2. Habilite la autenticación de la dirección MAC para que Switch pueda controlar los derechos de acceso a la red de los terminales tontos en el departamento de control de acceso físico.
  3. Configure el modo de acceso del usuario para multi-autenticar y establezca el número máximo de usuarios de acceso a 100, por lo que el dispositivo puede controlar los derechos de acceso a la red de cada usuario de forma independiente.
NOTA:

Antes de configurar este ejemplo, asegúrese de que los dispositivos se puedan comunicar entre ellos en la red.

Procedimiento

  1. Cree las VLAN y configure las VLAN permitidas por la interfaz para garantizar la comunicación de la red.

    # Cree VLAN 10 y VLAN 20.

    <Quidway> system-view
    [Quidway] sysname Switch
    [Switch] vlan batch 10 20

    # En Switch, configure la interfaz GE1/0/1 conectada a los usuarios como una interfaz de acceso y agregue la interfaz a la VLAN 10.

    [Switch] interface gigabitethernet1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type access
    [Switch-GigabitEthernet1/0/1] port default vlan 10 
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface vlanif 10
    [Switch-Vlanif10] ip address 192.168.1.10 24
    [Switch-Vlanif10] quit
    NOTA:

    Configure el tipo de interfaz y las VLAN según los requisitos del sitio. En este ejemplo, los usuarios se agregan a la VLAN 10.

    # En Switch, configure la interfaz GE1/0/2 conectada al servidor RADIUS como una interfaz de acceso y agregue la interfaz a la VLAN 20.

    [Switch] interface gigabitethernet1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type access
    [Switch-GigabitEthernet1/0/2] port default vlan 20
    [Switch-GigabitEthernet1/0/2] quit

  2. Cree y configure una plantilla de servidor RADIUS, un esquema AAA y un dominio de autenticación.

    # Cree y configure la plantilla de servidor RADIUS rd1.

    [Switch] radius-server template rd1
    [Switch-radius-rd1] radius-server authentication 192.168.2.30 1812
    [Switch-radius-rd1] radius-server shared-key cipher Huawei@2012
    [Switch-radius-rd1] quit

    # Cree un esquema de autenticación AAA abc y configure el modo de autenticación a RADIUS.

    [Switch] aaa
    [Switch-aaa] authentication-scheme abc
    [Switch-aaa-authen-abc] authentication-mode radius
    [Switch-aaa-authen-abc] quit

    # Cree un dominio de autenticación isp1, y enlace el esquema AAA abc y la plantilla de servidor RADIUS rd1 al dominio isp1.

    [Switch-aaa] domain isp1
    [Switch-aaa-domain-isp1] authentication-scheme abc
    [Switch-aaa-domain-isp1] radius-server rd1
    [Switch-aaa-domain-isp1] quit
    [Switch-aaa] quit

    # Configure isp1 como el dominio predeterminado global. Durante la autenticación de acceso, introduzca un nombre de usuario en el formato user@isp1 para realizar la autenticación AAA en el dominio isp1. Si el nombre de usuario no contiene el nombre de dominio o contiene un nombre de dominio inválido, el usuario se autentica en el dominio predeterminado.

    [Switch] domain isp1

  3. Configure la autenticación de dirección MAC en Switch.

    # Cambie el modo NAC al modo unificado.
    [Switch] authentication unified-mode
    NOTA:

    Después de cambiar el modo común y el modo unificado, el dispositivo se reinicia automáticamente.

    # Habilite la autenticación de dirección MAC en la interfaz GE1/0/1.

    [Switch] interface gigabitethernet1/0/1
    [Switch-GigabitEthernet1/0/1] authentication mac-authen
    [Switch-GigabitEthernet1/0/1] authentication mode multi-authen max-user 100
    [Switch-GigabitEthernet1/0/1] quit

    # (Recomendado) Configure la dirección IP de origen y la dirección MAC de origen para los paquetes de detección fuera de línea en una VLAN especificada. Se le recomienda configurar la dirección IP del gateway de usuario y su dirección MAC correspondiente como la dirección IP de origen y la dirección MAC de origen de los paquetes de detección fuera de línea.

    [Switch] access-user arp-detect vlan 10 ip-address 192.168.1.10 mac-address 2222-1111-1234

  4. Verifique la configuración.

    1. Ejecute el comando display mac-authen para verificar la configuración de la autenticación de dirección MAC. La salida del comando (MAC address authentication is enabled) muestra que la autenticación de dirección MAC se ha habilitado en la interfaz GE1/0/1.
    2. Después de que el usuario inicie el terminal, el dispositivo obtiene automáticamente la dirección MAC del terminal y la usa como nombre de usuario y contraseña para la autenticación.
    3. El usuario puede acceder a la red después de que la autenticación sea exitosa.
    4. Después de que el usuario se conecte, puede ejecutar el comando display access-user access-type mac-authen en el dispositivo para verificar la información de usuario de autenticación de dirección MAC en línea.

Archivos de configuración

Archivo de configuración de Switch

#
sysname Switch
#
vlan batch 10 20
#
domain isp1 
#
access-user arp-detect vlan 10 ip-address 192.168.1.10 mac-address 2222-1111-1234
#
radius-server template rd1
 radius-server shared-key cipher %^%#Q75cNQ6IF(e#L4WMxP~%^7'u17,]D87GO{"[o]`D%^%#
 radius-server authentication 192.168.2.30 1812 weight 80
#
aaa
 authentication-scheme abc
  authentication-mode radius  
 domain isp1
  authentication-scheme abc
  radius-server rd1
#
interface GigabitEthernet1/0/1
 port link-type access
 port default vlan 10
 authentication mac-authen 
 authentication mode multi-authen max-user 100    
#
interface GigabitEthernet1/0/2
 port link-type access
 port default vlan 20   
#                                                                               
return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15592

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente