No se encuentran recursos de mapeo en el idioma seleccionado.

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar la autenticación de dirección MAC para controlar el acceso del usuario

Ejemplo para configurar la autenticación de dirección MAC para controlar el acceso del usuario

Descripción general de la autenticación de dirección MAC

Como uno de los modos de autenticación NAC, la autenticación de dirección MAC controla los derechos de acceso a la red de un usuario en función de la interfaz del usuario y la dirección MAC. El usuario no debe instalar ningún software de cliente. La autenticación de dirección MAC garantiza la seguridad de las intranets empresariales.

En la autenticación de dirección MAC, el software del cliente no debe instalarse en los terminales del usuario, pero las direcciones MAC deben estar registradas en los servidores, lo que resulta en una administración compleja. Otros dos métodos de autenticación NAC tienen sus ventajas y desventajas: La autenticación 802.1X garantiza una alta seguridad, pero se requiere que el software del cliente 802.1X se instale en los terminales del usuario, lo que causa una implementación inflexible de la red. La autenticación Portal tampoco requiere la instalación del software del cliente y proporciona una implementación flexible, pero tiene poca seguridad.

La autenticación de dirección MAC se aplica para acceder a escenarios de autenticación de terminales tontos, como impresoras y máquinas de fax.

Notas de configuración

Este ejemplo se aplica a todos los switches de la serie S en V100R006C05, V200R001C00 o una versión posterior.

NOTA:
Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de redes

Como se muestra Figura 11-41, los terminales en el departamento de control de acceso físico están conectados a la red interna de la compañía a través de Switch. El acceso no autorizado a la red interna puede dañar el sistema de servicio de la empresa y provocar la fuga de información clave. Por lo tanto, el administrador requiere que Switch debe controlar los derechos de acceso a la red de los usuarios para garantizar la seguridad de la red interna.

Figura 11-41  Configuración de la autenticación de dirección MAC para controlar el acceso del usuario

Hoja de ruta de configuración

La hoja de ruta de configuración es la siguiente:

  1. Cree y configure una plantilla de servidor RADIUS, un esquema AAA y un dominio de autenticación. Enlace la plantilla de servidor RADIUS y el esquema AAA al dominio de autenticación para que Switch pueda autenticar a los usuarios de acceso a través del servidor RADIUS.
  2. Habilite la autenticación de la dirección MAC para que Switch pueda controlar los derechos de acceso a la red de los terminales tontos en el departamento de control de acceso físico.
NOTA:

Antes de configurar este ejemplo, asegúrese de que los dispositivos se puedan comunicar entre ellos en la red.

Procedimiento

  1. Cree las VLAN y configure la VLAN permitida por la interfaz para garantizar la comunicación de la red.

    # Cree VLAN 10 y VLAN 20.

    <Quidway> system-view
    [Quidway] sysname Switch
    [Switch] vlan batch 10 20

    # En Switch, establezca GE1/0/1 conectándose a los usuarios como una interfaz de acceso y agregue GE1/0/1 a la VLAN 10.

    [Switch] interface gigabitethernet1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type access
    [Switch-GigabitEthernet1/0/1] port default vlan 10 
    [Switch-GigabitEthernet1/0/1] quit
    NOTA:

    Configure el tipo de interfaz y las VLAN según la situación real. En este ejemplo, los usuarios se agregan a la VLAN 10.

    # En Switch, establezca GE1/0/2 conectándose al servidor RADIUS como una interfaz de acceso, y agregue GE1/0/2 a la VLAN 20.

    [Switch] interface gigabitethernet1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type access
    [Switch-GigabitEthernet1/0/2] port default vlan 20
    [Switch-GigabitEthernet1/0/2] quit

  2. Cree y configure una plantilla de servidor RADIUS, un esquema AAA y un dominio de autenticación.

    # Cree y configure la plantilla de servidor RADIUS rd1.

    [Switch] radius-server template rd1
    [Switch-radius-rd1] radius-server authentication 192.168.2.30 1812
    [Switch-radius-rd1] radius-server shared-key cipher Huawei@2012
    [Switch-radius-rd1] quit

    # Cree esquema AAA abc y establezca el modo de autenticación a RADIUS.

    [Switch] aaa
    [Switch-aaa] authentication-scheme abc
    [Switch-aaa-authen-abc] authentication-mode radius
    [Switch-aaa-authen-abc] quit

    # Cree el dominio de autenticación isp1, y enlace el esquema AAA abc y la plantilla de servidor RADIUS rd1 al dominio de autenticación isp1.

    [Switch-aaa] domain isp1
    [Switch-aaa-domain-isp1] authentication-scheme abc
    [Switch-aaa-domain-isp1] radius-server rd1
    [Switch-aaa-domain-isp1] quit
    [Switch-aaa] quit

    # Configure el dominio predeterminado isp1 en la vista del sistema. Cuando un usuario introduzca el nombre de usuario en el formato de user@isp1, el usuario se autentica en el dominio de autenticación isp1. Si el nombre de usuario no lleva el nombre de dominio o lleva un nombre de dominio inexistente, el usuario se autentica en el dominio predeterminado.

    [Switch] domain isp1

  3. Configure la autenticación de dirección MAC.

    # Cambie el modo NAC a modo común. Este paso se aplica solo a los switches en V200R005C00 y versiones posteriores.

    [Switch] undo authentication unified-mode
    Warning: Switching the authentication mode will take effect after system restart
    . Some configurations are invalid after the mode is switched. For the invalid co
    mmands, see the user manual. Save the configuration file and reboot now? [Y/N] y
    NOTA:
    • Por defecto, se utiliza el modo unificado NAC.
    • Después de que el modo unificado se cambie al modo común, debe guardar la configuración y reiniciar el dispositivo para que todas las funciones en el nuevo modo de configuración entren en vigor. En versiones anteriores a V200R007C00, debe ejecutar manualmente los comandos para guardar la configuración y reiniciar el dispositivo.

    # Habilite la autenticación de dirección MAC globalmente y en la interfaz.

    <Switch> system-view
    [Switch] mac-authen
    [Switch] interface gigabitethernet1/0/1
    [Switch-GigabitEthernet1/0/1] mac-authen
    [Switch-GigabitEthernet1/0/1] quit

  4. Verifique la configuración.

    1. Ejecute el comando display mac-authen para verificar la configuración de la autenticación de dirección MAC. La salida del comando (MAC address authentication is enabled) muestra que la autenticación de dirección MAC se ha habilitado en la interfaz GE1/0/1.
    2. Después de que el usuario inicie el terminal, el dispositivo obtiene automáticamente la dirección MAC del terminal y la usa como nombre de usuario y contraseña para la autenticación.
    3. El usuario puede acceder a la red después de que la autenticación sea exitosa.
    4. Después de que el usuario se conecte, puede ejecutar el comando display access-user en el dispositivo para verificar la información de usuario de autenticación de dirección MAC en línea.

Archivos de configuración

Archivo de configuración de Switch

#
sysname Switch 
#                                                                               
vlan batch 10 20
#                                                                               
undo authentication unified-mode
#                                                                               
domain isp1
#
mac-authen 
#
radius-server template rd1
 radius-server shared-key cipher %^%#Q75cNQ6IF(e#L4WMxP~%^7'u17,]D87GO{"[o]`D%^%#
 radius-server authentication 192.168.2.30 1812 weight 80
#
aaa
 authentication-scheme abc
  authentication-mode radius
 domain isp1
  authentication-scheme abc
  radius-server rd1
#
interface GigabitEthernet1/0/1
 port link-type access           
 port default vlan 10 
 mac-authen                                                                     
#                                                                              
interface GigabitEthernet1/0/2            
 port link-type access                                                          
 port default vlan 20
#
return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15679

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente