No se encuentran recursos de mapeo en el idioma seleccionado.

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para permitir que ciertos usuarios accedan a Internet en el rango de tiempo especificado

Ejemplo para permitir que ciertos usuarios accedan a Internet en el rango de tiempo especificado

Descripción general del rango de tiempo de ACL

Una ACL define muchas condiciones de coincidencia para filtrar la mayoría de los paquetes transmitidos en una red; sin embargo, no puede filtrar paquetes en el rango de tiempo especificado.

Puede configurar un rango de tiempo y asociar el rango de tiempo con una regla de ACL para filtrar los paquetes según el tiempo. Esto especifica diferentes políticas para usuarios en diferentes rangos de tiempo.

En este ejemplo, se aplica una ACL básica asociada con un rango de tiempo al módulo de política de tráfico para que el dispositivo pueda filtrar los paquetes enviados desde los usuarios internos a Internet en el rango de tiempo especificado. Como resultado, los usuarios pueden acceder a Internet solo en el rango de tiempo especificado.

Notas de configuración

Este ejemplo se aplica a todas las versiones de todos los switches de la serie S.

NOTA:

Los siguientes comandos e información de salida se obtienen de S9306 ejecutando V200R007C00.

Requisitos de red

Como se muestra en Figura 12-5, los departamentos de una empresa están conectados a través de Switch. La empresa permite a todos los empleados acceder a Internet en días de trabajo (de lunes a viernes) y solo a los gerentes para acceder a Internet los fines de semana (sábados y domingos).

Figura 12-5  Permitir que ciertos usuarios accedan a Internet en el rango de tiempo especificado

Hoja de ruta de configuración

Las siguientes configuraciones se realizan en Switch. La hoja de ruta de la configuración es la siguiente:

  1. Configure el rango de tiempo, la ACL básica y el clasificador de tráfico basado en ACL para filtrar los paquetes enviados desde los usuarios internos a Internet y, por lo tanto, permitir que solo ciertos usuarios accedan a Internet en el rango de tiempo especificado.
  2. Configure un comportamiento de tráfico para permitir que los paquetes coincidan con la regla de permiso de ACL.
  3. Configure y aplique una política de tráfico para que la ACL y el comportamiento del tráfico entren en vigencia.

Procedimiento

  1. Configure las VLAN y las direcciones IP para las interfaces.

    # Cree VLAN 10 y VLAN 20.

    <Quidway> system-view
    [Quidway] sysname Switch
    [Switch] vlan batch 10 20
    

    Configure GE1/0/1 y GE1/0/2 de Switch como interfaces trunk y agréguelos a la VLAN 10 y VLAN 20 respectivamente. Configure GE2/0/1 deSwitch como una interfaz trunk y agréguela a la VLAN 10 y a la VLAN 20.

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type trunk
    [Switch-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type trunk
    [Switch-GigabitEthernet1/0/2] port trunk allow-pass vlan 20
    [Switch-GigabitEthernet1/0/2] quit
    [Switch] interface gigabitethernet 2/0/1
    [Switch-GigabitEthernet2/0/1] port link-type trunk
    [Switch-GigabitEthernet2/0/1] port trunk allow-pass vlan 10 20
    [Switch-GigabitEthernet2/0/1] quit

    # Cree VLANIF 10 y VLANIF 20 y les asigne direcciones IP.

    [Switch] interface vlanif 10
    [Switch-Vlanif10] ip address 10.1.1.1 24
    [Switch-Vlanif10] quit
    [Switch] interface vlanif 20
    [Switch-Vlanif20] ip address 10.1.2.1 24
    [Switch-Vlanif20] quit
    

  2. Configure un rango de tiempo.

    # Configure el rango de tiempo periódico de sábado a domingo.

    [Switch] time-range rest-time 0:00 to 23:59 off-day  //Configure un rango de tiempo periódico para una ACL.

  3. Configure una ACL.

    # Cree ACL básica 2001 y configure reglas para que permitan a los gerentes de I+D y marketing (10.1.1.11 y 10.1.2.12) acceder a Internet en cualquier momento y evitar que otros empleados accedan a Internet los sábados y domingos. Es decir, solo los gerentes de los departamentos de I+D y marketing pueden acceder a Internet los sábados y domingos.

    [Switch] acl 2001
    [Switch-acl-basic-2001] rule permit source 10.1.1.11 0  //Permita que el gerente del departamento de I+D acceda a Internet en cualquier momento.
    [Switch-acl-basic-2001] rule permit source 10.1.2.12 0  //Permita que el gerente del departamento de marketing acceda a Internet en cualquier momento.
    [Switch-acl-basic-2001] rule deny time-range rest-time  //Evite que otros usuarios accedan a Internet los sábados y domingos.
    [Switch-acl-basic-2001] quit

  4. Configure el clasificador de tráfico basado en ACL básico.

    # Configure el clasificador de tráfico tc1 para clasificar los paquetes que coincidan con ACL 2001.

    [Switch] traffic classifier tc1  //Cree un clasificador de tráfico.
    [Switch-classifier-tc1] if-match acl 2001  //Asocie ACL con el clasificador de tráfico.
    [Switch-classifier-tc1] quit

  5. Configure los comportamientos de tráfico.

    # Configure el comportamiento del tráfico tb1 y configure la acción para permitir (valor predeterminado).

    NOTA:

    Los paquetes que coinciden con la ACL se descartan siempre que exista una acción deny en una regla de ACL o en el comportamiento del tráfico.

    [Switch] traffic behavior tb1  //Cree un comportamiento de tráfico.
    [Switch-behavior-tb1] quit

  6. Configure la política de tráfico.

    # Defina la política de tráfico y asocie el clasificador de tráfico y el comportamiento del tráfico con la política de tráfico.

    [Switch] traffic policy tp1  //Cree una política de tráfico.
    [Switch-trafficpolicy-tp1] classifier tc1 behavior tb1  //Asocie el clasificador de tráfico tc1 con el comportamiento de tráfico tb1.
    [Switch-trafficpolicy-tp1] quit

  7. Aplique la política de tráfico a una interfaz.

    # Los paquetes de los hosts internos se envían a Internet a través de GE2/0/1; por lo tanto, aplique la política de tráfico tp1 a la dirección de salida deGE2/0/1.

    [Switch] interface gigabitethernet 2/0/1
    [Switch-GigabitEthernet2/0/1] traffic-policy tp1 outbound  //Aplique la política de tráfico a la dirección de salida de una interfaz.
    [Switch-GigabitEthernet2/0/1] quit
    

  8. Verifique la configuración

    # Compruebe la configuración de las reglas de ACL.

    [Switch] display acl 2001
    Basic ACL 2001, 3 rules                                                         
    Acl's step is 5                                                                 
     rule 5 permit source 10.1.1.11 0 (match-counter 0)                             
     rule 10 permit source 10.1.2.12 0 (match-counter 0)                            
     rule 15 deny time-range rest-time(match-counter 0) (Inactive)  

    # Compruebe la configuración del clasificador de tráfico.

    [Switch] display traffic classifier user-defined
      User Defined Classifier Information:
       Classifier: tc1
        Precedence: 5
        Operator: OR
        Rule(s) : if-match acl 2001                                                 
    
    Total classifier number is 1   

    # Compruebe la configuración de la política de tráfico.

    [Switch] display traffic policy user-defined tp1
      User Defined Traffic Policy Information:                                      
      Policy: tp1                                                                   
       Classifier: tc1                                                              
        Operator: OR                                                                
         Behavior: tb1                                                              
          Permit  
    Total policy number is 1

    # Todos los empleados pueden acceder a Internet en días laborables. Solo los gerentes(10.1.1.11 y 10.1.2.12) de los departamentos de I+D y marketing pueden acceder a Internet los fines de semana.

Archivos de configuración

Archivo de configuración de Switch

#
sysname Switch
#
vlan batch 10 20 
#                                                                               
time-range rest-time 00:00 to 23:59 off-day 
#
acl number 2001                                                                 
 rule 5 permit source 10.1.1.11 0                                               
 rule 10 permit source 10.1.2.12 0                                              
 rule 15 deny time-range rest-time 
#
traffic classifier tc1 operator or precedence 5  
 if-match acl 2001                                                              
#
traffic behavior tb1
 permit
#
traffic policy tp1 match-order config
 classifier tc1 behavior tb1
#
interface Vlanif10
 ip address 10.1.1.1 255.255.255.0
#
interface Vlanif20
 ip address 10.1.2.1 255.255.255.0
#
interface GigabitEthernet1/0/1
 port link-type trunk                                                           
 port trunk allow-pass vlan 10 
#
interface GigabitEthernet1/0/2
 port link-type trunk                                                           
 port trunk allow-pass vlan 20 
#
interface GigabitEthernet2/0/1
 port link-type trunk                                                           
 port trunk allow-pass vlan 10 20 
 traffic-policy tp1 outbound
#
return 
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15727

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente