No se encuentran recursos de mapeo en el idioma seleccionado.

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar la limitación de tasa basados ​​en ID de VLAN

Ejemplo para configurar la limitación de tasa basados ​​en ID de VLAN

Descripción general

Además de una ACL, un clasificador de tráfico en MQC define muchas reglas de coincidencia de Capa 2 y Capa 3, como la ID de VLAN, la prioridad 802.1p, la prioridad DSCP, la dirección MAC de origen y la dirección MAC de destino. Puede configurar diferentes clasificadores de tráfico en el dispositivo para identificar paquetes y configurar acciones para ellos, como la limitación de tasa, estadísticas o duplicación.

En este ejemplo, los clasificadores de tráfico se configuran en base a ID de VLAN y se configuran diferentes valores de CIR para que el dispositivo asigna diferentes anchos de banda a los flujos de servicio.

Notas de configuración

Tabla 13-6  Modelos de productos y versiones aplicables

Producto

Modelo del Producto

Versión del software

S2300

S2352P-EI

V100R006C05

S2320EI

V200R011C10, V200R012C00

S2350EI

V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

S3300

S3300SI y S3300EI

V100R006C05

S3300HI

V200R001C00

S5300

S5300LI

V200R001C00, V200R002C00, V200R003(C00&C02), V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5300SI

V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C02)

S5300EI

V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S5300HI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S5306

V200R001C00, V200R002C00, V200R003C00, V200R005C00

S5310EI

V200R002C00, V200R003C00, V200R005(C00&C02)

S5320LI

V200R010C00, V200R011C10, V200R012C00

S5320SI

V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5320EI

V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5320HI

V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5330SI

V200R011C10, V200R012C00

S6300

S6300EI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S6320SI

V200R011C10, V200R012C00

S6320EI

V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

S6320HI

V200R012C00

S9300

S9303, S9306 y S9312

V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

S9300

S9310

V200R010C00, V200R011C10, V200R012C00

S9300X

S9310X

V200R010C00, V200R011C10, V200R012C00

S9300E

S9303E, S9306E y S9312E

V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

NOTA:
Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de red

En Figura 13-6, el Switch conecta al router mediante GE 2/0/1 , y la empresa se conecta a Internet a través de Switch y router.

Los servicios de voz, video y datos se transmiten en VLAN 120, VLAN 110 y VLAN 100, respectivamente.

La vigilancia del tráfico debe configurarse en Switcha los paquetes policiales de diferentes servicios para que el tráfico esté limitado dentro de un rango adecuado, garantizando el ancho de banda de cada servicio.

Los servicios de voz, video y datos tienen requisitos de QoS en orden de prioridad descendente. El Switch necesita de volver a marcar las prioridades de DSCP en diferentes paquetes de servicio para que el router de vínculo descendente procese en función de las prioridades, asegurando la QoS de diferentes servicios.

Tabla 13-7 describe los requisitos de QoS.

Tabla 13-7  Garantía QoS para el tráfico del enlace ascendente en Switch

Tipo de tráfico

CIR (kbit/s)

PIR (kbit/s)

Prioridad DSCP

Voz

2000

10000

46

Video

4000

10000

30

Datos

4000

10000

14

Figura 13-6  Redes de vigilancia del tráfico

Hoja de ruta de configuración

La hoja de ruta de la configuración es la siguiente:
  1. Cree una VLAN y configure interfaces para que la empresa pueda acceder a Internet a través de Switch.
  2. Configure clasificadores de tráfico en Switch para clasificar paquetes basados ​​en ID de VLAN.
  3. Configure comportamientos de tráfico en Switch para limitar la tasa de paquetes y volver a marcar las prioridades de DSCP de los paquetes.
  4. Configure una política de tráfico Switch, vincule los comportamientos de tráfico y clasificadores de tráfico, y aplique la política de tráfico a la interfaz en Switch conectado al LSW.

Procedimiento

  1. Cree VLAN y configure interfaces.

    # Cree VLAN 100, VLAN 110 y VLAN 120 en elSwitch.

    <Quidway> system-view
    [Quidway] sysname Switch
    [Switch] vlan batch 100 110 120
    

    Configure GE1/0/1 y GE2/0/1 como trunk interfaces y agréguelos a la VLAN 100, VLAN 110, y VLAN 120.

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type trunk
    [Switch-GigabitEthernet1/0/1] port trunk allow-pass vlan 100 110 120
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 2/0/1
    [Switch-GigabitEthernet2/0/1] port link-type trunk
    [Switch-GigabitEthernet2/0/1] port trunk allow-pass vlan 100 110 120
    [Switch-GigabitEthernet2/0/1] quit

  2. Configure clasificadores de tráfico.

    # Configure los clasificadores de tráfico c1, c2, y c3 en Switch para clasificar los diferentes flujos de servicios empresariales basados en las ID de VLAN.

    [Switch] traffic classifier c1 operator and
    [Switch-classifier-c1] if-match vlan-id 120  //Configure una regla coincidente para coincidir los paquetes con la VLAN 120.
    [Switch-classifier-c1] quit
    [Switch] traffic classifier c2 operator and
    [Switch-classifier-c2] if-match vlan-id 110  //Configure una regla coincidente para coincidir los paquetes con la VLAN 110.
    [Switch-classifier-c2] quit
    [Switch] traffic classifier c3 operator and
    [Switch-classifier-c3] if-match vlan-id 100  //Configure una regla coincidente para coincidir los paquetes con la VLAN 100.
    [Switch-classifier-c3] quit
    

  3. Configure los comportamientos de tráfico.

    # Configure los comportamientos de tráfico b1, b2, y b3 en Switch para controlar los flujos del servicio y volver a marcar las prioridades de los flujos del servicio, y configure las estadísticas de tráfico.

    [Switch] traffic behavior b1
    [Switch-behavior-b1] car cir 2000 pir 10000 green pass  //Establezca el CIR de paquetes con VLAN 120 a 2000 kbit/s.
    [Switch-behavior-b1] remark dscp 46  //Configure el dispositivo para volver a marcar las prioridades DSCP de los paquetes de la VLAN 120 con 46.
    [Switch-behavior-b1] statistic enable  //Habilite las estadísticas de tráfico.
    [Switch-behavior-b1] quit
    [Switch] traffic behavior b2
    [Switch-behavior-b2] car cir 4000 pir 10000 green pass
    [Switch-behavior-b2] remark dscp 30
    [Switch-behavior-b2] statistic enable
    [Switch-behavior-b2] quit
    [Switch] traffic behavior b3
    [Switch-behavior-b3] car cir 4000 pir 10000 green pass
    [Switch-behavior-b3] remark dscp 14
    [Switch-behavior-b3] statistic enable
    [Switch-behavior-b3] quit
    

  4. Configure una política de tráfico y aplique la política de tráfico a una interfaz.

    # Cree una política de tráfico p1 en Switch, vincule los clasificadores de tráfico y los comportamientos de tráfico a la política de tráfico, y aplique el tráfico política a GE1/0/1 en la dirección de entrada para proteger los paquetes de la empresa y volver a marcar las prioridades del paquete.

    [Switch] traffic policy p1
    [Switch-trafficpolicy-p1] classifier c1 behavior b1
    [Switch-trafficpolicy-p1] classifier c2 behavior b2
    [Switch-trafficpolicy-p1] classifier c3 behavior b3
    [Switch-trafficpolicy-p1] quit
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] traffic-policy p1 inbound
    [Switch-GigabitEthernet1/0/1] quit
    

  5. Verifique la configuración

    # Compruebe la configuración del clasificador de tráfico.

    [Switch] display traffic classifier user-defined
      User Defined Classifier Information:
       Classifier: c2
        Precedence: 10
        Operator: AND
        Rule(s) : if-match vlan-id 110
                 
       Classifier: c3
        Precedence: 15
        Operator: AND
        Rule(s) : if-match vlan-id 100
                 
       Classifier: c1
        Precedence: 5
        Operator: AND
        Rule(s) : if-match vlan-id 120
                 
    Total classifier number is 3 

    # Compruebe la configuración de la política de tráfico p1.

    [Switch] display traffic policy user-defined p1
      User Defined Traffic Policy Information:
      Policy: p1
       Classifier: c2
        Operator: AND
         Behavior: b2
          Permit
          Committed Access Rate:
            CIR 4000 (Kbps), PIR 10000 (Kbps), CBS 500000 (byte), PBS 1250000 (byte)
            Color Mode: color Blind
            Conform Action: pass
            Yellow  Action: pass
            Exceed  Action: discard
           Remark:                            
            Remark DSCP af33
          Statistic: enable 
       Classifier: c3
        Operator: AND
         Behavior: b3
          Permit
          Committed Access Rate:
            CIR 4000 (Kbps), PIR 10000 (Kbps), CBS 500000 (byte), PBS 1250000 (byte)
            Color Mode: color Blind
            Conform Action: pass
            Yellow  Action: pass
            Exceed  Action: discard
          Remark:
            Remark DSCP af13
          Statistic: enable
       Classifier: c1
        Operator: AND
         Behavior: b1
          Permit
          Committed Access Rate:
            CIR 2000 (Kbps), PIR 10000 (Kbps), CBS 250000 (byte), PBS 1250000 (byte)
            Color Mode: color Blind
            Conform Action: pass
            Yellow  Action: pass
            Exceed  Action: discard
          Remark:
            Remark DSCP ef
          Statistic: enable

    # Compruebe la información sobre la política de tráfico que se aplica a la interfaz. Los paquetes de voz en GE1/0/1 se usan como ejemplo. Cuando la tasa de los paquetes es mayor que 10 000 kbit/s, se produce la pérdida de paquetes. La tasa de los paquetes de voz está limitada a 10 000 kbit/s.

    [Switch] display traffic policy statistics interface gigabitethernet 1/0/1 inbound verbose classifier-base class c1
    
     Interface:  GigabitEthernet1/0/1
     Traffic policy inbound: p1
     Rule number: 3
     Current status: success
     Statistics interval: 300   
    ---------------------------------------------------------------------
     Board : 1
    ---------------------------------------------------------------------
     Matched          |      Packets:                        49,491
                      |      Bytes:                               -
                      |      Rate(pps):                           0
                      |      Rate(bps):                           -
    ---------------------------------------------------------------------
       Passed         |      Packets:                        40,971
                      |      Bytes:                               -
                      |      Rate(pps):                           0
                      |      Rate(bps):                           -
    ---------------------------------------------------------------------
       Dropped        |      Packets:                         8,520
                      |      Bytes:                               -
                      |      Rate(pps):                           0
                      |      Rate(bps):                           -
    ---------------------------------------------------------------------
         Filter       |      Packets:                             0
                      |      Bytes:                               -
    --------------------------------------------------------------------- 
         Car          |      Packets:                         8,520
                      |      Bytes:                               -
    ---------------------------------------------------------------------
    

Archivos de configuración

Archivo de configuración de Switch

#
sysname Switch
#
vlan batch 100 110 120
#
traffic classifier c1 operator and precedence 5 
 if-match vlan-id 120
traffic classifier c2 operator and precedence 10
 if-match vlan-id 110
traffic classifier c3 operator and precedence 15
 if-match vlan-id 100
#
traffic behavior b1
 permit
 car cir 2000 pir 10000 cbs 250000 pbs 1250000 mode color-blind green pass yellow pass red discard
 remark dscp ef
 statistic enable
traffic behavior b2
 permit
 car cir 4000 pir 10000 cbs 500000 pbs 1250000 mode color-blind green pass yellow pass red discard
 remark dscp af33
 statistic enable
traffic behavior b3
 permit
 car cir 4000 pir 10000 cbs 500000 pbs 1250000 mode color-blind green pass yellow pass red discard
 remark dscp af13
 statistic enable
#
traffic policy p1 match-order config
 classifier c1 behavior b1
 classifier c2 behavior b2
 classifier c3 behavior b3
#
interface GigabitEthernet1/0/1
 port link-type trunk
 port trunk allow-pass vlan 100 110 120
 traffic-policy p1 inbound
#
interface GigabitEthernet2/0/1
 port link-type trunk
 port trunk allow-pass vlan 100 110 120
#
return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15825

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente