No se encuentran recursos de mapeo en el idioma seleccionado.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar la gestión de la congestión (modo de plantilla de planificación)

Ejemplo para configurar la gestión de la congestión (modo de plantilla de planificación)

Descripción general

La gestión de la congestión implementa las colas y la planificación cuando se envían flujos de paquetes. El dispositivo proporciona las siguientes tecnologías de gestión de congestión: Colas prioritarias (PQ), Round robin de déficit ponderado (WDRR), Round robin redondeado (WRR), PQ+WDRR y PQ+WRR. El dispositivo tiene ocho colas en cada interfaz en la dirección de salida, cual se identifican mediante los números de índice de 0 a 7. Basado en los mapeos entre las prioridades locales y las colas, el dispositivo envía los paquetes clasificados a las colas y luego planifica los paquetes mediante la planificación en cola mecanismos.

Este ejemplo usa PQ+WRR para implementar la gestión de la congestión. En la planificación de WRR, el dispositivo realiza la planificación en una votación de acuerdo con la ponderación de cada cola. El número de veces que los paquetes están planificados en cada cola es directamente proporcional a la ponderación de la cola. Una ponderación mayor indica más tiempos de planificación de paquetes.

Notas de configuración

Tabla 13-10  Modelos de productos y versiones aplicables

Producto

Modelo del Producto

Versión del software

S2300

S2320EI

V200R011C10, V200R012C00

S2350EI

V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5300

S5300LI

V200R001C00, V200R002C00, V200R003(C00&C02), V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5300SI

V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C02)

S5320LI

V200R010C00, V200R011C10, V200R012C00

S5320SI

V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5330SI

V200R011C10, V200R012C00

S6300

S6320SI

V200R011C10, V200R012C00

NOTA:
Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de red

En Figura 13-9, el Switch está conectado al router a través de GE0/0/3. Las prioridades 802.1p de los servicios de voz, video y datos son 7, 5 y 2, respectivamente, y estos servicios pueden llegar a los usuarios residenciales a través del router y Switch. Para reducir el impacto de la congestión de la red y asegurar el ancho de banda para los servicios de alta prioridad y sensibles a la demora, establezca los parámetros de acuerdo con la siguiente tabla.

Tabla 13-11  Parámetros de gestión de la congestión

Tipo de servicio

Valor CoS

Ponderación WRR

Voz

CS7

0

Video

EF

20

Datos

AF2

10

Figura 13-9  Redes de gestión de la congestión

Hoja de ruta de configuración

La hoja de ruta de la configuración es la siguiente:
  1. Configure una VLAN para cada interfaz para que los dispositivos puedan comunicarse entre sí en la capa de enlace.

  2. Configure una interfaz para confiar en las prioridades 802.1p de los paquetes.

  3. Configure un perfil de planificación y aplique el perfil de planificación a la interfaz.

Procedimiento

  1. Configure una VLAN para cada interfaz para que los dispositivos puedan comunicarse entre sí en la capa de enlace.

    <Quidway> system-view
    [Quidway] sysname Switch
    [Switch] vlan batch 10 20 30
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type trunk
    [Switch-GigabitEthernet0/0/1] port trunk allow-pass vlan 10 20 30
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type trunk
    [Switch-GigabitEthernet0/0/2] port trunk allow-pass vlan 10 20 30
    [Switch-GigabitEthernet0/0/2] quit
    [Switch] interface gigabitethernet 0/0/3
    [Switch-GigabitEthernet0/0/3] port link-type trunk
    [Switch-GigabitEthernet0/0/3] port trunk allow-pass vlan 10 20 30
    [Switch-GigabitEthernet0/0/3] quit
    

  2. Configure una interfaz para confiar en las prioridades 802.1p de los paquetes.

    [Switch] interface gigabitethernet 0/0/3
    [Switch-GigabitEthernet0/0/3] trust 8021p  //Configure la interfaz para confiar en las prioridades de 802.1p. Es decir, los paquetes entran en las colas diferentes de acuerdo con el mapeo predeterminads entre las prioridades 802.1p y las prioridades locales.
    [Switch-GigabitEthernet0/0/3] quit
    

  3. Configure la gestión de la congestión.

    # Cree un perfil de planificación y establezca los parámetros de planificación de la cola. Por defecto, se usa WRR.

    [Switch] qos schedule-profile p1
    [Switch-qos-schedule-profile-p1] qos queue 7 wrr weight 0  //Establezca la ponderación de la cola 7 a 0 y configure PQ para la cola 7.
    [Switch-qos-schedule-profile-p1] qos queue 5 wrr weight 20  //Establezca la ponderación WRR de la cola 5 a 20.
    [Switch-qos-schedule-profile-p1] qos queue 2 wrr weight 10  //Establezca la ponderación WRR de la cola 2 a 10. La proporción de ponderación de la cola 5 y la cola 2 es 2: 1.
    [Switch-qos-schedule-profile-p1] quit
    

    # Aplique el perfil de planificación a GE 0/0/1 y GE 0/0/2 de Switch.

    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] qos schedule-profile p1  //Aplique el perfil de planificación a GE0/0/1.
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] qos schedule-profile p1  //Aplique el perfil de planificación a GE0/0/1.
    [Switch-GigabitEthernet0/0/2] quit
    

  4. Verifique la configuración

    # Compruebe el perfil de planificación y los parámetros de planificación de la cola.

    [Switch] qos schedule-profile p1
    [Switch-qos-schedule-profile-p1] display this
    #
     qos schedule-profile p1
       qos queue 2 wrr weight 10
       qos queue 5 wrr weight 20
       qos queue 7 wrr weight 0 
    #
    return
    

Archivos de configuración

Archivo de configuración de Switch

#
sysname Switch
#
vlan batch 10 20 30
#
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 10 20 30
 qos schedule-profile p1
 #
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 10 20 30
 qos schedule-profile p1
#
interface GigabitEthernet0/0/3
 port link-type trunk
 port trunk allow-pass vlan 10 20 30
 trust 8021p
#
 qos schedule-profile p1
   qos queue 2 wrr weight 10
   qos queue 5 wrr weight 20
   qos queue 7 wrr weight 0
#
return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15498

Descargas: 129

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente