No se encuentran recursos de mapeo en el idioma seleccionado.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar la evitación de congestión y la gestión de congestión (mediante la planificación de WRR y una política de SRED)

Ejemplo para configurar la evitación de congestión y la gestión de congestión (mediante la planificación de WRR y una política de SRED)

Descripción general

La gestión de la congestión implementa las colas y la planificación cuando se envían flujos de paquetes. El dispositivo proporciona las siguientes tecnologías de gestión de congestión: Priority Queuing (PQ), Weighted Deficit Round Robin (WDRR), Weighted Round Robin (WRR), PQ+WDRR y PQ+WRR.. El dispositivo tiene ocho colas en cada interfaz en la dirección de salida, cual se identifican mediante los números de índice de 0 a 7. Basado en los mapeos entre las prioridades locales y las colas, el dispositivo envía los paquetes clasificados a las colas y luego planifica los paquetes mediante la planificación en cola mecanismos.

La evitación de la congestión es un mecanismo de control de flujo. Un sistema configurado con evitación de la congestión monitorea el uso de los recursos de la red, como las colas y los búferes de memoria. Cuando la congestión ocurre o se agrava, el sistema descarta los paquetes. La evitación de la congestión utiliza políticas de caída de cola y caída aleatoria para descartar paquetes. Las políticas de caída aleatoria incluyen Simple Random Early Detection (SRED) y Weighted Random Early Detection (WRED).

Este ejemplo utiliza la planificación de WRR para implementar la gestión de congestión. En la planificación de WRR, el dispositivo realiza la planificación en una votación de acuerdo con la ponderación de cada cola. El número de veces que se planifican los paquetes en cada cola es directamente proporcional a la ponderación de esta cola. Una ponderación mayor indica más veces que los paquetes están planificados. SRED está configurado para implementar la prevención de la congestión. El dispositivo descarta el exceso de tráfico según la probabilidad de caída máxima.

Notas de configuración

Tabla 13-12  Modelos de productos y versiones aplicables

Producto

Modelo del Producto

Versión del software

S2300

S2352P-EI

V100R006C05

S3300

S3300SI y S3300EI

V100R006C05

S5300

S5300EI

V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C01&C02)

NOTA:
Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de red

En Figura 13-10, el Switch está conectado al router a través de GE0/0/3. Las prioridades 802.1p de los servicios de voz, video y datos son 7, 5 y 2, respectivamente, y estos servicios pueden llegar a los usuarios residenciales a través del router y Switch. Para reducir el impacto de la congestión de la red y asegurar el ancho de banda para los servicios de alta prioridad y sensibles a la demora, establezca los parámetros de acuerdo con la siguiente tabla.

Tabla 13-13  Parámetros para la evitación de la congestión

Tipo de servicio

Color

Umbral de caída inferior

Probabilidad de caída máxima

Voz

Amarillo

1000

0.78125%

Rojo

500

6.25%

Video

Amarillo

1000

0.78125%

Rojo

500

6.25%

Datos

Amarillo

1000

0.78125%

Rojo

500

6.25%

Tabla 13-14  Parámetros de gestión de la congestión

Tipo de servicio

Valor CoS

Ponderación WRR

Voz

CS7

0

Video

EF

20

Datos

AF2

10

Figura 13-10  Redes de evitación de congestión y gestión de congestión

Hoja de ruta de configuración

La hoja de ruta de la configuración es la siguiente:
  1. Configure una VLAN para cada interfaz para que los dispositivos puedan comunicarse entre sí en la capa de enlace.

  2. Configure una interfaz para confiar en las prioridades 802.1p de los paquetes.

  3. Establezca los parámetros de planificación de colas.

  4. Establezca los umbrales de caída de SRED y la probabilidad de caída máxima de las colas.

Procedimiento

  1. Configure una VLAN para cada interfaz para que los dispositivos puedan comunicarse entre sí en la capa de enlace.

    <Quidway> system-view
    [Quidway] sysname Switch
    [Switch] vlan batch 10 20 30
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type trunk
    [Switch-GigabitEthernet0/0/1] port trunk allow-pass vlan 10 20 30
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type trunk
    [Switch-GigabitEthernet0/0/2] port trunk allow-pass vlan 10 20 30
    [Switch-GigabitEthernet0/0/2] quit
    [Switch] interface gigabitethernet 0/0/3
    [Switch-GigabitEthernet0/0/3] port link-type trunk
    [Switch-GigabitEthernet0/0/3] port trunk allow-pass vlan 10 20 30
    [Switch-GigabitEthernet0/0/3] quit
    

  2. Configure una interfaz para confiar en las prioridades 802.1p de los paquetes.

    [Switch] interface gigabitethernet 0/0/3
    [Switch-GigabitEthernet0/0/3] trust 8021p  //Configure la interfaz para confiar en las prioridades 802.1p. Es decir, los paquetes entran en las colas diferentes de acuerdo con el mapeo predeterminado entre las prioridades 802.1p y las prioridades locales.
    [Switch-GigabitEthernet0/0/3] quit
    

  3. Configure la evitación de congestión.

    # Establezca los umbrales de caída de SRED y la probabilidad de caída máxima de las colas.

    [Switch] qos sred queue 2 red 500 discard-probability 1 yellow 1000 discard-probability 4  //Establezca el umbral de caída y la probabilidad de caída máxima para los paquetes rojos y amarillos en la cola 2. Es decir, cuando hay más de 500 paquetes rojos, el dispositivo descarta los paquetes rojos adicionales según la proporción de 6,25 %. Cuando hay más de 1000 paquetes amarillos, el dispositivo descarta los paquetes amarillos adicionales de acuerdo con la proporción de 0,78125 %.
    [Switch] qos sred queue 5 red 500 discard-probability 1 yellow 1000 discard-probability 4
    [Switch] qos sred queue 7 red 500 discard-probability 1 yellow 1000 discard-probability 4
    

  4. Configure la gestión de la congestión.

    # Establezca el modo de planificación de cada cola en GE0/0/1 y GE0/0/2 en elSwitch. Por defecto, se usa WRR.

    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] qos queue 7 wrr weight 0  //Establezca el ponderación WRR de la cola 7 a 0 y use la planificación PQ.
    [Switch-GigabitEthernet0/0/1] qos queue 5 wrr weight 20  //Establezca el ponderación WRR de la cola 5 a 20.
    [Switch-GigabitEthernet0/0/1] qos queue 2 wrr weight 10  //Establezca el ponderación WRR de la cola 2 a 10. El dispositivo planifica los paquetes en la cola 5 y la cola 2 según la proporción de 2:1.
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] qos queue 7 wrr weight 0
    [Switch-GigabitEthernet0/0/2] qos queue 5 wrr weight 20
    [Switch-GigabitEthernet0/0/2] qos queue 2 wrr weight 10
    [Switch-GigabitEthernet0/0/2] quit
    

  5. Verifique la configuración

    # Compruebe la configuración global de SRED de la cola de interfaz en la dirección de salida.

    [Switch] display qos sred
    Current sred configuration:
    qos sred queue-index 2 red 500 discard-probability 1 yellow 1000 discard-probability 4
    qos sred queue-index 5 red 500 discard-probability 1 yellow 1000 discard-probability 4
    qos sred queue-index 7 red 500 discard-probability 1 yellow 1000 discard-probability 4
    

Archivos de configuración

Archivo de configuración de Switch

#
sysname Switch
#
vlan batch 10 20 30
#
 qos sred queue 2 red 500 discard-probability 1 yellow 1000 discard-probability 4
 qos sred queue 5 red 500 discard-probability 1 yellow 1000 discard-probability 4
 qos sred queue 7 red 500 discard-probability 1 yellow 1000 discard-probability 4
#
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 10 20 30
 qos queue 2 wrr weight 10
 qos queue 5 wrr weight 20
 qos queue 7 wrr weight 0 
#
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 10 20 30
 qos queue 2 wrr weight 10
 qos queue 5 wrr weight 20
 qos queue 7 wrr weight 0
#
interface GigabitEthernet0/0/3
 port link-type trunk
 port trunk allow-pass vlan 10 20 30
 trust 8021p
#
return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15516

Descargas: 129

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente