No se encuentran recursos de mapeo en el idioma seleccionado.

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar la evitación de congestión y la gestión de congestión (mediante la planificación PQ+WDRR y un perfil WERD)

Ejemplo para configurar la evitación de congestión y la gestión de congestión (mediante la planificación PQ+WDRR y un perfil WERD)

Descripción general

La gestión de la congestión implementa las colas y la planificación cuando se envían flujos de paquetes. En función de las políticas de colas y planificación, el dispositivo proporciona las siguientes tecnologías de gestión de la congestión: Priority Queuing (PQ), Weighted Deficit Round Robin (WDRR), Weighted Round Robin (WRR), PQ+WDRR y PQ+WRR. El dispositivo tiene ocho colas en cada interfaz en la dirección de salida, cual se identifican mediante los números de índice de 0 a 7. Basado en los mapeos entre las prioridades locales y las colas, el dispositivo envía los paquetes clasificados a las colas y luego planifica los paquetes mediante los mecanismos de planificación de cola.

La evitación de la congestión es un mecanismo de control de flujo. Un sistema configurado con evitación de la congestión monitorea el uso de los recursos de la red, como las colas y los búferes de memoria. Cuando la congestión ocurre o se agrava, el sistema descarta los paquetes. La evitación de la congestión utiliza políticas de caída de cola y caída aleatoria para descartar paquetes. Las políticas de caída aleatoria incluyen la Simple Random Early Detection (SRED) y Weighted Random Early Detection (WRED).

Este ejemplo utiliza la planificación PQ+WDRR para implementar la gestión de la congestión. En la planificación de WRR, el número de veces que se planifican los paquetes en cada cola es directamente proporcional a la ponderación de esta cola. Una ponderación mayor indica más veces que los paquetes están planificados. WRR planifica paquetes basados ​​en la cantidad de paquetes. Es decir, es más probable que los paquetes de gran tamaño se planifican y obtengan más ancho de banda. WDRR planifica paquetes teniendo en cuenta la longitud del paquete, asegurando que los paquetes se planifican con la misma probabilidad. WRED está configurado para implementar la evitación de la congestión. El dispositivo descarta el exceso de tráfico según la probabilidad de caída máxima.

Notas de configuración

Tabla 13-15  Modelos de productos y versiones aplicables

Producto

Modelo del Producto

Versión del software

S3300

S3300HI

V200R001C00

S5300

S5300HI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S5306

V200R001C00, V200R002C00, V200R003C00, V200R005C00

S5310EI

V200R002C00, V200R003C00, V200R005(C00&C02)

S5320EI

V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5320HI

V200R009C00, V200R010C00, V200R011C10, V200R012C00

S6300

S6300EI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S6320EI

V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

S6320HI

V200R012C00

S9300

S9303, S9306 y S9312

V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

S9300

S9310

V200R010C00, V200R011C10, V200R012C00

S9300X

S9310X

V200R010C00, V200R011C10, V200R012C00

S9300E

S9303E, S9306E y S9312E

V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

NOTA:
Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de red

En Figura 13-11, Switch está conectado al router a través de GE2/0/1. Las prioridades 802.1p de los servicios de voz, video y datos son 6, 5 y 2, respectivamente, y estos servicios pueden llegar a los usuarios residenciales a través del router y Switch. En el Switch, la tasa de GE2/0/1 (interfaz de entrada) es superior que las tasas de GE1/0/1 y GE1/0/2 (interfaces de salida), por lo que la congestión puede ocurrir en las dos interfaces de salida.

Para reducir el impacto de la congestión de la red y asegurar el ancho de banda para los servicios de alta prioridad y sensibles a la demora, establezca los parámetros de acuerdo con Tabla 13-16 y Tabla 13-17.

Tabla 13-16  Parámetros para la evitación de la congestión

Tipo de servicio

Color

Umbral de caída inferior (%)

Umbral de caída superior(%)

Probabilidad de caída máxima

Voz

Verde

80

100

10

Video

Amarillo

60

80

20

Datos

Rojo

40

60

40

Tabla 13-17  Parámetros de gestión de la congestión

Tipo de servicio

Valor CoS

WDRR

Voz

EF

0

Video

AF3

100

Datos

AF1

50

Figura 13-11  Redes de evitación de congestión y gestión de congestión

Hoja de ruta de configuración

La hoja de ruta de la configuración es la siguiente:
  1. Configure una VLAN para cada interfaz para que los dispositivos puedan comunicarse entre sí en la capa de enlace.

  2. Cree un dominio DiffServ en Switch para mapear prioridades 802.1p de paquetes de servicio diferentes a PHB y colores, y vincule el dominio DiffServ a la interfaz de entrada de Switch.

  3. Configure un perfil de WRED en Switch y aplique el perfil de WRED a las interfaces de salida.

  4. Establezca los parámetros de planificación de cada cola en la interfaz de salida de Switch.

Procedimiento

  1. Configure una VLAN para cada interfaz para que los dispositivos puedan comunicarse entre sí en la capa de enlace.

    <Quidway> system-view
    [Quidway] sysname Switch
    [Switch] vlan batch 2 5 6
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type trunk
    [Switch-GigabitEthernet1/0/1] port trunk allow-pass vlan 2 5 6
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type trunk
    [Switch-GigabitEthernet1/0/2] port trunk allow-pass vlan 2 5 6
    [Switch-GigabitEthernet1/0/2] quit
    [Switch] interface gigabitethernet 2/0/1
    [Switch-GigabitEthernet2/0/1] port link-type trunk
    [Switch-GigabitEthernet2/0/1] port trunk allow-pass vlan 2 5 6
    [Switch-GigabitEthernet2/0/1] quit
    

  2. Configure el mapeo de prioridad.

    # Cree un dominio DiffServ ds1 para mapear las prioridades 802.1p de 6, 5, 2 a los PHB de EF, AF3 y AF1 y los colores de verde, amarillo y rojo, respectivamente.

    [Switch] diffserv domain ds1
    [Switch-dsdomain-ds1] 8021p-inbound 6 phb ef green  //Cree un dominio DiffServ para mapear las prioridades 802.1p de los diferentes paquetes de servicio a PHB para que los paquetes ingresen en diferentes colas.
    [Switch-dsdomain-ds1] 8021p-inbound 5 phb af3 yellow
    [Switch-dsdomain-ds1] 8021p-inbound 2 phb af1 red
    [Switch-dsdomain-ds1] quit
    

    # Vincule el dominio DiffServ a GE2/0/1 de Switch.

    [Switch] interface gigabitethernet 2/0/1
    [Switch-GigabitEthernet2/0/1] trust upstream ds1  //Aplique el dominio DiffServ a la interfaz.
    [Switch-GigabitEthernet2/0/1] trust 8021p inner  //Configure la interfaz para confiar en las prioridades 802.1p.
    [Switch-GigabitEthernet2/0/1] quit

  3. Configure la evitación de la congestión.

    # Cree un perfil WRED wred1 en Switch y establezca los parámetros de planificación en el perfil WRED.

    [Switch] drop-profile wred1
    [Switch-drop-wred1] color green low-limit 80 high-limit 100 discard-percentage 10  //Configure un perfil de caída WRED y establezca el umbral de caída superior e inferior y la probabilidad de caída máxima para los paquetes verdes.
    [Switch-drop-wred1] color yellow low-limit 60 high-limit 80 discard-percentage 20  //Cuando el porcentaje de la longitud del paquete amarillo alcanza el 60 % de la longitud de la cola, el dispositivo comienza a descartar los paquetes con una probabilidad de caída máxima del 20 %. Cuando el porcentaje de la longitud del paquete amarillo alcanza el 80 % de la longitud de la cola, el dispositivo descarta todos los paquetes nuevos.
    [Switch-drop-wred1] color red low-limit 40 high-limit 60 discard-percentage 40
    [Switch-drop-wred1] quit
    

    # Aplique el perfil WRED wred1 a GE1/0/1 y GE1/0/2 en el Switch.

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] qos wred wred1
    [Switch-GigabitEthernet1/0/1] qos queue 5 wred wred1
    [Switch-GigabitEthernet1/0/1] qos queue 3 wred wred1
    [Switch-GigabitEthernet1/0/1] qos queue 1 wred wred1
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] qos wred wred1
    [Switch-GigabitEthernet1/0/2] qos queue 5 wred wred1
    [Switch-GigabitEthernet1/0/2] qos queue 3 wred wred1
    [Switch-GigabitEthernet1/0/2] qos queue 1 wred wred1
    [Switch-GigabitEthernet1/0/2] quit

  4. Configure la gestión de la congestión.

    # Establezca los parámetros de planificación de cada cola en GE1/0/1 y GE1/0/2 de Switch.

    Los siguientes pasos son aplicables solo al switch del chasis.

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] qos pq 5  //Configure la planificación PQ para la cola 5.
    [Switch-GigabitEthernet1/0/1] qos drr 0 to 4  //Configure la planificación WDRR para las colas de 0 a 4.
    [Switch-GigabitEthernet1/0/1] qos queue 3 drr weight 100  //Establezca la ponderación WDRR de la cola 3 a 100.
    [Switch-GigabitEthernet1/0/1] qos queue 1 drr weight 50  //Establezca la ponderación WDRR de la cola 1 a 50. El dispositivo planifica los paquetes en la cola 1 y la cola 3 de acuerdo con la proporción de 1:2.
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] qos pq 5
    [Switch-GigabitEthernet1/0/2] qos drr 0 to 4
    [Switch-GigabitEthernet1/0/2] qos queue 3 drr weight 100
    [Switch-GigabitEthernet1/0/2] qos queue 1 drr weight 50
    [Switch-GigabitEthernet1/0/2] quit
    

    Los siguientes pasos son aplicables solo al switch de caja.

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] qos drr  //Configure WDRR en la interfaz. Por defecto, WRR se usa en una interfaz.
    [Switch-GigabitEthernet1/0/1] qos queue 5 drr weight 0  //Establezca la ponderación WDRR de la cola 5 a 0 y use la planificación PQ.
    [Switch-GigabitEthernet1/0/1] qos queue 3 drr weight 100  //Establezca la ponderación WDRR de la cola 3 a 100.
    [Switch-GigabitEthernet1/0/1] qos queue 1 drr weight 50  //Establezca la ponderación WDRR de la cola 1 a 50. El dispositivo planifica los paquetes en la cola 3 y la cola 1 de acuerdo con la proporción de 2:1.
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] qos drr
    [Switch-GigabitEthernet1/0/2] qos queue 5 drr weight 0
    [Switch-GigabitEthernet1/0/2] qos queue 3 drr weight 100
    [Switch-GigabitEthernet1/0/2] qos queue 1 drr weight 50
    [Switch-GigabitEthernet1/0/2] quit
    

  5. Verifique la configuración

    # Compruebe la configuración del dominio DiffServ ds1.

    [Switch] display diffserv domain name ds1
    diffserv domain name:ds1
     8021p-inbound 0 phb be green
     8021p-inbound 1 phb af1 green
     8021p-inbound 2 phb af1 red
     8021p-inbound 3 phb af3 green
     8021p-inbound 4 phb af4 green
     8021p-inbound 5 phb af3 yellow
     8021p-inbound 6 phb ef green
     8021p-inbound 7 phb cs7 green
     8021p-outbound be green map 0
    ......

    # Compruebe la configuración del perfil WRED.

    [Switch] display drop-profile name wred1
    Drop-profile[1]: wred1
    Queue depth    : default
    Color     Low-limit   High-limit  Discard-percentage
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    Green     80          100         10
    Yellow    60          80          20
    Red       40          60          40
    Non-tcp   100         100         100
    -----------------------------------------------------------------
    

Archivos de configuración

  • Archivo de configuración de Switch (switch modular)

    #
    sysname Switch
    #
    vlan batch 2 5 to 6
    #
    diffserv domain ds1
     8021p-inbound 2 phb af1 red
     8021p-inbound 5 phb af3 yellow
     8021p-inbound 6 phb ef green
    #
    drop-profile wred1
     color green low-limit 80 high-limit 100 discard-percentage 10
     color yellow low-limit 60 high-limit 80 discard-percentage 20
     color red low-limit 40 high-limit 60 discard-percentage 40
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 5 to 6
     qos wred wred1
     qos pq 5 to 7 drr 0 to 4
     qos queue 1 drr weight 50
     qos queue 3 drr weight 100
     qos queue 1 wred wred1
     qos queue 3 wred wred1
     qos queue 5 wred wred1
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 5 to 6
     qos wred wred1
     qos pq 5 to 7 drr 0 to 4
     qos queue 1 drr weight 50
     qos queue 3 drr weight 100
     qos queue 1 wred wred1
     qos queue 3 wred wred1
     qos queue 5 wred wred1
    #
    interface GigabitEthernet2/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 5 to 6
     trust upstream ds1
     trust 8021p inner
    #
    return
    
  • Archivo de configuración de Switch (switch fijo)

    #
    sysname Switch
    #
    vlan batch 2 5 to 6
    #
    diffserv domain ds1
     8021p-inbound 2 phb af1 red
     8021p-inbound 5 phb af3 yellow
     8021p-inbound 6 phb ef green
    #
    drop-profile wred1
     color green low-limit 80 high-limit 100 discard-percentage 10
     color yellow low-limit 60 high-limit 80 discard-percentage 20
     color red low-limit 40 high-limit 60 discard-percentage 40
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 5 to 6
     qos drr
     qos queue 1 drr weight 50
     qos queue 3 drr weight 100
     qos queue 5 drr weight 0
     qos wred wred1
     qos queue 1 wred wred1
     qos queue 3 wred wred1
     qos queue 5 wred wred1
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 5 to 6
     qos drr
     qos queue 1 drr weight 50
     qos queue 3 drr weight 100
     qos queue 5 drr weight 0
     qos wred wred1
     qos queue 1 wred wred1
     qos queue 3 wred wred1
     qos queue 5 wred wred1
    #
    interface GigabitEthernet2/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 5 to 6
     trust upstream ds1
     trust 8021p inner
    #
    return
    
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15791

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente