No se encuentran recursos de mapeo en el idioma seleccionado.

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar una política de tráfico para evitar que algunos usuarios accedan a Internet en el tiempo especificado

Ejemplo para configurar una política de tráfico para evitar que algunos usuarios accedan a Internet en el tiempo especificado

Descripción general

La interfaz de línea de comandos QoS modular (MQC) permite que el dispositivo clasifique el tráfico por tipo, proporcionando el mismo servicio para paquetes del mismo tipo y servicios diferenciados para paquetes de diferentes tipos. El filtrado del tipo especificado de paquetes solo se puede implementar a través de MQC.

Cuando los paquetes de un tipo se consideran no confiables, MQC se puede usar para diferenciar los paquetes de otros tipos de paquetes y descartarlos. Cuando los paquetes de un tipo se consideran confiables, MQC se puede usar para diferenciar los paquetes de otros tipos de paquetes y permitir que pasen.

En comparación con la lista negra, el filtrado de paquetes basado en MQC clasifica los paquetes de una manera más precisa y es más flexible de deslegar.

Notas de configuración

Tabla 13-18  Modelos de productos y versiones aplicables

Producto

Modelo del Producto

Versión del software

S2300

S2352P-EI

V100R006C05

S2320EI

V200R011C10, V200R012C00

S2350EI

V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

S3300

S3300SI y S3300EI

V100R006C05

S3300HI

V200R001C00

S5300

S5300LI

V200R001C00, V200R002C00, V200R003(C00&C02), V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5300SI

V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C02)

S5300EI

V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S5300HI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S5306

V200R001C00, V200R002C00, V200R003C00, V200R005C00

S5310EI

V200R002C00, V200R003C00, V200R005(C00&C02)

S5320LI

V200R010C00, V200R011C10, V200R012C00

S5320SI

V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5320EI

V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5320HI

V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5330SI

V200R011C10, V200R012C00

S6300

S6300EI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S6320SI

V200R011C10, V200R012C00

S6320EI

V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

S6320HI

V200R012C00

S9300

S9303, S9306 y S9312

V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

S9300

S9310

V200R010C00, V200R011C10, V200R012C00

S9300X

S9310X

V200R010C00, V200R011C10, V200R012C00

S9300E

S9303E, S9306E y S9312E

V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

NOTA:
Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.
En switches fijos excepto los siguientes en versiones especificadas, si la acción de permiso se configura en la vista de comportamiento de tráfico, CPCAR puede quedar invalidada:
  • S5320EI y S6320EI en V200R008C00 y versiones posteriores
  • S5320HI en V200R009C00 y versiones posteriores
  • S6320HI en V200R012C00

Requisitos de red

En Figura 13-12, la empresa tiene dos departamentos, que pertenecen a VLAN 10 y VLAN 20, respectivamente. Los servidores se implementan en la VLAN 10 para proporcionar servicios a usuarios internos y externos, y los servicios de oficina de los empleados se transmiten en la VLAN 20. La compañía requiere que los empleados de la VLAN 20 solo accedan a servidores en la VLAN 10 durante el horario de trabajo (8:00 a 18:00).

Figura 13-12  Evitar que los empleados accedan a Internet en el momento especificado

Dispositivo

Interfaz

VLAN

Interfaz de Capa 3

Dirección IP

SwitchA

GigabitEthernet1/0/1

VLAN 10

-

192.168.1.1/24

GigabitEthernet1/0/2

VLAN 20

-

192.168.2.1/24

GigabitEthernet1/0/3

VLAN 10 y VLAN 20

-

192.168.3.1/24

Switch

GigabitEthernet1/0/1

VLAN 10 y VLAN 20

VLANIF 10 y VLANIF 20

VLANIF 10: 192.168.1.1/24

VLANIF 20: 192.168.2.1/24

GigabitEthernet1/0/2

VLAN 30

VLANIF 30

10.1.20.2/24

GigabitEthernet1/0/3

VLAN 40

VLANIF 40

10.1.30.2/24

Hoja de ruta de configuración

La hoja de ruta de la configuración es la siguiente:
  1. Cree VLAN y configure interfaces y un protocolo de enrutamiento para implementar el interfuncionamiento entre la empresa y la red externa.
  2. En el Switch, configure un rango de tiempo de 8:00 a 18:00 de lunes a viernes para que el dispositivo pueda controlar el tráfico en función del rango de tiempo.
  3. En el Switch, configure una ACL para que coincida con el tráfico cuando los empleados de la VLAN 20 accedan a los servidores en la VLAN 10 en función del rango de tiempo,
  4. Configure un clasificador de tráfico en Switch para clasificar paquetes basados ​​en la ACL.
  5. Configure un comportamiento de tráfico en Switch para permitir el paso del tráfico coincidente.
  6. Configure una política de tráfico en el Switch, vincule la política de tráfico con el clasificador de tráfico y el comportamiento del tráfico, y aplique la política de tráfico a la dirección entrante de GE1/0/1 conectada a Switch A para que los empleados de la VLAN 20 no puedan acceder al Internet durante el horario de trabajo y puede acceder a Internet durante el tiempo no laborable.

Procedimiento

  1. Cree VLAN y configure interfaces.

    # Configure el switch.

    <Quidway> system-view
    [Quidway] sysname Switch
    [Switch] vlan batch 10 20 30 40  //Cree VLAN 10 a VLAN 40.
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type trunk  //Establezca el tipo de enlace de la interfaz a trunk.
    [Switch-GigabitEthernet1/0/1] port trunk allow-pass vlan 10 20  //Agregue la interfaz a VLAN 10 y VLAN 20.
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type access  //Establezca el tipo de enlace de la interfaz a acceso.
    [Switch-GigabitEthernet1/0/2] port default vlan 30  //Agregue la interfaz a la VLAN 30.
    [Switch-GigabitEthernet1/0/2] quit
    [Switch] interface gigabitethernet 1/0/3
    [Switch-GigabitEthernet1/0/3] port link-type access
    [Switch-GigabitEthernet1/0/3] port default vlan 40
    [Switch-GigabitEthernet1/0/3] quit
    [Switch] interface vlanif 10  //Cree una interfaz VLANIF.
    [Switch-Vlanif10] ip address 192.168.1.1 255.255.255.0  //Configure una dirección IP para la interfaz VLANIF. La dirección IP es la dirección de gateway del segmento de red 192.168.1.0/24.
    [Switch-Vlanif10] quit
    [Switch] interface vlanif 20
    [Switch-Vlanif20] ip address 192.168.2.1 255.255.255.0
    [Switch-Vlanif20] quit
    [Switch] interface vlanif 30  //Cree una interfaz VLANIF.
    [Switch-Vlanif30] ip address 10.1.20.2 255.255.255.0  //Configure una dirección IP a la interfaz VLANIF para conectarse con RouterA.
    [Switch-Vlanif30] quit
    [Switch] interface vlanif 40
    [Switch-Vlanif40] ip address 10.1.30.2 255.255.255.0
    [Switch-Vlanif40] quit
    [Switch] ip route-static 0.0.0.0 0 10.1.20.1  //Configure una ruta estática apuntando a la red externa para implementar el interfuncionamiento y configure el balanceo de carga.
    [Switch] ip route-static 0.0.0.0 0 10.1.30.1
    

    # Configure SwitchA.

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan batch 10 20  //Cree VLAN 10 y VLAN 20.
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type access  //Establezca el tipo de enlace de la interfaz a acceso.
    [SwitchA-GigabitEthernet1/0/1] port default vlan 10  //Agregue la interfaz a la VLAN 10.
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type access
    [SwitchA-GigabitEthernet1/0/2] port default vlan 20
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] interface gigabitethernet 1/0/3
    [SwitchA-GigabitEthernet1/0/3] port link-type trunk  //Establezca el tipo de enlace de la interfaz a trunk.
    [SwitchA-GigabitEthernet1/0/3] port trunk allow-pass vlan 10 20  //Agregue la interfaz a VLAN 10 y VLAN 20.
    [SwitchA-GigabitEthernet1/0/3] quit
    

    # Configure el router.

    Configure la dirección IP de 10.1.20.1/24 para la interfaz del RouterA conectada al switch.

    Configure la dirección IP de 10.1.30.1/24 para la interfaz del RouterB conectada al switch.

  2. Configure un rango de tiempo.

    # Configure un rango de tiempo de 8:00-18:00 de lunes a viernes en Switch.

    [Switch] time-range worktime 8:00 to 18:00 working-day
    

  3. Configure una ACL.

    # Configure una ACL en el Switchy defina reglas que permitan y rechacen el tráfico.

    [Switch] acl 3000
    [Switch-acl-adv-3000] rule permit ip source 192.168.2.0 0.0.0.255 destination 192.168.1.0 0.0.0.255 time-range worktime  //Configure una regla de ACL para permitir que los usuarios de la VLAN 20 accedan a los servidores de la VLAN 10 durante el tiempo de trabajo.
    [Switch-acl-adv-3000] rule deny ip source 192.168.2.0 0.0.0.255 time-range worktime  //Configure una regla de ACL para evitar que los usuarios de la VLAN 20 accedan a la red pública durante el tiempo de trabajo.
    [Switch-acl-adv-3000] quit
    

  4. Configure un clasificador de tráfico.

    # Configure un clasificador de tráfico en Switch para clasificar paquetes basados ​​en la ACL.

    [Switch] traffic classifier c1 operator and
    [Switch-classifier-c1] if-match acl 3000
    [Switch-classifier-c1] quit
    

  5. Configure un comportamiento de tráfico.

    # Configure un comportamiento de tráfico en el Switch y defina la acción de permiso.

    [Switch] traffic behavior b1
    [Switch-behavior-b1] permit
    [Switch-behavior-b1] quit
    

  6. Configure una política de tráfico y aplique la política de tráfico a una interfaz.

    # Cree una política de tráfico en Switch, vincule el comportamiento del tráfico y el clasificador de tráfico a la política de tráfico, y aplique la política de tráfico a la dirección entrante de GE1/0/1 conectado a SwitchA.

    [Switch] traffic policy p1
    [Switch-trafficpolicy-p1] classifier c1 behavior b1
    [Switch-trafficpolicy-p1] quit
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] traffic-policy p1 inbound
    [Switch-GigabitEthernet1/0/1] quit
    

  7. Verifique la configuración

    # Compruebe la configuración de ACL.

    [Switch] display acl 3000
    Advanced ACL 3000, 2 rules
    Acl's step is 5
     rule 5 permit ip source 192.168.2.0 0.0.0.255 destination 192.168.1.0 0.0.0.255 time-range worktime (match-counter 0)(Active)
     rule 10 deny ip source 192.168.2.0 0.0.0.255 time-range worktime (match-counter 0)(Active)
    
    NOTA:

    Si la hora del dispositivo está dentro del rango de tiempo definido, el rango de tiempo en la regla de ACL se muestra como Active; de lo contrario, el rango de tiempo en la regla de ACL se muestra como Inactive.

    # Compruebe la configuración de la política de tráfico.

    [Switch] display traffic policy user-defined p1
      User Defined Traffic Policy Information:
      Policy: p1
       Classifier: c1
        Operator: AND
         Behavior: b1
          Permit
    

    # Los empleados en la VLAN 20 no pueden acceder a la red pública durante el horario de trabajo y pueden acceder en los servidores en la VLAN 10.

Archivos de configuración

  • Archivo de configuración de Switch

    #
    sysname Switch
    #
    vlan batch 10 20 30 40
    #
    time-range worktime 08:00 to 18:00 working-day
    #
    acl number 3000  
     rule 5 permit ip source 192.168.2.0 0.0.0.255 destination 192.168.1.0 0.0.0.255 time-range worktime 
     rule 10 deny ip source 192.168.2.0 0.0.0.255 time-range worktime 
    #
    traffic classifier c1 operator and precedence 5
     if-match acl 3000
    #
    traffic behavior b1
     permit
    #
    traffic policy p1 match-order config
     classifier c1 behavior b1
    #
    interface Vlanif10
     ip address 192.168.1.1 255.255.255.0
    #
    interface Vlanif20
     ip address 192.168.2.1 255.255.255.0
    #
    interface Vlanif30
     ip address 10.1.20.2 255.255.255.0
    #
    interface Vlanif40
     ip address 10.1.30.2 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 20
     traffic-policy p1 inbound
    #
    interface GigabitEthernet1/0/2
     port link-type access
     port default vlan 30
    #
    interface GigabitEthernet1/0/3
     port link-type access
     port default vlan 40
    #
    ip route-static 0.0.0.0 0.0.0.0 10.1.20.1
    ip route-static 0.0.0.0 0.0.0.0 10.1.30.1
    #
    return
  • Archivo de configuración de SwitchA

    #
    sysname SwitchA
    #
    vlan batch 10 20
    #
    interface GigabitEthernet1/0/1
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet1/0/2
     port link-type access
     port default vlan 20
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     port trunk allow-pass vlan 10 20
    #
    return
    
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15766

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente