No se encuentran recursos de mapeo en el idioma seleccionado.

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar una política de tráfico para recopilar estadísticas en paquetes ping

Ejemplo para configurar una política de tráfico para recopilar estadísticas en paquetes ping

Descripción general

Durante la rectificación de fallos de red, los dispositivos no pueden hacer ping entre sí. Puede configurar el dispositivo para recopilar estadísticas sobre paquetes ping para reducir el ámbito de búsqueda y localizar puntos de fallo rápidamente.

Los paquetes ping son paquetes ICMP, por lo que puede definir ICMP en una ACL avanzada para que coincida con los paquetes ping. Cuando se usa una política de tráfico para recopilar estadísticas sobre paquetes de ping, una ACL se usa para clasificar paquetes y la acción de estadísticas de tráfico se define para los paquetes coincidentes. Los resultados estadísticos permiten a localizar fallos.

  • Si los números de paquetes ping recibidos y reenviados en un dispositivo son los mismos, los paquetes ping se reenvían normalmente y no se produce la pérdida de paquetes. Si la cantidad de paquetes ping recibidos es mayor que la cantidad de paquetes ping enviados, la pérdida de paquetes ocurre en el dispositivo.
  • Si el número de paquetes de ping recibidos es igual al número de paquetes ping recibidos en una interfaz, los paquetes de ping se reenvían normalmente y no se produce la pérdida de paquetes en el enlace de la interfaz. Si la cantidad de paquetes ping enviados es mayor que la cantidad de paquetes ping recibidos en la interfaz, la pérdida de paquetes se produce en el enlace de la interfaz. En este caso, el dispositivo remoto debe configurarse para recopilar estadísticas de paquetes para la ubicación de fallos.

Notas de configuración

Tabla 13-19  Modelos de productos y versiones aplicables

Producto

Modelo del Producto

Versión del software

S2300

S2352P-EI

V100R006C05

S2320EI

V200R011C10, V200R012C00

S2350EI

V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

S3300

S3300SI y S3300EI

V100R006C05

S3300HI

V200R001C00

S5300

S5300LI

V200R001C00, V200R002C00, V200R003(C00&C02), V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5300SI

V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C02)

S5300EI

V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S5300HI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S5306

V200R001C00, V200R002C00, V200R003C00, V200R005C00

S5310EI

V200R002C00, V200R003C00, V200R005(C00&C02)

S5320LI

V200R010C00, V200R011C10, V200R012C00

S5320SI

V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5320EI

V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5320HI

V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5330SI

V200R011C10, V200R012C00

S6300

S6300EI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S6320SI

V200R011C10, V200R012C00

S6320EI

V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

S6320HI

V200R012C00

S9300

S9303, S9306 y S9312

V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

S9300

S9310

V200R010C00, V200R011C10, V200R012C00

S9300X

S9310X

V200R010C00, V200R011C10, V200R012C00

S9300E

S9303E, S9306E y S9312E

V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

NOTA:
Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de red

En Figura 13-13, el PC no puede acceder al servidor. El dispositivo donde pasan los flujos de datos debe configurarse para recopilar estadísticas sobre los paquetes de ping para que se pueda ubicar el punto de fallo.

Figura 13-13  Configurar una política de tráfico para recopilar estadísticas sobre paquetes ping

Hoja de ruta de configuración

La hoja de ruta de la configuración es la siguiente:
  1. Cree VLAN y configure interfaces para garantizar la conectividad de la red.
  2. Configure las ACL para que coincidan con los paquetes ICMP intercambiados entre el PC y el servidor.
  3. Configure clasificadores de tráfico para clasificar paquetes basados ​​en las ACL.
  4. Configure comportamientos de tráfico y defina la acción de estadísticas de tráfico.
  5. Configure políticas de tráfico, vincule los clasificadores de tráfico y el comportamiento del tráfico con las políticas de tráfico, y aplique las políticas de tráfico a las direcciones entrantes y salientes de GE1/0/1 y GE1/0/2 deSwitch.

Procedimiento

  1. Cree VLAN y configure interfaces.

    # Configurar elSwitch.

    <Quidway> system-view
    [Quidway] sysname Switch
    [Switch] vlan 10  //Cree VLAN 10.
    [Switch-vlan10] quit
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type access  //Establezca el tipo de enlace de la interfaz a acceso.
    [Switch-GigabitEthernet1/0/1] port default vlan 10  //Agregue la interfaz a la VLAN 10.
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type access
    [Switch-GigabitEthernet1/0/2] port default vlan 10
    [Switch-GigabitEthernet1/0/2] quit
    

    # Configure la dirección de gateway del PC 10.1.1.2/24 para la interfaz del router conectado a Switch, y configure la dirección IP 10.1.2.1/24 para la interfaz del router conectado al servidor.

  2. Configure ACL.

    # Configure las reglas de ACL en Switch para que coincida con los paquetes ICMP intercambiados entre el PC y el servidor.

    [Switch] acl 3001
    [Switch-acl-adv-3001] rule permit icmp source 10.1.1.1 0 destination 10.1.2.10 0  //Configure una regla de ACL para permitir los paquetes desde el PC al servidor.
    [Switch-acl-adv-3001] quit
    [Switch] acl 3002
    [Switch-acl-adv-3002] rule permit icmp source 10.1.2.10 0 destination 10.1.1.1 0  //Configure una regla de ACL para permitir los paquetes desde el servidor al PC.
    [Switch-acl-adv-3002] quit
    

  3. Configure clasificadores de tráfico.

    # Configure los clasificadores de tráfico en Switch para clasificar paquetes basados ​​en la ACL.

    [Switch] traffic classifier c1 operator and
    [Switch-classifier-c1] if-match acl 3001
    [Switch-classifier-c1] quit
    [Switch] traffic classifier c2 operator and
    [Switch-classifier-c2] if-match acl 3002
    [Switch-classifier-c2] quit
    

  4. Configure los comportamientos de tráfico.

    # Configure los comportamientos de tráfico en Switch y defina la acción de estadísticas de tráfico en los comportamientos de tráfico.

    [Switch] traffic behavior b1
    [Switch-behavior-b1] statistic enable
    [Switch-behavior-b1] quit
    [Switch] traffic behavior b2
    [Switch-behavior-b2] statistic enable
    [Switch-behavior-b2] quit
    

  5. Configure las políticas de tráfico y aplique las políticas de tráfico a las interfaces.

    # Cree las políticas de tráfico p1 y p2 en Switch, enlace los comportamientos de tráfico y los clasificadores de tráfico a las políticas de tráfico, aplique la política de tráfico p1 a la dirección de entrada de GE1/0/1 y la dirección saliente de GE1/0/2, y aplique la política de tráfico p2 a la dirección de salida de GE1/0/1 y la dirección de entrada de GE1/0/2.

    [Switch] traffic policy p1
    [Switch-trafficpolicy-p1] classifier c1 behavior b1
    [Switch-trafficpolicy-p1] quit
    [Switch] traffic policy p2
    [Switch-trafficpolicy-p2] classifier c2 behavior b2
    [Switch-trafficpolicy-p2] quit
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] traffic-policy p1 inbound
    [Switch-GigabitEthernet1/0/1] traffic-policy p2 outbound
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] traffic-policy p1 outbound
    [Switch-GigabitEthernet1/0/2] traffic-policy p2 inbound
    [Switch-GigabitEthernet1/0/2] quit
    

  6. Verifique la configuración

    # Compruebe la configuración de ACL en elSwitch.

    [Switch] display acl all
     Total nonempty ACL number is 2
    
    Advanced ACL 3001, 1 rule
    Acl's step is 5
     rule 5 permit icmp source 10.1.1.1 0 destination 10.1.2.10 0 (match-counter 0)
    
    Advanced ACL 3002, 1 rule
    Acl's step is 5
     rule 5 permit icmp source 10.1.2.10 0 destination 10.1.1.1 0 (match-counter 0)
    

    # Compruebe la configuración de la política de tráfico enSwitch.

    [Switch] display traffic policy user-defined
      User Defined Traffic Policy Information:
      Policy: p2
       Classifier: c2
        Operator: AND
         Behavior: b2
          Permit
          Statistic: enable
    
      Policy: p1
       Classifier: c1
        Operator: AND
         Behavior: b1
          Permit
          Statistic: enable
    
    Total policy number is 2
    

    # Haga ping al servidor desde el PC y compruebe las estadísticas de tráfico en las direcciones entrantes y salientes deGE1/0/1 y GE1/0/2 en el Switch. Aquí, compruebe las estadísticas de tráfico en la dirección entrante de GE1/0/1.

    [Switch] display traffic policy statistics interface gigabitethernet 1/0/1 inbound
    
     Interface: GigabitEthernet1/0/1
     Traffic policy inbound: p1
     Rule number: 1
     Current status: success
     Statistics interval: 300
    ---------------------------------------------------------------------
     Board : 1
    ---------------------------------------------------------------------
     Matched          |      Packets:                             0
                      |      Bytes:                               0
                      |      Rate(pps):                           0
                      |      Rate(bps):                           0
    ---------------------------------------------------------------------
       Passed         |      Packets:                             0
                      |      Bytes:                               0
                      |      Rate(pps):                           0
                      |      Rate(bps):                           0
    ---------------------------------------------------------------------
       Dropped        |      Packets:                             0
                      |      Bytes:                               0
                      |      Rate(pps):                           0
                      |      Rate(bps):                           0
    ---------------------------------------------------------------------
         Filter       |      Packets:                             0
                      |      Bytes:                               0
    ---------------------------------------------------------------------
         Car          |      Packets:                             0
                      |      Bytes:                               0
    ---------------------------------------------------------------------
    

    Matched indica el número de paquetes y bytes que coinciden con el clasificador de tráfico, y Passed indica el número de paquetes reenviados y bytes que coinciden con el clasificador de tráfico. La siguiente tabla describe las estadísticas de tráfico.

    Estadísticas de tráfico en GigabitEthernet1/0/1

    Estadísticas de tráfico en GigabitEthernet1/0/2

    Descripción

    display traffic policy statistics interface gigabitethernet 1/0/1 inbound

    display traffic policy statistics interface gigabitethernet 1/0/2 outbound

    • Si las estadísticas son 0, los paquetes de solicitud de ping no llegan a Switch.
    • Si las estadísticas son consistentes y no son 0, los paquetes de solicitud de ping se reenvían normalmente.
    • Si las estadísticas en la dirección de entrada de GigabitEthernet1/0/1 son más que las estadísticas en la dirección de salida de GigabitEthernet1/0/2, los paquetes de solicitud de ping se descartan en Switch y Switch es el punto de fallo.

    display traffic policy statistics interface gigabitethernet 1/0/1 outbound

    display traffic policy statistics interface gigabitethernet 1/0/2 inbound

    • Si las estadísticas son 0, los paquetes de respuesta de ping no llegan a Switch.
    • Si las estadísticas son consistentes y no son 0, los paquetes de respuesta de ping se reenvían normalmente.
    • Si las estadísticas en la dirección de entrada de GigabitEthernet1/0/2 son más que las estadísticas en la dirección de salida de GigabitEthernet1/0/1, los paquetes de solicitud de ping se descartan en Switch ySwitch es el punto de fallo.

Archivos de configuración

Archivo de configuración de Switch

#
sysname Switch
#
vlan batch 10
#
acl number 3001
 rule 5 permit icmp source 10.1.1.1 0 destination 10.1.2.10 0
acl number 3002
 rule 5 permit icmp source 10.1.2.10 0 destination 10.1.1.1 0
#
traffic classifier c1 operator and precedence 5
 if-match acl 3001
traffic classifier c2 operator and precedence 10
 if-match acl 3002
#
traffic behavior b1
 permit
 statistic enable
traffic behavior b2
 permit
 statistic enable
#
traffic policy p1 match-order config
 classifier c1 behavior b1
traffic policy p2 match-order config
 classifier c2 behavior b2
#
interface GigabitEthernet1/0/1
 port link-type access
 port default vlan 10
 traffic-policy p1 inbound
 traffic-policy p2 outbound
#
interface GigabitEthernet1/0/2
 port link-type access
 port default vlan 10
 traffic-policy p2 inbound
 traffic-policy p1 outbound
#
return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15713

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente