No se encuentran recursos de mapeo en el idioma seleccionado.

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar una política de tráfico para implementar estadísticas de tráfico

Ejemplo para configurar una política de tráfico para implementar estadísticas de tráfico

Descripción general

Después de que MQC se usa para implementar estadísticas de tráfico, el dispositivo recopila estadísticas sobre paquetes y bytes de paquetes que coinciden con las reglas de clasificación de tráfico. Las estadísticas sobre los paquetes reenviados y descartados después de aplicar una política de tráfico le ayudan a verificar si la política de tráfico se aplica correctamente y ubicar las fallas.

Las estadísticas de tráfico basadas en la interfaz en las direcciones de entrada y de salida pueden configurarse simultáneamente o separadamente. El dispositivo recopila las estadísticas de tráfico en las direcciones de entrada y de salida separadamente.

Notas de configuración

Tabla 13-20  Modelos de productos y versiones aplicables

Producto

Modelo del Producto

Versión del software

S2300

S2352P-EI

V100R006C05

S2320EI

V200R011C10, V200R012C00

S2350EI

V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

S3300

S3300SI y S3300EI

V100R006C05

S3300HI

V200R001C00

S5300

S5300LI

V200R001C00, V200R002C00, V200R003(C00&C02), V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5300SI

V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C02)

S5300EI

V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S5300HI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S5306

V200R001C00, V200R002C00, V200R003C00, V200R005C00

S5310EI

V200R002C00, V200R003C00, V200R005(C00&C02)

S5320LI

V200R010C00, V200R011C10, V200R012C00

S5320SI

V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5320EI

V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5320HI

V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5330SI

V200R011C10, V200R012C00

S6300

S6300EI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S6320SI

V200R011C10, V200R012C00

S6320EI

V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

S6320HI

V200R012C00

S9300

S9303, S9306 y S9312

V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

S9300

S9310

V200R010C00, V200R011C10, V200R012C00

S9300X

S9310X

V200R010C00, V200R011C10, V200R012C00

S9300E

S9303E, S9306E y S9312E

V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

NOTA:
Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de red

En Figura 13-14, la empresa tiene dos departamentos, que pertenecen a VLAN 10 y VLAN 20, respectivamente. El administrador de la red desea determinar si el host de 192.168.2.200/24 en la VLAN 20 puede acceder al servidor de 192.168.1.100/24 en la VLAN 10.

Figura 13-14  Configurar una política de tráfico para implementar estadísticas de tráfico

Dispositivo

Interfaz

VLAN

Interfaz de Capa 3

Dirección IP

SwitchA

GigabitEthernet1/0/1

VLAN 10

-

-

GigabitEthernet1/0/2

VLAN 20

-

-

GigabitEthernet1/0/3

VLAN 10 y VLAN 20

-

-

Switch

GigabitEthernet1/0/1

VLAN 10 y VLAN 20

VLANIF 10 y VLANIF 20

VLANIF 10: 192.168.1.1/24

VLANIF 20: 192.168.2.1/24

GigabitEthernet1/0/2

VLAN 30

VLANIF 30

10.1.20.2/24

Hoja de ruta de configuración

La hoja de ruta de la configuración es la siguiente:
  1. Cree VLAN y configure interfaces y un protocolo de enrutamiento para implementar el interfuncionamiento.
  2. Configure una ACL en Switchpara coincidir con el tráfico especificado.
  3. Configure un clasificador de tráfico en Switch para clasificar paquetes basados ​​en la ACL.
  4. Configure un comportamiento de tráfico en Switchpara recopilar estadísticas sobre paquetes coincidentes.
  5. Configure una política de tráfico en Switch, vincule la política de tráfico con el clasificador de tráfico y el comportamiento del tráfico, y aplique la política de tráfico a GE1/0/1conectado a SwitchA en la dirección entrante.

Procedimiento

  1. Cree VLAN y configure interfaces.

    # Configure el switch.

    <Quidway> system-view
    [Quidway] sysname Switch
    [Switch] vlan batch 10 20 30  //Cree VLAN 10, VLAN 20 y VLAN 30.
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type trunk  //Establezca el tipo de enlace de la interfaz a trunk.
    [Switch-GigabitEthernet1/0/1] port trunk allow-pass vlan 10 20  //Agregue la interfaz a VLAN 10 y VLAN 20.
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type access  //Establezca el tipo de enlace de la interfaz a acceso.
    [Switch-GigabitEthernet1/0/2] port default vlan 30  //Agregue la interfaz a la VLAN 30.
    [Switch-GigabitEthernet1/0/2] quit
    [Switch] interface vlanif 10  //Cree una interfaz VLANIF.
    [Switch-Vlanif10] ip address 192.168.1.1 255.255.255.0  //Configure una dirección IP para la interfaz VLANIF. La dirección IP es la dirección de gateway del segmento de red 192.168.1.0/24.
    [Switch-Vlanif10] quit
    [Switch] interface vlanif 20
    [Switch-Vlanif20] ip address 192.168.2.1 255.255.255.0
    [Switch-Vlanif20] quit
    [Switch] interface vlanif 30  //Cree una interfaz VLANIF.
    [Switch-Vlanif30] ip address 10.1.20.2 255.255.255.0  //Configure una dirección IP a la interfaz VLANIF para conectarse con el router.
    [Switch-Vlanif30] quit
    [Switch] ip route-static 0.0.0.0 0 10.1.20.1  //Configure una ruta estática apuntando a la red externa para implementar el interfuncionamiento.
    

    # Configure SwitchA.

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan batch 10 20  //Cree VLAN 10 y VLAN 20.
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type access  //Establezca el tipo de enlace de la interfaz a acceso.
    [SwitchA-GigabitEthernet1/0/1] port default vlan 10  //Agregue la interfaz a la VLAN 10.
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type access
    [SwitchA-GigabitEthernet1/0/2] port default vlan 20
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] interface gigabitethernet 1/0/3
    [SwitchA-GigabitEthernet1/0/3] port link-type trunk  //Establezca el tipo de enlace de la interfaz a trunk.
    [SwitchA-GigabitEthernet1/0/3] port trunk allow-pass vlan 10 20  //Agregue la interfaz a VLAN 10 y VLAN 20.
    [SwitchA-GigabitEthernet1/0/3] quit
    

    # Configure el router.

    Configure la dirección IP de 10.1.20.1/24 para la interfaz del router conectado al switch.

  2. Configure una ACL.

    # Configure una regla de ACL en la Switchpara hacer coincidir el tráfico con la dirección IP de origen de 192.168.2.200 y la dirección IP de destino de 192.168.1.100.

    [Switch] acl 3000
    [Switch-acl-adv-3000] rule permit ip source 192.168.2.200 0.0.0.0 destination 192.168.1.100 0.0.0.0
    [Switch-acl-adv-3000] quit
    

  3. Configure un clasificador de tráfico.

    # Configure un clasificador de tráfico en Switchpara clasificar los paquetes basados ​​en la ACL.

    [Switch] traffic classifier c1 operator and
    [Switch-classifier-c1] if-match acl 3000
    [Switch-classifier-c1] quit
    

  4. Configure un comportamiento de tráfico.

    # Configure un comportamiento de tráfico en Switch y defina la acción de estadísticas de tráfico en el comportamiento del tráfico.

    [Switch] traffic behavior b1
    [Switch-behavior-b1] statistic enable
    [Switch-behavior-b1] quit
    

  5. Configure una política de tráfico y aplique la política de tráfico a una interfaz.

    # Cree una política de tráfico en Switch, vincule el comportamiento del tráfico y el clasificador de tráfico a la política de tráfico, y aplique la política de tráfico a la dirección entrante de GE1/0/1 conectado a SwitchA.

    [Switch] traffic policy p1
    [Switch-trafficpolicy-p1] classifier c1 behavior b1
    [Switch-trafficpolicy-p1] quit
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] traffic-policy p1 inbound
    [Switch-GigabitEthernet1/0/1] quit
    

  6. Verifique la configuración

    # Compruebe la configuración de ACL.

    [Switch] display acl 3000
    Advanced ACL 3000, 1 rule
    Acl's step is 5
     rule 5 permit ip source 192.168.2.200 0 destination 192.168.1.100 0 (match-counter 0)
    

    # Compruebe la configuración de la política de tráfico.

    [Switch] display traffic policy user-defined p1
      User Defined Traffic Policy Information:
      Policy: p1
       Classifier: c1
        Operator: AND
         Behavior: b1
          Permit
          Statistic: enable

    # Compruebe las estadísticas de tráfico.

    [Switch] display traffic policy statistics interface gigabitethernet 1/0/1 inbound
                                                                                    
     Interface: GigabitEthernet1/0/1                                                       
     Traffic policy inbound: p1                                                     
     Rule number: 1                                                                 
     Current status: success                                                            
     Statistics interval: 300                         
    ---------------------------------------------------------------------           
     Board : 1                           
    ---------------------------------------------------------------------       
     Matched          |      Packets:                             0
                      |      Bytes:                               0
                      |      Rate(pps):                           0
                      |      Rate(bps):                           0
    ---------------------------------------------------------------------           
       Passed         |      Packets:                             0
                      |      Bytes:                               0
                      |      Rate(pps):                           0
                      |      Rate(bps):                           0
    ---------------------------------------------------------------------           
       Dropped        |      Packets:                             0                 
                      |      Bytes:                               0                 
                      |      Rate(pps):                           0                 
                      |      Rate(bps):                           0                 
    ---------------------------------------------------------------------           
         Filter       |      Packets:                             0                 
                      |      Bytes:                               0                 
    ---------------------------------------------------------------------           
         Car          |      Packets:                             0                 
                      |      Bytes:                               0                 
    ---------------------------------------------------------------------
    
    

    Matched indica el número de paquetes y bytes que coinciden con el clasificador de tráfico, y Passed indica el número de paquetes reenviados y bytes que coinciden con el clasificador de tráfico. Si los valores de Matched y Passed no son 0, el host de 192.168.2.200 en la VLAN 20 ha accedido al servidor de 192.168.1.100 en la VLAN 10.

Archivos de configuración

  • Archivo de configuración deSwitch

    #
    sysname Switch
    #
    vlan batch 10 20 30
    #
    acl number 3000
     rule 5 permit ip source 192.168.2.200 0 destination 192.168.1.100 0
    #
    traffic classifier c1 operator and precedence 5
     if-match acl 3000
    #
    traffic behavior b1
     permit
     statistic enable
    #
    traffic policy p1 match-order config
     classifier c1 behavior b1
    #
    interface Vlanif10
     ip address 192.168.1.1 255.255.255.0
    #
    interface Vlanif20
     ip address 192.168.2.1 255.255.255.0
    #
    interface Vlanif30
     ip address 10.1.20.2 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 20
     traffic-policy p1 inbound
    #
    interface GigabitEthernet1/0/2
     port link-type access
     port default vlan 30
    #
    ip route-static 0.0.0.0 0.0.0.0 10.1.20.1
    #
    return
  • Archivo de configuración de SwitchA

    #
    sysname SwitchA
    #
    vlan batch 10 20
    #
    interface GigabitEthernet1/0/1
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet1/0/2
     port link-type access
     port default vlan 20
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     port trunk allow-pass vlan 10 20
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15715

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente