No se encuentran recursos de mapeo en el idioma seleccionado.

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar la exportación de estadísticas de flujo original

Ejemplo para configurar la exportación de estadísticas de flujo original

Descripción general de NetStream

NetStream es una tecnología que recopila estadísticas y análisis del tráfico del servicio en las redes. NetStream facilita hacer la cuenta y la vigilancia de red.

Tiene las siguientes ventajas:

  • NetStream recopila estadísticas sobre múltiples tipos de información en paquetes. Proporciona una potente función de recopilación de estadísticas y resultados estadísticos detallados.
  • NetStream se puede desplegar con bajo costo. No se requiere ningún dispositivo dedicado para recopilar información de tráfico y no está ocupada ninguna interfaz del dispositivo.

Las estadísticas de flujo original se exportan cuando sobrepasa el tiempo de envejecimiento del flujo. Las estadísticas de cada flujo se exportan al servidor de NetStream. El servidor de NetStream obtiene estadísticas detalladas sobre cada flujo.

Notas de configuración

Para los switches modulares, NetStream solo es compatible con las tarjetas de la serie B, las tarjetas de la serie E (excepto la tarjeta LE2D2X48SEC0), la tarjeta LE1D2S04SEC0, la tarjeta LE1D2X32SEC0, la tarjeta LE1D2H02QEC0 y las tarjetas de la serie X.

NetStream entra en conflicto con IP Source Trail en switches modulares, por lo que no debe configurarlos simultáneamente.

Tabla 14-4  Modelos de productos y versiones aplicables
Producto

Modelo del producto

Versión del software

S5300

S5320HI

V200R009C00, V200R010C00, V200R011C10, V200R012C00

S9300

S9303, S9306, S9312

V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

S9310

V200R010C00, V200R011C10, V200R012C00

S9300X

S9310X

V200R010C00, V200R011C10, V200R012C00

S9300E

S9303E, S9306E, S9312E

V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

S6300 S6320HI

V200R012C00

Requisitos de redes

Como se muestra en Figura 14-4, El Departamento 1 y el Departamento 2 se conectan a Internet a través de SwitchA. Los administradores de red desean vigilar la comunicación entre los dos departamentos e Internet, y hacer la cuenta para cada departamento.

Figura 14-4  Diagrama de redes para configurar la exportación de estadísticas de flujo original

Hoja de ruta de configuración

Pueden configurar las estadísticas de flujo original de IPv4 exportando en GE1/0/1 de SwitchA. Configure SwitchA para recopilar estadísticas sobre el tráfico entrante y saliente en la interfaz, y para enviar las estadísticas al servidor de NetStream para un análisis posterior. De esta manera, se puede vigilar la comunicación entre los dos departamentos e Internet, y hacer la cuenta para cada departamento.

La hoja de ruta de la configuración es la siguiente:

  1. Configure las direcciones IP para las interfaces en SwitchA.
  2. Configure el muestreo de NetStream.
  3. Configure el envejecimiento del flujo de NetStream.
  4. Configure las exportaciones de estadísticas de flujo original.
  5. Configure la versión de los paquetes exportados.
  6. Habilite la recopilación de estadísticas de flujo de NetStream en GE1/0/1.

Procedimiento

  1. Configure las direcciones IP para las interfaces en SwitchA según Figura 14-4.

    # Configure las direcciones IP para las interfaces en SwitchA.

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan batch 100 200 300 400
    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] ip address 10.1.1.1 24
    [SwitchA-Vlanif100] quit
    [SwitchA] interface vlanif 200
    [SwitchA-Vlanif200] ip address 10.1.2.1 24
    [SwitchA-Vlanif200] quit
    [SwitchA] interface vlanif 300
    [SwitchA-Vlanif300] ip address 10.1.3.1 24
    [SwitchA-Vlanif300] quit
    [SwitchA] interface vlanif 400
    [SwitchA-Vlanif400] ip address 10.1.4.1 24
    [SwitchA-Vlanif400] quit
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type hybrid 
    [SwitchA-GigabitEthernet1/0/1] port hybrid pvid vlan 100 
    [SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 100
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type hybrid 
    [SwitchA-GigabitEthernet1/0/2] port hybrid pvid vlan 200 
    [SwitchA-GigabitEthernet1/0/2] port hybrid untagged vlan 200
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] interface gigabitethernet 1/0/3
    [SwitchA-GigabitEthernet1/0/3] port link-type hybrid 
    [SwitchA-GigabitEthernet1/0/3] port hybrid pvid vlan 300 
    [SwitchA-GigabitEthernet1/0/3] port hybrid untagged vlan 300
    [SwitchA-GigabitEthernet1/0/3] quit
    [SwitchA] interface gigabitethernet 1/0/4
    [SwitchA-GigabitEthernet1/0/4] port link-type hybrid 
    [SwitchA-GigabitEthernet1/0/4] port hybrid pvid vlan 400 
    [SwitchA-GigabitEthernet1/0/4] port hybrid untagged vlan 400
    [SwitchA-GigabitEthernet1/0/4] quit
    

  2. Configure el muestreo de NetStream.

    # Configure el muestreo de NetStream en GE1/0/1, configure la proporción de muestreo en 1200.

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] ip netstream sampler fix-packets 1200 inbound
    [SwitchA-GigabitEthernet1/0/1] ip netstream sampler fix-packets 1200 outbound
    [SwitchA-GigabitEthernet1/0/1] quit
    

  3. Configure el envejecimiento del flujo de NetStream.

    # Establezca el tiempo de envejecimiento inactivo en 100 segundos y habilite el envejecimiento basado en FIN y RST.

    [SwitchA] ip netstream timeout inactive 100
    [SwitchA] ip netstream tcp-flag enable

  4. Configure la exportación de estadísticas de flujo original de NetStream.

    # Configure la dirección IP de origen de los paquetes exportados que llevan las estadísticas de flujo original en 10.1.2.1, la dirección IP de destino en 10.1.2.2 y el número de puerto de destino en 6000.

    [SwitchA] ip netstream export source 10.1.2.1
    [SwitchA] ip netstream export host 10.1.2.2 6000

  5. Configure la versión de los paquetes exportados.

    # Establezca la versión de paquetes exportados a V9.

    [SwitchA] ip netstream export version 9

  6. Habilite la recopilación de estadísticas de flujo de NetStream en GE1/0/1.

    # Habilite la recopilación de estadísticas de flujo de NetStream en GE1/0/1.

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] ip netstream inbound
    [SwitchA-GigabitEthernet1/0/1] ip netstream outbound
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] quit

  7. Verifique la configuración.

    # Una vez completada la configuración, el servidor de NetStream puede recibir paquetes de estadísticas de SwitchA. Ejecute el comando display ip netstream statistics en SwitchA para ver las estadísticas de flujo de NetStream.

    <SwitchA> display ip netstream statistics slot 1
    ===== Netstream statistics: =====                                              
     Origin/Flexible ingress entries  : 35
     Origin/Flexible ingress packets  : 381920
     Origin/Flexible ingress octets   : 125269760
     Origin/Flexible egress entries   : 0
     Origin/Flexible egress packets   : 0
     Origin/Flexible egress octets    : 0  
     Origin/Flexible total entries    : 35
     Handle origin entries            : 35
     Handle As aggre entries          : 0                                           
     Handle ProtPort aggre entries    : 0                                           
     Handle SrcPrefix aggre entries   : 0                                           
     Handle DstPrefix aggre entries   : 0                                           
     Handle Prefix aggre entries      : 0                                           
     Handle AsTos aggre entries       : 0                                           
     Handle ProtPortTos aggre entries : 0                                           
     Handle SrcPreTos aggre entries   : 0                                           
     Handle DstPreTos aggre entries   : 0                                           
     Handle PreTos aggre entries      : 0  

Archivos de configuración

El archivo de configuración de SwitchA

#                                                                               
sysname SwitchA 
#                                                                               
vlan batch 100 200 300 400 
# 
ip netstream timeout inactive 100
ip netstream export version 9
ip netstream export source 10.1.2.1
ip netstream export host 10.1.2.2 6000
#
ip netstream tcp-flag enable
#                                                                               
interface Vlanif100                                                             
 ip address 10.1.1.1 255.255.255.0 
#                                                                               
interface Vlanif200                                                             
 ip address 10.1.2.1 255.255.255.0 
#                                                                               
interface Vlanif300                                                             
 ip address 10.1.3.1 255.255.255.0 
#                                                                               
interface Vlanif400                                                             
 ip address 10.1.4.1 255.255.255.0 
#                                                                               
interface GigabitEthernet1/0/1                                                  
 port hybrid pvid vlan 100                                                      
 port hybrid untagged vlan 100  
 ip netstream inbound
 ip netstream outbound
 ip netstream sampler fix-packets 1200 inbound
 ip netstream sampler fix-packets 1200 outbound
#                                                                               
interface GigabitEthernet1/0/2                                                  
 port hybrid pvid vlan 200                                                      
 port hybrid untagged vlan 200  
#                                                                               
interface GigabitEthernet1/0/3                                                  
 port hybrid pvid vlan 300                                                      
 port hybrid untagged vlan 300  
#                                                                               
interface GigabitEthernet1/0/4                                                  
 port hybrid pvid vlan 400                                                      
 port hybrid untagged vlan 400  
#
return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15744

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente