No se encuentran recursos de mapeo en el idioma seleccionado.

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar el espejado de puerto remoto de Capa 2

Ejemplo para configurar el espejado de puerto remoto de Capa 2

Descripción general del espejado de puerto remoto de Capa 2

En el espejado de puerto remoto de Capa 2, un puerto de observación se conecta a un dispositivo de vigilancia a través de una red de Capa 2. Después de que el puerto de observación reciba paquetes espejados de un puerto espejado, el puerto de observación agrega una etiqueta VLAN correspondiente a la red de Capa 2 a los paquetes y los reenvía a la red de Capa 2. Un dispositivo intermedio de Capa 2 luego envía los paquetes al dispositivo de vigilancia.

Notas de configuración

  • Un puerto de observación está dedicado a reenviar tráfico espejado. No configure otros servicios en un puerto de observación; de lo contrario, el tráfico espejado y el tráfico de otros servicios interfieren entre sí.

  • Si la función de espejado se despliega en muchos puertos de un dispositivo, se ocupará una gran cantidad de ancho de banda de reenvío interno, lo que afecta el reenvío de otros servicios. Además, si el ancho de banda del puerto espejado es mayor que el ancho de banda del puerto de observación, por ejemplo, 1000 Mbit/s en un puerto espejado y 100 Mbit/s en un puerto de observación, el puerto de observación no podrá reenviar todos los paquetes espejados a tiempo debido a la insuficiencia de ancho de banda, lo que ocurre la pérdida de paquetes.

  • En todos los modelos de switch modular de la serie S de Huawei, Eth-Trunks se pueden configurar como puertos de observación. En los siguientes modelos de switch fijo de la serie S de Huawei, Eth-Trunks se pueden configurar como puertos de observación en V200R005 y versiones posteriores: S5300EI, S5300HI, S5306, S5310EI, S5320EI, S5320HI, S6300EI, S6320EI, y S6320HI.

  • Ambas interfaces físicas y Eth-Trunks se pueden configurar como puertos espejados. Si un Eth-Trunk está configurado como un puerto espejado, sus puertos de miembros no se pueden configurar como puertos de observación.

  • El parámetro vlan vlan-id se especificará durante la configuración de un puerto de observación remoto de Capa 2, lo que indica que el puerto de observación remoto de Capa 2 puede enviar paquetes espejados al dispositivo de vigilancia a través de la VLAN especificada. En esta situación, el puerto de observación remoto de Capa 2 no se debe agregar a la VLAN especificada.

  • Todos los modelos de switch de Huawei excepto S2300SI de V100R006C05 admiten el espejado de puertos remotos de Capa 2.

Requisitos de redes

Como se muestra en Figura 14-12, el departamento administrativo de una compañía accede a Internet a través del SwitchA, y el Server del dispositivo de vigilancia está directamente conectado al SwitchA por SwitchB.

El tráfico de acceso a Internet del departamento administrativo debe ser vigilado a través del Server.

Figura 14-12  Redes de puerto espejado remoto de Capa 2

Hoja de ruta de configuración

La hoja de ruta de la configuración es la siguiente:
  1. Configure GE1/0/2 del SwitchA como un puerto de observación remoto de Capa 2 para reenviar paquetes espejados a la VLAN especificada.
  2. Configure GE1/0/1 del SwitchA como un puerto espejado para copiar el tráfico de acceso a Internet del departamento administrativo al puerto de observación remoto de Capa 2.
  3. Cree una VLAN en SwitchB, desactive el aprendizaje de direcciones MAC en esta VLAN y agregue puertos a la VLAN para reenviar los paquetes espejados que se envían desde el puerto de observación al Server.

Procedimiento

  1. Configure un puerto de observación en SwitchA.

    Configure GE1/0/2 del SwitchA como un puerto de observación remoto de Capa 2 y vincule el puerto de observación a la VLAN 10.

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] observe-port 1 interface gigabitethernet 1/0/2 vlan 10     //Configure GE1/0/2 como el puerto de observación remoto 1 de Capa 2 y añádalo a la VLAN 10.

    Una vez completada la configuración, el puerto de observación reenvía los paquetes espejados a la VLAN 10, no se debe agregar el puerto de observación a la VLAN.

  2. Configure un puerto espejado en SwitchA.

    # Configure GE1/0/1 del SwitchA como un puerto espejado para copiar los paquetes recibidos por el puerto espejado al puerto de observación remoto de Capa 2 .

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port-mirroring to observe-port 1 inbound     //Espeje el tráfico entrante en GE1/0/1 al puerto de observación 1.
    [SwitchA-GigabitEthernet1/0/1] return

  3. Cree una VLAN en SwitchB y agregue puertos a la VLAN.

    # Cree VLAN 10 en SwitchB, deshabilite el aprendizaje de direcciones MAC en esta VLAN, y agregue GE1/0/1 y GE1/0/2 a VLAN 10.

    NOTA:

    Aquí, la VLAN 10 se usa para reenviar solo paquetes espejados. Si la VLAN 10 ya existe y ha aprendido las entradas de la dirección MAC, ejecute el comando undo mac-address vlan vlan-id en la vista del sistema para eliminar todas las entradas de la dirección MAC en la VLAN 10.

    <Quidway> system-view
    [Quidway] sysname SwitchB
    [SwitchB] vlan 10
    [SwitchB-vlan10] mac-address learning disable     //Deshabilite el aprendizaje de direcciones MAC en esta VLAN.
    [SwitchB-vlan10] quit
    [SwitchB] interface gigabitethernet 1/0/1
    [SwitchB-GigabitEthernet1/0/1] port link-type access     //Establezca el tipo de enlace de la interfaz en el dispositivo de vigilancia a access. El tipo de enlace predeterminado de las interfaces no es access.
    [SwitchB-GigabitEthernet1/0/1] port default vlan 10
    [SwitchB-GigabitEthernet1/0/1] quit
    [SwitchB] interface gigabitethernet 1/0/2
    [SwitchB-GigabitEthernet1/0/2] port link-type trunk     //Establezca el tipo de enlace de la interfaz en el lado de la red a Trunk. El tipo de enlace predeterminado de las interfaces no es Trunk.
    [SwitchB-GigabitEthernet1/0/2] port trunk allow-pass vlan 10
    [SwitchB-GigabitEthernet1/0/2] return

  4. Verifique la configuración.

    # Compruebe la configuración del puerto de observación.

    <SwitchA> display observe-port
      ----------------------------------------------------------------------
      Index          : 1
      Untag-packet   : No
      Interface      : GigabitEthernet1/0/2
      Vlan           : 10
      ----------------------------------------------------------------------
    

    # Compruebe la configuración del puerto espejado.

    <SwitchA> display port-mirroring
      ----------------------------------------------------------------------
      Observe-port 1 : GigabitEthernet1/0/2
      ----------------------------------------------------------------------
      Port-mirror:
      ----------------------------------------------------------------------
           Mirror-port               Direction  Observe-port
      ----------------------------------------------------------------------
      1    GigabitEthernet1/0/1      Inbound    Observe-port 1
      ----------------------------------------------------------------------  
    

Archivos de configuración

  • El archivo de configuración de SwitchA

    #
    sysname SwitchA
    #
    observe-port 1 interface GigabitEthernet1/0/2 vlan 10
    #
    interface GigabitEthernet1/0/1
     port-mirroring to observe-port 1 inbound
    #
    return
    
  • El archivo de configuración de SwitchB

    #
    sysname SwitchB
    #
    vlan batch 10
    #
    vlan 10
     mac-address learning disable
    #
    interface GigabitEthernet1/0/1
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15818

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente