No se encuentran recursos de mapeo en el idioma seleccionado.

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar el espejado de direcciones MAC remotas

Ejemplo para configurar el espejado de direcciones MAC remotas

Descripción general del espejado de direcciones MAC remotas

En el espejado de direcciones MAC remotas, un puerto de observación se conecta a un dispositivo de vigilancia a través de una red intermedia y reenvía los paquetes con una dirección MAC especificada al dispositivo de vigilancia a través de la red intermedia.

Notas de configuración

  • Un puerto de observación está dedicado a reenviar tráfico espejado. No configure otros servicios en un puerto de observación; de lo contrario, el tráfico espejado y el tráfico de otros servicios interfieren entre sí.

  • Si la función de espejado se despliega en muchos puertos de un dispositivo, se ocupará una gran cantidad de ancho de banda de reenvío interno, lo que afecta el reenvío de otros servicios. Además, si el ancho de banda del puerto espejado es mayor que el ancho de banda del puerto de observación, por ejemplo, 1000 Mbit/s en un puerto espejado y 100 Mbit/s en un puerto de observación, el puerto de observación no podrá reenviar todos los paquetes espejados a tiempo debido a la insuficiencia de ancho de banda, lo que ocurre la pérdida de paquetes.

  • En todos los modelos de switch modular de la serie S de Huawei, Eth-Trunks se pueden configurar como puertos de observación. En los siguientes modelos de switch fijo de la serie S de Huawei, Eth-Trunks se pueden configurar como puertos de observación en V200R005 y versiones posteriores: S5300EI, S5300HI, S5306, S5310EI, S5320EI, S5320HI, S6300EI, S6320EI, y S6320HI.

  • El espejado de direcciones MAC se aplica solo a los paquetes entrantes.

  • La siguiente tabla enumera los productos y las versiones aplicables de este ejemplo de configuración.

    Tabla 14-15  Modelos de productos y versiones aplicables
    Producto Modelo del producto

    Versión del software

    S2300

    S2320EI

    V200R011C10, V200R012C00

    S2350EI

    V200R005C00SPC300, V200R006C00, V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S2352P-EI

    V100R006C05

    S3300

    S3300SI

    V100R006C05

    S3300EI

    V100R006C05

    S3300HI

    V200R001C00

    S5300

    S5300LI

    V200R005C00SPC300, V200R006C00, V200R007C00, V200R008 (C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5300SI

    V200R005 (C00&C02)

    S5300EI

    V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5310EI

    V200R002C00, V200R003C00, V200R005(C00&C02)

    S5320LI

    V200R010C00, V200R011C10, V200R012C00

    S5320SI

    V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5330SI

    V200R011C10, V200R012C00

    S5320EI

    V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5300HI

    V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S6300

    S6300EI

    V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S6320SI

    V200R011C10, V200R012C00

    S6320EI

    V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    NOTA:
    Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de redes

Como se muestra en Figura 14-20, todos los hosts de una compañía acceden a Internet a través del SwitchA y pertenecen a la VLAN 10. El Server del dispositivo de vigilancia está directamente conectado al SwitchA por SwitchB.

El tráfico de acceso a Internet del host con una dirección MAC 0001-0001-0001 debe ser vigilado remotamente a través del Server.

Figura 14-20  Redes del espejado de direcciones MAC remotas

Hoja de ruta de configuración

La hoja de ruta de la configuración es la siguiente:
  1. Cree la VLAN 10 en SwitchA y agregue los puertos que conectan SwitchA a los hosts a la VLAN 10 para que los hosts puedan comunicarse con SwitchA en la Capa 2.
  2. Cree la VLAN 20 en SwitchB, deshabilite el aprendizaje de direcciones MAC en esta VLAN, y agregue los puertos que conectan SwitchB a SwitchA y el Server a la VLAN 20 para que SwitchB pueda comunicarse con SwitchA y el Server en la Capa 2.
  3. Configure GE0/0/4 de SwitchA como un puerto de observación remoto para reenviar los paquetes espejados a la VLAN 20.
  4. Configure el espejado de direcciones MAC en la VLAN 10 para copiar el tráfico de acceso a Internet del host con una dirección MAC especificada en la VLAN 10 al puerto de observación remoto.

Procedimiento

  1. Agregue puertos a VLAN.

    # Cree la VLAN 10 en SwitchA y agregue de GE0/0/1 a GE0/0/3 a la VLAN 10.

    <Quidway> system-view
    [Quidway] sysname Switch
    [SwitchA] vlan batch 10
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type access     //Establezca el tipo de enlace de la interfaz del lado del host a access. El tipo de enlace predeterminado de las interfaces no es access.
    [SwitchA-GigabitEthernet0/0/1] port default vlan 10
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type access     //Establezca el tipo de enlace de la interfaz del lado del host a access. El tipo de enlace predeterminado de las interfaces no es access.
    [SwitchA-GigabitEthernet0/0/2] port default vlan 10
    [SwitchA-GigabitEthernet0/0/2] quit
    [SwitchA] interface gigabitethernet 0/0/3
    [SwitchA-GigabitEthernet0/0/3] port link-type access     //Establezca el tipo de enlace de la interfaz del lado del host a access. El tipo de enlace predeterminado de las interfaces no es access.
    [SwitchA-GigabitEthernet0/0/3] port default vlan 10
    [SwitchA-GigabitEthernet0/0/3] quit

    # Cree la VLAN 20 en SwitchB, deshabilite el aprendizaje de direcciones MAC en esta VLAN, y agregue GE0/0/1 y GE0/0/4 a la VLAN 20.

    NOTA:

    Aquí, la VLAN 20 se usa para reenviar solo paquetes espejados. Si la VLAN 20 ya existe y ha aprendido las entradas de la dirección MAC, ejecute el comando undo mac-address vlan vlan-id en la vista del sistema para eliminar todas las entradas de la dirección MAC en la VLAN 20.

    <Quidway> system-view
    [Quidway] sysname SwitchB
    [SwitchB] vlan 20
    [SwitchB-vlan20] mac-address learning disable     //Deshabilite el aprendizaje de direcciones MAC en esta VLAN.
    [SwitchB-vlan20] quit
    [SwitchB] interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] port link-type access     //Establezca el tipo de enlace de la interfaz en el dispositivo de vigilancia a access. El tipo de enlace predeterminado de las interfaces no es access.
    [SwitchB-GigabitEthernet0/0/1] port default vlan 20
    [SwitchB-GigabitEthernet0/0/1] quit
    [SwitchB] interface gigabitethernet 0/0/4
    [SwitchB-GigabitEthernet0/0/4] port link-type trunk
    [SwitchB-GigabitEthernet0/0/4] port trunk allow-pass vlan 20     //Establezca el tipo de enlace de la interfaz en el lado de la red a Trunk. El tipo de enlace predeterminado de las interfaces no es Trunk.
    [SwitchB-GigabitEthernet0/0/4] return

  2. Configure un puerto de observación.

    # Configure GE0/0/4 de SwitchA como un puerto de observación remoto.

    [SwitchA] observe-port 1 interface gigabitethernet 0/0/4 vlan 20     //Configure GE0/0/4 como como el puerto de observación remoto 1 de Capa 2, y agréguelo a la VLAN 20.
    

    Una vez completada la configuración, el puerto de observación reenvía los paquetes espejados a la VLAN 20, no se debe agregar el puerto de observación a la VLAN.

  3. Configure el espejado de direcciones MAC.

    # En SwitchA, configure el espejado de direcciones MAC en la VLAN 10 y copie los paquetes que son recibidos por todos los puertos en la VLAN 10 y que contengan una dirección MAC 0001-0001-0001 en el puerto de observación remoto.

    [SwitchA] vlan 10
    [SwitchA-vlan10] mac-mirroring 0001-0001-0001 to observe-port 1 inbound     //Espeje los paquetes entrantes con la dirección MAC 0001-0001-0001 en todas las interfaces de la VLAN 10 al puerto de observación 1.
    [SwitchA-vlan10] return

  4. Verifique la configuración.

    # Compruebe la configuración del puerto de observación.

    <SwitchA> display observe-port
      ----------------------------------------------------------------------
      Index          : 1
      Untag-packet   : No
      Interface      : GigabitEthernet0/0/4
      Vlan           : 20
      ----------------------------------------------------------------------
    

    # Compruebe la configuración de espejado.

    <Switch> display port-mirroring
      ----------------------------------------------------------------------
      Observe-port 1 : GigabitEthernet0/0/4
      ---------------------------------------------------------------------- 
      Mac-mirror:
      ----------------------------------------------------------------------
      Mirror-mac       Vlan    Direction     Observe-port
      ----------------------------------------------------------------------
      0001-0001-0001   10      Inbound       Observe-port 1
      ----------------------------------------------------------------------
    

Archivos de configuración

  • El archivo de configuración de SwitchA

    #
    sysname SwitchA
    #
    vlan batch 10
    #
    observe-port 1 interface GigabitEthernet0/0/4 vlan 20
    #
    vlan 10
     mac-mirroring 0001-0001-0001 to observe-port 1 inbound
    #
    interface GigabitEthernet0/0/1
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet0/0/3
     port link-type access
     port default vlan 10
    #
    return
    
  • El archivo de configuración de SwitchB

    #
    sysname SwitchB
    #
    vlan batch 20
    #
    vlan 20
     mac-address learning disable
    #
    interface GigabitEthernet0/0/1
     port link-type access
     port default vlan 20
    #
    interface GigabitEthernet0/0/4
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    return
    
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15665

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente