Nessuna risorsa pertinente trovata nella lingua selezionata.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Reliability

S7700 and S9700 V200R011C10

This document describes the configuration of BFD, DLDP, VRRP, SmartLink, CFM, EFM, Y.1731 and MAC swap loopback to ensure reliability on the device.
Rate and give feedback:
Huawei utilizza la traduzione automatica insieme alla revisione umana per tradurre questo documento in diverse lingue, per facilitare la comprensione del contenuto di questo documento. Nota: la traduzione automatica, anche la più avanzata, non può corrispondere alla qualità dei trasduttori professionisti. Huawei non accetta alcuna responsabilità per l'accuratezza della traduzione e raccomanda di fare riferimento al documento inglese (per il quale è stato fornito un collegamento).
Example for Configuring VLAN-based Ethernet CFM on a Layer 2 Network

Example for Configuring VLAN-based Ethernet CFM on a Layer 2 Network

Networking Requirements

As shown in Figure 9-19, VLANs are configured between devices. UPE2 and UPE3 back up each other. It is required that connectivity of links between UPE1 and UPE2 and between UPE2 and PEAGG be detected in real time.

Figure 9-19  Networking for configuring VLAN-based Ethernet CFM on a Layer 2 network

Configuration Roadmap

The configuration roadmap is as follows:

  • Configure VLANs for UPE1, UPE2, UPE3, and PEAGG to implement Layer 2 connectivity.

  • Configure basic CFM functions on UPE1 and PEAGG to detect connectivity of the link between UPE1 and PEAGG.

Procedure

  1. Configure VLANs.

    # Configure UPE1.

    <HUAWEI> system-view
    [HUAWEI] sysname UPE1
    [UPE1] vlan 2
    [UPE1-vlan2] quit
    [UPE1] interface gigabitethernet 1/0/1
    [UPE1-GigabitEthernet1/0/1] port link-type trunk
    [UPE1-GigabitEthernet1/0/1] port trunk allow-pass vlan 2
    [UPE1-GigabitEthernet1/0/1] quit
    [UPE1] interface gigabitethernet 1/0/2
    [UPE1-GigabitEthernet1/0/2] port link-type trunk
    [UPE1-GigabitEthernet1/0/2] port trunk allow-pass vlan 2
    [UPE1-GigabitEthernet1/0/2] quit

    # Configure UPE2.

    <HUAWEI> system-view
    [HUAWEI] sysname UPE2
    [UPE2] vlan 2
    [UPE2-vlan2] quit
    [UPE2] interface gigabitethernet 1/0/1
    [UPE2-GigabitEthernet1/0/1] port link-type trunk
    [UPE2-GigabitEthernet1/0/1] port trunk allow-pass vlan 2
    [UPE2-GigabitEthernet1/0/1] quit
    [UPE2] interface gigabitethernet 1/0/2
    [UPE2-GigabitEthernet1/0/2] port link-type trunk
    [UPE2-GigabitEthernet1/0/2] port trunk allow-pass vlan 2
    [UPE2-GigabitEthernet1/0/2] quit
    

    # Configure UPE3.

    <HUAWEI> system-view
    [HUAWEI] sysname UPE3
    [UPE3] vlan 2
    [UPE3-vlan2] quit
    [UPE3] interface gigabitethernet 1/0/1
    [UPE3-GigabitEthernet1/0/1] port link-type trunk
    [UPE3-GigabitEthernet1/0/1] port trunk allow-pass vlan 2
    [UPE3-GigabitEthernet1/0/1] quit
    [UPE3] interface gigabitethernet 1/0/2
    [UPE3-GigabitEthernet1/0/2] port link-type trunk
    [UPE3-GigabitEthernet1/0/2] port trunk allow-pass vlan 2
    [UPE3-GigabitEthernet1/0/2] quit
    

    # Configure the PEAGG.

    <HUAWEI> system-view
    [HUAWEI] sysname PEAGG
    [PEAGG] vlan 2
    [PEAGG-vlan2] quit
    [PEAGG] interface gigabitethernet 1/0/1
    [PEAGG-GigabitEthernet1/0/1] port link-type trunk
    [PEAGG-GigabitEthernet1/0/1] port trunk allow-pass vlan 2
    [PEAGG-GigabitEthernet1/0/1] quit
    [PEAGG] interface gigabitethernet 1/0/2
    [PEAGG-GigabitEthernet1/0/2] port link-type trunk
    [PEAGG-GigabitEthernet1/0/2] port trunk allow-pass vlan 2
    [PEAGG-GigabitEthernet1/0/2] quit
    

  2. Configure basic CFM functions.

    # Configure basic CFM functions on UPE1.

    [UPE1] cfm enable
    [UPE1] cfm md md
    [UPE1-md-md] ma ma
    [UPE1-md-md-ma-ma] map vlan 2
    [UPE1-md-md-ma-ma] mep mep-id 1 interface gigabitethernet 1/0/2 outward
    [UPE1-md-md-ma-ma] mep ccm-send mep-id 1 enable
    [UPE1-md-md-ma-ma] remote-mep mep-id 2
    [UPE1-md-md-ma-ma] remote-mep ccm-receive mep-id 2 enable
    [UPE1-md-md-ma-ma] quit
    [UPE1-md-md] quit

    # Configure basic CFM functions on the PEAGG.

    [PEAGG] cfm enable
    [PEAGG] cfm md md
    [PEAGG-md-md] ma ma
    [PEAGG-md-md-ma-ma] map vlan 2
    [PEAGG-md-md-ma-ma] mep mep-id 2 interface gigabitethernet 1/0/2 outward
    [PEAGG-md-md-ma-ma] mep ccm-send mep-id 2 enable
    [PEAGG-md-md-ma-ma] remote-mep mep-id 1
    [PEAGG-md-md-ma-ma] remote-mep ccm-receive mep-id 1 enable
    [PEAGG-md-md-ma-ma] quit
    [PEAGG-md-md] quit

    After the configuration is complete, run the display cfm remote-mep command on UPE1 and PEAGG. You can view MEP information.

    [UPE1] display cfm remote-mep
    The total number of RMEPs is : 1
    The status of RMEPs : 1 up, 0 down, 0 disable
    --------------------------------------------------
     MD Name            : md
     Level              : 0
     MA Name            : ma
     RMEP ID            : 2
     VLAN ID            : 2
     VSI Name           : --
     L2VC ID            : --
     MAC                : 00e0-0003-0003
     CCM Receive        : enabled
     Trigger-If-Down    : disabled
     CFM Status         : up
     Alarm Status       : none
     Interface TLV      : --                                                        
     Connect Status     : up              

Configuration Files

  • UPE1 configuration file

    #                                                                               
    sysname UPE1                                                               
    #                                                                               
    vlan batch 2                                                                    
    #                                                                               
    cfm enable                                                                      
    #                                                                               
    interface GigabitEthernet1/0/1                                                  
     port link-type trunk                                                           
     port trunk allow-pass vlan 2                                                   
    #                                                                               
    interface GigabitEthernet1/0/2                                                  
     port link-type trunk                                                           
     port trunk allow-pass vlan 2                                                   
    #                                                                               
    cfm md md                                                                      
     ma ma                                                                         
      map vlan 2                                                                    
      mep mep-id 1 interface GigabitEthernet1/0/2 outward                           
      mep ccm-send mep-id 1 enable                                                  
      remote-mep mep-id 2                                                           
      remote-mep ccm-receive mep-id 2 enable                                        
    #
    return           
  • UPE2 configuration file

    #                                                                               
    sysname UPE2                                                                    
    #                                                                               
    vlan batch 2                                                                    
    #                                                                               
    interface GigabitEthernet1/0/1                                                  
     port link-type trunk                                                           
     port trunk allow-pass vlan 2                                                   
    #                                                                               
    interface GigabitEthernet1/0/2                                                  
     port link-type trunk                                                           
     port trunk allow-pass vlan 2                                                   
    #                                                                               
    return   
  • UPE3 configuration file

    #                                                                               
    sysname UPE3                                                                    
    #                                                                               
    vlan batch 2                                                                    
    #                                                                               
    interface GigabitEthernet1/0/1                                                  
     port link-type trunk                                                           
     port trunk allow-pass vlan 2                                                   
    #                                                                               
    interface GigabitEthernet1/0/2                                                  
     port link-type trunk                                                           
     port trunk allow-pass vlan 2                                                   
    #                                                                               
    return   
  • PEAGG configuration file

    #                                                                               
    sysname PEAGG                                                               
    #                                                                               
    vlan batch 2                                                                    
    #
    cfm enable                                                                      
    #                                                                               
    interface GigabitEthernet1/0/1                                                  
     port link-type trunk                                                           
     port trunk allow-pass vlan 2                                                   
    #                                                                              
    interface GigabitEthernet1/0/2                                                  
     port link-type trunk                                                           
     port trunk allow-pass vlan 2                                                   
    #                                                                               
    cfm md md                                                                      
     ma ma                                                                         
      map vlan 2                                                                    
      mep mep-id 2 interface GigabitEthernet1/0/2 outward                           
      mep ccm-send mep-id 2 enable                                                  
      remote-mep mep-id 1                                                           
      remote-mep ccm-receive mep-id 1 enable                                        
    #
    return
Traduzione
Download
Updated: 2019-09-23

N. documento: EDOC1000178318

Visualizzazioni:124009

Download: 81

Average rating:
This Document Applies to these Products
Documenti correlati
Related Version
Share
Precedente Avanti