Nessuna risorsa pertinente trovata nella lingua selezionata.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Reliability

S7700 and S9700 V200R011C10

This document describes the configuration of BFD, DLDP, VRRP, SmartLink, CFM, EFM, Y.1731 and MAC swap loopback to ensure reliability on the device.
Rate and give feedback:
Huawei utilizza la traduzione automatica insieme alla revisione umana per tradurre questo documento in diverse lingue, per facilitare la comprensione del contenuto di questo documento. Nota: la traduzione automatica, anche la più avanzata, non può corrispondere alla qualità dei trasduttori professionisti. Huawei non accetta alcuna responsabilità per l'accuratezza della traduzione e raccomanda di fare riferimento al documento inglese (per il quale è stato fornito un collegamento).
Example for Configuring Association Between CFM Modules

Example for Configuring Association Between CFM Modules

Networking Requirements

As networks develop quickly, more and more IP networks are used to carry multiple services such as voice and video services. These services pose high requirements on network reliability and rapid fault detection.

Link detection protocols are usually deployed on a network to detect link connectivity and faults. A single fault detection protocol cannot detect all faults in all links on a complex network. Network environments and user requirements need to be analyzed, and various detection techniques are required to implement rapid link fault detection.

As shown in Figure 9-21, SwitchA, SwitchB, and SwitchC are connected at Layer 2. The requirements are as follows:

  • Connectivity of the links between SwitchA and SwitchB and between SwitchB and SwitchC can be monitored.

  • When the link between SwitchA and SwitchB becomes faulty, SwitchC can detect the fault.

Figure 9-21  Networking diagram for configuring association between CFM and CFM

Configuration Roadmap

The configuration roadmap is as follows:

  1. Create VLANs and add interfaces to the VLANs.

  2. Configure CFM between SwitchA and SwitchB and between SwitchB and SwitchC to monitor link connectivity.

  3. Configure association between CFM modules on SwitchB and SwitchC.

Procedure

  1. Create VLANs and add interfaces to the VLANs.

    # Configure SwitchA.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type trunk
    [SwitchA-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet1/0/1] quit

    # Configure SwitchB.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan batch 10 20
    [SwitchB] interface gigabitethernet 1/0/1
    [SwitchB-GigabitEthernet1/0/1] port link-type trunk
    [SwitchB-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [SwitchB-GigabitEthernet1/0/1] quit
    [SwitchB] interface gigabitethernet 2/0/1
    [SwitchB-GigabitEthernet2/0/1] port link-type trunk
    [SwitchB-GigabitEthernet2/0/1] port trunk allow-pass vlan 20
    [SwitchB-GigabitEthernet2/0/1] quit

    # Configure SwitchC.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchC
    [SwitchC] vlan batch 20
    [SwitchC] interface gigabitethernet 2/0/1
    [SwitchC-GigabitEthernet2/0/1] port link-type trunk
    [SwitchC-GigabitEthernet2/0/1] port trunk allow-pass vlan 20
    [SwitchC-GigabitEthernet2/0/1] quit

  2. Configure CFM between SwitchA and SwitchB.

    # Configure SwitchA.

    [SwitchA] cfm enable
    [SwitchA] cfm md md1
    [SwitchA-md-md1] ma ma1
    [SwitchA-md-md1-ma-ma1] map vlan 10
    [SwitchA-md-md1-ma-ma1] mep mep-id 1 interface gigabitethernet 1/0/1 outward
    [SwitchA-md-md1-ma-ma1] remote-mep mep-id 2
    [SwitchA-md-md1-ma-ma1] mep ccm-send enable
    [SwitchA-md-md1-ma-ma1] remote-mep ccm-receive enable
    [SwitchA-md-md1-ma-ma1] quit
    [SwitchA-md-md1] quit

    # Configure SwitchB.

    [SwitchB] cfm enable
    [SwitchB] cfm md md1
    [SwitchB-md-md1] ma ma1
    [SwitchB-md-md1-ma-ma1] map vlan 10
    [SwitchB-md-md1-ma-ma1] mep mep-id 2 interface gigabitethernet 1/0/1 outward
    [SwitchB-md-md1-ma-ma1] remote-mep mep-id 1
    [SwitchB-md-md1-ma-ma1] mep ccm-send enable
    [SwitchB-md-md1-ma-ma1] remote-mep ccm-receive enable
    [SwitchB-md-md1-ma-ma1] quit
    [SwitchB-md-md1] quit

  3. Configure CFM between SwitchB and SwitchC.

    # Configure SwitchB.

    [SwitchB] cfm md md1
    [SwitchB-md-md1] ma ma2
    [SwitchB-md-md1-ma-ma2] map vlan 20
    [SwitchB-md-md1-ma-ma2] mep mep-id 1 interface gigabitethernet 2/0/1 outward
    [SwitchB-md-md1-ma-ma2] remote-mep mep-id 2
    [SwitchB-md-md1-ma-ma2] mep ccm-send enable
    [SwitchB-md-md1-ma-ma2] remote-mep ccm-receive enable
    [SwitchB-md-md1-ma-ma2] quit
    [SwitchB-md-md1] quit

    # Configure SwitchC.

    [SwitchC] cfm enable
    [SwitchC] cfm md md1
    [SwitchC-md-md1] ma ma2
    [SwitchC-md-md1-ma-ma2] map vlan 20
    [SwitchC-md-md1-ma-ma2] mep mep-id 2 interface gigabitethernet 2/0/1 outward
    [SwitchC-md-md1-ma-ma2] remote-mep mep-id 1
    [SwitchC-md-md1-ma-ma2] mep ccm-send enable
    [SwitchC-md-md1-ma-ma2] remote-mep ccm-receive enable
    [SwitchC-md-md1-ma-ma2] quit
    [SwitchC-md-md1] quit

    Run the display cfm remote-mep command on SwitchB to check the CFM status. You can see that the CFM status is Up.

    [SwitchB] display cfm remote-mep
    The total number of RMEPs is : 2
    The status of RMEPs : 2 up, 0 down, 0 disable
    --------------------------------------------------
     MD Name            : md1
     Level              : 0
     MA Name            : ma1
     RMEP ID            : 1
     VLAN ID            : 10
     VSI Name           : --
     L2VC ID            : --
     MAC                : 0025-9efb-494a
     CCM Receive        : enabled
     Trigger-If-Down    : disabled
     CFM Status         : up
     Alarm Status       : none
     Interface TLV      : --
     Connect Status     : up
    
     MD Name            : md1
     Level              : 0
     MA Name            : ma2
     RMEP ID            : 2
     VLAN ID            : 20
     VSI Name           : --
     L2VC ID            : --
     MAC                : 0002-0003-0161
     CCM Receive        : enabled
     Trigger-If-Down    : disabled
     CFM Status         : up
     Alarm Status       : none
     Interface TLV      : --
     Connect Status     : up

  4. Configure association between CFM modules.

    # Associate CFM between SwitchA and SwitchB with CFM between SwitchB and SwitchC in both directions.

    [SwitchB] oam-mgr
    [SwitchB-oam-mgr] oam-bind cfm md md1 ma ma1 cfm md md1 ma ma2
    [SwitchB-oam-mgr] quit

  5. Verify the configuration.

    # Shut down GE2/0/1 on SwitchB.

    [SwitchB] interface gigabitethernet 2/0/1
    [SwitchB-GigabitEthernet2/0/1] shutdown
    [SwitchB-GigabitEthernet2/0/1] quit

    # Run the display cfm remote-mep command on SwitchA to check the CFM status between SwitchA and SwitchB. You can see that the CFM status is Down.

    [SwitchA]display cfm remote-mep
    The total number of RMEPs is : 1
    The status of RMEPs : 0 up, 1 down, 0 disable
    --------------------------------------------------
     MD Name            : md1
     Level              : 0
     MA Name            : ma1
     RMEP ID            : 2
     VLAN ID            : 10
     VSI Name           : --
     L2VC ID            : --
     MAC                : 0044-0141-5410
     CCM Receive        : enabled
     Trigger-If-Down    : disabled
     CFM Status         : down
     Alarm Status       : RDI
     Interface TLV      : --
     Connect Status     : up

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10
    #
    cfm enable
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    cfm md md1
     ma ma1
      map vlan 10
      mep mep-id 1 interface GigabitEthernet1/0/1 outward
      mep ccm-send mep-id 1 enable
      remote-mep mep-id 2
      remote-mep ccm-receive mep-id 2 enable
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 10 20
    #
    cfm enable
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet2/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    cfm md md1
     ma ma1
      map vlan 10
      mep mep-id 2 interface GigabitEthernet1/0/1 outward
      mep ccm-send mep-id 2 enable
      remote-mep mep-id 1
      remote-mep ccm-receive mep-id 1 enable
     ma ma2
      map vlan 20
      mep mep-id 1 interface GigabitEthernet2/0/1 outward
      mep ccm-send mep-id 1 enable
      remote-mep mep-id 2
      remote-mep ccm-receive mep-id 2 enable
    #
    oam-mgr
     oam-bind ingress cfm md md1 ma ma1 egress cfm md md1 ma ma2
     oam-bind ingress cfm md md1 ma ma2 egress cfm md md1 ma ma1
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 20
    #
    cfm enable
    #
    interface GigabitEthernet2/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    cfm md md1
     ma ma2
      map vlan 20
      mep mep-id 2 interface GigabitEthernet2/0/1 outward
      mep ccm-send mep-id 2 enable
      remote-mep mep-id 1
      remote-mep ccm-receive mep-id 1 enable
    #
    return
Traduzione
Download
Updated: 2019-09-23

N. documento: EDOC1000178318

Visualizzazioni:123974

Download: 81

Average rating:
This Document Applies to these Products
Documenti correlati
Related Version
Share
Precedente Avanti