Nessuna risorsa pertinente trovata nella lingua selezionata.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Raccolta di casi di configurazione dello scenario tipico del router aziendale NE-ME60 2.0

Rate and give feedback:
Huawei utilizza la traduzione automatica insieme alla revisione umana per tradurre questo documento in diverse lingue, per facilitare la comprensione del contenuto di questo documento. Nota: la traduzione automatica, anche la più avanzata, non può corrispondere alla qualità dei trasduttori professionisti. Huawei non accetta alcuna responsabilità per l'accuratezza della traduzione e raccomanda di fare riferimento al documento inglese (per il quale è stato fornito un collegamento).
Esempio per la configurazione dell'interconnessione WAN finanziaria

Esempio per la configurazione dell'interconnessione WAN finanziaria

Questa sezione fornisce un tipico caso di configurazione di MPLS VPN per implementare l'interconnessione WAN per le filiali di un'azienda in uno scenario di settore finanziario.

Prodotti e versioni applicabili

Questa configurazione si applica ai prodotti della serie NE40E/NE20E/NE5000E/CX6600 che eseguono V800R010C00 o versioni successive.

Requisiti di rete

Una banca utilizza il modo "tre centri di dati in due città" (three data centers in two cities) per distribuire un centro di dati e ha filiali in più città. Come mostrato nella figura seguente, WAN utilizza un'architettura di livelli di accesso, aggregazione e backbone, e doppio nodo, rete di collegamento per implementare l'interconnessione WAN per centri di dati e filiali e integrare più servizi su una rete fisica. Inoltre, utilizza la tecnologia MPLS VPN per isolare logicamente i servizi E2E e il controller AC-WAN per implementare una rapida implementazione del servizio e l'ottimizzazione del traffico, facilitando l'espansione del servizio completo.


Configurazioni di base

Accedere a un dispositivo per la prima volta

Per i dettagli, vedere "Accesso a un dispositivo per la prima volta" (Logging In to a Device for the First Time) in "Caratteristiche comuni".

Configurare un nome dispositivo e gli indirizzi IP delle interfacce.

Configurare un nome specifico per ogni dispositivo per identificare un dispositivo dopo l'accesso. Ad esempio, nominare un dispositivo HUAWEI.

#
sysname HUAWEI
#

Configurare un indirizzo IP per l'interfaccia di rete di gestione del dispositivo in modo che sia possibile accedere in remoto al dispositivo tramite questo indirizzo IP. Ad esempio, assegnare 172.16.1.1/24 a GE0/0/0.

#
interface GigabitEthernet0/0/0
 undo shutdown
 ip address 172.16.1.1 255.255.255.0   //Configurare un indirizzo IP per l'interfaccia di rete di gestione.
#

Ripetere il passaggio precedente per configurare un indirizzo IP per l'interfaccia di servizio.

Configurare un fuso orario locale.

Eseguire le seguenti operazioni su tutti i dispositivi per impostare il fuso orario locale:

#
clock timezone BJ add 08:00:00   //Prendere a Pechino, in Cina, un esempio. Impostare il nome del fuso orario locale su BJ e aumentare il valore dell'offset di tempo di 8, in quanto Pechino si trova nel fuso orario UTC+8.
#

Configurare il dispositivo per salvare periodicamente le configurazioni.

Eseguire le seguenti operazioni su tutti i dispositivi:

#
set save-configuration
#

Configurare il login remoto.

È possibile accedere da remoto al dispositivo tramite Telnet o SSH. Telnet ha i rischi per la sicurezza. SSH è raccomandato.

Per ulteriori informazioni, vedere "SSH (Using STelnet) per accedere in remoto a un dispositivo" in "Caratteristiche comuni".

Configurare la gestione della rete.

NMS di un ramo viene implementato nella sua sala apparecchiature di produzione e gestire e i dispositivi di rete di ramo in modalità inband.
Parametro Valore pianificato
Schema NMS In questo esempio, in ciascun centro di dati viene distribuita una rete di gestione della rete separata per gestire i dispositivi di rete nel centro di dati o la rete core di backbone nella modalità hybrid di inband e outband. NMS di una filiale viene implementato nella sua sala apparecchiature di produzione e gestisce i dispositivi di rete di filiali in modalità inband.
Schema di gestione Outband Collegare un cavo Ethernet all'interfaccia di gestione di un router e configurare VPN locale sull'interfaccia GigabitEthernet0/0/0 per l'isolamento da altri instradamenti sulla rete pubblica. Configurare l'instradamento predefinito nella VPN e impostare l'hop successivo switch Layer 3 del NMS outband.
Connessione ai server AAA Collegare un router ai server AAA attivi e di standby tramite l'interfaccia di gestione utilizzando HWTACACS.
Connessione ai server syslog Collegare un router ai server syslog attivi e di standby tramite l'interfaccia di gestione.

Configurare NMS VPN su tutti i dispositivi che supportano outband NMS.

#
ip vpn-instance MGT        //Configurare un'istanza VPN NMS.
 ipv4-family
  route-distinguisher 65530:65530   //Configurare un RD.
#
interface GigabitEthernet0/0/0    //Accedere all'interfaccia di gestione.
 speed auto
 duplex auto
 undo shutdown
 ip binding vpn-instance MGT      //Associare la NMS VPN all'interfaccia.
 ip address 10.10.1.1 255.255.255.0   //Configurare un indirizzo IP di gestione.
#

Eseguire le seguenti operazioni su tutti i dispositivi per configurare SNMP:

#
acl name ACL_SNMP_A basic                      //Configurare un ACL di base per NMS nella regione A per consentire solo al NMS di un indirizzo IP specificato di gestire il dispositivo.
 description ACL_FOR_SNMP_A                  //Aggiungere una descrizione.
 rule 10 permit vpn-instance MGT source 10.10.2.1 0    //Aggiungere un indirizzo NMS.
 ….      //Aggiungere altri indirizzi NMS come richiesto.
#
….       //Configurare ACL e corrispondenti indirizzi NMS per gli NMS in altre città, come richiesto.
#
snmp-agent             //Abilitare SNMP.
snmp-agent community read cipher *************** acl ACL_SNMP_A     //Impostare un nome di comunità di lettura / scrittura SNMP (testo normale o testo cifrato) e un ACL.
….   //Impostare i nomi di comunità di lettura/scrittura SNMP per altri ACL come richiesto.
#
snmp-agent sys-info version v2c v3        //Configurare una versione SNMP.
snmp-agent community complexity-check disable       //Disabilitare la verifica della complessità del nome della comunità.
snmp-agent group v3 NMS_G privacy read-view iso notify-view iso   //Configurare un gruppo di utenti SNMP, mappare gli utenti SNMP alla vista SNMP, autenticare e crittografare i pacchetti e specificare il nome della vista di lettura/scrittura come iso.
snmp-agent target-host host-name ACController trap address udp-domain 10.17.1.1 udp-port 1666 params securityname ACTrap_A v3 privacy  //Impostare un indirizzo di destinazione per la ricezione dei messaggi Inform.
#
snmp-agent mib-view included iso iso        //Configurare una vista MIB per includere una vista iso e iso sottonodo.
snmp-agent mib-view included alliso iso      //Configure a MIB view to include an alliso view and an iso subnode.
snmp-agent usm-user v3 ACTrap_A         //Aggiungere un utente al gruppo SNMP.
snmp-agent usm-user v3 ACTrap_A group NMS_G   //Specificare il nome del gruppo a cui appartiene l'utente.
snmp-agent usm-user v3 ACTrap_A authentication-mode sha cipher **********  //Impostare la modalità di autenticazione dell'utente SNMP su SHA e specificare una chiave.
snmp-agent usm-user v3 ACTrap_A privacy-mode aes128 cipher *******    //Impostare l'algoritmo di crittografia per le informazioni utente SNMP su AES128 e configurare una chiave.
#
snmp-agent trap source LoopBack0      //Specificare un indirizzo di origine per l'invio di messaggi trap.
#
snmp-agent trap enable   //Abilitare il router per inviare messaggi trap.

Eseguire le seguenti operazioni su tutti i dispositivi per configurare syslog:

#
info-center loghost source GigabitEthernet0/0/0       //Configurare GE0/0/0 per inviare i registri.
info-center loghost 10.10.2.1 vpn-instance MGT level critical  //Specificare l'indirizzo IP di un server syslog e impostare il livello di registro su critical. Il server è in VPN. Pertanto, è necessario specificare un'istanza VPN.
#

Configurare NTP.

Eseguire le seguenti operazioni su tutti i dispositivi:

#
ntp-service source-interface GigabitEthernet0/0/0 vpn-instance MGT  //Specificare un'interfaccia locale per l'invio di messaggi NTP. In questo esempio, l'interfaccia appartiene a NMS VPN. Pertanto, è necessario specificare il nome di un'istanza VPN NMS.
ntp-service unicast-server 10.10.2.254 vpn-instance MGT  //Specificare l'indirizzo IP di un server NTP.
#

Configurare un IGP

Pianificazione generale

Gli instradamenti sono classificati nei seguenti tipi:

  • Gli instradamenti di rete: generato in base agli indirizzi IP dei dispositivi, come gli indirizzi di interfaccia di rete gli indirizzi di interfaccia di loopback utilizzati dai protocolli (IGP, BGP o MPLS ad esempio). Gli instradamenti di rete vengono utilizzate per implementare la connettività di rete.
  • Gli instradamenti di servizio: includere gli instradamenti del terminale e del sistema di assistenza. Gli instradamenti di servizio vengono utilizzate per implementare la connettività di servizio.

Gli instradamenti di rete sono solitamente trasportate da un IGP, che può essere OSPF o IS-IS. In questo esempio, OSPF viene utilizzato come IGP.

NOTA:

Non importare gli instradamenti di servizio in una tabella di routing IGP.

Semplificare il più possibile gli instradamenti di rete distribuendo solo una zona o un livello IGP all'interno della WAN.

Procedura

  1. Eseguire le configurazioni di base OSPF.

    Tabella 1-7  Pianificazione di parametri OSPF di base
    Parametro Valore pianificato
    Tipo di protocollo OSPF
    ID Processo 1
    ID Router Indirizzo IP dello loopback 0
    Area Area 0 (considerando il numero limitato di dispositivi sulla rete backbone core WAN)
    Tipo di interfaccia P2P. Viene trasmesso il tipo di interfaccia predefinito delle interfacce Ethernet. Poiché su OSPF vengono eseguiti solo due dispositivi sullo stesso segmento di rete nell'area backbone, è possibile modificare il tipo di rete delle interfacce coinvolte in P2P
    Annuncio degli instradamenti Gli instradamenti verso gli indirizzi IP delle interfacce interconnesse e loopback 0

    Le configurazioni su tutti i dispositivi WAN, inclusi PE, DC-P, RR e WAN-P sono i seguenti:

    #
    router id 10.80.3.2              // Configurare un ID router..
    #
    ospf 1                        // Configurare un ID processo OSPF.
     bandwidth-reference 100000     // Configurare il valore di riferimento della larghezza di banda.
     area 0.0.0.0                  // Configurare un ID area OSPF.
      network 10.1.1.1 0.0.0.0 description loopback 0   //Pubblicizzare l'indirizzo IP di loopback 0.
      network 10.2.1.1 0.0.0.0 description Eth-trunk 0   //Pubblicizzare l'indirizzo IP di Eth-Trunk 0.
      …..                        //Pubblicizzare gli indirizzi IP di altre interfacce come richiesto.
    #
    interface Eth-Trunk0
     ospf network-type p2p    //Impostare il tipo di interfaccia OSPF su P2P.
    #
    
    NOTA:
    Durante la configurazione, impostare il tipo di tutte le interfacce nell'area OSPF su P2P. In questo esempio, la configurazione di Eth-Trunk 0 viene utilizzata come esempio.
  2. Configurare i costi OSPF.

    La rete principale di backbone della WAN utilizza la rete a doppio piano. Durante la distribuzione IGP, pianificare correttamente i costi dell'instradamento in modo che il traffico di diversi servizi sulla rete backbone possa essere bilanciato su piani diversi. In questo modo, la larghezza di banda può essere pienamente utilizzata, la qualità del servizio può essere migliorata e l'affidabilità del servizio può essere garantita. Raccomandazioni per l'implementazione dei costi IGP:
    • I costi dei collegamenti WAN devono essere superiori a quelli dei collegamenti locali di almeno 10 volte.
    • Se due interfacce hanno lo stesso ruolo di rete, impostare un costo inferiore per l'interfaccia con larghezza di banda del collegamento più elevata.
    • Secondo il formula "Interface cost = valore di riferimento della larghezza di banda/larghezza di banda dell'interfaccia", il valore di riferimento della larghezza di banda (in Mbit/s) di un'interfaccia 10GE equivale alla larghezza di banda dell'interfaccia (10000 Mbit/s) moltiplicata per il costo dell'interfaccia (10, ad esempio), e il risultato del calcolo è 100000 Mbit/s.

    Tabella 1-8  Pianificazione dei costi OSPF
    Collegamento Suggerimenti per la pianificazione dei costi Costo in questo esempio
    Collegamento LAN locale tra DC-P nello stesso sito Impostare il costo del collegamento LAN locale su un valore inferiore rispetto a quello dei collegamenti WAN per garantire che il traffico venga inoltrato tra i piani preferibilmente da P. 10
    Collegamento LAN locale tra DC-PE nello stesso sito Impostare il costo del collegamento LAN locale su un valore inferiore rispetto a quello dei collegamenti WAN per garantire che il traffico venga inoltrato tra i piani preferenzialmente da P e quindi da PE. 20
    Collegamento LAN locale tra DC-PE e DC-P nello stesso sito Impostare il costo del collegamento LAN locale su un valore inferiore rispetto a quello dei collegamenti WAN. 50
    Collegamento WAN tra DC-P nella stessa città Garantire che il traffico tra i centri di dati sia trasmesso attraverso gli aerei piuttosto che attraverso una deviazione verso un altro centro di dati. 100
    Collegamento WAN tra DC-P in diverse città Assicurarsi che il costo del collegamento WAN sia maggiore di quello di ciascun collegamento MAN o LAN. 200
    Collegamento LAN tra WAN-P e DC-P Su WAN-P, impostare il costo del collegamento LAN locale ad un valore inferiore a quello del collegamento WAN tra il WAN-P e il livello di accesso PE. 100
    Collegamento WAN tra un WAN-P e un filiale PE Su WAN-P, impostare il costo del collegamento WAN su un valore maggiore di quello del collegamento LAN tra WAN-P e DC-P. 1000
    Collegamento LAN locale tra un RR e un DC-P RR riflettono gli instradamenti piuttosto che il traffico di inoltro. Pertanto, impostare il costo maggiore per questo collegamento tra tutti i collegamenti. 10000

    Le configurazioni su tutti i dispositivi WAN, inclusi PE, DC-P, RR e WAN-P sono le seguenti:

    #
    interface Eth-Trunk0        //Inserire la vista dell'interfaccia.
     ospf cost 20              //Impostare il costo OSPF su 20.
    #
    
    NOTA:
    Impostare i costi su tutte le interfacce nell'area OSPF come pianificato. In questo esempio, la configurazione di costo di un'interfaccia viene utilizzata come esempio.
  3. (Facoltativo) Regolare i parametri di convergenza OSPF.

    Se BFD per OSPF non è distribuito sulla rete in tempo reale, è necessario regolare i parametri OSPF in base ai requisiti della WAN e della qualità della linea dedicata per garantire l'affidabilità della rete e accelerare la convergenza OSPF.

    NOTA:
    Se la rete in tempo reale è costituita da dispositivi forniti da diversi fornitori, è necessario definire i parametri di convergenza veloce OSPF unificati sulla base della verifica del test, poiché le funzionalità software e hardware variano con il dispositivo del fornitore e anche la stessa funzione di un protocollo standard ha un'interpretazione diversa e modalità di implementazione tra i fornitori.

    Regolare i parametri di convergenza veloce OSPF per raggiungere i seguenti obiettivi:

    • Implementare la convergenza IGP di secondo livello nel caso di un singolo punto di errore su un dispositivo WAN.
    • Mantenere la stabilità della rete (senza l'instabilità dell'instradamento).
    • Mantenere un carico CPU adeguato sui router.
    • Prevenire le connessioni di rete frequenti o l'instabilità degli instradamenti causati da frequenti aggiornamenti LSA e ridurre la larghezza di banda della rete e il consumo delle risorse del dispositivo impostando l'intervallo (configurato utilizzando il comando lsa-arrival-interval) a cui gli LSA vengono ricevuti per essere inferiore o uguale all'intervallo (configurato utilizzando il comando lsa-originate-interval) a cui vengono aggiornati LSA.
    • Mantenere i parametri sull'intera rete per essere coerenti (eccetto per diversi meccanismi di implementazione o intervalli di valori dei parametri).
    Tabella 1-9  Pianificazione dei parametri di convergenza OSPF
    Parametro Valore predefinito Valore in questo esempio
    Intervallo in cui vengono inviati i pacchetti Hello 10s 3s
    Intervallo morto di OSPF neighbor 40s Valore predefinito
    Ritrasmissione dell'intervallo LSA 5s 2s
    Intervallo della ricezione LSA Intervallo massimo (1000 ms), intervallo iniziale (500 ms) e intervallo continuo (500 ms) Valore predefinito
    Intervallo dell'aggiornamento LSA Intervallo massimo (5000 ms), intervallo iniziale (500 ms) e intervallo continuo (1000 ms) Valore predefinito
    Intervallo in cui vengono calcolate gli instradamenti OSPF Intervallo massimo (5000 ms), intervallo iniziale (500 ms) e intervallo continuo (1000 ms) Intervallo massimo (10000 ms), intervallo iniziale (500 ms) e intervallo continuo (1000 ms)
    NOTA:
    I valori utilizzati in questo esempio sono per il riferimento.

    Le configurazioni su tutti i dispositivi WAN, inclusi PE, DC-P, RR e WAN-P sono le seguenti:

    #
    ospf 1              //Configurare un ID processo OSPF.
     spf-schedule-interval intelligent-timer 10000 500 1000    //Configurare l'intervallo in base al quale vengono calcolati gli instradamenti OSPF.
    #
    interface Eth-Trunk0
     ospf timer hello 3        //Configurare l'intervallo al quale vengono inviati i pacchetti Hello.
     ospf timer retransmit 2    //Configurare l'intervallo a cui vengono ritrasmessi gli LSA.
    #
    interface Eth-Trunk1
     ospf timer hello 3
     ospf timer retransmit 2
    #
    
    NOTA:
    Impostare i parametri di convergenza OSPF su tutte le interfacce nell'area OSPF secondo il piano.
  4. Configurare la sicurezza OSPF.

    Su una rete che richiede elevata sicurezza, si consiglia di configurare l'autenticazione OSPF. Per impostazione predefinita, nessuna modalità di autenticazione o password è configurata per un'area OSPF.

    Tabella 1-10  Pianificazione dei parametri di sicurezza OSPF
    Parametro Valore pianificato
    Tipo di autenticazione Autenticazione area
    Modalità di autenticazione MD5
    Tipo di password del testo cifrato cipher

    Le configurazioni su tutti i dispositivi WAN, inclusi PE, DC-P, RR e WAN-P sono le seguenti:

    #
    ospf 1
     area 0.0.0.0              //Configurare l'autenticazione di sicurezza nella vista dell'area OSPF.
      authentication-mode md5 1 cipher *****************************   //Configurare autenticazione OSPF MD5. Il file di configurazione viene visualizzato in ciphertext.
    #
    

Configurare BGP

Pianificazione generale

Poiché MPLS VPN è utilizzato per trasportare vari servizi, MP-IBGP deve essere utilizzato per lo scambio dell'instradamento VPN tra PE; l'instradamento statico, IGP multe-instanze, o EBGP è utilizzato tra PE e CE. In questo esempio, EBGP viene utilizzato tra PE e CE. Attraverso la potente capacità di controllo delle politiche BGP, gli instradamenti VPN vengono trasmesse tra gli AS, implementando un controllo di accesso complesso.

La rete principale di backbone, la rete di centro di dati, la rete di centri di servizi e le filiali sono divisi in AS indipendenti e utilizzano i numeri AS privati. Gli indirizzi loopback 0 vengono utilizzati per stabilire relazioni peer IBGP, mentre gli indirizzi IP delle interfacce connesse direttamente vengono utilizzati per stabilire le relazioni peer EBGP.

Procedura

  1. Configurare BGP RR.

    In questo esempio, quattro router vengono distribuiti sulla rete principale di backbone come RR per eseguire il backup reciproco. RR forniscono BGP e le funzioni di riflessione dell'instradamento VPNv4 per aggregazione e dispositivo dell'accesso. PE dei centri di dati e le filiali funzionano come client RR e non vengono stabilite relazioni peer di IBGP tra RR.

    Tabella 1-11  Pianificazione dei parametri BGP di base
    Parametro Pianificazione generale
    Cluster ID Numero AS del livello principale di backbone. I quattro RR condividono lo stesso cluster ID.
    Priorità RR Più basso è l'indirizzo IP di loopback di una RR, maggiore è la priorità della RR.
    Nomi di gruppo peer GROUP_IBGP e GROUP_EBGP. Configurare i nomi dei gruppi peer come richiesto.
    Tempo di Keepalive di peer o gruppo peer 10s. Impostare il valore in base alla qualità del collegamento WAN. La riduzione del valore di questo parametro può accelerare il rilevamento dei guasti del collegamento.
    Tempo di attesa del gruppo peer o peer 30s. Impostare il valore in base alla qualità del collegamento WAN. La riduzione del valore di questo parametro può accelerare il rilevamento dei guasti del collegamento.
    Scambio degli instradamenti di rete pubblica IPv4 unicast Disabilitato perché MPLS VPN è utilizzato per trasportare i vari tipi di servizi.
    NOTA:
    Si consiglia di utilizzare i valori predefiniti dei timer LDP. È inoltre possibile pianificare i timer LDP in base alla qualità della linea affittata. I valori utilizzati in questo esempio sono per il riferimento.

    Configurare su un RR:

    #
    bgp 64512
     undo default ipv4-unicast                //Disabilitare gli scambi degli instradamenti unicast della rete pubblica IPv4.
     group GROUP_IBGP internal            //Creare un gruppo peer IBGP.
     peer GROUP_IBGP connect-interface LoopBack0  //L'indirizzo di Loopback 0 viene utilizzato per stabilire una relazione peer IBGP.
     peer 10.1.3.2 as-number 64512           //Stabilire una relazione peer IBGP con il peer alla 10.1.3.2 (indirizzo di loopback di un PE).
     peer 10.1.3.2 group GROUP_IBGP        //Aggiungere il peer alla 10.1.3.2 al gruppo peer.
     peer 10.1.3.2 description TO_PE01-A      // Configurare una descrizione per il peer 10.1.3.2.
     peer 10.1.3.2 timer keepalive 10 hold 30    //Regolare i timer per velocizzare il rilevamento dei guasti. …//Aggiungere gli altri PE al gruppo peer come richiesto.
     #
     ipv4-family unicast                    //Immettere la vista famiglia di indirizzo unicast IPv4.
      undo synchronization
      undo peer GROUP_IBGP enable        //Disabilitare gli scambi dei gli instradamenti unicast della rete pubblica IPv4.
     #
     ipv4-family vpnv4
      reflector cluster-id 64512              //Imposta ID del cluster per i RR.
      undo policy vpn-target                //Ricevere tutte gli instradamenti VPN e annullare il filtraggio delle destinazioni VPN per gli instradamenti VPNv4.
      peer GROUP_IBGP enable             //Abilitare il gruppo peer per lo scambio delle informazioni di routing VPNv4.
      peer GROUP_IBGP reflect-client        //Abilitare la riflessione dell'instradamento per il gruppo di peer.
      peer GROUP_IBGP advertise-community  //Abilitare l'attributo della comunità da pubblicizzare ai peer.
    #
    

    Configurare su un PE:

    #
    bgp 64512                            //Impostare il numero AS su 64512.
     undo default ipv4-unicast               //Disabilitare tutti i peer dallo scambio dell'instradamento unicast IPv4.
     group GROUP_IBGP internal           //Configurare un gruppo peer IBGP..
     peer GROUP_IBGP connect-interface LoopBack0  //Usare loopback 0 per stabilire una sessione BGP con RR.
     peer 10.1.3.5 as-number 64512          //Stabilire una relazione peer IBGP con RR (10.1.3.5).
     peer 10.1.3.5 group GROUP_IBGP       //Aggiungere il peer al gruppo peer GROUP_IBGP.
     peer 10.1.3.5 description TO_RR01-A     //Configurare una descrizione per il peer.
     peer 10.1.3.5 timer keepalive 10 hold 30   //Regolare i timer per velocizzare il rilevamento dei guasti.
     ….  //Eseguire le configurazioni relative ad altri RR come richiesto.
    #
     ipv4-family vpnv4
      policy vpn-target
      peer GROUP_IBGP enable              //Abilitare il dispositivo per lo scambio delle informazioni di routing VPNv4 con il gruppo peer BGP.
      peer GROUP_IBGP advertise-community  //Abilitare l'attributo della comunità da pubblicizzare ai peer.
    #
    
  2. Configurare gli attributi BGP.

    Tabella 1-12  Pianificazione degli attributi BGP
    Attributo BGP Descrizione
    Comunità L'attributo comunità viene utilizzato per determinare attraverso quale piano IBGP pubblicizza gli instradamenti. È possibile impostare i valori di attributo di comunità diversi per diversi piani di rete, posizioni geografiche, origini del protocollo di routing e tipi di servizio in base alla distribuzione dell'instradamento.
    Preferenza locale Quando un centro di dati PE riceve gli instradamenti da peer IBGP, è possibile utilizzare una politica dell'instradamento o per impostare una preferenza locale per gli instradamenti. Ad esempio, la preferenza locale dell'instradamento ricevuta dallo stesso piano è impostata su 200 e la preferenza locale dell'instradamento ricevuta da un altro piano è impostata su un valore inferiore, ad esempio 100. Più grande è la preferenza locale, maggiore è la priorità. Quando gli instradamenti BGP vengono pubblicizzate tra due CE dual-homed di un ramo, l'attributo della preferenza locale deve essere pubblicizzato. Quando si apprendono gli instradamenti BGP da PE, CE modifica l'attributo della preferenza locale.

    Configurare le politiche dell'instradamento su PE e CE e applicare le politiche dell'instradamento all'instradamento BGP ricevute. Nell'esempio seguente viene utilizzata la configurazione su un PE:

    #
    route-policy EBGP_CE_TO_PE permit node 10
     if-match ip-prefix EBGP_CE_TO_PE
     apply community 100:1 additive
    #
    ip community-filter basic ADD_LOCALPREF1 index 10 permit 100:1    //Configurare un filtro di comunità di base denominato ADD_LOCALPREF1 per abbinare l'instradamento con il valore dell'attributo di 100: 1.
    ip community-filter basic ADD_LOCALPREF2 index 10 permit 100:2    //Configurare un filtro di comunità di base denominato ADD_LOCALPREF2 per abbinare gli instradamenti con il valore di attributo di 100: 2#
    route-policy ADD_LOCAL_PREFERENCE permit node 10           //Configurare un criterio dell'instradamento.
     if-match community-filter ADD_LOCAL_PREFERENCE1          //Configurare una regola di corrispondenza.
     apply local-preference 200            //Applicare la preferenza locale agli instradamneti che corrispondono alla regola configurata.
    #
    route-policy ADD_LOCAL_PREFERENCE permit node 20
     if-match community-filter ADD_LOCAL_PREFERENCE2
     apply local-preference 100
    #
    bgp 64512
     ipv4-family vpnv4
      peer 10.1.3.5 route-policy ADD_LOCAL_PREFERENCE import  //Applicare un criterio dell'instradamento agli instradamenti ricevuti dalla RR (10.1.3.5).
      …//Aggiungere le configurazioni per applicare un criterio dell'instradamento a RR.
    #
    
  3. Configurare la sicurezza BGP.

    Tabella 1-13  Pianificazione dei parametri di sicurezza BGP
    Parametro Valore pianificato
    Tipo di autenticazione MD5
    Password -
    Tipo di password del testo cifrato cipher

    Eseguire le seguenti configurazioni su PE e RR:

    #
    bgp 64512
     peer GROUP_IBGP password cipher *****************************
    #
    

Configurare MPLS

Pianificazione generale

I tunnel MPLS LDP sono distribuiti sull'intera rete. LDP LSP full-meshed vengono stabiliti automaticamente tra tutti i router su una rete backbone. Un gruppo TE viene distribuito tra le PE in ogni centro di dati. I tunnel TE vengono delegati al controllore tramite PCEP per l'ottimizzazione del traffico. Hot standby è distribuito su ogni tunnel TE per migliorare l'affidabilità.

Il traffico tra reti di ramo e gli centri di dati e tra un ramo viene trasportato attraverso i tunnel LDP. Anche il traffico tra i centri di dati viene effettuato su tunnel LDP se tutti i collegamenti TE sono difettosi. Il traffico trasmesso su LDP LSP non può essere elaborato per l'ottimizzazione del traffico. In questa situazione, i tunnel TE sono distribuiti tra P che sono direttamente connessi tramite collegamenti WAN e i peer remoti LDP sono anche implementati, che implementa LDP su TE.

Procedura

  1. Configurare MPLS LDP.

    Tabella 1-14  Pianificazione dei parametri LDP
    Parametro Valore pianificato
    MPLS LSR ID LSR ID di ciascun dispositivo deve essere univoco. L'indirizzo loopback0 di ciascun dispositivo viene utilizzato come LSR ID.
    La politica per stabilire LDP LSP Host, Che impedisce la generazione di LSP indesiderati
    Ambito dei dispositivi su cui sono stabiliti LDP LSP Tutti PE e P
    Hello Send timer In questo esempio, il valore pianificato è 5s. Il valore predefinito è 15s.
    Timer Hello Hold Valori predefiniti utilizzati:
    • 15s per il collegamento Hello Hold Timer
    • 45s per target Hello Hold timer
    Keepalive Send timer In questo esempio, il valore pianificato è 10s. Il valore predefinito è 15s.
    Keepalive Hold timer In questo esempio, il valore pianificato è 30s. Il valore predefinito è 45s.
    Affidabilità LDP

    Attivare la sincronizzazione LDP-OSPF.

    LDP FRR è disabilitato e la regolazione del percorso LDP viene attivata dalla convergenza IGP. Poiché i centri di dati sono trasportati su tunnel TE, non è richiesto LDP FRR. Se non esiste alcun collegamento WAN di backup tra un ramo e un centro di dati o tra rami, LDP FRR non è efficace come previsto.

    NOTA:
    Si consiglia di utilizzare i valori predefiniti per i timer LDP. È inoltre possibile pianificare i parametri in base alla situazione reale della WAN e alla qualità dei servizi di linea affittati di un operatore. In questo esempio, i valori pianificati sono solo di riferimento.

    Eseguire i seguenti passaggi su ciascun dispositivo WAN (PE, DC-P e WAN-P, esclusi i RR):

    #
    mpls lsr-id 10.1.2.3               //Impostare un ID LSR MPLS.
    #
    mpls                          //Abilitare MPLS a livello globale.
    #
    mpls ldp                       //Abilitare MPLS LDP globalmente.
    #
    interface Eth-Trunk0             //Immettere la vista dell'interfaccia.
    mpls                          //Abilitare MPLS sull'interfaccia.
    mpls ldp                       //Abilitare MPLS LDP sull'interfaccia.
     mpls ldp timer hello-send 5       //Regolare l'intervallo di invio dei messaggi MPLS LDP Hello.
     mpls ldp timer keepalive-hold 30   //Impostare timer tenuto MPLS LDP Keepalive.
     mpls ldp timer keepalive-send 10   //Impostare il tempo di invio MPLS LDP Keepalive.
    
    NOTA:
    In applicazioni effettive, abilitare MPLS LDP e regolare i parametri su tutte le interfacce in un dominio MPLS. La configurazione di ogni interfaccia è la stessa di quella di Eth-Trunk0.
  2. Configurare MPLS TE.

    Tabella 1-15  Pianificazione tunnel TE
    Parametro Valore pianificato
    Nome tunnel

    Formato: VpnType-ServiceType-Source-Destination-n

    Esempio: L3-Key-PE1-PE4-01

    Stato amministrativo Up (predefinito)
    Nodo di origine Selezionare Source node.
    Nodo di destinazione Selezionare Destination node.
    Vincolo larghezza di banda 0
    Priorità Impostare questo parametro in base alla progettazione del tunnel. Per ulteriori informazioni, vedere il disegno del tunnel in questa sezione.
    Etichetta utente Non impostato (valore predefinito)
    Hot standby Abilitare
    Percorso di best-effort Il percorso di best-effort è abilitato per L2VPN, non per i tunnel.
    Percorso esplicito Impostare questo parametro come richiesto.
    Tipo di segnalazione RSVP-TE
    Modalità di controllo Delegare
    Protocollo di Southbound NETCONF
    MTU 1500, in byte
    Modalità larghezza di banda Larghezza di banda dinamica
    Switchback ON
    Tempo (s) di switchback 10
    Includere l'attributo delle affinità

    "Include qualsiasi 0x1" (Includere qualsiasi 0x1) per il tunnel primario (il tunnel con la priorità più alta nell'intervallo da 1 a 4)

    Non impostato per i tunnel di backup

    Escludendo l'attributo delle affinità Non impostato
    Ritardo del tunnel (s) 0
    Limite di hop 32
    Classe di servizio Consultare la tabella TE priority planning.
    Limite di velocità OFF
    Iterazione vincolante

    Tunnel a cui viene iterato il traffico L3VPN: OFF

    Tunnel a cui viene iterato il traffico L2VPN: ON

    Raccolta di statistiche sul traffico ON
    Tabella 1-16  Pianificazione priorità TE
    Priorità del pacchetto Tipo di servizio Priorità del tunnel
    CS7 Riservato per un protocollo 1
    CS6 Riservato per un protocollo 1
    EF Chiave e i servizi di connessione esterna 1
    AF4 Voce e video 2
    AF3 Interazione 3
    AF2 Batch, test 4
    AF1 OA 5
    BE Predefinito 6
    NOTA:
    In questo esempio, la gestione del tunnel (compresa la creazione, la modifica e l'eliminazione) viene eseguita dal controller SDN (la configurazione delle scorciatoie viene modificata sul router). I comandi seguenti sono solo di riferimento.
    #
    mpls
     mpls te             //Abilitare MPLS TE a livello globale.
     mpls te pce delegate   //Configurare l'algoritmo di stato attivo del PCE utilizzato per calcolare i percorsi per i tunnel TE.
     mpls rsvp-te         //Abilitare RSVP-TE a livello globale.
     mpls rsvp-te hello    //Abilitare il meccanismo Hello a livello globale.
     mpls rsvp-te srefresh  //Configurare Srefresh.
     mpls te cspf         //Abilitare CSPF.
    #
    interface Eth-Trunk0
    mpls
     mpls te              //Abilitare MPLS TE sull'interfaccia.
     mpls te link administrative group 1   //Configurare un attributo di gruppo amministrativo per l'interfaccia.
     mpls te bandwidth max-reservable-bandwidth dynamic 75  //Impostare la larghezza di banda massima prenotabile dinamica del collegamento.
     mpls te bandwidth dynamic bc0 100  //Impostare la larghezza di banda dinamica BC0 del collegamento.
     mpls rsvp-te         //Abilitare RSVP-TE sull'interfaccia.
     mpls rsvp-te hello    //Abilitare il meccanismo Hello sull'interfaccia.
    #
    ¡­..                //Le configurazioni delle altre interfacce sono simili alla configurazione di Eth-Trunk0. I dettagli di configurazione non sono forniti.
    #
    interface Tunnel1          //Creare un'interfaccia tunnel TE.
     ip address unnumbered interface LoopBack0   //Assegnare un indirizzo IP a un'interfaccia tunnel TE.
     tunnel-protocol mpls te    //Abilitare MPLS TE come protocollo di tunnel.
     destination 10.1.2.3       //Impostare un indirizzo di destinazione del tunnel che è LSR ID dell'uscita.
     mpls te record-route label  //Abilitare il dispositivo per registrare gli instradamenti ed le etichette, che viene utilizzato per visualizzare un'etichetta che ogni nodo su un percorso assegna al tunnel durante la manutenzione.
     mpls te priority 6        //Impostare la configurazione e le priorità di mantenimento per il tunnel MPLS TE.
     mpls te backup hot-standby dynamic-bandwidth  //Attivare hot standby TE e la regolazione dinamica della larghezza di banda per un HSB CR-LSP.
     mpls te backup hot-standby overlap-path   //Configurare la funzione in modo che sia possibile stabilire un CR-LSP hot-standby su un percorso che contiene solo alcuni collegamenti di un CR-LSP primario. I CR-LSP hot-standby e primari non possono sovrapporsi completamente.
     statistic enable                  //Abilitare la raccolta statistiche sul traffico.
     mpls te affinity property 1 mask 1  //Impostare un'affinità.
     mpls te tunnel-id 1              //Impostare un tunnel ID.
     mpls te pce delegate            //Abilitare il dispositivo a delegare il tunnel al server PCE per il calcolo del percorso.
     mpls te service-class ef cs6 cs7   //Impostare le classi di servizio per i pacchetti che possono passare attraverso il tunnel MPLS TE.
    #
    ¡­.                          //Le configurazioni dell'altra interfaccia tunnel TE sono simili alle configurazioni di Tunnel1. I dettagli di configurazione non sono forniti.
    #
    

    Per i tunnel sul nodo DC-P che devono partecipare al calcolo del percorso, abilitare la funzione di collegamento TE IGP su ogni interfaccia tunnel.

    NOTA:
    Nel momento in cui questo documento viene rilasciato, la funzione di collegamento a TE IGP di ogni versione deve essere configurata manualmente sui server di inoltro.
    #
    interface Tunnel1                  //Abilitare la vista dell'interfaccia tunnel TE.
      mpls te igp shortcut              //Abilitare la funzione di scorciatoia TE IGP..
      mpls te igp metric absolute 190     //Impostare una metrica per il tunnel TE.
    #
    

Configurare MPLS VPN

Pianificazione generale

In questo caso, un L3VPN o L2VPN può essere utilizzato per trasportare più servizi, quali servizi di produzione, servizi di test di rete, servizi di interconnessione sussidiaria, servizi di interconnessione di organizzazioni di delegazione, i servizi di ripristino disastro DC e i servizi di connessione esterni. Si consiglia di selezionare una modalità portante basata sui seguenti principi.
Tipo di servizio Tipo VPN
Servizio di produzione L3VPN
Servizio di test di rete L3VPN
Servizio di interconnessione sussidiaria L3VPN
Servizio dell'interconnessione delle organizzazioni della delegazione L3VPN
Servizio di scoperta di disastro di DC L2VPN
Servizio di accesso per filiali al di fuori di un paese specifico L2VPN
Servizio di connessione esterna L2VPN

Procedura

  1. Configurare un MPLS L3VPN.

    Tabella 1-17  Pianificazione dei parametri L3VPN
    Parametro Valore pianificato in questo esempio
    Nome istanza VPN VPNA
    Distinguitore dell'instradamento

    As-number: n

    Esempio: 64512:1

    VPN target

    As-number: n

    Esempio: 64512:01

    Politica di selezione tunnel I tunnel TE hanno la precedenza su LDP LSP per il bilanciamento del carico.
    Modalità di assegnazione delle etichette Un'etichetta per istanza
    Modalità TTL Uniforme
    Protocollo di routing tra PE e CE È possibile utilizzare gli instradamenti statici, multe-istanze IGP o EBGP. In questo esempio, EBGP viene utilizzato tra PE e CE.
    Modalità MPLS DiffServ Valori predefiniti utilizzati: Uniforme

    Configurazione su ogni PE

    #
    ip vpn-instance VPNA                     //Creare un'istanza VPN denominata VPNA.
     description VPNA                       //Configurare una descrizione.
     ipv4-family
      route-distinguisher 64512:1               //Impostare un RD.
      tnl-policy L3VPN-Tunnel-Policy                        //Configurare una politica del tunnel.
      apply-label per-instance                  //Impostare la modalità di assegnazione delle etichette su "un'etichetta per istanza".
      vpn-target 64512:01 export-extcommunity   //Configurare la destinazione VPN di esportazione.
      vpn-target 64512:01 import-extcommunity   //Configurare la destinazione VPN di importazione.
      ttl-mode uniform                        //Impostare una modalità TTL MPLS.
    #
    interface Eth-Trunk2
     ip binding vpn-instance VPNA             //Associare l'interfaccia all'istanza VPN.
     ip address 10.3.1.1 255.255.255.252        //Assegnare un indirizzo IP all'interfaccia.
    #
    bgp 64512
     ipv4-family vpn-instance VPNA
      import-route direct med 0                //Importare l'instradamento diretto del CE locale verso la tabella di routing VPN e restare il MED minimo. Se le altre condizioni sono uguali, l'instradamento diretto viene selezionato preferenzialmente. Se questo comando non viene eseguito, il PE non annuncia l'instradamento diretto verso il PE remoto usando MP-BGP.
      auto-frr
      peer 10.3.1.2 as-number 65001
      peer 10.3.1.2 route-policy EBGP_CE_TO_PE import
    #
    tunnel-policy L3VPN-Tunnel-Policy                     //Configurare una politica del tunnel.
     tunnel select-seq cr-lsp lsp load-balance-number 10 unmix     //Configurare il dispositivo per preferire un TE LSP a un LDP LSP. È possibile stabilire un massimo di 10 LSP per bilanciare il traffico.
    #
    

    Configurazione su ogni CE

    #
    bgp 65001
    peer 10.3.1.1 as-number 65001
    # 
    ipv4-family unicast
      undo synchronization
      peer 10.3.1.2 enable
      import-route direct
      ¡­ //TQuesto comando consente al CE di annunciare l'indirizzo del segmento di rete VPN al PE e al CE remoto. Il tipo dell'instradamento da importare in questo passaggio dipende dalla rete reale.
    #
    
  2. Configurare un MPLS L2VPN.

    Tabella 1-18  Pianificazione dei parametri L2VPN
    Parametro Valore pianificato
    Tipo L2VPN VLL
    Protocollo di distribuzione etichette VC MPLS LDP
    Politica di selezione tunnel Vincolare il tunnel TE
    VC ID Per ogni VC è previsto un ID specifico.
    Modalità di MPLS DiffServ Valori predefiniti utilizzati: Uniforme

    Eseguire i seguenti passaggi su ogni PE.

    #
    mpls l2vpn                    //Abilitare globalmente MPLS L2VPN.
    #
    mpls ldp remote-peer 10.1.2.2     //Configurare un peer LDP remoto.
     remote-ip 10.1.2.2             //Specificare l'indirizzo IP del peer remoto che è LSR ID del PE remoto.
    #
    interface GigabitEthernet1/0/0
     description to_PE2_G1/0/0
     mpls l2vc 10.1.2.2 1000 tunnel-policy L2VPN_PE1_TO_PE2   //Creare un VC.
    #
    tunnel-policy L2VPN_PE1_TO_PE2
     tunnel binding destination 10.1.1.1 te Tunnel1 Tunnel2        //Configurare TE tunnel vincolante.
    #
    
    NOTA:
    La configurazione di VC da PE2 a PE1 è simile a quella di VC da PE1 a PE2. I dettagli di configurazione non sono forniti.

Configurazione dell'affidabilità

Pianificazione generale

Tabella 1-19  Pianificazione dell'affidabilità
Categoria Pianificazione dell'affidabilità
Protocollo di Routing

Attivare BFD per OSPF per tutti i collegamenti di trasmissione WAN.

Attivare BFD per BGP tra RR e ogni filiale PE.

Affidabilità del tunnel Configurare TE hot-standby per lavorare con BFD per TE-LSP e BFD per le tecnologie tunnel.
L3VPN Configurare VPN FRR per lavorare con BFD per IP per implementare una rapida commutazione di protezione.
Tabella 1-20  Pianificazione dei parametri BFD
Parametro Valore pianificato
BFD per OSPF

min-tx-interval: 50 ms (predefinito: 1000 ms)

min-tx-interval: 50 ms (predefinito: 1000 ms)

detect-multiplier: 3

BFD per TE LSP

min-tx-interval: 50 ms (predefinito: 10 ms)

min-rx-interval: 50 ms (predefinito: 10 ms)

detect-multiplier: 3

BFD per TE

min-tx-interval: 100 ms (predefinito: 10 ms)

min-rx-interval: 100 ms (predefinito: 10 ms)

detect-multiplier: 3

BFD per IP (per VPN FRR)

min-tx-interval: 100 ms (predefinito: 10 ms)

min-rx-interval: 100 ms (predefinito: 10 ms)

detect-multiplier: 3

BFD per BGP

min-tx-interval: 200 ms (predefinito: 10 ms)

min-rx-interval: 200 ms (predefinito: 10 ms)

detect-multiplier: 3

NOTA:
I precedenti parametri BFD devono essere pianificati correttamente in base alla qualità effettiva della linea WAN. I valori pianificati forniti in questo esempio sono solo di riferimento.

Procedura

  1. Configurare TE hot standby.

    Configurare hot standby sulle interfacce TE. La configurazione correlata al tunnel in questo esempio viene completata utilizzando il controller SDN. Per dettagli, vedere Italian/dc_ne_typical-cfg_wan_026.xml.

  2. Configurare VPN FRR.

    #
    ip vpn-instance VPNA
      vpn frr                                //Abilitare VPN FRR.
    #
    
  3. Configurare BFD per OSPF.

    Abilitare BFD per OSPF sulle interfacce su entrambe le estremità di ciascun collegamento di trasmissione WAN e configura la soppressione dell'instabilità della relazione OSPF neighbor.

    #
    interface GigabitEthernet2/1/1                  //Accedere alla vista dell'interfaccia.
     ospf bfd enable                             //Abilitare BFD per OSPF.
     ospf bfd min-tx-interval 50 min-rx-interval 50    //Configurare l'intervallo minimo a cui vengono inviati i pacchetti BFD e l'intervallo minimo a cui vengono ricevuti i pacchetti BFD.
     ospf suppress-flapping peer detecting-interval 180 threshold 3 resume-interval 240 //Set detection parameters for OSPF neighbor relationship flapping suppression.
     ospf suppress-flapping peer hold-down 300       //Configurare una modalità di soppressione di oscillazione della relazione vicina OSPF e una durata di soppressione.
    #
    
  4. Configurare BFD per TE.

    Configurare BFD per il tunnel TE e BFD per TE-LSP a entrambe le estremità del tunnel TE specificato.

    NOTA:
    BFD per TE può essere configurato utilizzando i comandi o il controller SDN. Si consiglia di completare la configurazione utilizzando il controller SDN. I comandi di configurazione forniti in questo esempio sono solo di riferimento.
    #
    bfd Bfd101 bind mpls-te interface Tunnel1   //Configurare BFD per tunnel.
     discriminator local 1                      //Configurare un discriminatore locale.
     discriminator remote 101                   //Configurare un discriminatore remoto.
      min-tx-interval 100                        //Configurare l'intervallo minimo al quale vengono inviati i pacchetti BFD.
     min-rx-interval 100                        //Configurare l'intervallo minimo al quale vengono ricevuti i pacchetti BFD.
     process-pst                                //Abilitare una sessione BFD per modificare la tabella dello stato della porta (PST) se la sessione BFD rileva un errore, in modo che la sessione BFD sia associata al PST.
    #
    bfd Bfd102 bind mpls-te interface Tunnel1 te-lsp  //Configurare BFD per TE LSP.
     discriminator local 2                        //Configurare un discriminatore locale.
     discriminator remote 102                    //Configurare un discriminatore remoto.
     min-tx-interval 50                         //Configurare l'intervallo minimo al quale vengono inviati i pacchetti BFD.
     min-rx-interval 50                         //Configurare l'intervallo minimo al quale vengono ricevuti i pacchetti BFD.
     process-pst                              //Abilitare una sessione BFD per modificare il PST se la sessione BFD rileva un errore.
    #
    
  5. Configurare BFD per VPN FRR.

    Configurare BFD per IP su PE a entrambe le estremità di un servizio L3VPN.

    Configurazione per PE nei centri di dati:

    #
    bfd D-PE1_B-PE1_1 bind peer-ip 10.4.1.2
     discriminator local 101
     discriminator remote 101
     min-tx-interval 100
     min-rx-interval 100
    #
    

    Configurazione per la filiale PE:

    #
    bfd B-PE1_D-PE1_1 bind peer-ip 10.1.1.2
     discriminator local 101
     discriminator remote 101
     min-tx-interval 100
     min-rx-interval 100
    #
    
  6. Configurare BFD per BGP.

    Configurare BFD per BGP per il collegamento tra il RR e la filiale PE.

    Configurazione per RR:

    #
    bgp 65000
     peer 10.7.1.2 bfd min-tx-interval 200 min-rx-interval 200     //Impostare i parametri BFD. In questo esempio, l'indirizzo di sessione BGP del ramo PE è 10.7.1.2.
     peer 10.7.1.2 bfd enable                               //Abilitare BFD per BGP.
    ¡­             .//Abilitare BFD per BGP per i collegamenti tra RR e altri PE di settore, se presenti.
    #
    

    Configurazione per la filiale PE:

    #
    bgp 65000
     peer 10.1.3.5 bfd min-tx-interval 200 min-rx-interval 200     //Impostare i parametri BFD. In questo esempio, l'indirizzo della sessione BGP della RR è 10.1.3.5.
     peer 10.1.3.5 bfd enable                               //Abilitare BFD per BGP.
    ¡­.            //Abilitare BFD per BGP per i collegamenti tra il ramo PE e altri eventuali RR.
    #
    

Configurare QoS

Pianificazione generale

  • CE sulla rete contrassegnano i valori DSCP per i pacchetti di dati. La classificazione del comportamento aggregato (BA) viene distribuita su tutti i collegamenti e le tecnologie PQ e WFQ vengono distribuite sui collegamenti WAN. La larghezza di banda è allocata in base ai valori DSCP dei pacchetti dati per fornire i servizi differenziati.
  • I pacchetti che non sono contrassegnati con le priorità QoS su CE devono essere contrassegnati su PE.
  • Intranet VPN utilizza il modello Uniform. Altri VPN utilizzano il modello Pipe, con la priorità BE.
Tabella 1-21  Pianificazione dei parametri QoS
Parametro Valore pianificato
Dominio DiffServ per la classificazione BA Dominio predefinito
Mappature del dominio DiffServ Valore predefinito
Contrassegno di priorità La classificazione multi-campi (MF) viene utilizzata per il contrassegno.
Modello L3VPN DiffServ Uniform
Modello di L2VPN DiffServ Pipe
Scopo della sagomatura del traffico La modellatura del traffico è implementata sui collegamenti WAN che possono essere congestionati. Per impostazione predefinita, la modellatura del traffico viene implementato su un'interfaccia basata sulla larghezza di banda dell'interfaccia.
Modalità di evasione congestione WRED (Weighted random early detection)
NOTA:
In applicazioni, pianificare i parametri QoS precedenti in base ai requisiti WAN effettivi. I valori pianificati in questo esempio sono solo di riferimento.

Procedura

  1. Configurare la classificazione BA.

    Eseguire il comando trust upstream default su tutte le interfacce attraverso le quali passa il servizio (come mo strato nella figura seguente) per fidare le priorità dei pacchetti upstream (compresi i valori EXP dei pacchetti MPLS e dei valori DSCP dei pacchetti IP).

    Figura 1-9  Interfacce su cui è richiesta la classificazione BA
    #
    interface Eth-Trunk0               //Inserire la vista dell'interfaccia.
     trust upstream default             //Configurare la classificazione BA.
    #
    
  2. Configurazione della classificazione MF.

    Se la CE non segnala la priorità QoS dei pacchetti o la priorità QoS dei flussi di servizio deve essere reimpostata sulla WAN perché il valore di priorità QoS non soddisfa i requisiti di pianificazione, contrassegnare il valore su PE.

    #
    acl name Remark_QOS advance              //Configurare un ACL..
     description Remark_QOS                  //Aggiungere una descrizione.
     rule 5 permit ip source 10.1.0.0 0.1.255.255    //Configurare una regola per abbinare l'indirizzo IP di origine.
    #
    traffic classifier RemarkClass operator or       //Configurare un classificatore del traffico.
     if-match acl name Remark_QOS             //Configurare una regola ACL.
    #
    traffic behavior RemarkBehavior              //Configurare un comportamento del traffico.
     service-class af1 color green                 //Posizionare il traffico corrispondente alla regola nella coda AF1.
     user-queue cir 250000 pir 250000             //Impostare il valore di sagmatura su 250 Mbps.
    #
    traffic policy RemarkPolicy                   //Configurare una politica del traffico.
     share-mode                               //Configurare tutto il traffico su un'interfaccia per condividere la larghezza di banda.
     classifier RemarkClass behavior RemarkBehavior precedence 1   //Associare il classificatore del traffico al comportamento del traffico.
    #
    interface Eth-Trunk3
    traffic-policy TestPolicy inbound               //Applicare la politica del traffico al traffico in entrata sull'interfaccia.
    
    #
    
  3. Configurare la gestione della congestione e l'evitamento.

    Sui dispositivi DC-P, WAN-P e PE ramo collegati ai collegamenti WAN, regolare la velocità di forma del traffico che entra nei collegamenti WAN e modificare il meccanismo di prevenzione della congestione.

    NOTA:
    Per impostazione predefinita, la modellatura del traffico viene eseguito su un'interfaccia basata sulla larghezza di banda dell'interfaccia. La coda di priorità (PQ) si applica alle code CS7, CS6 e EF e la coda ponderata (WFQ) si applica alle altre code. La soluzione caduta di coda viene utilizzata per evitare la congestione. Nelle applicazioni, pianificare i parametri QoS in base ai requisiti WAN effettivi. Le configurazioni in questo esempio sono solo di riferimento.
    # 
    port-wred W                  //Configurare WRED.
     color green low-limit 70 high-limit 100 discard-percentage 10   //Configurare le soglie superiore e inferiore e eliminare la probabilità di WRED.
     color yellow low-limit 60 high-limit 90 discard-percentage 30
     color red low-limit 50 high-limit 80 discard-percentage 50
    #
    interface GigabitEthernet1/0/0
     port shaping 200                    //Impostare la velocità di sagomatura dell'interfaccia su 200 Mbps.
     port-queue be lpq outbound           //Configurare LPQ per la coda BE.
     port-queue af1 lpq outbound          //Configurare LPQ per la coda AF1.
     port-queue af2 wfq weight 50 port-wred W outbound   //Configurare WFQ per la coda AF2 e impostare il peso su 50%. Utilizzare la politica WRED.
     port-queue af3 wfq weight 50 port-wred W outbound   //Configurare WFQ per la coda AF3 e impostare il peso su 50%. Utilizzare la politica WRED.
     port-queue af4 pq shaping 50 outbound             //Configurare PQ per la coda AF4 e impostare la velocità di sagomatura su 50 Mbps.
    #
    
  4. Configurare il modello MPLS DiffServ.

    Configurare i modelli MPLS DiffServ per L2VPN e L3VPN su PE.

    #
    ip vpn-instance VPNA
     diffserv-mode uniform         //Configurare il modello Uniform per L3VPN. Usare la configurazione predefinita.
    #
    interface GigabitEthernet1/0/1
     mpls l2vc 10.1.2.2 1000 tunnel-policy L2VPN_PE1_TO_PE2
     diffserv-mode pipe ef green      //Configurare il modello DiffServ come Pipe sull'interfaccia associata a L2VPN e configurare il traffico L2VPN per entrare nella coda EF.
    #
    

Configurazione dei protocolli Southbound del controller

Procedura

  1. Configurare PCEP.

    Eseguire i seguenti passaggi su ogni PE e P:

    #
    pce-client                       //Configurare questo router come PCC.
     connect-server 10.100.1.1         //Assegnare un indirizzo IP al server PCE.
    #
    
  2. Configurare BGP-LS.

    Eseguire i seguenti passaggi sul RR per stabilire una connessione BGP-LS con il controller in modo che il controller possa raccogliere la topologia di rete.

    #
    bgp 64512
     peer 10.100.1.1 as-number 64512              //Abilitare il PCC a stabilire una relazione peer BGP con il controllore.
     peer 10.100.1.1 connect-interface LoopBack0    //Configurare un'interfaccia utilizzata per stabilire una relazione peer BGP.
     ipv4-family unicast
      undo peer 10.100.1.1 enable                 //Disabilitare il PCC dall'istituzione di una relazione peer BGP con il controllore nella famiglia di indirizzi unicast.
     link-state-family unicast
      peer 10.100.1.1 enable                     //Abilitare il PCC a stabilire una relazione peer BGP-LS con il controllore.
    #
    ospf 65000
     bgp-ls enable                             //Abilitare BGP-LS per pubblicizzare le informazioni sulla topologia OSPF.
    #
    
  3. Configurare NETCONF.

    Eseguire le seguenti operazioni su ciascun forwarder (PE, P e RR):

    NOTA:
    Prima di configurare NETCONF, configurare il protocollo SSH. Per ulteriori informazioni, vedere "Configurazione di un accesso remoto".
    #
    aaa
     local-user netconf password irreversible-cipher 8$1c$ca8S~hql  //Creare un utente denominato netconf e configurare la modalità e la chiave di autenticazione AAA.
     local-user netconf service-type ssh                        //Abilitare SSH.
     local-user netconf state block fail-times 3 interval 5          //Impostare il numero massimo di tentativi di accesso non riusciti a 3. Se un accesso non riesce per tre volte, è possibile effettuare un altro tentativo di accesso in 5 minuti dopo aver bloccato l'account.
     local-user netconf user-group ug                  //Aggiungere l'utente a un gruppo di uteniti specificato.
    #
    snetconf server enable                           //Abilitare SNETCONF.
    ssh user netconf                                //Creare un utente SSH.
    ssh user netconf authentication-type password        //Specificare una modalità di autenticazione.
    ssh user netconf service-type snetconf              //Configurare SSH per supportare SNETCONF.
    ssh client first-time enable                       //Abilitare l'autenticazione per la prima volta sul client SSH.
    #
    
  4. Configurare LLDP.

    Eseguire le seguenti operazioni su ciascun forwarder (PE, P e RR):

    #
    lldp enable                  //Abilitare LLDP globalmente per scoprire la topologia Layer 2.
    #
    

Configurazione di NetStream

Pianificazione generale

Questa sezione descrive come configurare NetStream per raccogliere il traffico di collegamento per l'analisi del traffico e il rilevamento anomalo del traffico. La seguente pianificazione è fornita come esempio. Regolare la pianificazione in base ai requisiti effettivi.

Parametro Valore pianificato
Posizione di schieramento

WAN-P e interfaccia DC-P WAN e interfaccia di accesso NMS VPN.

Interfaccia di accesso al servizio DC-PE e interfaccia di accesso NMS VPN.

Tempo di invecchiamento attivo del flusso originale Il valore predefinito è 30 minuti. In questo esempio, il valore è impostato su 1 minuto per accelerare il rilevamento dello stato del flusso attivo.
Tempo di invecchiamento inattivo dei flussi originale Il valore predefinito è 30 secondi. In questo esempio, il valore è impostato a 5 secondi per migliorare l'efficienza della raccolta delle statistiche.
Raccogliere le statistiche sui flussi originali basati su TCP-flag Attivato.
Modalità di campionamento dei pacchetti MPLS Pacchetto IP interno e raccolta di etichette.
Versione dei pacchetti esportati che trasportano le statistiche del flusso originale V9.
Formato degli indici di interfaccia contenuti nei pacchetti esportati 32.
Intervallo di aggiornamento del modello di esportazione del flusso originale Il valore predefinito è 30 minuti. In questo esempio, il valore è impostato su 1 minuto.
Numero di pacchetti basati su cui viene campionato un pacchetto Un pacchetto viene campionato ogni 100 pacchetti.
NOTA:
Nelle applicazioni effettive, è necessario pianificare i parametri NetStream in base ai requisiti WAN effettivi. I valori pianificati in questo esempio sono solo di riferimento.

Procedura

#
slot 1                            //Accedere alla vista slot.
 ip netstream sampler to slot self      //Specificare una scheda di elaborazione del servizio NetStream per una scheda di interfaccia.
#
….//Aggiungere le configurazioni precedenti a tutti gli slot della scheda di interfaccia in cui le interfacce utilizzano NetStream per raccogliere il traffico come richiesto.
#
ip netstream timeout active 1          //Impostare il tempo di invecchiamento attivo dei flussi originali.
ip netstream timeout inactive 5        //Impostare il tempo di invecchiamento inattivo dei flussi originali.
ip netstream tcp-flag enable          //Abilitare NetStream per raccogliere statistiche sui flag TCP nei flussi originali.
ip netstream mpls-aware label-and-ip  //Configurare il dispositivo per raccogliere le etichette e i pacchetti IP interni nei pacchetti MPLS.
ip netstream export version 9         //Configurare la versione dei pacchetti esportati che trasportano le statistiche del flusso originale.
ip netstream export index-switch 32   //Configurare il formato degli indici di interfaccia contenuti nei pacchetti esportati.
ip netstream export template timeout-rate 1   //Impostare l'intervallo di aggiornamento del modello di esportazione del flusso originale.
ip netstream sampler fix-packets 100 inbound //Configurare un pacchetto da campionare ogni 100 pacchetti nella direzione di ingresso.
ip netstream sampler fix-packets 100 outbound//Configurare un pacchetto da campionare ogni 100 pacchetti nella direzione di uscita.
ip netstream export source 10.10.8.1   //Impostare l'indirizzo IP di origine dei pacchetti esportati.
ip netstream export host 10.117.3.13 9996 vpn-instance MGT  //Impostare l'indirizzo IP di destinazione dei pacchetti esportati.
#
interface Eth-Trunk2
 ip binding vpn-instance VPNA
 ip netstream inbound              //Abilitare la funzione NetStream per raccogliere statistiche sui flussi di dati in entrata su un'interfaccia.
 ip netstream outbound             //Abilitare la funzione NetStream per raccogliere statistiche sui flussi di dati in uscita su un'interfaccia.
#
….//Abilitare la funzione NetStream per i flussi di dati in entrata e in uscita su tutte le interfacce che richiedono a NetStream di raccogliere il traffico.
#
Download
Updated: 2019-05-16

N. documento: EDOC1100082601

Visualizzazioni:859

Download: 2

Average rating:
This Document Applies to these Products
Documenti correlati
Related Version
Share
Precedente Avanti