Nessuna risorsa pertinente trovata nella lingua selezionata.

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Raccolta di casi di configurazione dello scenario tipico del router aziendale NE-ME60 2.0

Rate and give feedback:
Huawei utilizza la traduzione automatica insieme alla revisione umana per tradurre questo documento in diverse lingue, per facilitare la comprensione del contenuto di questo documento. Nota: la traduzione automatica, anche la più avanzata, non può corrispondere alla qualità dei trasduttori professionisti. Huawei non accetta alcuna responsabilità per l'accuratezza della traduzione e raccomanda di fare riferimento al documento inglese (per il quale è stato fornito un collegamento).
QoS

QoS

Esempio di configurazione di un criterio di traffico per limitare la velocità di traffico a larghezza di banda elevata

Prodotti e versioni applicabili

Questo esempio di configurazione si applica ai prodotti della serie NE40E/ME60 con V800R010C00 o versioni successive.

Requisiti di rete

In Figura 1-45, la velocità di traffico di Eth-Trunk 1, che collega il router di bordo PE1 di una WAN a LAN X, supera il limite In base al rilevamento dei guasti, un host con l'indirizzo IP 10.1.1.1/32 su LAN X sta scaricando molti file da un server remoto con l'indirizzo IP 10.2.1.1/32, causando un consumo eccessivo di larghezza di banda. È possibile limitare la velocità del traffico per proteggere la larghezza di banda dei servizi chiave sulla rete.

Figura 1-45  Configurare un criterio di traffico per limitare la velocità del traffico alla larghezza di banda elevata
Roadmap di configurazione
  1. Configurare un ACL avanzato per abbinare il traffico con l'indirizzo di origine 10.1.1.1/32 e l'indirizzo di destinazione 10.2.1.1/32.

  2. Configurare un classificatore del traffico e specificare l'ACL nel classificatore del traffico.

  3. Configurare un comportamento del traffico e impostare la sua azione su CAR.

  4. Configurare un criterio di traffico e associare la classificazione del traffico al comportamento del traffico in questa politica.

  5. Applicare la politica di traffico all'interfaccia in entrata.

Procedura

  1. Configurare un ACL avanzato su PE1 per far corrispondere il traffico con larghezza di banda elevata.

    #
    system-view                                                   //Inserire la vista di sistema.
    #
    acl name flow-limit advance                                   //Configurare un ACL avanzato denominato flusso-limite per far corrispondere il traffico con larghezza di banda elevata.
    rule 5 permit ip source 10.2.1.1 0 destination 10.1.1.1 0     //Abbinare il traffico con l'indirizzo IP di origine di 10.2.1.1 e l'indirizzo IP di destinazione di 10.1.1.1.
    #
    

  2. Configurare un classificatore del traffico.

    #
    traffic classifier flow-limit operator or                 //Configurare un classificatore del traffico denominato flow-limit.
    if-match acl name flow-limit                              //Configurare un classificatore del traffico denominato flusso-limite.
    #
    

  3. Configurare un comportamento del traffico.

    #
    traffic behavior flow-limit                                //Configurare un comportamento del traffico denominato flusso-limite.
    car cir 10 pir 10 green pass yellow discard red discard    //Limitare la velocità del traffico. In questo esempio, i valori di CIR e PIR sono 10 kbps. Imposta questi valori in base alla tua situazione attuale.
    #
    

  4. Configurare una politica del traffico.

    #
    traffic-policy flow-limit                                  //Configurare un criterio di traffico denominato flusso-limite.
    classifier flow-limit behavior flow-limit                  //Associare il classificatore del traffico al comportamento del traffico nella politica del traffico.
    #
    

  5. Applicare la politica del traffico.

    #
    interface Eth-trunk 1                                      //Immettere la vista dell'interfaccia in entrata del traffico a larghezza di banda elevata. In questo esempio, l'interfaccia in entrata è Eth-Trunk 1. Specificare un'interfaccia in base alla situazione attuale.
     traffic-policy flow-limit outbound                        //Applicare la politica del traffico all'interfaccia.
    #
    

  6. Verificare la configurazione.

    Eseguire il comando display interface [ interface-type [ interface-number ] ] per visualizzare le informazioni sul traffico dell'interfaccia specificata.

Esempio per la configurazione di una politica di traffico per bloccare il traffico

Prodotti e versioni applicabili

Questo esempio di configurazione si applica ai prodotti della serie NE40E/ME60 con V800R010C00 o versioni successive.

Requisiti di rete

In Figura 1-46, un MAN porta i servizi multicast e i punti di replica multicast si trovano sul router di bordo MAN. Per evitare che i pacchetti di protocollo multicast influiscano su MAN, i pacchetti di protocollo multicast inviati dai dispositivi downstream devono essere bloccati sui dispositivi di bordo del MAN.

Figura 1-46  Configurazione di un criterio di traffico per bloccare il traffico
Roadmap di configurazione
  1. Configurare un ACL avanzato per abbinare pacchetti di protocolli multicast come quelli di PIM e IGMP.

  2. Configurare un classificatore del traffico e specificare l'ACL nel classificatore del traffico.

  3. Configurare un comportamento del traffico e impostare la sua azione su deny.

  4. Configurare una politica di traffico e associare il classificatore del traffico al comportamento del traffico in questa politica.

  5. Applicare il criterio di traffico a tutte le interfacce di rete.

Procedura

  1. Configurare un ACL avanzato per abbinare pacchetti di protocolli multicast come quelli di PIM e IGMP.

    #
    system-view                                                //Inserire la vista di sistema.
    #
    acl number 3001                                           //Configurare un ACL.
     rule 10 permit 103 destination 224.0.0.13 0               
     rule 20 permit igmp destination 224.0.0.1 0               
     rule 30 permit ip source 10.89.8.0 0.0.0.255 
     rule 40 permit ip source 10.222.8.0 0.0.0.255 
    #
    #
    

  2. Configurare un classificatore del traffico.

    #
    traffic classifier 3001 operator or                     //Configurare un classificatore del traffico.
     if-match acl 3001
    #
    

  3. Configurare un comportamento del traffico.

    #
    traffic behavior 3001                                   //Configurare un comportamento del traffico.
     deny
    #
    

  4. Configurare una politica del traffico.

    #
    traffic policy LOOP_AVOID                             //Configurare una politica del traffico.
     share-mode
     statistics enable
     classifier 3001 behavior 3001
    #
    

  5. Applicare la politica del traffico.

    #
    interface Eth-Trunk1
     traffic-policy LOOP_AVOID outbound                  //Applicare la politica del traffico.
     trust upstream default
    #
    

  6. Verificare la configurazione.

    Eseguire il comando display interface [ interface-type [ interface-number ] ] per visualizzare le informazioni sul traffico dell'interfaccia specificata.

Esempio per la configurazione della classificazione del traffico complessa basata su IP

Questa sezione fornisce un esempio di come configurare la classificazione del traffico complessa basata su IP.

Prodotti e versioni applicabili

Questo esempio di configurazione si applica ai prodotti della serie NE40E/ME60 con V800R010C00 o versioni successive.

Requisiti di rete

Come mostrato in Figura 1-47, la classificazione MF è configurata suDevice C per implementare il controllo di accesso traDevice A e Device B. Inoltre, è possibile raccogliere statistiche sul traffico per verificare l'invio e la ricezione dei pacchetti.

NOTA:

Le interfacce 1 e 2 in questo esempio sono GE0/1/0 e GE0/2/0, rispettivamente.

Figura 1-47  Configurazione di un criterio di traffico basato sulla classificazione MF

Roadmap di configurazione

La roadmap di configurazione è seguente:

  1. Configurare una regola ACL.

  2. Configurare un classificatore del traffico.

  3. Configurare un comportamento del traffico.

  4. Configurare una politica del traffico.

  5. Applicare la politica del traffico.

Preparazione dei dati

Per completare la configurazione, sono necessari i seguenti dati:

  • Numero ACL

  • Nomi del classificatore del traffico, comportamento del traffico e politica del traffico e numero dell'interfaccia a cui viene applicata la politica del traffico

Procedura

  1. Configurare una regola ACL.

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceC
    [*HUAWEI] commit
    [~DeviceC] acl number 3333
    [*DeviceC-acl-adv-3333]rule 5 permit ip source 1.1.1.1 0 destination 2.2.2.2 0
    [*DeviceC-acl-adv-3333]rule 10 permit ip source 2.2.2.2 0 destination 1.1.1.1 0
    [*DeviceC-acl-adv-3333] commit
    [~DeviceC-acl-adv-3333] quit

  2. Configurare un classificatore del traffico.

    [~DeviceC] traffic classifier c1
    [*DeviceC-classifier-c1] if-match acl 3333
    [*DeviceC-classifier-c1] commit
    [~DeviceC-classifier-c1] quit

  3. Configurare un comportamento del traffico.

    [~DeviceC] traffic behavior b1
    [*DeviceC-behavior-b1] permit
    [*DeviceC-behavior-b1] commit
    [~DeviceC-behavior-b1] quit

  4. Configurare una politica del traffico.

    [~DeviceC] traffic policy p1
    [*DeviceC-trafficpolicy-p1] classifier c1 behavior b1
    [*DeviceC-trafficpolicy-p1] share-mode
    [*DeviceC-trafficpolicy-p1] statistic enable
    [*DeviceC-trafficpolicy-p1] commit
    [~DeviceC-trafficpolicy-p1] quit

  5. Applicare la politica del traffico.

    [~DeviceC] interface gigabitethernet 0/1/0
    [~DeviceC-GigabitEthernet0/1/0] traffic-policy p1 inbound
    [*DeviceC-GigabitEthernet0/1/0] traffic-policy p1 outbound
    [*DeviceC-GigabitEthernet0/1/0] commit
    [~DeviceC-GigabitEthernet0/1/0] quit

    [~DeviceC] interface gigabitethernet 0/2/0
    [~DeviceC-GigabitEthernet0/2/0] traffic-policy p1 inbound
    [*DeviceC-GigabitEthernet0/2/0] traffic-policy p1 outbound
    [*DeviceC-GigabitEthernet0/2/0] commit
    [~DeviceC-GigabitEthernet0/2/0] quit

  6. Verificare la configurazione.

    Dopo aver completato le configurazioni, eseguire il comando ping 2.2.2.2 su Device A to ping Device B, ed eseguire il comando display traffic policy statistics per visualizzare le statistiche sul traffico scambiato tra Device A eDevice B.

    [~DeviceC] display traffic policy statistics interface gigabitethernet 0/1/0 inbound
    Info: The statistics is shared because the policy is shared.
    Interface: GigabitEthernet0/1/0 
    Traffic policy inbound: p1
    Traffic policy applied at 2017-08-30 18:30:20 
    Statistics enabled at 2017-08-30 18:30:20
    Statistics last cleared: Never
    Rule number: 1 IPv4, 0 IPv6 
    Current status: OK!
    Item                             Packets                      Bytes
    -------------------------------------------------------------------
    Matched                                5                       500
      +--Passed                            4                       400
      +--Dropped                           1                       100
    
    Last 30 seconds rate
    Item                                 pps                        bps
    -------------------------------------------------------------------
    Matched                                5                       500
      +--Passed                            4                       400
      +--Dropped                           1                       100
    

File di configurazione
#
sysname DeviceC
#
acl number 3333
 rule 5 permit ip source 1.1.1.1 0 destination 2.2.2.2 0
 rule 10 permit ip source 2.2.2.2 0 destination 1.1.1.1 0
#
traffic classifier c1
 if-match acl 3333
#
traffic behavior b1
 permit
#        
traffic policy p1
 share-mode
 statistic enable
 classifier c1 behavior b1
#
interface GigabitEthernet0/1/0
 traffic-policy p1 inbound
 traffic-policy p1 outbound
#
interface GigabitEthernet0/2/0
 traffic-policy p1 inbound
 traffic-policy p1 outbound

Esempio per la configurazione della classificazione di campo molto basata su IP su un'interfaccia MPLS

Questa sezione fornisce un esempio per la configurazione della classificazione di campo molto (MF) basata su IP su un'interfaccia MPLS.

Prodotti e versioni applicabili

Questo esempio di configurazione si applica ai prodotti della serie NE40E/ME60 con V800R010C00 o versioni successive.

Requisiti di rete

Come mostrato in Figura 1-48, PE1, P e PE2 sono router su una rete backbone MPLS. CE1, CE2, CE3 e CE4 sono router di accesso sul bordo della rete backbone. Utilizzare PE1 come esempio. È possibile configurare la classificazione MF basata su IP sull'interfaccia di rete pubblica (interfaccia 3) di PE1 per implementare il controllo del traffico sul lato della rete pubblica e verificare l'invio e la ricezione di pacchetti attraverso le statistiche sul traffico.

NOTA:

Le interfacce da 1 a 3 in questo esempio sono GE0/1/0, GE 0/2/0, e GE0/3/0, rispettivamente.

Figura 1-48  Configurazione della classificazione MF basata su IP su un'interfaccia MPLS

Roadmap di configurazione

La roadmap di configurazione è seguente:

  1. Configurare le funzioni di base MPLS.

  2. Configurare la classificazione MF basata su IP per i pacchetti in uscita o in entrata nell'interfaccia di rete pubblica.

  3. Configurare una regola ACL.

  4. Configurare un classificatore del traffico.

  5. Configurare un comportamento del traffico.

  6. Configurare una politica del traffico.

  7. Applicare la politica del traffico.

Preparazione dei dati

Per completare la configurazione, sono necessari i seguenti dati:

  • Numero ACL

  • Nomi del classificatore del traffico, comportamento del traffico e politica del traffico e numero dell'interfaccia a cui viene applicata la politica del traffico

Procedura

  1. Configurare le funzioni di base MPLS.

    Per i dettagli su come configurare le funzioni di base di MPLS, consulta Example for Configuring BGP/MPLS IP VPN in HUAWEI NE20E-S Guida della configurazione - VPN – configurazione di BGP/MPLS IP VPN..

  2. Configurare la classificazione MF basata su IP per i pacchetti in uscita o in entrata nell'interfaccia di rete pubblica.

    <HUAWEI> system-view
    [~HUAWEI] sysname PE1
    [*HUAWEI] commit
    [~PE1] slot 1
    [~PE1-slot-1] traffic-policy match-ip-layer mpls-pop
    [*PE1-slot-1] traffic-policy match-ip-layer mpls-push
    [*PE1-slot-1] commit
    [~PE1-slot-1] quit

  3. Configurare una regola ACL.

    [~PE1] acl number 3333
    [*PE1-acl-adv-3333] rule 5 permit ip source 11.11.11.11 0 destination 33.33.33.33 0
    [*PE1-acl-adv-3333] rule 10 permit ip source 33.33.33.33 0 destination 11.11.11.11 0
    [*PE1-acl-adv-3333] commit
    [~PE1-acl-adv-3333] quit

  4. Configurare un classificatore del traffico.

    [~PE1] traffic classifier c1
    [*PE1-classifier-c1] if-match acl 3333
    [*PE1-classifier-c1] commit
    [~PE1-classifier-c1] quit

  5. Configurare un comportamento del traffico.

    [~PE1] traffic behavior b1
    [*PE1-behavior-b1] permit
    [*PE1-behavior-b1] commit
    [~PE1-behavior-b1] quit

  6. Configurare una politica del traffico.

    [~PE1] traffic policy p1
    [*PE1-trafficpolicy-p1] classifier c1 behavior b1
    [*PE1-trafficpolicy-p1] share-mode
    [*PE1-trafficpolicy-p1] statistic enable
    [*PE1-trafficpolicy-p1] commit
    [~PE1-trafficpolicy-p1] quit

  7. Applicare la politica del traffico.

    [~PE1] interface gigabitethernet 0/3/0
    [~PE1-GigabitEthernet0/3/0] traffic-policy p1 inbound
    [*PE1-GigabitEthernet0/3/0] traffic-policy p1 outbound
    [*PE1-GigabitEthernet0/3/0] commit
    [~PE1-GigabitEthernet0/3/0] quit

  8. Verificare la configurazione.

    Dopo aver completato le configurazioni, eseguire il comando ping 33.33.33.33 su CE1 per eseguire il ping su CE3 ed eseguire il comando display traffic policy statistics per visualizzare le statistiche sul traffico scambiato tra CE1 e CE3.

    [~PE1] display traffic policy statistics interface gigabitethernet 0/3/0 inbound
    Info: The statistics is shared because the policy is shared.
    Interface: GigabitEthernet0/3/0
    Traffic policy inbound: p1
    Traffic policy applied at 2017-08-30 18:30:20 
    Statistics enabled at 2017-08-30 18:30:20
    Statistics last cleared: Never
    Rule number: 1 IPv4, 0 IPv6 
    Current status: OK!
    Item                             Packets                      Bytes
    -------------------------------------------------------------------
    Matched                                5                       500
      +--Passed                            4                       400
      +--Dropped                           1                       100
    
    Last 30 seconds rate
    Item                                 pps                        bps
    -------------------------------------------------------------------
    Matched                                5                       500
      +--Passed                            4                       400
      +--Dropped                           1                       100
    

File di configurazione
#
sysname PE1
#
slot 1 
 traffic-policy match-ip-layer mpls-pop
 traffic-policy match-ip-layer mpls-push
#
acl number 3333
 rule 5 permit ip source 11.11.11.11 0 destination 33.33.33.33 0
 rule 5 permit ip source 33.33.33.33 0 destination 11.11.11.11 0
#
traffic classifier c1
 if-match acl 3333
#
traffic behavior b1
 permit
#        
traffic policy p1
 share-mode
 statistic enable
 classifier c1 behavior b1
#
interface GigabitEthernet0/3/0
 traffic-policy p1 inbound
 traffic-policy p1 outbound

Esempio per la configurazione del reindirizzamento sulle interfacce a doppia uscita

Questa sezione fornisce un esempio per configurare il reindirizzamento sulle interfacce a doppia uscita.

Prodotti e versioni applicabili

Questo esempio di configurazione si applica ai prodotti della serie NE40E/ME60 con V800R010C00 o versioni successive.

Requisiti di rete

Come mostrato in Figura 1-49, Device A si connette a l'intranet tramite l'interfaccia 1 e si connette alla rete pubblica tramite l'interfaccia 2 e l'interfaccia 3. Per impostazione predefinita, il traffico proveniente dalla intranet viene trasmesso alla rete pubblica tramite l'interfaccia 3. Per abilitare il traffico proveniente dal server da trasmettere alla rete pubblica tramite l'interfaccia 2 e altro traffico verso la rete pubblica attraverso l'interfaccia 3, configurare un criterio di traffico su Device A.

NOTA:

Le interfacce da 1 a 3 sono GE0/1/0, GE 0/2/0, e GE0/3/0, rispettivamente.

Figura 1-49  Configurazione del reindirizzamento sulle interfacce a doppia uscita
Roadmap di configurazione

La roadmap di configurazione è seguente:

  1. Configurare l'instradamento predefinito.

  2. Configurare una regola ACL.

  3. Configurare i classificatori del traffico.

  4. Configurare i comportamenti del traffico.

  5. Configurare una politica del traffico.

  6. Applicare la politica del traffico.

Preparazione dei dati

Per completare la configurazione, sono necessari i seguenti dati:

  • Numero ACL

  • Nomi del classificatore del traffico, comportamento del traffico e politica del traffico e numero dell'interfaccia a cui viene applicata la politica del traffico

Procedura

  1. Configurare l'instradamento predefinito in modo che il traffico intranet venga trasmesso alla rete pubblica tramite l'interfaccia 3 per impostazione predefinita e l'interfaccia 2 sia utilizzata come interfaccia di backup in uscita.

    <HUAWEI> system-view
    [~HUAWEI] ip route-static 0.0.0.0 0.0.0.0 10.1.99.1
    [*HUAWEI] ip route-static 0.0.0.0 0.0.0.0 10.1.99.5 pre 70
    [*HUAWEI] commit

  2. Configurare una regola ACL.

    # Configurare la regola 3001 per abbinare il traffico dal server ad altri dispositivi dell'intranet.

    [~HUAWEI]acl 3001
    [*HUAWEI-acl-adv-3001]rule permit ip source 10.1.40.0 0.0.0.255 destination 10.1.40.0 0.0.0.255
    [*HUAWEI-acl-adv-3001]rule permit ip source 10.1.40.0 0.0.0.255 destination 10.1.41.0 0.0.0.255 
    [*HUAWEI-acl-adv-3001]rule permit ip source 10.1.40.0 0.0.0.255 destination 10.1.42.0 0.0.0.255 
    [*HUAWEI-acl-adv-3001]commit
    [~HUAWEI-acl-adv-3001]quit

    # Configurare la regola 3002 in modo che corrisponda al traffico con l'indirizzo di origine che rappresenta l'indirizzo IP del server.

    [~HUAWEI] acl 3002
    [*HUAWEI-acl-adv-3002] rule permit ip source 10.1.40.0 0.0.0.255
    [*HUAWEI-acl-adv-3002] commit
    [~HUAWEI-acl-adv-3001]commit

  3. Configurare i classificatori del traffico.

    # Configurare un classificatore del traffico denominato c1.

    [~HUAWEI]traffic classifier c1
    [*HUAWEI-classifier-c1]if-match acl 3001
    [*HUAWEI-classifier-c1]commit
    [~HUAWEI-classifier-c1]quit

    # Configurare un classificatore del traffico denominato c2.

    [~HUAWEI]traffic classifier c2
    [*HUAWEI-classifier-c2]if-match acl 3002
    [*HUAWEI-classifier-c2]commit
    [~HUAWEI-classifier-c2]quit

  4. Configurare i comportamenti del traffico.

    # Configurare un comportamento del traffico chiamato b1.

    [~HUAWEI]traffic behavior b1
    [*HUAWEI-behavior-b1] permit
    [*HUAWEI-behavior-b1] commit
    [~HUAWEI-behavior-b1] quit

    # Configurare un comportamento del traffico b2.

    [~HUAWEI] traffic behavior b2
    [*HUAWEI-behavior-b2] redirect ip-nexthop 10.1.99.5
    [*HUAWEI-behavior-b2] commit
    [~HUAWEI-behavior-b2] quit

  5. Configurare una politica del traffico.

    [~HUAWEI] traffic policy p1
    [*HUAWEI-trafficpolicy-p1] classifier c1 behavior b1
    [*HUAWEI-trafficpolicy-p1] classifier c2 behavior b2
    [*HUAWEI-trafficpolicy-p1] commit
    [~HUAWEI-trafficpolicy-p1] quit

  6. Applicare la politica del traffico.

    [~HUAWEI] interface gigabitethernet 0/1/0
    [~HUAWEI-GigabitEthernet0/1/0] traffic-policy p1 inbound
    [*HUAWEI-GigabitEthernet0/1/0] commit
    [~HUAWEI-GigabitEthernet0/1/0] quit

  7. Verificare la configurazione.

    Dopo aver completato le configurazioni, eseguire il comando display traffic policy su Device A per visualizzare le configurazioni del traffico politica, classificatore del traffico e comportamento del traffico.

    [~HUAWEI] display traffic policy user-defined p1
      User Defined Traffic Policy Information:                                      
        Policy: p1                                                                  
          Total: 5120  Used: 3  Free: 5117                                          
          Description:                                                              
          Step: 1                                                                   
          Share-mode                                                                
          Classifier: c1 Precedence: 1                                              
            Behavior: b1                                                            
            -none-                                                                  
                                                                                    
          Classifier: c2 Precedence: 2                                              
            Behavior: b2                                                            
            Redirecting:                                                            
              redirect ip-nexthop 10.1.99.5                                         
                                                                                    
          Classifier: default-class Precedence: 65535                               
            Behavior: be                                                            
            -none-                              

File di configurazione
#
ip route-static 0.0.0.0 0.0.0.0 10.1.99.1     
ip route-static 0.0.0.0 0.0.0.0 10.1.99.5 pre 70  
#
acl 3001
 rule permit ip source 10.1.40.0 0.0.0.255 destination 10.1.40.0 0.0.0.255    
 rule permit ip source 10.1.40.0 0.0.0.255 destination 10.1.41.0 0.0.0.255    
 rule permit ip source 10.1.40.0 0.0.0.255 destination 10.1.42.0 0.0.0.255
acl 3002
 rule permit ip source 10.1.40.0 0.0.0.255                   
#
traffic classifier c1
 if-match acl 3001
traffic classifier c2
 if-match acl 3002
#
traffic behavior b1
 permit                     
traffic behavior b2
 redirect ip-nexthop 10.1.99.5   
#
traffic policy p1
 classifier c1 behavior b1      
 classifier c2 behavior b2            
#
interface gigabitethernet0/1/0
 traffic-policy p1 inbound
#
return

Esempio per la configurazione dell'elusione della congestione

Questa sezione fornisce un esempio di come configurare l'evitamento della congestione. Un dispositivo su cui è configurata la prevenzione della congestione controlla l'utilizzo delle risorse di rete e inizia a scartare i pacchetti quando determina che la congestione si sta intensificando.

Prodotti e versioni applicabili

Questo esempio di configurazione si applica ai prodotti della serie NE40E/ME60 con V800R010C00 o versioni successive.

Requisiti di rete

Come mostrato in Figura 1-50, il server invia dati mission-critical, il telefono invia dati vocali e PC1 e PC2 inviano dati non mission-critical alla rete attraverso Device A. In Device A, la velocità dell'interfaccia in entrata GE 0/1/0 è maggiore di quella dell'interfaccia in uscita GE 0/2/0. Pertanto, la congestione potrebbe verificarsi su GE 0/2/0 potrebbe intensificare.

In caso di congestione della rete, i dati di servizio dal server e dal telefono devono essere inviati preferenzialmente. Inoltre, il telefono richiede larghezza di banda 5 Mbit/s e il server richiede una larghezza di banda di 4 Mbit/s. Poiché PC1 e PC2 sono utenti VIP, la larghezza di banda deve essere garantita per i dati inviati da PC1 e PC2. Il ritardo deve essere il più basso possibile. Se la congestione si intensifica sulla rete, i pacchetti vengono eliminati in base alla priorità.

In questo scenario, WFQ e WRED devono essere configurati su Device A.

NOTA:

Le interfacce da 1 a 2 in questo esempio sono GE0/1/0, GE0/2/0.

Figura 1-50  Diagramma di rete per la configurazione dell'elusione della congestione

Roadmap di configurazione

La roadmap di configurazione è seguente:

  1. Segnare le priorità del servizio di diversi flussi sull'interfaccia in entrata GE0/1/0 diDevice A.
  2. Configurare un profilo WRED e impostare la soglia di caduta inferiore, la soglia di caduta superiore e la probabilità di caduta per i pacchetti.

  3. Sull'interfaccia in uscita GE 0/2/0 di Device A, configurare una politica di pianificazione diversa per le code di classe di ciascun livello di servizio e applicare un oggetto WRED configurato al criterio di pianificazione.

Preparazione dei dati

Per completare la configurazione, sono necessari i seguenti dati:

  • Numeri ACL, nomi del classificatore di traffico, nomi del comportamento del traffico, priorità del servizio contrassegnate nuovamente e nomi dei criteri del traffico
  • Nome profilo WRED, soglie di caduta inferiori e superiori, probabilità di caduta e colore del pacchetto in ogni coda

  • Interfacce e code di classe a cui vengono applicate le politiche di caduta di WRED

Procedura

  1. Configurare le regole ACL per i pacchetti da Server, Telefono, PC1 e PC2.

    <*DeviceA> system-view
    [~DeviceA] acl number 2001
    [*DeviceA-acl4-basic-2001] rule permit source 10.1.1.3 0.0.0.0
    [*DeviceA-acl4-basic-2001] commit
    [~DeviceA-acl4-basic-2001] quit
    [~DeviceA] acl number 2002
    [*DeviceA-acl4-basic-2002] rule permit source 10.1.1.2 0.0.0.0
    [*DeviceA-acl4-basic-2002] commit
    [~DeviceA-acl4-basic-2002] quit
    [~DeviceA] acl number 2003
    [*DeviceA-acl4-basic-2003] rule permit source 10.1.1.4 0.0.0.0
    [*DeviceA-acl4-basic-2003] commit
    [~DeviceA-acl4-basic-2003] quit
    [~DeviceA] acl number 2004
    [*DeviceA-acl4-basic-2004] rule permit source 10.1.1.5 0.0.0.0
    [*DeviceA-acl4-basic-2004] commit
    [~DeviceA-acl4-basic-2004] return

  2. In GE0/1/0 di Device A, configurare la classificazione del traffico complessa e contrassegnare la priorità del servizio di ogni flusso.

    <*DeviceA> system-view
    [~DeviceA] traffic classifier aa
    [*DeviceA-classifier-aa] if-match acl 2001
    [*DeviceA-classifier-aa] commit
    [~DeviceA-classifier-aa] quit
    [~DeviceA] traffic classifier bb
    [*DeviceA-classifier-bb] if-match acl 2002
    [*DeviceA-classifier-bb] commit
    [~DeviceA-classifier-bb] quit
    [~DeviceA] traffic classifier cc
    [*DeviceA-classifier-cc] if-match acl 2003
    [*DeviceA-classifier-cc] commit
    [~DeviceA-classifier-cc] quit
    [~DeviceA] traffic classifier dd
    [*DeviceA-classifier-dd] if-match acl 2004
    [*DeviceA-classifier-dd] commit
    [~DeviceA-classifier-dd] quit
    [~DeviceA] traffic behavior aa
    [*DeviceA-behavior-aa] remark ip-precedence 5
    [*DeviceA-behavior-aa] car cir 5000
    [*DeviceA-behavior-aa] commit
    [~DeviceA-behavior-aa] quit
    [~DeviceA] traffic behavior bb
    [*DeviceA-behavior-bb] remark ip-precedence 4
    [*DeviceA-behavior-bb] car cir 4000
    [*DeviceA-behavior-bb] commit
    [~DeviceA-behavior-bb] quit
    [~DeviceA] traffic behavior cc
    [*DeviceA-behavior-cc] remark ip-precedence 3
    [*DeviceA-behavior-cc] commit
    [~DeviceA-behavior-cc] quit
    [~DeviceA] traffic behavior dd
    [*DeviceA-behavior-dd] remark ip-precedence 2
    [*DeviceA-behavior-dd] commit
    [~DeviceA-behavior-dd] quit
    [~DeviceA] traffic policy ee
    [*DeviceA-trafficpolicy-ee] classifier aa behavior aa
    [*DeviceA-trafficpolicy-ee] classifier bb behavior bb
    [*DeviceA-trafficpolicy-ee] classifier cc behavior cc
    [*DeviceA-trafficpolicy-ee] classifier dd behavior dd
    [*DeviceA-trafficpolicy-ee] commit
    [~DeviceA-trafficpolicy-ee] quit
    [~DeviceA] interface gigabiethernet0/1/0
    [~DeviceA-GigabitEthernet0/1/0] undo shutdown
    [*DeviceA-GigabitEthernet0/1/0] traffic-policy ee inbound
    [*DeviceA-GigabitEthernet0/1/0] commit
    [~DeviceA-GigabitEthernet0/1/0] return
    NOTA:
    Le priorità delle code con classi di servizio specifiche sono calcolate in base agli algoritmi di pianificazione.
    • Se la pianificazione PQ è configurata per tutte le code con le otto classi di servizio, le priorità delle code vengono posizionate in ordine decrescente come segue: CS7 > CS6 > EF > AF4 > AF3 > AF2 > AF1 > BE.
    • Se la pianificazione PQ è configurata per la coda BE (non applicata nella maggior parte dei casi) e la pianificazione WFQ è configurata per le code con le altre classi di servizio, la priorità della coda BE è superiore a quella delle altre code.
    • Se la pianificazione WFQ è configurata per tutte le code con le otto classi di servizio, tutte le code hanno la stessa priorità.

  3. Configurare un profilo WRED su Device A.

    <DeviceA> system-view
    [~DeviceA] port-wred pw
    [*DeviceA-port-wred-pw] color green low-limit 70 high-limit 100 discard-percentage 100
    [*DeviceA-port-wred-pw] color yellow low-limit 60 high-limit 90 discard-percentage 100
    [*DeviceA-port-wred-pw] color red low-limit 50 high-limit 80 discard-percentage 100
    [*DeviceA-port-wred-pw] commit
    [~DeviceA-port-wred-pw] quit

    Dopo aver completato la configurazione precedente, eseguire il comando display port-wred configuration verbose per verificare i parametri del profilo WRED.

    <DeviceA> display port-wred configuration verbose
    Port wred name : pw
    ---------------------------------------------------
    Color    Low-limit    High-limit    Discard-percent
    ---------------------------------------------------
    green    70           100           100
    yellow   60           90            100
    red      50           80            100
    Queue Depth : 8000
    Reference relationships : NULL 

  4. Su GE0/2/0 di Device A, configurare le code delle classi e applicare l'oggetto WRED configurato pw alle code delle classi.

    [~DeviceA] interface gigabitethernet0/2/0
    [~DeviceA-GigabitEthernet0/2/0] undo shutdown
    [*DeviceA-GigabitEthernet0/2/0] port-queue ef pq port-wred pw outbound
    [*DeviceA-GigabitEthernet0/2/0] port-queue af4 wfq weight 15 shaping 100 port-wred pw outbound
    [*DeviceA-GigabitEthernet0/2/0] port-queue af3 wfq weight 10 shaping 50 port-wred pw outbound
    [*DeviceA-GigabitEthernet0/2/0] port-queue af2 wfq weight 10 shaping 50 port-wred pw outbound
    [*DeviceA-GigabitEthernet0/2/0] commit
    [~DeviceA-GigabitEthernet0/2/0] return

    Dopo aver completato la configurazione precedente, eseguire il comando display port-queue configuration interface per visualizzare le configurazioni dettagliate delle code delle classi.

    <DeviceA> display port-queue configuration interface gigabitethernet 0/2/0 outbound
    GigabitEthernet0/2/0                                                         
     be current configuration:                                                      
       Arithmetic: wfq                                                              
       weight: 10                                                                   
       tm weight: 3                                                                 
       fact weight: 10                                                              
       shaping(mbps): NA                                                            
       port-wred name: NA                                                           
     af1 current configuration:                                                     
       Arithmetic: wfq                                                              
       weight: 10                                                                   
       tm weight: 3                                                                 
       fact weight: 10                                                              
       shaping(mbps): NA                                                            
       port-wred name: NA                                                           
     af2 current configuration:                                                     
       Arithmetic: wfq                                                              
       weight: 10                                                                   
       tm weight: 3                                                                 
       fact weight: 10                                                              
       shaping(mbps): 50                                                            
       port-wred name: pw                                                           
     af3 current configuration:                                                     
       Arithmetic: wfq                                                              
       weight: 10                                                                   
       tm weight: 3                                                                 
       fact weight: 10                                                              
       shaping(mbps): 50                                                            
       port-wred name: pw                                                           
     af4 current configuration:                                                     
       Arithmetic: wfq                                                              
       weight: 15                                                                   
       tm weight: 3                                                                 
       fact weight: 10                                                              
       shaping(mbps): 100                                                           
       port-wred name: pw                                                           
     ef current configuration:                                                      
       Arithmetic: pq                                                               
       weight: NA                                                                   
       tm weight: NA                                                                
       fact weight: NA                                                              
       shaping(mbps): NA                                                            
       port-wred name: pw                                                           
     cs6 current configuration:                                                     
       Arithmetic: pq                                                               
       weight: NA                                                                   
       tm weight: NA                                                                
       fact weight: NA                                                              
       shaping(mbps): NA                                                            
       port-wred name: NA                                                           
     cs7 current configuration:                                                     
       Arithmetic: pq                                                               
       weight: NA                                                                   
       tm weight: NA                                                                
       fact weight: NA                                                              
       shaping(mbps): NA                                                            
       port-wred name: NA     

  5. Verificare la configurazione.

    Quando la rete ha traffico display port-queue statistics [ slot slot-id | interface { interface-type interface-number | interface-name } ] [ cos-value ] outbound command on Device A. L'output del comando mostra che i volumi di traffico di vari livelli di servizio aumentano rapidamente. Con il rapido aumento dei volumi di traffico, anche il volume del traffico di caduta aumenta rapidamente in base ai parametri di caduta WRED configurati.

File di configurazione
  • File di configurazione di Device A

    #
     sysname DeviceA
    #
    acl number 2001
     rule permit source 10.1.1.3 0
    #
    acl number 2002
     rule permit source 10.1.1.2 0
    #
    acl number 2003
     rule permit source 10.1.1.4 0
    #
    acl number 2004
     rule permit source 10.1.1.5 0 
    #
    traffic classifier cc operator or
     if-match acl 2003
    traffic classifier dd operator or
     if-match acl 2004
    traffic classifier aa operator or
     if-match acl 2001
    traffic classifier bb operator or
     if-match acl 2002
    #
    traffic behavior cc
     remark ip-precedence 3
    traffic behavior dd
     remark ip-precedence 2
    traffic behavior aa
     car cir 5000
     remark ip-precedence 5
    traffic behavior bb
     car cir 4000
     remark ip-precedence 4
    #
    traffic policy ee
     classifier aa behavior aa
     classifier bb behavior bb
     classifier cc behavior cc
     classifier dd behavior dd
    #
    port-wred pw
     color green low-limit 70 high-limit 100 discard-percentage 100
     color yellow low-limit 60 high-limit 90 discard-percentage 100
     color red low-limit 50 high-limit 80 discard-percentage 100
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
     traffic-policy ee inbound
    #
    interface GigabitEthernet0/2/0
     undo shutdown
     ip address 10.10.1.1 255.255.255.0
     port-queue af2 wfq weight 10 shaping 50 port-wred pw outbound
     port-queue af3 wfq weight 10 shaping 50 port-wred pw outbound
     port-queue af4 wfq weight 15 shaping 100 port-wred pw outbound
     port-queue ef pq port-wred pw outbound
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.10.1.0 0.0.0.255
    #
    return
Download
Updated: 2019-05-16

N. documento: EDOC1100082601

Visualizzazioni:880

Download: 2

Average rating:
This Document Applies to these Products
Documenti correlati
Related Version
Share
Precedente Avanti