Nessuna risorsa pertinente trovata nella lingua selezionata.

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Raccolta di casi di configurazione dello scenario tipico del router aziendale NE-ME60 2.0

Rate and give feedback:
Huawei utilizza la traduzione automatica insieme alla revisione umana per tradurre questo documento in diverse lingue, per facilitare la comprensione del contenuto di questo documento. Nota: la traduzione automatica, anche la più avanzata, non può corrispondere alla qualità dei trasduttori professionisti. Huawei non accetta alcuna responsabilità per l'accuratezza della traduzione e raccomanda di fare riferimento al documento inglese (per il quale è stato fornito un collegamento).
GRE

GRE

Esempio per la configurazione di un'instradamento statico per GRE

Questa sezione fornisce un esempio per la configurazione di un'instradamento statico GRE. In questo schema di rete, il traffico tra gli utenti viene trasmesso attraverso un tunnel GRE; Un'instradamento statico è configurato tra il dispositivo e il client collegato.

Prodotti e versioni applicabili

Questo esempio di configurazione si applica ai prodotti della serie NE20E-S con V800R010C00 o versioni successive.

Requisiti di rete

In Figura 1-41, Device A, Device B, e Device. C appartengono al rete backbone VPN e OSPF si corre tra di loro.

È necessario che venga stabilito statico tra Device A and Device C Per soddisfare tale requisito, configurare un tunnel GRE traDevice A e Device C e specificare l'interfaccia tunnel come l'interfaccia in uscita di un'instradamento statico in modo che PC1 e PC2 possano comunicare tra loro.

PC1 accetta Device A come gateway predefinito e PC2 accetta Device C come gateway predefinito.

Figura 1-41  Diagramma di rete della configurazione di un'instradamento statico per GRE
NOTA:

Le interfacce da 1 a 3 in questo esempio sono GE0/1/0, GE0/2/0, Tunnel1, rispettivamente.



Precauzioni

Un tunnel GRE distribuito viene utilizzato come esempio

La differenza tra tunnel GRE distribuito e il tunnel GRE integrato si differenziano che il primo utilizza un'interfaccia monodimensionale (denominata solo dal numero di interfaccia) come interfaccia tunnel mentre il secondo utilizza un'interfaccia tridimensionale (denominata dall'ID slot, ID scheda secondaria, e numero di interfaccia) come l'interfaccia del tunnel.

Per un tunnel GRE tunnel, il commando target-board slot-number [ backup slave-slot-number ] deve essere eseguito prima che l'interfaccia tunnel sia collegata a GRE usando binding tunnel gre il commando. Al termine della configurazione, il tunnel GRE invia i pacchetti ricevuti dall'interfaccia del tunnel di origine alle corrispondenti schede di servizio GRE per l'elaborazione.

Roadmap di configurazione

La roadmap di configurazione è seguente:

  1. Configurare un protocollo di routing dinamico su routers.

  2. Creare un'interfaccia seriale sincrona su Device A eDevice B.

  3. Specificare l'indirizzo di origine dell'interfaccia tunnel come l'indirizzo IP dell'interfaccia che invia il pacchetto.

  4. Specificare l'indirizzo di destinazione dell'interfaccia tunnel come l'indirizzo IP dell'interfaccia che riceve il pacchetto.

  5. Assegnare gli indirizzi di rete alle interfacce tunnel per consentire al tunnel di supportare il protocollo di routing dinamico.

  6. Configurare l'instradamento statico tra Device A e il suo PC connesso, e l'instradamento statico traDevice C e il suo PC connesso per far passare il traffico tra PC1 e PC2 attraverso il tunnel GRE.

  7. Configurare l'uscita dell'instradamento statico come interfaccia del tunnel locale.

Preparazione dei dati

Per completare la configurazione, sono necessari i seguenti dati:

  • Dati per l'esecuzione di OSPF

  • Indirizzo sorgente e indirizzo di destinazione del tunnel GRE e indirizzi IP delle interfacce tunnel

Procedura

  1. Configurare un indirizzo IP per ogni interfaccia.

    Assegnare un indirizzo IP a ciascuna interfaccia come mostrato in Figura 1-41. La configurazione specifica non è menzionata qui.

  2. Configurare IGP per la rete backbone VPN.

    # Configurare Device A.

    [~DeviceA] ospf 1
    [*DeviceA-ospf-1] area 0
    [*DeviceA-ospf-1-area-0.0.0.0] network 172.20.1.0 0.0.0.255
    [*DeviceA-ospf-1-area-0.0.0.0] quit
    [*DeviceA-ospf-1] quit
    [*DeviceA] commit

    Configurare DeviceB.

    [~DeviceB] ospf 1
    [*DeviceB-ospf-1] area 0
    [*DeviceB-ospf-1-area-0.0.0.0] network 172.20.1.0 0.0.0.255
    [*DeviceB-ospf-1-area-0.0.0.0] network 172.21.1.0 0.0.0.255
    [*DeviceB-ospf-1-area-0.0.0.0] quit
    [*DeviceB-ospf-1] quit
    [*DeviceB] commit

    Configurare Device C.

    [~DeviceC] ospf 1
    [*DeviceC-ospf-1] area 0
    [*DeviceC-ospf-1-area-0.0.0.0] network 172.21.1.0 0.0.0.255
    [*DeviceC-ospf-1-area-0.0.0.0] quit
    [*DeviceC-ospf-1] quit
    [*DeviceC] commit

    Dopo la configurazione, eseguire il comando display ip routing-table su Device A eDevice C. L'output del comando mostra che entrambi apprendono l'instradamento OSPF sul segmento di rete dell'interfaccia remota.

    Prendere Device A come esempio:

    [~DeviceA] display ip routing-table
    Route Flags: R - relay, D - download
    to fib, T - to vpn-instance, B - black hole route
    ------------------------------------------------------------------------------
    Routing Table : _public_
             Destinations : 11       Routes : 11
    
    Destination/Mask    Proto   Pre  Cost        Flags NextHop         Interface
    
           10.1.1.0/24  Direct  0    0             D  10.1.1.2        GigabitEthernet0/2/0
           10.1.1.2/32  Direct  0    0             D  127.0.0.1       GigabitEthernet0/2/0
         10.1.1.255/32  Direct  0    0             D  127.0.0.1       GigabitEthernet0/2/0
         172.20.1.0/24  Direct  0    0             D  172.20.1.1      GigabitEthernet0/1/0
         172.20.1.1/32  Direct  0    0             D  127.0.0.1       GigabitEthernet0/1/0
       172.20.1.255/32  Direct  0    0             D  127.0.0.1       GigabitEthernet0/1/0
         172.21.1.0/24  OSPF    10   2             D  172.20.1.2      GigabitEthernet0/1/0
          127.0.0.0/8   Direct  0    0             D  127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0             D  127.0.0.1       InLoopBack0
    127.255.255.255/32  Direct  0    0             D  127.0.0.1       InLoopBack0
    255.255.255.255/32  Direct  0    0             D  127.0.0.1       InLoopBack0

  3. Configurare l'interfaccia del tunnel.

    # Configurare Device A.

    [~DeviceA] interface GigabitEthernet 0/1/0
    [~DeviceA-GigabitEthernet0/1/0] binding tunnel gre
    [*DeviceA-GigabitEthernet0/1/0] commit
    [~DeviceA-GigabitEthernet0/1/0] quit
    [~DeviceA] interface tunnel 1
    [*DeviceA-Tunnel1] tunnel-protocol gre
    [*DeviceA-Tunnel1] ip address 172.22.1.1 255.255.255.0
    [*DeviceA-Tunnel1] source 172.20.1.1
    [*DeviceA-Tunnel1] destination 172.21.1.2
    [*DeviceA-Tunnel1] quit
    [*DeviceA] commit

    Configurare Device C.

    [~DeviceC] interface GigabitEthernet 0/1/0
    [~DeviceC-GigabitEthernet0/1/0] binding tunnel gre
    [*DeviceC-GigabitEthernet0/1/0] commit
    [~DeviceC-GigabitEthernet0/1/0] quit
    [~DeviceC] interface tunnel 1
    [*DeviceC-Tunnel1] tunnel-protocol gre
    [*DeviceC-Tunnel1] ip address 172.22.1.2 255.255.255.0
    [*DeviceC-Tunnel1] source 172.21.1.2
    [*DeviceC-Tunnel1] destination 172.20.1.1
    [*DeviceC-Tunnel1] quit
    [*DeviceC] commit

    Dopo la configurazione, lo stato delle interfacce tunnel diventa Up, e le interfacce tunnel possono eseguire il ping tra loro.

    # Prendere Device A come esempio:

    [~DeviceA] ping -a 172.22.1.1 172.22.1.2
      PING 172.22.1.2: 56  data bytes, press CTRL_C to break
        Reply from 172.22.1.2: bytes=56 Sequence=1 ttl=255 time=24 ms
        Reply from 172.22.1.2: bytes=56 Sequence=2 ttl=255 time=33 ms
        Reply from 172.22.1.2: bytes=56 Sequence=3 ttl=255 time=48 ms
        Reply from 172.22.1.2: bytes=56 Sequence=4 ttl=255 time=33 ms
        Reply from 172.22.1.2: bytes=56 Sequence=5 ttl=255 time=36 ms
      --- 172.22.1.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 24/34/48 ms

  4. Configurare gli instradamenti statici.

    # Configurare Device A.

    [~DeviceA] ip route-static 10.2.1.0 255.255.255.0 tunnel1
    [*DeviceA] commit

    # Configurare DeviceC.

    [~DeviceC] ip route-static 10.1.1.0 255.255.255.0 tunnel1
    [*DeviceC] commit

  5. Verificare la configurazione.

    Dopo la configurazione, eseguire il comando display ip routing-table su Device A eDevice C L'output del comando mostra l'instradamento statico verso il segmento di rete dell'utente remoto attraverso l'interfaccia tunnel.

    Prendere Device A come esempio:

    [~DeviceA] display ip routing-table
    Route Flags: R - relay, D - download
    to fib, T - to vpn-instance, B - black hole route
    ------------------------------------------------------------------------------
    Routing Table : _public_
             Destinations : 15       Routes : 15
    
    Destination/Mask    Proto   Pre  Cost        Flags NextHop         Interface
    
           10.1.1.0/24  Direct  0    0             D  10.1.1.2        GigabitEthernet0/2/0
           10.1.1.2/32  Direct  0    0             D  127.0.0.1       GigabitEthernet0/2/0
         10.1.1.255/32  Direct  0    0             D  127.0.0.1       GigabitEthernet0/2/0
        10.2.1.0/24  Static  60   0           D  172.22.1.1       Tunnel1
         172.20.1.0/24  Direct  0    0             D  172.20.1.1      GigabitEthernet0/1/0
         172.20.1.1/32  Direct  0    0             D  127.0.0.1       GigabitEthernet0/1/0
       172.20.1.255/32  Direct  0    0             D  127.0.0.1       GigabitEthernet0/1/0
         172.21.1.0/24  OSPF    10   2             D  172.20.1.2      GigabitEthernet0/1/0
         172.22.1.0/24  Direct  0    0             D  172.22.1.1      Tunnel1
         172.22.1.1/32  Direct  0    0             D  127.0.0.1       Tunnel1
       172.22.1.255/32  Direct  0    0             D  127.0.0.1       Tunnel1
          127.0.0.0/8   Direct  0    0             D  127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0             D  127.0.0.1       InLoopBack0
    127.255.255.255/32  Direct  0    0             D  127.0.0.1       InLoopBack0
    255.255.255.255/32  Direct  0    0             D  127.0.0.1       InLoopBack0

File di configurazione
  • Device A file di configurazione

    #
    sysname DeviceA
    #
    interface GigabitEthernet 0/1/0
     undo shutdown
     ip address 172.20.1.1 255.255.255.0
     binding tunnel gre
    #
    interface GigabitEthernet 0/2/0
     undo shutdown
     ip address 10.1.1.2 255.255.255.0
    #
    interface Tunnel1
     ip address 172.22.1.1 255.255.255.0
     tunnel-protocol gre
     source 172.20.1.1
     destination 172.21.1.2
    #
    ospf 1
     area 0.0.0.0
      network 172.20.1.0 0.0.0.255
    #
    ip route-static 10.2.1.0 255.255.255.0 Tunnel1
    #
    return
  • Device B file di configurazione

    #
    sysname DeviceB
    #
    interface GigabitEthernet 0/1/0
     undo shutdown
     ip address 172.20.1.2 255.255.255.0
    #
    interface GigabitEthernet 0/2/0
     undo shutdown
     ip address 172.21.1.1 255.255.255.0
    #
    ospf 1
     area 0.0.0.0
      network 172.20.1.0 0.0.0.255
      network 172.21.1.0 0.0.0.255
    #
    return
  • Device file di configurazione

    #
    sysname DeviceC
    #
    interface GigabitEthernet 0/1/0
     undo shutdown
     ip address 172.21.1.2 255.255.255.0
     binding tunnel gre
    #
    interface GigabitEthernet 0/2/0
     undo shutdown
     ip address 10.2.1.2 255.255.255.0
    #
    interface Tunnel1
     ip address 172.22.1.2 255.255.255.0
     tunnel-protocol gre
     source 172.21.1.2
     destination 172.20.1.1
    #
    ospf 1
     area 0.0.0.0
     network 172.21.1.0 0.0.0.255
    #
    ip route-static 10.1.1.0 255.255.255.0 Tunnel1
    #
    return

Esempio per la configurazione di un protocollo di routing dinamico per GRE

Questa sezione fornisce un esempio per la configurazione di un'instradamento dinamico per GRE. In questo schema di rete, il traffico tra gli utenti viene trasmesso attraverso un tunnel GRE; Un'instradamento dinamico è configurato tra il dispositivo e il suo utente connesso.

Prodotti e versioni applicabili

Questo esempio di configurazione si applica ai prodotti della serie NE20E-S con V800R010C00 o versioni successive.

Requisiti di rete

In Figura 1-42, Device A, Device B, e Device C appartengono al rete backbone VPN e OSPF si corre tra di loro.

GRE viene utilizzato tra Device A e Device C per l'interazione tra PC1 e PC2.

OSPF è abilitato sull'interfaccia del tunnel. Il processo OSPF 1 viene utilizzato per la rete backbone VPN e il processo OSPF 2 viene utilizzato per l'accesso utente.

PC1 accetta Device A come gateway predefinito e PC2 accetta Device C as its default gateway.

Figura 1-42  Diagramma di rete della configurazione di un protocollo di routing dinamico per GRE
NOTA:

Le interface1 e 3 in questo esempio sono GE0/1/0, GE0/2/0, e Tunnel 1, rispettivamente



Precauzioni

Un tunnel GRE distribuito viene utilizzato come esempio

La differenza tra tunnel GRE distribuito e il tunnel GRE integrato si differenziano che il primo utilizza un'interfaccia monodimensionale (denominata solo dal numero di interfaccia) come interfaccia tunnel mentre il secondo utilizza un'interfaccia tridimensionale (denominata dall'ID slot, ID scheda secondaria, e numero di interfaccia) come l'interfaccia del tunnel.

Per un tunnel GRE tunnel, il commando target-board slot-number [ backup slave-slot-number ] deve essere eseguito prima che l'interfaccia tunnel sia collegata a GRE usando binding tunnel gre il commando. Al termine della configurazione, il tunnel GRE invia i pacchetti ricevuti dall'interfaccia del tunnel di origine alle corrispondenti schede di servizio GRE per l'elaborazione.

Roadmap di configurazione

La roadmap di configurazione è seguente:

  1. Configurare IGP su ogni router nella rete backbone per realizzare l'interazione tra questi dispositivi. Qui viene utilizzato il processo OSPF 1.

  2. Creare il tunnel GRE tra routers che sono connessi a PC. Quindirouters possono comunicare attraverso il tunnel GRE.

  3. Configurare il protocollo di routing dinamico sui segmenti di rete attraverso i quali i PC accedono alla rete backbone. Qui viene utilizzato il processo OSPF 2.

Preparazione dei dati

Per completare la configurazione, sono necessari i seguenti dati:

  • Indirizzo di origine e indirizzo di destinazione del tunnel GRE

  • Indirizzi IP delle interfacce su entrambe le estremità del tunnel GRE

Procedura

  1. Configurare gli indirizzi IP per le interfacce.

    Per i dettagli sulla configurazione, vedere "File di configurazione" in questa sezione.

  2. Configurare IGP per la rete backbone VPN.

    Le procedure di configurazione specifiche sono le stesse di Esempio per la configurazione di un'instradamento statico per GRE non sono menzionati qui.

  3. Configurazione delle inteh rfacce tunnel

    Le procedure di configurazione specifiche sono le stesse di Esempio per la configurazione di un'instradamento statico per GRE e non sono menzionati qui.

  4. Configurare OSPF sulle interfacce tunnel.

    # Configurare Device A.

    [~DeviceA] ospf 2
    [*DeviceA-ospf-2] area 0
    [*DeviceA-ospf-2-area-0.0.0.0] network 172.18.1.0 0.0.0.255
    [*DeviceA-ospf-2-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [*DeviceA-ospf-2-area-0.0.0.0] quit
    [*DeviceA-ospf-2] quit
    [*DeviceA] commit

    Configurare Device C.

    [~DeviceC] ospf 2
    [*DeviceC-ospf-2] area 0
    [*DeviceC-ospf-2-area-0.0.0.0] network 172.18.1.0 0.0.0.255
    [*DeviceC-ospf-2-area-0.0.0.0] network 10.2.1.0 0.0.0.255
    [*DeviceC-ospf-2-area-0.0.0.0] quit
    [*DeviceC-ospf-2] quit
    [*DeviceC] commit

  5. Verificare la configurazione.

    Dopo la configurazione, eseguire il comando display ip routing-table su Device A eDevice C. L'output del comando mostra l'instradamento OSPF al segmento di rete dell'utente remoto attraverso l'interfaccia tunnel. Inoltre, il hop successivo all'indirizzo fisico di destinazione (172.17.1.0/24) del tunnel non è l'interfaccia del tunnel.

    Prendere Device A come esempio:

    [~DeviceA] display ip routing-table
    Route Flags: R - relay, D - download
    to fib, T - to vpn-instance, B - black hole route
    ------------------------------------------------------------------------------
    Routing Table : _public_
             Destinations : 15       Routes : 15
    
    Destination/Mask    Proto   Pre  Cost        Flags NextHop         Interface
    
            1.1.1.1/32  Direct  0    0             D  127.0.0.1       InLoopBack0
            2.2.2.2/24  OSPF    10   2             D  172.16.1.2      Vlanif10
           10.1.1.0/24  Direct  0    0             D  10.1.1.2        Vlanif20
           10.1.1.2/32  Direct  0    0             D  127.0.0.1       Vlanif20
         10.1.1.255/32  Direct  0    0             D  127.0.0.1       Vlanif20
           10.2.1.0/24  OSPF    10  2              D  172.18.1.2      Tunnel1
         172.16.1.0/24  Direct  0    0             D  172.16.1.1      Vlanif10
         172.16.1.1/32  Direct  0    0             D  127.0.0.1       Vlanif10
       172.16.1.255/32  Direct  0    0             D  127.0.0.1       Vlanif10
         172.17.1.0/24  OSPF    10  2              D  172.16.1.2      Vlanif10
         172.18.1.0/24  Direct  0    0             D  172.18.1.1      Tunnel1
         172.18.1.1/32  Direct  0    0             D  127.0.0.1       Tunnel1
       172.18.1.255/32  Direct  0    0             D  127.0.0.1       Tunnel1
          127.0.0.0/8   Direct  0    0             D  127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0             D  127.0.0.1       InLoopBack0
    127.255.255.255/32  Direct  0    0             D  127.0.0.1       InLoopBack0
    255.255.255.255/32  Direct  0    0             D  127.0.0.1       InLoopBack0

File di configurazione
  • File di configurazione di Device A

    #
    sysname DeviceA
    #
    vlan batch 10 20
    #
    interface Vlanif10
     ip address 172.16.1.1 255.255.255.0
    #
    interface Vlanif20
     ip address 10.1.1.2 255.255.255.0
    #
    interface GigabitEthernet0/1/0
     portswitch
     undo shutdown
     port default vlan 10
    #
    interface GigabitEthernet0/2/0
     portswitch
     undo shutdown
     port default vlan 20
    #
    interface LoopBack1
     ip address 1.1.1.1 255.255.255.255
     binding tunnel gre
    #
    interface Tunnel1
     ip address 172.18.1.1 255.255.255.0
     tunnel-protocol gre
     source 1.1.1.1
     destination 2.2.2.2
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.1 0.0.0.0
      network 172.16.1.0 0.0.0.255
    #
    ospf 2
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 172.18.1.0 0.0.0.255
    #
    return
  • File di configurazione di Device B

    #
    sysname DeviceB
    #
    vlan batch 10 20
    #
    interface Vlanif10
     ip address 172.16.1.2 255.255.255.0
    #
    interface Vlanif20
     ip address 172.17.1.1 255.255.255.0
    #
    interface GigabitEthernet0/1/0
     portswitch
     undo shutdown
     port default vlan 10
    #
    interface GigabitEthernet0/2/0
     portswitch
     undo shutdown
     port default vlan 20
    #
    ospf 1
     area 0.0.0.0
      network 172.16.1.0 0.0.0.255
      network 172.17.1.0 0.0.0.255
    #
    return
  • File di configurazione di Device C

    #
    sysname DeviceC
    #
    vlan batch 10 20
    #
    interface Vlanif10
     ip address 10.2.1.2 255.255.255.0
    #
    interface Vlanif20
     ip address 172.17.1.2 255.255.255.0
    #
    interface GigabitEthernet0/1/0
     portswitch
     undo shutdown
     port default vlan 20
    #
    interface GigabitEthernet0/2/0
     portswitch
     undo shutdown
     port default vlan 10
    #
    interface LoopBack1
     ip address 2.2.2.2 255.255.255.255
     binding tunnel gre
    #
    interface Tunnel1
     ip address 172.18.1.2 255.255.255.0
     tunnel-protocol gre
     source 2.2.2.2
     destination 1.1.1.1
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.2 0.0.0.0
      network 172.17.1.0 0.0.0.255
    #
    ospf 2
     area 0.0.0.0
      network 10.2.1.0 0.0.0.255
      network 172.18.1.0 0.0.0.255
    #
    return
Download
Updated: 2019-05-16

N. documento: EDOC1100082601

Visualizzazioni:865

Download: 2

Average rating:
This Document Applies to these Products
Documenti correlati
Related Version
Share
Precedente Avanti