Nessuna risorsa pertinente trovata nella lingua selezionata.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Raccolta di casi di configurazione dello scenario tipico del router aziendale NE-ME60 2.0

Rate and give feedback:
Huawei utilizza la traduzione automatica insieme alla revisione umana per tradurre questo documento in diverse lingue, per facilitare la comprensione del contenuto di questo documento. Nota: la traduzione automatica, anche la più avanzata, non può corrispondere alla qualità dei trasduttori professionisti. Huawei non accetta alcuna responsabilità per l'accuratezza della traduzione e raccomanda di fare riferimento al documento inglese (per il quale è stato fornito un collegamento).
Esempio di configurazione delle interfacce RS-232 per i servizi trasparenti in modalità P2MP

Esempio di configurazione delle interfacce RS-232 per i servizi trasparenti in modalità P2MP

Per implementare il protocollo P2MP, un gruppo SCADA può associare un'interfaccia seriale RS-232 con più interfacce seriali virtuali. L'interfaccia seriale RS-232 si connette a un centro di controllo locale e ciascuna interfaccia seriale virtuale si collega a una RTU attraverso PW. In un gruppo SCADA, i dati dell'interfaccia seriale RS-232 possono essere trasmessi a più interfacce seriali virtuali e i dati delle interfacce seriali virtuali possono essere filtrati e convertiti nell'interfaccia seriale RS-232.

Prodotti e versioni applicabili

Questa configurazione si applica ai prodotti della serie NE05E e 08E con V300R003C10 o versioni successive.

Requisiti di rete

In Figura 1-1, viene stabilito PW tra ciascuna RTU e il centro di controllo per trasmettere in modo trasparente i servizi. I PE non analizzano i dati di servizio. Quando il centro di controllo trasmette le sue informazioni alle RTU, solo una RTU può rispondere al centro di controllo in una volta sola sulla sua PW. Altri PW rimangono inattivi.

Figura 1-1  Configurare TDMoPSN
NOTA:

In questo esempio, l'interfaccia 1, interface2, interface3, interfacce4, interface5, interface6, interface7, interface8 e interface9 si riferiscono a Serial0/2/1, Serial0/2/2, Serial0/2/3, GE0/1/4, GE0/1/5, GE0/1/6, GE0/1/7, Serial0/2/4, e Serial0/2/5, rispettivamente.



Dispositivo

Interfaccia

Indirizzo IP

PE1

GE0/1/4

Loopback0

10.1.1.1/24

192.168.1.1/32

P

GE0/1/5

GE0/1/6

Loopback0

10.1.1.2/24

10.2.1.1/24

192.168.4.4/32

PE2

GE0/1/7

Loopback0

10.2.1.2/24

192.168.2.2/32

Roadmap di configurazione

La roadmap di configurazione è seguente:

  1. Attivare un IGP sulla rete backbone per i dispositivi sulla rete backbone da comunicare.

  2. Configurare le funzioni di base MPLS sulla rete backbone e MPLS L2VPN su PE. Quindi, stabilire un rapporto di peer MPLS LDP remoto tra PE alle due estremità di PW da creare.

  3. Configurare gli attributi delle interfacce RS-232.

  4. Configurare TDM come protocollo di incapsulamento delle interfacce seriali RS-232.

  5. Creare un gruppo SCADA su PE2 e aggiungere le interfacce seriali RS-232 e le interfacce seriali virtuali al gruppo.

  6. Configurare le PW.

  7. Creare MPLS L2VC su PE.

Preparazione dei dati

Per completare la configurazione, è necessario disporre dei seguenti dati.

  • L2VC ID (devono essere gli stessi) a entrambe le estremità di ogni PW
  • MPLS LSR ID di PE e P
  • Indirizzi IP dei peer remoti di PE
  • Attributi dell'interfaccia RS-232

Procedura

  1. Abilitare un IGP sulla rete backbone per comunicare tra dispositivi sulla rete backbone. Per le configurazioni dettagliate, vedere i file di configurazione in questo esempio.
  2. Configurare le funzioni di base MPLS sulla rete backbone e MPLS L2VPN su PE. Quindi, stabilire una relazione di peer MPLS LDP remoto tra PE alle due estremità di PW da creare. Per le configurazioni dettagliate, vedere i file di configurazione in questo esempio.

    NOTA:

    La relazione tra peer MPLS LDP remota deve essere stabilita solo quando viene creato un PW dinamico.

  3. Configurare gli attributi delle interfacce RS-232 con una velocità di 19200 bit/s.

    1. Configurare PE1.

      # Configurare gli attributi dell'interfaccia per serial 0/2/1, serial 0/2/2 e serial 0/2/3 di PE.

      <HUAWEI> system-view
      [~HUAWEI] sysname PE1
      [*HUAWEI] commit
      [~PE1] interface serial 0/2/1
      [~PE1-Serial0/2/1] portmode rs-232
      [*PE1-Serial0/2/1] baudrate 5
      [*PE1-Serial0/2/1] databits 7
      [*PE1-Serial0/2/1] stopbits 2
      [*PE1-Serial0/2/1] parity odd
      [*PE1-Serial0/2/1] mux-protocol 2
      [*PE1-Serial0/2/1] x-50 set phasemode interval
      [*PE1-Serial0/2/1] quit
      [*PE1] commit
      [~PE1] interface serial 0/2/2
      [~PE1-Serial0/2/2] portmode rs-232
      [*PE1-Serial0/2/2] baudrate 5
      [*PE1-Serial0/2/2] databits 7
      [*PE1-Serial0/2/2] stopbits 2
      [*PE1-Serial0/2/2] parity odd
      [*PE1-Serial0/2/2] mux-protocol 2
      [*PE1-Serial0/2/2] x-50 set phasemode interval
      [*PE1-Serial0/2/2] quit
      [*PE1] commit
      [~PE1] interface serial 0/2/3
      [~PE1-Serial0/2/3] portmode rs-232
      [*PE1-Serial0/2/3] baudrate 5
      [*PE1-Serial0/2/3] databits 7
      [*PE1-Serial0/2/3] stopbits 2
      [*PE1-Serial0/2/3] parity odd
      [*PE1-Serial0/2/3] mux-protocol 2
      [*PE1-Serial0/2/3] x-50 set phasemode interval
      [*PE1-Serial0/2/3] quit
      [*PE1] commit
      
    2. Configurare PE2.

      # Configurare gli attributi dell'interfaccia per seriale 0/2/4 e seriale 0/2/5 di PE2.

      <HUAWEI> system-view
      [~HUAWEI] sysname PE2
      [*HUAWEI] commit
      [~PE2] interface serial 0/2/4
      [~PE2-Serial0/2/4] portmode rs-232
      [*PE2-Serial0/2/4] baudrate 5
      [*PE2-Serial0/2/4] databits 7
      [*PE2-Serial0/2/4] stopbits 2
      [*PE2-Serial0/2/4] parity odd
      [*PE2-Serial0/2/4] mux-protocol 2
      [*PE2-Serial0/2/4] x-50 set phasemode interval
      [*PE2-Serial0/2/4] quit
      [*PE2] commit
      [~PE2] interface serial 0/2/5
      [~PE2-Serial0/2/5] portmode rs-232
      [*PE2-Serial0/2/5] baudrate 7
      [*PE2-Serial0/2/5] databits 8
      [*PE2-Serial0/2/5] stopbits 1
      [*PE2-Serial0/2/5] parity odd
      [*PE2-Serial0/2/5] mux-protocol 0
      [*PE2-Serial0/2/5] x-50 set phasemode interval
      [*PE2-Serial0/2/5] quit
      [*PE2] commit
      

  4. Configurare TDM come protocollo di incapsulamento delle interfacce seriali RS-232.

    1. Configurare PE1.

      # Configurare TDM come protocollo di incapsulamento di serial0/2/1, serial0/2/2e serial0/2/3 di PE1.

      [~PE1] interface serial0/2/1
      [~PE1-Serial0/2/1] link-protocol tdm
      [*PE1-Serial0/2/1] quit
      [*PE1] commit
      [~PE1] interface serial0/2/2
      [~PE1-Serial0/2/2] link-protocol tdm
      [*PE1-Serial0/2/2] quit
      [*PE1] commit
      [~PE1] interface serial0/2/3
      [~PE1-Serial0/2/3] link-protocol tdm
      [*PE1-Serial0/2/3] quit
      [*PE1] commit
      
    2. Configurare PE2.

      # Creare virtual-serial0/2/1, virtual-serial 0/2/2, e virtual-serial 0/2/3 su PE2 e configurare TDM come protocollo di incapsulamento delle tre interfacce seriali virtuali.

      [~PE2] interface virtual-serial0/2/1
      [~PE2-Virtual-Serial0/2/1] link-protocol tdm
      [*PE2-Virtual-Serial0/2/1] quit
      [*PE2] commit
      [~PE2] interface virtual-serial0/2/2
      [~PE2-Virtual-Serial0/2/2] link-protocol tdm
      [*PE2-Virtual-Serial0/2/2] quit
      [*PE2] commit
      [~PE2] interface virtual-serial0/2/3
      [~PE2-Virtual-Serial0/2/3] link-protocol tdm
      [*PE2-Virtual-Serial0/2/3] quit
      [*PE2] commit
      

  5. Creare un gruppo SCADA su PE2 e aggiungere le interfacce seriali RS-232 e le interfacce seriali virtuali al gruppo.

    [~PE2] scada-group 1
    [*PE2-scada-group-1] commit
    [~PE2-scada-group-1] quit
    [~PE2] interface serial0/2/4
    [~PE2-Serial0/2/4] scada-group 1 work
    [*PE2-Serial0/2/4] commit
    [~PE2-Serial0/2/4] quit
    [~PE2] interface serial0/2/5
    [~PE2-Serial0/2/5] scada-group 1 protect
    [*PE2-Serial0/2/5] commit
    [~PE2-Serial0/2/5] quit
    [~PE2] interface virtual-serial0/2/1
    [~PE2-Virtual-Serial0/2/1] bind scada-group 1
    [*PE2-Virtual-Serial0/2/1] commit
    [~PE2-Virtual-Serial0/2/1] quit
    [~PE2] interface virtual-serial0/2/2
    [~PE2-Virtual-Serial0/2/2] bind scada-group 1
    [*PE2-Virtual-Serial0/2/2] commit
    [~PE2-Virtual-Serial0/2/2] quit
    [~PE2] interface virtual-serial0/2/3
    [~PE2-Virtual-Serial0/2/3] bind scada-group 1
    [*PE2-Virtual-Serial0/2/3] commit
    [~PE2-Virtual-Serial0/2/3] quit
    

  6. Configurare PW.

    1. Configurare PE1.

      [~PE1] pw-template pe1tope2
      [*PE1-pw-template-pe1tope2] peer-address 192.168.2.2
      [*PE1-pw-template-pe1tope2] jitter-buffer depth 6
      [*PE1-pw-template-pe1tope2] tdm-encapsulation-number 24
      [*PE1-pw-template-pe1tope2] commit
      [~PE1-pw-template-pe1tope2] quit
      [~PE1] interface serial0/2/1
      [~PE1-Serial0/2/1] mpls l2vc pw-template pe1tope2 101 control-word
      [*PE1-Serial0/2/1] undo shutdown
      [*PE1-Serial0/2/1] quit
      [*PE1] commit
      [~PE1] interface serial0/2/2
      [~PE1-Serial0/2/2] mpls l2vc pw-template pe1tope2 102 control-word
      [*PE1-Serial0/2/2] undo shutdown
      [*PE1-Serial0/2/2] quit
      [*PE1] commit
      [~PE1] interface serial0/2/3
      [~PE1-Serial0/2/3] mpls l2vc pw-template pe1tope2 103 control-word
      [*PE1-Serial0/2/3] undo shutdown
      [*PE1-Serial0/2/3] quit
      [*PE1] commit
      
    2. Configurare PE2.

      [~PE2] pw-template pe2tope1
      [~PE2-pw-template-pe2tope1] peer-address 192.168.1.1
      [*PE2-pw-template-pe2tope1] jitter-buffer depth 6
      [*PE2-pw-template-pe2tope1] tdm-encapsulation-number 24
      [*PE2-pw-template-pe2tope1] quit
      [*PE2] commit
      [~PE2] interface virtual-serial0/2/1
      [~PE2-Virtual-Serial0/2/1] mpls l2vc pw-template pe2tope1 101 control-word
      [*PE2-Virtual-Serial0/2/1] undo shutdown
      [*PE2-Virtual-Serial0/2/1] quit
      [*PE2] commit
      [~PE2] interface virtual-serial0/2/2
      [~PE2-Virtual-Serial0/2/2] mpls l2vc pw-template pe2tope1 102 control-word
      [*PE2-Virtual-Serial0/2/2] undo shutdown
      [*PE2-Virtual-Serial0/2/2] quit
      [*PE2] commit
      [~PE2] interface virtual-serial0/2/3
      [~PE2-Virtual-Serial0/2/3] mpls l2vc pw-template pe2tope1 103 control-word
      [*PE2-Virtual-Serial0/2/3] undo shutdown
      [*PE2-Virtual-Serial0/2/3] quit
      [*PE2] commit
      

  7. Verificare la configurazione.

    Eseguire il comando display mpls l2vc su PE per verificare lo stato di PW. L'esempio seguente utilizza l'output del comando su PE1. L'output del comando mostra che il PW stabilito utilizzando virtual-serial0/2/1 è Up.

    # PE2, output del comando

    <PE2> display mpls l2vc interface virtual-serial0/2/1
     *client interface       : Virtual-Serial0/2/1 is up
      Administrator PW       : no
      session state          : up
      AC state               : up
      VC state               : up
      Label state            : 0
      Token state            : 0
      VC ID                  : 100
      VC type                : CESoPSN basic mode
      destination            : 192.168.1.1
      local group ID         : 0            remote group ID      : 0
      local VC label         : 17           remote VC label      : 17
      local TDM Encap Num    : 24           remote TDM Encap Num : 24
      jitter-buffer          : 6
      idle-code              : ff
      local rtp-header       : enable       remote rtp-header    : enable
      local bit-rate         : enable       remote bit-rate      : enable
      local AC OAM State     : up
      local PSN OAM State    : up
      local forwarding state : forwarding
      local status code      : 0x0 
      BFD for PW             : unavailable
      VCCV State             : up
      manual fault           : not set
      active state           : active
      forwarding entry       : exist
      OAM Protocol           : --                                       
      OAM Status             : --                                       
      OAM Fault Type         : --                                       
      PW APS ID              : 0                                        
      PW APS Status          : --                                       
      TTL Value              : 1                                        
      link state             : up
      local VC MTU           : 1500         remote VC MTU        : 20000
      local VCCV             : cw alert ttl lsp-ping bfd                     
      remote VCCV            : cw alert ttl lsp-ping bfd                     
      local control word     : enable       remote control word  : enable    
      tunnel policy name     : --                                           
      PW template name       : pe2tope1                                       
      primary or secondary   : primary                                       
      load balance type      : flow                                          
      Access-port            : false                                         
      Switchover Flag        : false                                         
      VC tunnel/token info   : 1 tunnels/tokens                              
        Backup TNL type      : lsp   , TNL ID : 0x0                          
      create time            : 0 days, 18 hours, 36 minutes, 29 seconds      
      up time                : 0 days, 0 hours, 0 minutes, 32 seconds        
      last change time       : 0 days, 0 hours, 0 minutes, 32 seconds        
      VC last up time        : 2014/11/11 10:36:45                           
      VC total up time       : 0 days, 1 hours, 25 minutes, 31 seconds       
      CKey                   : 2                                             
      NKey                   : 1                                             
      PW redundancy mode     : frr                                           
      AdminPw interface      : --                                            
      AdminPw link state     : --                                            
      Diffserv Mode          : pipe                                          
      Service Class          : ef                                            
      Color                  : green                                         
      DomainId               : --                                            
      Domain Name            : --                                            
    

File di configurazione

  • File di configurazione PE1

    #
     sysname PE1
    #
     mpls lsr-id 192.168.1.1
     mpls
    #
     mpls l2vpn
    #
    pw-template pe1tope2
     peer-address 192.168.2.2
     jitter-buffer depth 6
     tdm-encapsulation-number 24
    #
    mpls ldp
    #
     mpls ldp remote-peer 192.168.2.2
     remote-ip 192.168.2.2 
    #
    interface serial0/2/1
     link-protocol tdm                                        
     undo shutdown
     mpls l2vc pw-template pe1tope2 101 control-word 
     portmode rs-232
     baudrate 5
     parity odd
     stopbits 2
     databits 7
     mux-protocol 2
     x-50 set phasemode interval
    #
    interface serial0/2/2
     link-protocol tdm                                        
     undo shutdown
     mpls l2vc pw-template pe1tope2 102 control-word 
     portmode rs-232
     baudrate 5
     parity odd
     stopbits 2
     databits 7
     mux-protocol 2
     x-50 set phasemode interval
    #
    interface serial0/2/3
     link-protocol tdm                                        
     undo shutdown
     mpls l2vc pw-template pe1tope2 103 control-word 
     portmode rs-232
     baudrate 5
     parity odd
     stopbits 2
     databits 7
     mux-protocol 2
     x-50 set phasemode interval
    #
    interface GigabitEthernet0/1/4
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack0
     ip address 192.168.1.1 255.255.255.255
    #
    ospf 1
    area 0.0.0.0
      network 192.168.1.1 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    return
    
  • File di configurazione PE2

    #
     sysname PE2
    #
     mpls lsr-id 192.168.2.2
     mpls
    #
     mpls l2vpn
    #
    pw-template 3to1
     peer-address 192.168.1.1
     jitter-buffer depth 6
     tdm-encapsulation-number 24
    #
    mpls ldp
    #
     mpls ldp remote-peer 192.168.1.1
     remote-ip 192.168.1.1
    #
    interface serial0/2/4
     undo shutdown
     portmode rs-232
     baudrate 5
     parity odd
     stopbits 2
     databits 7
     mux-protocol 2
     x-50 set phasemode interval
     scada-group 1 work
    #
    interface serial0/2/5
     undo shutdown                                            
     portmode rs-232                                          
     baudrate 7                                               
     parity odd 
     undo shutdown
     scada-group 1 protect
    #
    interface GigabitEthernet0/1/7 
     undo shutdown
     ip address 10.2.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack0
     ip address 192.168.3.3 255.255.255.255
    #
    interface Virtual-Serial0/2/1
     link-protocol tdm
     mpls l2vc pw-template pe2tope1 101 control-word 
     bind scada-group 1
    #
    interface Virtual-Serial0/2/2
     link-protocol tdm
     mpls l2vc pw-template pe2tope1 103 control-word 
     bind scada-group 1
    #
    interface Virtual-Serial0/2/3
     link-protocol tdm
     mpls l2vc pw-template pe2tope1 103 control-word 
     bind scada-group 1
    #
    ospf 1
     area 0.0.0.0
      network 192.168.3.3 0.0.0.0
      network 10.2.1.0 0.0.0.255
    #
    return
    
  • P file di configurazione

    #
     sysname P
    #
     mpls lsr-id 192.168.4.4
     mpls
    #
    mpls ldp
    #
    interface GigabitEthernet0/1/5
     undo shutdown
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet0/1/6
     undo shutdown
     ip address 10.2.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack0
     ip address 192.168.4.4 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 192.168.4.4 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.1.0 0.0.0.255
    #
    return
    
Download
Updated: 2019-05-16

N. documento: EDOC1100082601

Visualizzazioni:788

Download: 2

Average rating:
This Document Applies to these Products
Documenti correlati
Related Version
Share
Precedente Avanti