Nessuna risorsa pertinente trovata nella lingua selezionata.

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Raccolta di casi di configurazione dello scenario tipico del router aziendale NE-ME60 2.0

Rate and give feedback:
Huawei utilizza la traduzione automatica insieme alla revisione umana per tradurre questo documento in diverse lingue, per facilitare la comprensione del contenuto di questo documento. Nota: la traduzione automatica, anche la più avanzata, non può corrispondere alla qualità dei trasduttori professionisti. Huawei non accetta alcuna responsabilità per l'accuratezza della traduzione e raccomanda di fare riferimento al documento inglese (per il quale è stato fornito un collegamento).
Esempio per la configurazione di un'interfaccia V.24 per i servizi di trasmissione trasparente

Esempio per la configurazione di un'interfaccia V.24 per i servizi di trasmissione trasparente

I servizi CES, come i dati relativi alla gestione dei prodotti e alla gestione delle informazioni di una centrale elettrica, tra un'unità terminale remota (RTU) e un centro di controllo possono essere trasmessi in modo trasparente su collegamenti TDM sulla rete ME (Metro Ethernet).

Prodotti e versioni applicabili

Questo esempio di configurazione si applica ai prodotti della serie NE05E e 08E con V300R003C10 o versioni successive.

Requisiti di rete

In Figura 1-2, quando i servizi di dati in uplink di una unità terminale remota (RTU), come un contatore intelligente, aggregano su un'interfaccia seriale di PE1, PE1 incapsula i servizi dati in pacchetti PSN sull'interfaccia seriale e li trasmette tramite il PSN. Dopo che i pacchetti arrivano a PE2, PE2 non incapsula i pacchetti PSN, ricostruisce i servizi dati originali e li invia al centro di controllo. Il dispositivo del centro di controllo è vecchio e ha solo pin RX, TX, e GND che non producono segnali di controllo.

Figura 1-2  Configurare TDMoPSN
NOTA:

In questo esempio, interface1, interface2, interface3, interface4, interface5 e interface6 si riferiscono a Serial 0/4/0, GE0/2/4, GE0/1/0, GE0/2/1, GE0/2/0, e Serial 0/4/0, rispettivamente.



Dispositivo

Interfaccia

Indirizzo IP

PE1

GE0/2/4

Loopback0

10.1.1.1/24

192.168.2.2/32

P

GE0/1/0

GE0/2/1

Loopback0

10.1.1.2/24

10.2.1.1/24

192.168.4.4/32

PE2

GE0/2/0

Loopback0

10.2.1.2/24

192.168.3.3/32

Roadmap di configurazione

La roadmap di configurazione è seguente:

  1. Attivare un IGP sulla rete backbone per la comunicazione dei dispositivi sulla rete backbone.

  2. Configurare le funzioni di base MPLS sulla rete backbone e MPLS L2VPN su PE. Quindi, stabilire una relazione di peer MPLS LDP remoto tra PE alle due estremità di PW da creare.

  3. Configurare gli attributi delle interfacce V.24.

  4. Configurare l'interfaccia utilizzata da PE2 per connettersi al centro di controllo per garantire che l'interfaccia sia attiva anche quando l'interfaccia rileva un segnale anomalo.

  5. Configurare TDM come protocollo di incapsulamento delle interfacce V.35.

  6. Configurare PW.

  7. Creare MPLS L2VC su PE.

Preparazione dei dati

Per completare la configurazione, è necessario disporre dei seguenti dati.

  • L2VC ID (devono essere gli stessi) a entrambe le estremità di PW
  • MPLS LSR ID di PE e P
  • Indirizzi IP dei peer remoti di PE
  • V.24 attributi dell'interfaccia

Procedura

  1. Abilitare un IGP sulla rete backbone per comunicare tra dispositivi sulla rete backbone. Per le configurazioni dettagliate, vedere i file di configurazione in questo esempio.
  2. Configurare le funzioni di base MPLS sulla rete backbone e MPLS L2VPN su PE. Quindi, stabilire una relazione di peer MPLS LDP remoto tra PE alle due estremità di PW da creare. Per le configurazioni dettagliate, vedere i file di configurazione in questo esempio.

    NOTA:

    La relazione tra peer MPLS LDP remota deve essere stabilita solo quando viene creato un PW dinamico.

  3. Configurare gli attributi delle interfacce V.24 con una velocità di 9600 bit/s e in modalità asincrona.

    1. Configurare PE1.

      # Configurare gli attributi dell'interfaccia per serial 0/4/0 di PE1.

      <HUAWEI> system-view
      [~HUAWEI] sysname PE1
      [*HUAWEI] commit
      [~PE1] interface serial 0/4/0
      [~PE1-Serial0/4/0] portmode v-24
      [*PE1-Serial0/4/0] physical-mode async
      [*PE1-Serial0/4/0] baudrate 4
      [*PE1-Serial0/4/0] workmode dce
      [*PE1-Serial0/4/0] clocksource slave
      [*PE1-Serial0/4/0] quit
      [*PE1] commit
      
    2. Configurare PE2.

      # Configurare gli attributi dell'interfaccia per serial 0/4/0 di PE2.

      <HUAWEI> system-view
      [~HUAWEI] sysname PE2
      [*HUAWEI] commit
      [~PE2] interface serial 0/4/0
      [~PE2-Serial0/4/0] portmode v-24
      [*PE1-Serial0/4/0] physical-mode async
      [*PE2-Serial0/4/0] baudrate 4
      [*PE2-Serial0/4/0] workmode dce
      [*PE2-Serial0/4/0] clocksource slave
      [*PE2-Serial0/4/0] quit
      [*PE2] commit
      

  4. Eliminare il rilevamento del segnale di controllo dallo stato dell'interfaccia seriale di PE2 collegata al centro di controllo per garantire che l'interfaccia rimanga in Up in caso di segnali anomali.

    [~PE2] interface serial 0/4/0
    [~PE2-Serial0/4/0] nodetect dtr
    [*PE2-Serial0/4/0] quit
    [*PE2] commit
    

  5. Configurare TDM come protocollo di incapsulamento delle interfacce V.35.

    1. Configurare PE1.

      [~PE1] interface serial0/4/0
      [~PE1-Serial0/4/0] link-protocol tdm
      [*PE1-Serial0/4/0] quit
      [*PE1] commit
      
    2. Configurare PE2.

      [~PE2] interface serial0/4/0
      [~PE2-Serial0/4/0] link-protocol tdm
      [*PE2-Serial0/4/0] quit
      [*PE2] commit
      

  6. Configurare PW.

    1. Configurare PE1.

      [~PE1] pw-template 1to3
      [*PE1-pw-template-1to3] peer-address 192.168.3.3
      [*PE1-pw-template-1to3] jitter-buffer depth 6
      [*PE1-pw-template-1to3] tdm-encapsulation-number 24
      [*PE1-pw-template-1to3] quit
      [*PE1] commit
      [~PE1] interface serial0/4/0
      [~PE1-Serial0/4/0] mpls l2vc pw-template 1to3 100 control-word 
      [*PE1-Serial0/4/0] undo shutdown
      [*PE1-Serial0/4/0] quit
      [*PE1] commit
      
    2. Configurare PE2.

      [~PE2] pw-template 3to1
      [*PE2-pw-template-3to1] peer-address 192.168.2.2
      [*PE2-pw-template-3to1] jitter-buffer depth 6
      [*PE2-pw-template-3to1] tdm-encapsulation-number 24
      [*PE2-pw-template-3to1] quit
      [*PE2] commit
      [~PE2] interface serial0/4/0
      [~PE2-Serial0/4/0] mpls l2vc pw-template 3to1 100 control-word 
      [*PE2-Serial0/4/0] undo shutdown
      [*PE2-Serial0/4/0] quit
      [*PE2] commit
      

  7. Verificare la configurazione.

    Eseguire il comando display mpls l2vc su PE per verificare lo stato di PW. L'esempio seguente utilizza l'output del comando su PE1. L'output del comando mostra che il PW è Up.

    # PE1's command output

    <PE1> display mpls l2vc interface serial0/4/0
     *client interface       : Serial0/4/0 is up
      Administrator PW       : no
      session state          : up
      AC state               : up
      VC state               : up
      Label state            : 0
      Token state            : 0
      VC ID                  : 100
      VC type                : CESoPSN basic mode
      destination            : 192.168.3.3
      local group ID         : 0            remote group ID      : 0
      local VC label         : 16           remote VC label      : 16
      TDM encapsulation number: 24
      jitter-buffer          : 8
      idle-code              : ff
      rtp-header             : enable
      local AC OAM State     : up
      local PSN OAM State    : up
      local forwarding state : forwarding
      local status code      : 0x0 
      remote AC OAM state    : up 
      remote PSN OAM state   : up 
      remote forwarding state: forwarding 
      remote status code     : 0x0
      ignore standby state   : no 
      Dynamic BFD for PW     : enable 
      Detect Multipier       : 3
      Min Transit Interval   : 1500
      Max Receive Interval   : 1500
      Dynamic BFD Session    : built
      BFD for PW             : unavailable
      VCCV State             : up
      manual fault           : not set
      active state           : active
      forwarding entry       : exist
      link state             : up
      local VC MTU           : 2000         remote VC MTU        : 1500
      local VCCV             : cw alert ttl lsp-ping bfd                     
      remote VCCV            : cw alert ttl lsp-ping bfd                     
      local control word     : enable       remote control word  : enable    
      tunnel policy name     : --                                           
      traffic behavior name  : --                                            
      PW template name       : 1to3                                           
      primary or secondary   : primary                                       
      load balance type      : flow                                          
      Access-port            : false                                         
      Switchover Flag        : false                                         
      VC tunnel/token info   : 1 tunnels/tokens                              
        NO.0  TNL type       : lsp   , TNL ID : 0x392                        
        Backup TNL type      : lsp   , TNL ID : 0x0                          
      create time            : 0 days, 18 hours, 36 minutes, 29 seconds      
      up time                : 0 days, 0 hours, 0 minutes, 32 seconds        
      last change time       : 0 days, 0 hours, 0 minutes, 32 seconds        
      VC last up time        : 2014/11/11 10:36:45                           
      VC total up time       : 0 days, 1 hours, 25 minutes, 31 seconds       
      CKey                   : 2                                             
      NKey                   : 1                                             
      PW redundancy mode     : frr                                           
      AdminPw interface      : --                                            
      AdminPw link state     : --                                            
      Diffserv Mode          : pipe                                          
      Service Class          : ef                                            
      Color                  : green                                         
      DomainId               : --                                            
      Domain Name            : --                                            
    

File di configurazione

  • File di configurazione PE1

    #
     sysname PE1
    #
     mpls lsr-id 192.168.2.2
     mpls
    #
     mpls l2vpn
    #
    pw-template 1to3
     peer-address 192.168.3.3
     jitter-buffer depth 6
     tdm-encapsulation-number 24
    #
    mpls ldp
    #
     mpls ldp remote-peer 192.168.3.3
     remote-ip 192.168.3.3 
    #
    interface serial0/4/0
     link-protocol tdm
     portmode v-24
     physical-mode async
     baudrate 4
     clocksource slave
     mpls l2vc pw-template 1to3 100 control-word control-word
     undo shutdown
    #
    interface GigabitEthernet0/2/4
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack0
     ip address 192.168.2.2 255.255.255.255
    #
    ospf 1
    area 0.0.0.0
      network 192.168.2.2 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    return
    
  • File di configurazione PE2

    #
     sysname PE2
    #
     mpls lsr-id 192.168.3.3
     mpls
    #
     mpls l2vpn
    #
    pw-template 3to1
     peer-address 192.168.2.2
     jitter-buffer depth 6
     tdm-encapsulation-number 24
    #
    mpls ldp
    #
     mpls ldp remote-peer 192.168.2.2
     remote-ip 192.168.2.2
    #
    interface serial0/4/0
     link-protocol tdm
     portmode v-24
     physical-mode async
     baudrate 4
     clocksource slave
     nodetect dtr
     mpls l2vc pw-template 3to1 100 control-word
     undo shutdown
    #
    interface GigabitEthernet0/2/0 
     undo shutdown
     ip address 10.2.2.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack0
     ip address 192.168.3.3 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 192.168.3.3 0.0.0.0
      network 10.2.2.0 0.0.0.255
    #
    return
    
  • P file di configurazione

    #
     sysname P
    #
     mpls lsr-id 192.168.4.4
     mpls
    #
    mpls ldp
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet0/2/1
     undo shutdown
     ip address 10.2.2.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack0
     ip address 192.168.4.4 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 192.168.4.4 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.2.0 0.0.0.255
    #
    return
    
Download
Updated: 2019-05-16

N. documento: EDOC1100082601

Visualizzazioni:886

Download: 2

Average rating:
This Document Applies to these Products
Documenti correlati
Related Version
Share
Precedente Avanti