Nessuna risorsa pertinente trovata nella lingua selezionata.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Raccolta di casi di configurazione dello scenario tipico del router aziendale NE-ME60 2.0

Rate and give feedback:
Huawei utilizza la traduzione automatica insieme alla revisione umana per tradurre questo documento in diverse lingue, per facilitare la comprensione del contenuto di questo documento. Nota: la traduzione automatica, anche la più avanzata, non può corrispondere alla qualità dei trasduttori professionisti. Huawei non accetta alcuna responsabilità per l'accuratezza della traduzione e raccomanda di fare riferimento al documento inglese (per il quale è stato fornito un collegamento).
Funzioni di servizio a bassa velocità

Funzioni di servizio a bassa velocità

Esempio per la configurazione di CESoPSN

Attraverso il trasporto di celle trasparenti TDM, i servizi tra gli utenti e le aziende nella stessa città possono essere trasmessi in modo trasparente tramite collegamenti CES in una rete ME (Metro Ethernet).

Prodotti e versioni applicabili
  • Router della serie NE05E con versione V200R005C00 o successiva, supportano la scheda di interfaccia E1 NED2ML1A/NED2ML1B - 16 canali.

  • Router serie NE08E con versione V200R005C00 o successiva, con la scheda di interfaccia E1 NED3ML1A/NED3ML1B - 16 canali o supportano NED2CQ1B - 4 canali canalizzati OC-3c/STM-1c scheda di interfaccia ottica POS.

Requisiti di rete

Come mostrato in Figura 1-51, è necessario che l'utente e PE1 siano connessi tramite due collegamenti E1. L'Azienda e PE2 devono essere collegati tramite l'interfaccia CPOS. Sull'interfaccia seriale canalizzata dei collegamenti E1, configurare il protocollo di incapsulamento come CES. Quindi, viene configurato PW tra PE1 e PE2 per trasmettere in modo trasparente i dati TDM.

Figura 1-51  Diagramma di rete della configurazione di TDMoPSN

Router

Interfaccia

Indirizzo IP

PE1

GE0/2/4

Loopback0

10.1.1.1/24

192.168.2.2/32

P

GE1/0/0

GE 2/0/0

Loopback0

10.1.1.2/24

10.2.1.1/24

192.168.4.4/32

PE2

GE2/0/0

Loopback0

10.2.1.2/24

192.168.3.3/32

Roadmap di configurazione

La roadmap di configurazione è seguente:

  1. Eseguire il protocollo IGP sulla rete backbone in modo che i dispositivi possano comunicare tra loro.

  2. Configurare le funzioni di base MPLS sulla rete backbone e le funzioni MPLS L2VPN sui PE. Stabilire una relazione di peer MPLS LDP remoto tra PE a entrambe le estremità di PW di destinazione.

  3. Configurare i parametri per l'interfaccia TDM.

  4. Configurare PW.

  5. Stabilire connessioni MPLS L2VC su PE.

Preparazione dei dati

Per completare la configurazione, sono necessari i seguenti dati:

  • L2VC ID alle due estremità di PW (deve essere lo stesso)
  • MPLS LSR ID di router PE e P
  • Indirizzi IP dei peer remoti di PE
  • Modalità di codifica e formato di frame dell'interfaccia E1/CE1

Procedura

  1. Eseguire il protocollo IGP sulla rete backbone in modo che i dispositivi possano comunicare tra loro. Per configurazioni dettagliate, vedere il file di configurazione di questo esempio.
  2. Configurare le funzioni MPLS di base sulla rete backbone e configurare le funzioni MPLS L2VPN sui dispositivi PE. Quindi, stabilire la relazione di peer MPLS LDP remoto tra PE a entrambe le estremità di PW. Per configurazioni dettagliate, vedere il file di configurazione di questo esempio.

    La relazione di peer MPLS LDP remoto è necessaria solo per il PW dinamico.

  3. Configurare i parametri per l'interfaccia TDM.

    1. Configurare PE1.

      # Configurare la modalità canalizzata e i frame CRC4 per il Controller E1 0/2/1 e Controller E1 0/2/2 su PE1.

      NOTA:
      I NE supportano le seguenti modalità per fasce orarie di associazione per formare un'interfaccia seriale sincrona:
      • Le fasce orarie da 1 a 31 sono destinate a formare un'interfaccia seriale sincrona e la fasce orarie 0 viene utilizzato per trasmettere le informazioni di segnalazione (applicabile quando ATM, PPP o TDM sono specificati come protocollo di livello di collegamento su un'interfaccia).

      • Le fasce orarie da 1 a 15 e le fasce orarie da 17 a 31 sono obbligate a formare un'interfaccia seriale sincrona, e le fasce orarie 0 e 16 sono utilizzate per trasmettere informazioni di segnalazione (applicabile quando ATM, PPP o TDM sono specificati come protocollo di livello di collegamento su un'interfaccia).

      • Raggruppamento di fasce orarie nelle fasce orarie 1-31, con le fasce orarie 0 utilizzato per trasmettere le informazioni di segnalazione. Questo tipo di raggruppamento è applicabile quando TDM è specificato come protocollo del livello di collegamento su un'interfaccia.
      [PE1] controller e1 0/2/1
      [PE1-E1 0/2/1] using ce1
      [PE1-E1 0/2/1] frame-format crc4
      [PE1-E1 0/2/1] channel-set 1 timeslot-list 1-31
      [PE1-E1 0/2/1] quit
      [PE1] controller e1 0/2/2
      [PE1-E1 0/2/2] using ce1
      [PE1-E1 0/2/2] frame-format crc4
      [PE1-E1 0/2/2] channel-set 1 timeslot-list 1-31
      [PE1-E1 0/2/2] quit
      
    2. Configurare PE2.

      # Impostare i parametri per l'interfaccia CPOS su PE2.

      [PE2] controller cpos 3/0/1
      [PE2-Cpos3/0/1] e1 1 channel-set 1 timeslot-list 1-31
      [PE2-Cpos3/0/1] e1 2 channel-set 2 timeslot-list 1-31

  4. Configurare il protocollo di incapsulamento sull'interfaccia seriale come TDM.

    1. Configurare PE1.

      [PE1] interface serial0/2/1:1
      [PE1-Serial0/2/1:1] link-protocol tdm
      [PE1-Serial0/2/1:1] quit
      [PE1] interface serial0/2/2:1
      [PE1-Serial0/2/2:1] link-protocol tdm
      [PE1-Serial0/2/2:1] quit
      
    2. Configurare PE2.

      [PE2] interface serial3/0/1/1:1
      [PE2-Serial3/0/1/1:1] link-protocol tdm
      [PE2-Serial3/0/1/1:1] quit
      [PE2] interface serial3/0/1/2:2
      [PE2-Serial3/0/1/2:2] link-protocol tdm
      [PE2-Serial3/0/1/2:2] quit
      

  5. Configurare PW.

    1. [PE1] pw-template 1to3
      [PE1-pw-template-1to3] peer-address 192.168.3.3
      [PE1-pw-template-1to3] jitter-buffer depth 8
      [PE1-pw-template-1to3] tdm-encapsulation-number 24
      [PE1-pw-template-1to3] quit
      [PE1] interface serial0/2/1:1
      [PE1-Serial0/2/1:1] mpls l2vc pw-template 1to3 100 control-word
      [PE1] interface serial0/2/2:1
      [PE1-Serial0/2/2:1] mpls l2vc pw-template 1to3 200 control-word
      
    2. Configurare PE2.

      [PE2] pw-template 3to1
      [PE2-pw-template-3to1] peer-address 192.168.2.2
      [PE2-pw-template-3to1] jitter-buffer depth 8
      [PE2-pw-template-3to1] tdm-encapsulation-number 24
      [PE2-pw-template-3to1] quit
      [PE2] interface serial3/0/1/1:1
      [PE2-Serial3/0/1/1:1] mpls l2vc pw-template 3to1 100 control-word
      [PE2-Serial3/0/1/1:1] undo shutdown
      [PE2-Serial3/0/1/1:1] quit
      [PE2] interface serial3/0/1/2:2
      [PE2-Serial3/0/1/2:2] mpls l2vc pw-template 3to1 200 control-word
      [PE2-Serial3/0/1/2:2] undo shutdown
      [PE2-Serial3/0/1/2:2] quit
      

  6. Verificare la configurazione.

    Eseguire il comando display mpls l2vc su PE. È possibile visualizzare che lo stato della PW è Up.

    Prendere la visualizzazione su PE1 come esempio:

    <PE1> display mpls l2vc interface serial0/2/1:1
     *client interface       : Serial0/2/1:1 is up
      Administrator PW       : no
      session state          : up
      AC state               : up
      VC state               : up
      Label state            : 0
      Token state            : 0
      VC ID                  : 100
      VC type                : CESoPSN basic mode
      destination            : 192.168.3.3
      local group ID         : 0            remote group ID      : 0
      local VC label         : 16           remote VC label      : 16
      TDM encapsulation number: 24
      jitter-buffer          : 8
      idle-code              : ff
      rtp-header             : enable
      local AC OAM State     : up
      local PSN OAM State    : up
      local forwarding state : forwarding
      local status code      : 0x0 
      remote AC OAM state    : up 
      remote PSN OAM state   : up 
      remote forwarding state: forwarding 
      remote status code     : 0x0
      ignore standby state   : no 
      Dynamic BFD for PW     : enable 
      Detect Multipier       : 3
      Min Transit Interval   : 1500
      Max Receive Interval   : 1500
      Dynamic BFD Session    : built
      BFD for PW             : unavailable
      VCCV State             : up
      manual fault           : not set
      active state           : active
      forwarding entry       : exist
      link state             : up
      local VC MTU           : 2000         remote VC MTU        : 1500
      local VCCV             : cw alert ttl lsp-ping bfd                     
      remote VCCV            : cw alert ttl lsp-ping bfd                     
      local control word     : enable       remote control word  : enable    
      tunnel policy name     : --                                           
      traffic behavior name  : --                                            
      PW template name       : 1to3                                           
      primary or secondary   : primary                                       
      load balance type      : flow                                          
      Access-port            : false                                         
      Switchover Flag        : false                                         
      VC tunnel/token info   : 1 tunnels/tokens                              
        NO.0  TNL type       : lsp   , TNL ID : 0x392                        
        Backup TNL type      : lsp   , TNL ID : 0x0                          
      create time            : 0 days, 18 hours, 36 minutes, 29 seconds      
      up time                : 0 days, 0 hours, 0 minutes, 32 seconds        
      last change time       : 0 days, 0 hours, 0 minutes, 32 seconds        
      VC last up time        : 2014/11/11 10:36:45                           
      VC total up time       : 0 days, 1 hours, 25 minutes, 31 seconds       
      CKey                   : 2                                             
      NKey                   : 1                                             
      PW redundancy mode     : frr                                           
      AdminPw interface      : --                                            
      AdminPw link state     : --                                            
      Diffserv Mode          : pipe                                          
      Service Class          : ef                                            
      Color                  : green                                         
      DomainId               : --                                            
      Domain Name            : --                                            
    

File di configurazione
  • File di configurazione di PE1

    #
     sysname PE1
    #
     mpls lsr-id 192.168.2.2
     mpls
    #
     mpls l2vpn
    #
    pw-template 1to3
     peer-address 192.168.3.3
     jitter-buffer depth 8
     tdm-encapsulation-number 24
    #
    mpls ldp
    #
     mpls ldp remote-peer 192.168.3.3
     remote-ip 192.168.3.3 
    #
    controller e1 0/3/1
    using ce1
    frame-format crc4
    channel-set 1 timeslot-list 1-31
    undo shutdown
    #
    controller e1 0/2/2
    using ce1
    frame-format crc4
    channel-set 1 timeslot-list 1-31
    undo shutdown
    #
    interface serial0/2/1:1
    link-protocol tdm
    mpls l2vc pw-template 1to3 100 control-word
    undo shutdown
    #
    interface serial0/2/2:1
    link-protocol tdm
    mpls l2vc pw-template 1to3 200 control-word
    undo shutdown
    #
    interface GigabitEthernet0/2/4
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack0
     ip address 192.168.2.2 255.255.255.255
    #
    ospf 1
    area 0.0.0.0
      network 192.168.2.2 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    return
    
  • File di configurazione di PE2

    #
     sysname PE2
    #
     mpls lsr-id 192.168.3.3
     mpls
    #
     mpls l2vpn
    #
    pw-template 3to1
     peer-address 192.168.2.2
     jitter-buffer depth 8
     tdm-encapsulation-number 24
    #
    mpls ldp
    #
     mpls ldp remote-peer 192.168.2.2
     remote-ip 192.168.2.2
    #
    controller cpos 3/0/1
    e1 1 channel-set 1 timeslot-list 1-31
    e1 2 channel-set 1 timeslot-list 1-31
    #
    interface serial3/0/1/1:1
    link-protocol tdm
    mpls l2vc pw-template 3to1 100 control-word
    undo shutdown
    #
    interface serial3/0/1/2:2
    link-protocol tdm
    mpls l2vc pw-template 3to1 200 control-word
    undo shutdown
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 10.2.2.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack0
     ip address 192.168.3.3 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 192.168.3.3 0.0.0.0
      network 10.2.2.0 0.0.0.255
    #
    return
    
  • File di configurazione di P

    #
     sysname P
    #
     mpls lsr-id 192.168.4.4
     mpls
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 10.2.2.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack0
     ip address 192.168.4.4 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 192.168.4.4 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.2.0 0.0.0.255
    #
    return
    

Esempio per la configurazione dell'estensione dell'interfaccia Z

Per implementare l'estensione dell'interfaccia Z, i segnali di un telefono analog collegato a un PBX sono trasmessi in modo trasparente sul PSN tra PE1 e PE2 in un altro luogo utilizzando CESoPSN.

Prodotti e versioni applicabili

Questa configurazione si applica ai prodotti della serie NE05E e 08E che eseguono V300R003C10 o versioni successive.

Requisiti di rete

Figura 1 mostra che gli utenti di un hotel (telefoni) sono collegati a un PBX. Per estendere la distanza di chiamata dei telefoni POTS, un'interfaccia del PBX è collegata a PE1. I telefoni di ramo remoto sono collegati a PE2. PE1 e PE2 sono collegati tramite E1 o PWE3.

Figura 1-52  Diagramma di rete dell'estensione dell'interfaccia Z.
NOTA:

In questo esempio, interface1, interface2, interface3 e interface4 si riferiscono a GE0/2/4, GE0/1/0, GE0/2/1, e GE0/2/0, rispettivamente.



Dispositivo

Interfaccia

PE1

GE0/2/4

FXO

P

GE0/1/0

GE0/2/1

PE2

GE0/2/0

FXS

Roadmap di configurazione

Per configurare un PW sulla rete PSN per trasmettere i servizi TDM, la roadmap di configurazione è la seguente:

  1. Configurare il tipo di interfaccia FXSO di PE1 e gli attributi fisici dell'interfaccia.

  2. Configurare il tipo di interfaccia FXSO di PE2 e gli attributi fisici dell'interfaccia e disabilitare la funzione del telefono fisso.

  3. Abilitare un IGP sulla rete backbone in modo che i dispositivi possano comunicare tra loro.

  4. Configurare le funzioni di base MPLS sulla rete backbone e MPLS L2VPN su PE. Quindi, stabilire una relazione di peer MPLS LDP remoto tra PE alle due estremità di PW.

  5. Configurare i parametri dell'interfaccia TDM.

  6. Configurare PW.

  7. Creare MPLS L2VC su PE.

Preparazione dei dati

Per completare la configurazione, sono necessari i seguenti dati:

No.

Dati

1

Numeri di interfaccia seriale PE1 e PE2

2

Tipi di interfaccia seriale PE1 e PE2 (FXS/FXO)

3

Le interfacce FXS e FXO ricevono e trasmettono guadagno

4

La corrente di squillo dell'interfaccia FXO di PE1

5

L2VC ID (devono essere gli stessi) a entrambe le estremità di PW

6

MPLS LSR ID di PE e P

7

Modalità di codifica e formato di frame dell'interfaccia E1/CE1

Procedura

  1. Configurare il tipo di interfaccia FXSO di PE1 e gli attributi fisici dell'interfaccia.

    <HUAWEI> system-view
    [~HUAWEI] sysname PE1
    [*HUAWEI] commit
    [~PE1] interface serial 0/4/0
    [~PE1-Serial0/4/0] portmode fxo
    Warning: The operation will update the existing interface mode, 
              and delete the interface configurations.                    
    continue?[y/n]:y 
    [*PE1-Serial0/4/0] fxo ring minimum-duration 5
    [*PE1-Serial0/4/0] fxo ring  maximum-interval 15
    [*PE1-Serial0/4/0] undo shutdown
    [*PE1-Serial0/4/0] commit
    [~PE1-Serial0/4/0] display this
    #                       
    interface Serial0/4/0        
     undo shutdown                
     fxo ring minimum-duration 5  
     fxo ring maximum-interval 15 
    #                             
    return

  2. Configurare il tipo di interfaccia FXSO di PE2 e gli attributi fisici dell'interfaccia e disabilitare la funzione del telefono fisso.

    <HUAWEI> system-view
    [~HUAWEI] sysname PE2
    [*HUAWEI] commit
    [~PE2] interface serial 0/4/1
    [~PE2-Serial0/4/1] portmode fxs
    Warning: The operation will update the existing interface mode, 
              and delete the interface configurations.                    
    continue?[y/n]:y 
    [*PE2-Serial0/4/1] undo shutdown
    [*PE2-Serial0/4/1] fxs gain send 5
    [*PE2-Serial0/4/1] fxs gain receive 0
    [*PE2-Serial0/4/1] fxs hotline disable
    [*PE2-Serial0/4/0] commit
    [~PE2-Serial0/4/1] display this
    #                                                                                                                                   
    interface Serial0/4/1                                                                                                               
     undo shutdown                                                                                                                      
     portmode fxs                                                                                                                       
     fxs gain send 5                                                                                                                    
     fxs gain receive 0                                                                                                                 
     fxs hotline disable                                                                                                                
    #                                                                                                                                   
    return 

  3. Eseguire un IGP sulla rete backbone in modo che i dispositivi possano comunicare tra loro. Per le configurazioni dettagliate, vedere i file di configurazione.
  4. Configurare le funzioni di base MPLS sulla rete backbone e MPLS L2VPN su PE. Quindi, stabilire la relazione di peer MPLS LDP remoto tra i PE a entrambe le estremità del PW. Per i dettagli sulla configurazione, vedere "File di configurazione" in questa sezione.

    La relazione di peer MPLS LDP remoto deve essere stabilita solo quando viene stabilito un PW dinamico.

  5. Configurare il protocollo di incapsulamento delle interfacce seriali come TDM.

    1. Configurare PE1.

      [~PE1] interface serial0/4/0
      [~PE1-Serial0/4/0] link-protocol tdm
      [*PE1-Serial0/4/0] quit
      [*PE1] commit
      
    2. Configurare PE2.

      [~PE2] interface serial0/4/1
      [~PE2-serial0/4/1] link-protocol tdm
      [*PE2-serial0/4/1] quit
      [*PE2] commit
      

  6. Configurare PW.

    1. Configurare PE1.

      [~PE1] pw-template 1to3
      [*PE1-pw-template-1to3] peer-address 192.168.3.3
      [*PE1-pw-template-1to3] jitter-buffer depth 8
      [*PE1-pw-template-1to3] tdm-encapsulation-number 24
      [*PE1-pw-template-1to3] quit
      [*PE1] commit
      [~PE1] interface serial0/4/0
      [~PE1-serial0/4/0] mpls l2vc pw-template 1to3 100 control-word 
      [*PE1-serial0/4/0] undo shutdown
      [*PE1-serial0/4/0] quit
      [*PE1] commit
      
    2. Configurare PE2.

      [~PE2] pw-template 3to1
      [*PE2-pw-template-3to1] peer-address 192.168.2.2
      [*PE2-pw-template-3to1] jitter-buffer depth 8
      [*PE2-pw-template-3to1] tdm-encapsulation-number 24
      [*PE2-pw-template-3to1] quit
      [*PE2] commit
      [~PE2] interface serial0/4/1
      [~PE2-serial0/4/1] mpls l2vc pw-template 3to1 100 control-word 
      [*PE2-serial0/4/1] undo shutdown
      [*PE2-serial0/4/1] quit
      [*PE2] commit
      

  7. Verificare la configurazione.

    Eseguire il comando display this interface su PE per visualizzare la configurazione e lo stato dell'interfaccia FXO o FXS

    # PE1, output del comando

    [~PE1-Serial0/4/0] display this interface
    Serial0/4/0 current state : UP                                                  
    Line protocol current state : UP                                                
    Last line protocol up time : 2015-03-20 16:59:13                                
    Description:Huawei, Serial0/4/0 Interface                                       
    Route Port,The Maximum Transmit Unit is 1500, Hold timer is 10(sec)             
    Internet protocol processing : disabled                                         
    Last physical up time   : 2015-03-20 16:59:13                                   
    Last physical down time : 2015-03-20 16:57:39                                   
    Current system time: 2015-03-23 10:36:46                                        
    Physical layer is: FXO, loopback none                                           
        Pcm code: A-law  
        Impedance: 600 ohm, Hotline: ENABLE                                                             
        DC impedance: 50 ohm, AC impedance: 600 ohm                                 
        Ring: Minimum duration: 5 ms, Maximum interval: 15 ms, Frequence: 25 Hz,
     AC amplitude: 50 V, Offset: 70 mA                                              
        Receive gain: 0 dB, Send gain: 0 dB                                         
      Output error:                                                                 
        0 Underrun Count , 0 Overrun Count                                          
        0 LosPkts , 0 MisOrderPkts                                                  
        0 MalformedPkts , 0 ErrorPkts                                               
        0 TotleErrorCur, 0 TotleErrorOld                                            
        ES: 0 , SES: 0 , UAS: 0                                                     
        Input bandwidth utilization  :    0%                                        
        Output bandwidth utilization :    0% 

    # L'output del comando di PE2

    [~PE2-Serial0/4/1] display this interface
    Serial0/4/1 current state : UP                                                  
    Line protocol current state : UP                                                
    Last line protocol up time : 2015-03-20 16:59:13                                
    Description:Huawei, Serial0/4/1 Interface                                       
    Route Port,The Maximum Transmit Unit is 1500, Hold timer is 10(sec)             
    Internet protocol processing : disabled                                         
    Last physical up time   : 2015-03-20 16:59:13                                   
    Last physical down time : 2015-03-20 16:57:39                                   
    Current system time: 2015-03-23 10:36:46                                        
    Physical layer is: FXS, loopback none                                           
        Pcm code: A-law                                                             
        DC impedance: 50 ohm, AC impedance: 600 ohm                                 
        Receive gain: 0 dB, Send gain: 5 dB                                         
      Output error:                                                                 
        0 Underrun Count , 0 Overrun Count                                          
        0 LosPkts , 0 MisOrderPkts                                                  
        0 MalformedPkts , 0 ErrorPkts                                               
        0 TotleErrorCur, 0 TotleErrorOld                                            
        ES: 0 , SES: 0 , UAS: 0                                                     
        Input bandwidth utilization  :    0%                                        
        Output bandwidth utilization :    0% 

    Eseguire il comando display mpls l2vc su PE. L'esempio seguente utilizza l'output del comando su PE1. L'output del comando mostra che lo stato del PW è Up.

    # PE1, output del comando

    <PE1> display mpls l2vc interface serial0/4/0
     *client interface       : serial0/4/0 is up
      Administrator PW       : no
      session state          : up
      AC state               : up
      VC state               : up
      Label state            : 0
      Token state            : 0
      VC ID                  : 100
      VC type                : CESoPSN basic mode
      destination            : 192.168.3.3
      local group ID         : 0            remote group ID      : 0
      local VC label         : 16           remote VC label      : 16
      TDM encapsulation number: 24
      jitter-buffer          : 8
      idle-code              : ff
      rtp-header             : enable
      local AC OAM State     : up
      local PSN OAM State    : up
      local forwarding state : forwarding
      local status code      : 0x0 
      remote AC OAM state    : up 
      remote PSN OAM state   : up 
      remote forwarding state: forwarding 
      remote status code     : 0x0
      ignore standby state   : no 
      Dynamic BFD for PW     : enable 
      Detect Multipier       : 3
      Min Transit Interval   : 1500
      Max Receive Interval   : 1500
      Dynamic BFD Session    : built
      BFD for PW             : unavailable
      VCCV State             : up
      manual fault           : not set
      active state           : active
      forwarding entry       : exist
      link state             : up
      local VC MTU           : 2000         remote VC MTU        : 1500
      local VCCV             : cw alert ttl lsp-ping bfd                     
      remote VCCV            : cw alert ttl lsp-ping bfd                     
      local control word     : enable       remote control word  : enable    
      tunnel policy name     : --                                           
      traffic behavior name  : --                                            
      PW template name       : 1to3                                           
      primary or secondary   : primary                                       
      load balance type      : flow                                          
      Access-port            : false                                         
      Switchover Flag        : false                                         
      VC tunnel/token info   : 1 tunnels/tokens                              
        NO.0  TNL type       : lsp   , TNL ID : 0x392                        
        Backup TNL type      : lsp   , TNL ID : 0x0                          
      create time            : 0 days, 18 hours, 36 minutes, 29 seconds      
      up time                : 0 days, 0 hours, 0 minutes, 32 seconds        
      last change time       : 0 days, 0 hours, 0 minutes, 32 seconds        
      VC last up time        : 2014/11/11 10:36:45                           
      VC total up time       : 0 days, 1 hours, 25 minutes, 31 seconds       
      CKey                   : 2                                             
      NKey                   : 1                                             
      PW redundancy mode     : frr                                           
      AdminPw interface      : --                                            
      AdminPw link state     : --                                            
      Diffserv Mode          : pipe                                          
      Service Class          : ef                                            
      Color                  : green                                         
      DomainId               : --                                            
      Domain Name            : --                                            
    

File di configurazione
  • File di configurazione PE1

    #
     sysname PE1
    #                       
     mpls lsr-id 192.168.2.2
     mpls
    #
     mpls l2vpn
    #
    pw-template 1to3
     peer-address 192.168.3.3
     jitter-buffer depth 8
     tdm-encapsulation-number 24
    #
    mpls ldp
    #
     mpls ldp remote-peer 192.168.3.3
     remote-ip 192.168.3.3 
    #
    interface serial0/4/0
    undo shutdown
    link-protocol tdm
    portmode fxo                
    fxo ring minimum-duration 5  
    fxo ring maximum-interval 15 
    mpls l2vc pw-template 1to3 100 control-word control-word
    #
    interface GigabitEthernet0/2/4
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    ospf 1
    area 0.0.0.0
      network 192.168.2.2 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    return
    
  • File di configurazione PE2

    #
     sysname PE2
    #           
     mpls lsr-id 192.168.3.3
     mpls
    #
     mpls l2vpn
    #
    pw-template 3to1
     peer-address 192.168.2.2
     jitter-buffer depth 8
     tdm-encapsulation-number 24
    #
    mpls ldp
    #
     mpls ldp remote-peer 192.168.2.2
     remote-ip 192.168.2.2
    #
    interface Serial0/4/1 
    undo shutdown 
    link-protocol tdm
    portmode fxs                                             
    fxs gain send 5                                          
    fxs gain receive 0                                       
    fxs hotline disable
    mpls l2vc pw-template 3to1 100 control-word
    undo shutdown
    #
    interface GigabitEthernet0/2/0 
     undo shutdown
     ip address 10.2.2.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack0
     ip address 192.168.3.3 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 192.168.3.3 0.0.0.0
      network 10.2.2.0 0.0.0.255
    #
    return
    
  • P file di configurazione

    #
     sysname P
    #
     mpls lsr-id 192.168.4.4
     mpls
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 10.2.2.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack0
     ip address 192.168.4.4 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 192.168.4.4 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.2.0 0.0.0.255
    #
    return
    

Esempio per la configurazione della funzione telefono hotline

La funzione telefono hotline consente al sistema di squillare automaticamente il telefono fisso dopo che il chiamante ha sollevato il telefono. Quando il chiamante riceve il telefono, viene stabilita una connessione di chiamata.

Prodotti e versioni applicabili

Questa configurazione si applica ai prodotti della serie NE05E e 08E che eseguono V300R003C10 o versioni successive.

Requisiti di rete

Figura 1 mostra che un telefono dell'hotel è collegato a PE1 e un altro telefono è collegato a PE2. PE1 e PE2 sono collegati tramite E1 o PWE3. Nello scenario del telefono hotline, la funzione del telefono hotline deve essere abilitata sulle interfacce FXS sia PE1 sia PE2.

Figura 1-53  Diagramma di rete telefonica hotline
NOTA:

In questo esempio, interface1, interface2, interface3 e interface4 si riferiscono a GE0/2/4, GE0/1/0, GE 0/2/1, e GE0/2/0, rispettivamente.



Dispositivo

Interfaccia

PE1

GE0/2/4

FXS

P

GE0/1/0

GE0/2/1

PE2

GE0/2/0

FXS

Roadmap di configurazione

Per configurare un PW sulla rete PSN per trasmettere i servizi TDM, la roadmap di configurazione è la seguente:

  1. Configurare il tipo di interfaccia FXSO di PE1 e gli attributi fisici dell'interfaccia e abilitare la funzione del telefono hotline.

  2. Configurare il tipo di interfaccia FXSO di PE2 e gli attributi fisici dell'interfaccia e abilitare la funzione del telefono hotline.

  3. Abilitare un IGP sulla rete backbone affinché i dispositivi possano comunicare tra loro.

  4. Configurare le funzioni di base MPLS sulla rete backbone e MPLS L2VPN su PE. Quindi, stabilire una relazione di peer MPLS LDP remoto tra PE alle due estremità di PW.

  5. Configurare i parametri dell'interfaccia TDM.

  6. Configurare PW.

  7. Creare un MPLS L2VC su PE1.

  8. Creare un MPLS L2VC su PE2.

Preparazione dei dati

Per completare la configurazione, sono necessari i seguenti dati:

No.

Dati

1

Numeri di interfaccia seriale PE1 e PE2

2

Tipi di interfaccia seriale PE1 e PE2 (FXS)

3

L2VC ID (deve essere lo stesso) su entrambe le estremità di PW

4

MPLS LSR ID di PE e P

5

Modalità di codifica e formato frame dell'interfaccia E1/CE1

Procedura

  1. Configurare il tipo di interfaccia FXSO di PE1 e gli attributi fisici dell'interfaccia e abilitare la funzione del telefono hotline.

    <HUAWEI> system-view
    [~HUAWEI] sysname PE1
    [*HUAWEI] commit
    [~PE1] interface serial 0/4/0
    [*PE1-Serial0/4/0] portmode fxs
    Warning: The operation will update the existing interface mode, 
              and delete the interface configurations.                    
    continue?[y/n]:y 
    [*PE1-Serial0/4/0] undo shutdown
    [*PE1-Serial0/4/0] fxs hotline enable
    [*PE1-Serial0/4/0] commit
    [~PE1-Serial0/4/0] quit

  2. Configurare il tipo di interfaccia FXSO di PE2 e gli attributi fisici dell'interfaccia e abilitare la funzione del telefono hotline.

    <HUAWEI> system-view
    [~HUAWEI] sysname PE2
    [*HUAWEI] commit
    [~PE2] interface serial 0/4/1
    [~PE2-Serial0/4/1] portmode fxs
    Warning: The operation will update the existing interface mode, 
              and delete the interface configurations.                    
    continue?[y/n]:y 
    [*PE2-Serial0/4/1] undo shutdown
    [*PE2-Serial0/4/1] fxs hotline enable
    [*PE2-Serial0/4/1] commit
    [~PE2-Serial0/4/1] quit

  3. Eseguire un IGP sulla rete backbone in modo che i dispositivi possano comunicare tra loro. Per i dettagli sulla configurazione, vedere "File di configurazione" in questa sezione.
  4. Configurare le funzioni di base MPLS sulla rete backbone e MPLS L2VPN su PE. Quindi, stabilire la relazione di peer MPLS LDP remoto tra i PE a entrambe le estremità di PW. Per i dettagli sulla configurazione, vedere "File di configurazione" in questa sezione.

    La relazione di peer MPLS LDP remoto deve essere stabilita solo quando viene stabilito PW dinamico.

  5. Configurare il protocollo di incapsulamento delle interfacce seriali come TDM.

    1. Configurare PE1.

      [~PE1] interface serial0/4/0
      [~PE1-Serial0/4/0] link-protocol tdm
      [*PE1-Serial0/4/0] quit
      [*PE1] commit
      
    2. Configurare PE2.

      [~PE2] interface serial0/4/1
      [~PE2-serial0/4/1] link-protocol tdm
      [*PE2-serial0/4/1] quit
      [*PE2] commit
      

  6. Configurare PW.

    1. Configurare PE1.

      [~PE1] pw-template 1to3
      [*PE1-pw-template-1to3] peer-address 192.168.3.3
      [*PE1-pw-template-1to3] jitter-buffer depth 8
      [*PE1-pw-template-1to3] tdm-encapsulation-number 24
      [*PE1-pw-template-1to3] quit
      [*PE1] commit
      [~PE1] interface serial0/4/0
      [~PE1-serial0/4/0] mpls l2vc pw-template 1to3 100 control-word 
      [*PE2-serial0/4/0] undo shutdown
      [*PE2-serial0/4/0] quit
      [*PE2] commit
      
    2. Configurare PE2.

      [~PE2] pw-template 3to1
      [*PE2-pw-template-3to1] peer-address 192.168.2.2
      [*PE2-pw-template-3to1] jitter-buffer depth 8
      [*PE2-pw-template-3to1] tdm-encapsulation-number 24
      [*PE2-pw-template-3to1] quit
      [*PE2] commit
      [~PE2] interface serial0/4/1
      [~PE2-serial0/4/1] mpls l2vc pw-template 3to1 100 control-word 
      [*PE2-serial0/4/1] undo shutdown
      [*PE2-serial0/4/1] quit
      [*PE2] commit
      

  7. Verificare la configurazione.

    Eseguire il comando display this interface su PE per visualizzare la configurazione e lo stato dell'interfaccia FXS.

    # PE1, output del comando

    [~PE1-Serial0/4/0] display this interface
    Serial0/4/0 current state : UP                                                  
    Line protocol current state : UP                                                                                                    
    Last line protocol up time : 2015-06-17 13:24:20                                                                                    
    Description:HUAWEI, Serial0/4/0 Interface                                                                                           
    Route Port,The Maximum Transmit Unit(L3) is 1500 bytes, Hold timer is 10(sec)                                                       
    Internet protocol processing : disabled                                                                                             
    Last physical up time   : 2015-06-17 13:24:20                                                                                       
    Last physical down time : 2015-06-17 13:24:20                                                                                       
    Current system time: 2015-06-17 13:24:23                                                                                            
    Physical layer is: FXS, loopback none                                                                                               
        Pcmcode: A-law, Current:16 mA                                                                                                   
        Impedance: 600 ohm, Hotline: ENABLE                                                                                             
        Receive gain: -7 dB, Send gain: 0 dB                                                                                            
    TDM statistics:                                                                                                                     
      Output error:                                                                                                                     
        0 Underrun Count , 0 Overrun Count                                                                                              
        0 LosPkts , 0 MisOrderPkts                                                                                                      
        0 MalformedPkts , 0 ErrorPkts                                                                                                   
        0 TotleErrorCur, 0 TotleErrorOld                                                                                                
        ES: 0 , SES: 0 , UAS: 0                                                                                                         
        Input bandwidth utilization  :    0%                                                                                            
        Output bandwidth utilization :    0%

    # L'output del comando di PE2

    [~PE2-Serial0/4/1] display this interface
    Serial0/4/1 current state : UP                                                  
    Line protocol current state : UP                                                
    Last line protocol up time : 2015-03-20 16:59:13                                
    Description:Huawei, Serial0/4/1 Interface                                       
    Route Port,The Maximum Transmit Unit is 1500, Hold timer is 10(sec)             
    Internet protocol processing : disabled                                         
    Last physical up time   : 2015-03-20 16:59:13                                   
    Last physical down time : 2015-03-20 16:57:39                                   
    Current system time: 2015-03-23 10:36:46                                        
    Physical layer is: FXS, loopback none                                           
        Pcm code: A-law                                                             
        DC impedance: 50 ohm, AC impedance: 600 ohm                                 
        Receive gain: 0 dB, Send gain: 5 dB                                         
      Output error:                                                                 
        0 Underrun Count , 0 Overrun Count                                          
        0 LosPkts , 0 MisOrderPkts                                                  
        0 MalformedPkts , 0 ErrorPkts                                               
        0 TotleErrorCur, 0 TotleErrorOld                                            
        ES: 0 , SES: 0 , UAS: 0                                                     
        Input bandwidth utilization  :    0%                                        
        Output bandwidth utilization :    0% 

    Eseguire il comando display mpls l2vc su PE. L'esempio seguente utilizza l'output del comando su PE1. L'output del comando mostra che lo stato di PW è Up.

    # PE1, output del comando

    <PE1> display mpls l2vc interface serial0/4/0
     *client interface       : serial0/4/0 is up
      Administrator PW       : no
      session state          : up
      AC state               : up
      VC state               : up
      Label state            : 0
      Token state            : 0
      VC ID                  : 100
      VC type                : CESoPSN basic mode
      destination            : 192.168.3.3
      local group ID         : 0            remote group ID      : 0
      local VC label         : 16           remote VC label      : 16
      TDM encapsulation number: 24
      jitter-buffer          : 8
      idle-code              : ff
      rtp-header             : enable
      local AC OAM State     : up
      local PSN OAM State    : up
      local forwarding state : forwarding
      local status code      : 0x0 
      remote AC OAM state    : up 
      remote PSN OAM state   : up 
      remote forwarding state: forwarding 
      remote status code     : 0x0
      ignore standby state   : no 
      Dynamic BFD for PW     : enable 
      Detect Multipier       : 3
      Min Transit Interval   : 1500
      Max Receive Interval   : 1500
      Dynamic BFD Session    : built
      BFD for PW             : unavailable
      VCCV State             : up
      manual fault           : not set
      active state           : active
      forwarding entry       : exist
      link state             : up
      local VC MTU           : 2000         remote VC MTU        : 1500
      local VCCV             : cw alert ttl lsp-ping bfd                     
      remote VCCV            : cw alert ttl lsp-ping bfd                     
      local control word     : enable       remote control word  : enable    
      tunnel policy name     : --                                           
      traffic behavior name  : --                                            
      PW template name       : 1to3                                           
      primary or secondary   : primary                                       
      load balance type      : flow                                          
      Access-port            : false                                         
      Switchover Flag        : false                                         
      VC tunnel/token info   : 1 tunnels/tokens                              
        NO.0  TNL type       : lsp   , TNL ID : 0x392                        
        Backup TNL type      : lsp   , TNL ID : 0x0                          
      create time            : 0 days, 18 hours, 36 minutes, 29 seconds      
      up time                : 0 days, 0 hours, 0 minutes, 32 seconds        
      last change time       : 0 days, 0 hours, 0 minutes, 32 seconds        
      VC last up time        : 2014/11/11 10:36:45                           
      VC total up time       : 0 days, 1 hours, 25 minutes, 31 seconds       
      CKey                   : 2                                             
      NKey                   : 1                                             
      PW redundancy mode     : frr                                           
      AdminPw interface      : --                                            
      AdminPw link state     : --                                            
      Diffserv Mode          : pipe                                          
      Service Class          : ef                                            
      Color                  : green                                         
      DomainId               : --                                            
      Domain Name            : --                                            
    

File di configurazione
  • File di configurazione PE1

    #
     sysname PE1
    #                       
     mpls lsr-id 192.168.2.2
     mpls
    #
     mpls l2vpn
    #
    pw-template 1to3
     peer-address 192.168.3.3
     jitter-buffer depth 8
     tdm-encapsulation-number 24
    #
    mpls ldp
    #
     mpls ldp remote-peer 192.168.3.3
     remote-ip 192.168.3.3 
    #
    interface serial0/4/0
    undo shutdown                
    link-protocol tdm
    portmode fxs
    fxs hotline enable
    mpls l2vc pw-template 1to3 100 control-word control-word
    #
    interface GigabitEthernet0/2/4
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    ospf 1
    area 0.0.0.0
      network 192.168.2.2 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    return
    
  • File di configurazione PE2

    #
     sysname PE2
    #           
     mpls lsr-id 192.168.3.3
     mpls
    #
     mpls l2vpn
    #
    pw-template 3to1
     peer-address 192.168.2.2
     jitter-buffer depth 8
     tdm-encapsulation-number 24
    #
    mpls ldp
    #
     mpls ldp remote-peer 192.168.2.2
     remote-ip 192.168.2.2
    #
    interface Serial0/4/1 
    undo shutdown 
    link-protocol tdm
    portmode fxs                                             
    fxs hotline enable
    mpls l2vc pw-template 3to1 100 control-word
    undo shutdown
    #
    interface GigabitEthernet0/2/0 
     undo shutdown
     ip address 10.2.2.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack0
     ip address 192.168.3.3 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 192.168.3.3 0.0.0.0
      network 10.2.2.0 0.0.0.255
    #
    return
    
  • P file di configurazione

    #
     sysname P
    #
     mpls lsr-id 192.168.4.4
     mpls
    #
    mpls ldp
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet0/2/1
     undo shutdown
     ip address 10.2.2.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack0
     ip address 192.168.4.4 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 192.168.4.4 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.2.0 0.0.0.255
    #
    return
    

Esempio per la configurazione della trasmissione trasparente dei servizi TDM su interfacce E&M

Le interfacce E&M sono utilizzate principalmente per trasmettere in modo trasparente i dati del servizio TDM in arrivo all'estremità remota.

Prodotti e versioni applicabili

Questa configurazione si applica ai prodotti della serie NE05E e 08E che eseguono V300R003C10 o versioni successive.

Requisiti di rete

Figura 1 mostra che l'interfaccia E&M di PE1 è collegata a un PBX. L'interfaccia E&M di PE2 è collegata a un altro PBX. PE1 e PE2 sono collegati tramite E1 o PWE3 per implementare la trasmissione trasparente su interfacce E&M.

Figura 1-54  Trasmissione trasparente del servizio TDM su interfacce E&M
NOTA:

In questo esempio, interface1, interface2, interface3, e interface4 si riferiscono a GE0/2/4, GE0/1/0, GE0/2/1, e GE0/2/0, rispettivamente.



Dispositivo

Interfaccia

PE1

GE0/2/4

E&M interfaccia

P

GE0/1/0

GE0/2/1

PE2

GE0/2/0

E&M interfaccia

Roadmap di configurazione

Per configurare un PW sulla rete PSN per trasmettere i servizi TDM, la roadmap di configurazione è la seguente:

  1. Configurare gli attributi fisici dell'interfaccia E&M di PE1.

  2. Configurare gli attributi fisici dell'interfaccia E&M di PE2.

  3. Abilitare un IGP sulla rete backbone affinché i dispositivi possano comunicare tra loro.

  4. Configurare le funzioni di base MPLS sulla rete backbone e MPLS L2VPN su PE. Quindi, stabilire una relazione di peer MPLS LDP remoto tra PE alle due estremità di PW.

  5. Configurare i parametri dell'interfaccia TDM.

  6. Configurare PW.

  7. Creare MPLS L2VC su PE.

Preparazione dei dati

Per completare la configurazione, sono necessari i seguenti dati:

No.

Dati

1

Modalità di segnalazione E&M di PE1 e PE2

2

Modalità di linea degli abbonati delle interfacce E&M

3

L2VC ID (deve essere lo stesso) su entrambe le estremità di PW

4

MPLS LSR ID di PE e P

5

Modalità di codifica e formato frame dell'interfaccia E1/CE1

Procedura

  1. Configurare gli attributi fisici dell'interfaccia E&M di PE1.

    <HUAWEI> system-view
    [~HUAWEI] sysname PE1
    [*HUAWEI] commit
    [~PE1]em signal-mode bell-5 card 1
    [*PE1]em userline 4wire card 1
    [*PE1]commit

  2. Configurare gli attributi fisici dell'interfaccia E&M di PE2.

    <HUAWEI> system-view
    [~HUAWEI] sysname PE2
    [*HUAWEI] commit
    [~PE2]em signal-mode bell-5 card 1
    [*PE2]em userline 4wire card 1
    [*PE2]commit

  3. Eseguire un IGP sulla rete backbone in modo che i dispositivi possano comunicare tra loro. Per i dettagli sulla configurazione, vedere "File di configurazione" in questa sezione.
  4. Configurare le funzioni di base MPLS sulla rete backbone e MPLS L2VPN su PE. Quindi, stabilire la relazione di peer MPLS LDP remoto tra i PE a entrambe le estremità di PW. Per i dettagli sulla configurazione, vedere "File di configurazione" in questa sezione.

    La relazione di peer MPLS LDP remoto deve essere stabilita solo quando viene stabilito PW dinamico.

  5. Configurare il protocollo di incapsulamento delle interfacce seriali come TDM.

    1. Configurare PE1.

      [~PE1] interface serial0/4/0
      [~PE1-Serial0/4/0] link-protocol tdm
      [*PE1-Serial0/4/0] quit
      [*PE1]commit
      
    2. Configurare PE2.

      [~PE2] interface serial0/4/1
      [~PE2-serial0/4/1] link-protocol tdm
      [*PE2-serial0/4/1] quit
      [*PE2]commit
      

  6. Configurare PW.

    1. Configurare PE1.

      [~PE1] pw-template 1to3
      [*PE1-pw-template-1to3] peer-address 192.168.3.3
      [*PE1-pw-template-1to3] jitter-buffer depth 8
      [*PE1-pw-template-1to3] tdm-encapsulation-number 24
      [*PE1-pw-template-1to3] quit
      [*PE1]commit
      [~PE1] interface serial0/4/0
      [~PE1-serial0/4/0] mpls l2vc pw-template 1to3 100 control-word 
      [*PE1-serial0/4/0] undo shutdown
      [*PE1-serial0/4/0] quit
      [*PE1]commit
      
    2. Configurare PE2.

      [~PE2] pw-template 3to1
      [*PE2-pw-template-3to1] peer-address 192.168.2.2
      [*PE2-pw-template-3to1] jitter-buffer depth 8
      [*PE2-pw-template-3to1] tdm-encapsulation-number 24
      [*PE2-pw-template-3to1] quit
      [*PE2]commit
      [~PE2] interface serial0/4/1
      [~PE2-serial0/4/1] mpls l2vc pw-template 3to1 100 control-word 
      [*PE2-serial0/4/1] undo shutdown
      [*PE2-serial0/4/1] quit
      [*PE2]commit
      

  7. Verificare la configurazione.

    Eseguire il comando display this interface su PE per visualizzare la configurazione di base e le statistiche dell'interfaccia Serial0/4/0.

    # PE1, output del comando

    [~PE1-Serial0/4/0] display this interface
    Serial0/4/0 current state : UP                                                  
    Line protocol current state : DOWN                                              
    Description:HUAWEI, Serial0/4/0 Interface                                       
    Route Port,The Maximum Transmit Unit is 2000, Hold timer is 10(sec)             
    Internet protocol processing : disabled                                         
    Last physical up time   : 2015-03-20 16:59:13                                   
    Last physical down time : 2015-03-20 16:57:39                                   
    Current system time: 2015-03-23 11:12:29                                        
    Physical layer is: E&M, loopback none                                          
        Pcm code: A-law, Signal mode: Bell-5                                        
        User line: 4 Wire, Passthrough: ENABLE                                      
        Receive gain: 0 dB, Send gain: 0 dB                                         
        Input bandwidth utilization  :    0%                                        
        Output bandwidth utilization :    0% 

    # L'output del comando di PE2

    [~PE2-Serial0/4/1] display this interface
    Serial0/4/1 current state : UP                                                  
    Line protocol current state : DOWN                                              
    Description:HUAWEI, Serial0/4/1 Interface                                       
    Route Port,The Maximum Transmit Unit is 2000, Hold timer is 10(sec)             
    Internet protocol processing : disabled                                         
    Last physical up time   : 2015-03-20 16:59:13                                   
    Last physical down time : 2015-03-20 16:57:39                                   
    Current system time: 2015-03-23 11:12:29                                        
    Physical layer is: E&M, loopback none                                          
        Pcm code: A-law, Signal mode: Bell-5                                        
        User line: 4 Wire, Passthrough: ENABLE                                      
        Receive gain: 0 dB, Send gain: 0 dB                                         
        Input bandwidth utilization  :    0%                                        
        Output bandwidth utilization :    0% 

    Eseguire il comando displaympls l2vc su PE. L'esempio seguente utilizza l'output del comando su PE1. L'output del comando mostra che lo stato di PW è Up.

    # PE1, output del comando

    <PE1> display mpls l2vc interface serial0/4/0
     *client interface       : serial0/4/0 is up
      Administrator PW       : no
      session state          : up
      AC state               : up
      VC state               : up
      Label state            : 0
      Token state            : 0
      VC ID                  : 100
      VC type                : CESoPSN basic mode
      destination            : 192.168.3.3
      local group ID         : 0            remote group ID      : 0
      local VC label         : 16           remote VC label      : 16
      TDM encapsulation number: 24
      jitter-buffer          : 8
      idle-code              : ff
      rtp-header             : enable
      local AC OAM State     : up
      local PSN OAM State    : up
      local forwarding state : forwarding
      local status code      : 0x0 
      remote AC OAM state    : up 
      remote PSN OAM state   : up 
      remote forwarding state: forwarding 
      remote status code     : 0x0
      ignore standby state   : no 
      Dynamic BFD for PW     : enable 
      Detect Multipier       : 3
      Min Transit Interval   : 1500
      Max Receive Interval   : 1500
      Dynamic BFD Session    : built
      BFD for PW             : unavailable
      VCCV State             : up
      manual fault           : not set
      active state           : active
      forwarding entry       : exist
      link state             : up
      local VC MTU           : 2000         remote VC MTU        : 1500
      local VCCV             : cw alert ttl lsp-ping bfd                     
      remote VCCV            : cw alert ttl lsp-ping bfd                     
      local control word     : enable       remote control word  : enable    
      tunnel policy name     : --                                           
      traffic behavior name  : --                                            
      PW template name       : 1to3                                           
      primary or secondary   : primary                                       
      load balance type      : flow                                          
      Access-port            : false                                         
      Switchover Flag        : false                                         
      VC tunnel/token info   : 1 tunnels/tokens                              
        NO.0  TNL type       : lsp   , TNL ID : 0x392                        
        Backup TNL type      : lsp   , TNL ID : 0x0                          
      create time            : 0 days, 18 hours, 36 minutes, 29 seconds      
      up time                : 0 days, 0 hours, 0 minutes, 32 seconds        
      last change time       : 0 days, 0 hours, 0 minutes, 32 seconds        
      VC last up time        : 2014/11/11 10:36:45                           
      VC total up time       : 0 days, 1 hours, 25 minutes, 31 seconds       
      CKey                   : 2                                             
      NKey                   : 1                                             
      PW redundancy mode     : frr                                           
      AdminPw interface      : --                                            
      AdminPw link state     : --                                            
      Diffserv Mode          : pipe                                          
      Service Class          : ef                                            
      Color                  : green                                         
      DomainId               : --                                            
      Domain Name            : --                                            
    

File di configurazione
  • File di configurazione PE1

    #
     sysname PE1
    #                       
     mpls lsr-id 192.168.2.2
     mpls
    #
     mpls l2vpn
    #
    pw-template 1to3
     peer-address 192.168.3.3
     jitter-buffer depth 8
     tdm-encapsulation-number 24
    #
    mpls ldp
    #
     mpls ldp remote-peer 192.168.3.3
     remote-ip 192.168.3.3 
    #
    interface serial0/4/0
     undo shutdown                
     link-protocol tdm
     mpls l2vc pw-template 1to3 100 control-word control-word
    #
    em signal-mode bell-5 card 1
    em userline 4wire card 1
    #
    interface GigabitEthernet0/2/4
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    ospf 1
    area 0.0.0.0
      network 192.168.2.2 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    return
    
  • File di configurazione PE2

    #
     sysname PE2
    #           
     mpls lsr-id 192.168.3.3
     mpls
    #
     mpls l2vpn
    #
    pw-template 3to1
     peer-address 192.168.2.2
     jitter-buffer depth 8
     tdm-encapsulation-number 24
    #
    mpls ldp
    #
     mpls ldp remote-peer 192.168.2.2
     remote-ip 192.168.2.2
    #
    interface Serial0/4/1 
     undo shutdown 
     link-protocol tdm
     mpls l2vc pw-template 3to1 100 control-word
    #
    em signal-mode bell-5 card 1
    em userline 4wire card 1
    #
    interface GigabitEthernet0/2/0 
     undo shutdown
     ip address 10.2.2.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack0
     ip address 192.168.3.3 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 192.168.3.3 0.0.0.0
      network 10.2.2.0 0.0.0.255
    #
    return
    
  • P file di configurazione

    #
     sysname P
    #
     mpls lsr-id 192.168.4.4
     mpls
    #
    mpls ldp
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet0/2/1
     undo shutdown
     ip address 10.2.2.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack0
     ip address 192.168.4.4 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 192.168.4.4 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.2.0 0.0.0.255
    #
    return
    

Esempio per la configurazione dell'interconnessione dell'interfaccia CPOS

Questa sezione fornisce un esempio su come collegare i dispositivi tramite interfacce CPOS e come configurare le interfacce di MP-group per il raggruppamento dei collegamenti.

Prodotti e versioni applicabili

Questo esempio di configurazione si applica ai prodotti della serie NE40E/ME60 con V800R010C00 o versioni successive.

Requisiti di rete

Sulla rete mostrata in Figura 1-55, Device A e Device B devono comunicare tra loro tramite le interfacce CPOS e le interfacce MP-group devono essere configurate per il collegamento dei collegamenti.

Figura 1-55  Configurazione dell'interconnessione interfaccia CPOS
NOTA:

In questo esempio, interface1 e interface2 rappresentano CPOS 0/3/0 e CPOS 0/5/0, rispettivamente.



Roadmap di configurazione

La roadmap di configurazione è seguente:

  1. Configurare una modalità di lavoro per le interfacce CPOS e canalizzarle in interfacce seriali sincrone.

  2. Configurare le interfacce di MP-group e aggiungere le interfacce seriali sincrone alle interfacce di MP-group.

Preparazione dei dati

Per completare la configurazione, sono necessari i seguenti dati:

  • Numero di canale e numero di tempo di ciascun canale E1

  • Indirizzi IP delle interfacce di MP-group

NOTA:

L'interfaccia da aggiungere a un'interfaccia MP-group deve avere lo stesso numero di slot e il numero di scheda dell'interfaccia di MP-group.

I canali del periodo di applicazione delle interfacce seriali su Device A devono essere uguali a quelli suDevice B.

Procedura

  1. Configurare una modalità di lavoro per le interfacce CPOS e canalizzarle in interfacce seriali sincrone.

    # Creare interfacce seriali sincrone sull'interfaccia CPOS di Device A.

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceA
    [*DeviceA] controller cpos 0/3/0
    [*DeviceA-Cpos0/3/0] e1 1 channel-set 1 timeslot-list 1-15
    [*DeviceA-Cpos0/3/0] e1 2 channel-set 1 timeslot-list 16-31
    [*DeviceA-Cpos0/3/0] undo shutdown
    [*DeviceA-Cpos0/3/0] commit
    [~DeviceA-Cpos0/3/0] quit

    # Creare interfacce seriali sincrone sull'interfaccia CPOS di Device B.

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceB
    [*DeviceB] controller cpos 0/5/0
    [*DeviceB-Cpos0/5/0] e1 1 channel-set 1 timeslot-list 1-15
    [*DeviceB-Cpos0/5/0] e1 2 channel-set 1 timeslot-list 16-31
    [*DeviceB-Cpos0/5/0] undo shutdown
    [*DeviceB-Cpos0/5/0] commit
    [~DeviceB-Cpos0/5/0] quit

  2. Configurare le interfacce di MP-group e aggiungere le interfacce seriali sincrone alle interfacce di MP-group.

    # Creare un'interfaccia MP-group su Device A.

    [~DeviceA] interface mp-group 0/3/0
    [*DeviceA-Mp-group0/3/0] ip address 10.1.1.1 255.255.255.0
    [*DeviceA-Mp-group0/3/0] undo shutdown
    [*DeviceA-Mp-group0/3/0] commit
    [~DeviceA-Mp-group0/3/0] quit

    # Aggiungere le interfacce seriali sincrone all'interfaccia MP-group su Device A.

    [~DeviceA] interface serial 0/3/0/1:1
    [~DeviceA-Serial0/3/0/1:1] link-protocol ppp
    [*DeviceA-Serial0/3/0/1:1] ppp mp mp-group 0/3/0
    [*DeviceA-Serial0/3/0/1:1] commit
    [~DeviceA-Serial0/3/0/1:1] quit
    [~DeviceA] interface serial 0/3/0/2:1
    [~DeviceA-Serial0/3/0/2:1] link-protocol ppp
    [*DeviceA-Serial0/3/0/2:1] ppp mp mp-group 0/3/0
    [*DeviceA-Serial0/3/0/2:1] commit
    [~DeviceA-Serial0/3/0/2:1] quit

    # Creare un'interfaccia di gruppo MP su Device B.

    [~DeviceB] interface mp-group 0/5/0
    [*DeviceB-Mp-group0/5/0] ip address 10.1.1.2 255.255.255.0
    [*DeviceB-Mp-group0/5/0] undo shutdown
    [*DeviceB-Mp-group0/5/0] commit
    [~DeviceB-Mp-group0/5/0] quit

    # Aggiungere le interfacce seriali sincrone all'interfaccia del gruppo MP Device B.

    [~DeviceB] interface serial 0/5/0/1:1
    [~DeviceB-Serial0/5/0/1:1] link-protocol ppp
    [*DeviceB-Serial0/5/0/1:1] ppp mp mp-group 0/5/0
    [*DeviceB-Serial0/5/0/1:1] commit
    [~DeviceB-Serial0/5/0/1:1] quit
    [~DeviceB] interface serial 0/5/0/2:1
    [~DeviceB-Serial0/5/0/2:1] link-protocol ppp
    [*DeviceB-Serial0/5/0/2:1] ppp mp mp-group 0/5/0
    [*DeviceB-Serial0/5/0/2:1] commit
    [~DeviceB-Serial0/5/0/2:1] quit

  3. Verificare la configurazione.

    # Device A, esegue il ping dell'indirizzo IP dell'interfaccia del gruppo MP su Device B. L'output del comando mostra che il ping ha avuto successo.

    [~DeviceA] ping 10.1.1.2
    PING 10.1.1.2: 56  data bytes, press CTRL_C to break
        Reply from 10.1.1.2: bytes=56 Sequence=1 ttl=255 time=29 ms
        Reply from 10.1.1.2: bytes=56 Sequence=2 ttl=255 time=31 ms
        Reply from 10.1.1.2: bytes=56 Sequence=3 ttl=255 time=29 ms
        Reply from 10.1.1.2: bytes=56 Sequence=4 ttl=255 time=30 ms
        Reply from 10.1.1.2: bytes=56 Sequence=5 ttl=255 time=30 ms
      --- 10.1.1.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 29/29/31 ms

File di configurazione
  • Device A file di configurazione

    #
    sysname DeviceA
    #
    controller Cpos0/3/0
     e1 1 channel-set 1 timeslot-list 1-15
     e1 2 channel-set 1 timeslot-list 16-31
     undo shutdown
    #
    interface Mp-group0/3/0
    #
    interface Serial0/3/0/1:1
     link-protocol ppp
     ppp mp Mp-group0/3/0
    #
    interface Serial0/3/0/2:1
     link-protocol ppp
     ppp mp Mp-group0/3/0
    #
    return
  • Device B file di configurazione

    #
    sysname DeviceB
    #
    controller Cpos0/5/0
     e1 1 channel-set 1 timeslot-list 1-15
     e1 2 channel-set 1 timeslot-list 16-31
     undo shutdown
    #
    interface Mp-group0/5/0
    #
    interface Serial0/5/0/1:1
     link-protocol ppp
     ppp mp Mp-group0/5/0
    #
    interface Serial0/5/0/2:1
     link-protocol ppp
     ppp mp Mp-group0/5/0
    #
    return

Esempio per la configurazione di un test PRBS

Questa sezione fornisce un esempio su come configurare un test PRBS per controllare la connettività dei dispositivi quando due dispositivi sono collegati tra loro tramite interfacce E1.

Prodotti e versioni applicabili

Questo esempio di configurazione si applica ai prodotti della serie NE40E/ME60 con V800R010C00 o versioni successive.

Requisiti di rete

Sulla rete mostrata in Figura 1-56, Device A eDevice B si connettono tra loro tramite le interfacce E1. È necessario eseguire un test PRBS per verificare la connettività tra i due dispositivi.

Figura 1-56  Diagramma di rete per la configurazione di un test PRBS
NOTA:

In questo esempio, interface1 e interface2 rappresentano E1 0/1/0 e E1 0/2/0, rispettivamente.



Roadmap di configurazione
La roadmap di configurazione è seguente:
  1. Creare un'interfaccia seriale sincrona su Device A eDevice B.
  2. Configurare loopback remoto sull'interfaccia E1 di Device B.
  3. Eseguire un test PRBS su Device A.
  4. Controllare il risultato del test PRBS su Device A.
  5. Al completamento del test PRBS, annullare la configurazione remota del loopback nell'interfaccia E1 di Device B.
Preparazione dei dati

Per completare la configurazione, sono necessari i seguenti dati:

  • E1 numero di interfaccia di Device A

  • E1 numero di interfaccia di Device B

Procedura

  1. Creare un'interfaccia seriale sincrona su Device A eDevice B.

    # Configurare l'interfaccia E1 su Device A come interfaccia seriale sincrona.

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceA
    [*HUAWEI] commit
    [~DeviceA] controller e1 0/1/0
    [~DeviceA-E1 0/1/0] channel-set 1 timeslot-list 1-31
    [*DeviceA-E1 0/1/0] commit
    [~DeviceA-E1 0/1/0] quit
    

    # Configurare l'interfaccia E1 su Device B come interfaccia seriale sincrona.

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceB
    [*HUAWEI] commit
    [~DeviceB] controller e1 0/2/0
    [~DeviceB-E1 0/2/0] channel-set 1 timeslot-list 1-31
    [*DeviceB-E1 0/2/0] commit
    [~DeviceB-E1 0/2/0] quit
    

  2. Configurare loopback remoto sull'interfaccia E1 di Device B.

    [~DeviceB] controller e1 0/2/0
    [~DeviceB-E1 0/2/0] loopback remote
    [*DeviceB-E1 0/2/0] commit
    [~DeviceB-E1 0/2/0] quit
    

  3. Eseguire un test PRBS su Device A.

    [~DeviceA] interface serial 0/1/0:1
    [~DeviceA-Serial0/1/0:1] link-protocol tdm
    [*DeviceA-Serial0/1/0:1] commit
    [~DeviceA-Serial0/1/0:1] quit
    [~DeviceA] test connectivity interface Serial0/1/0:1 uni-direction pattern prbs15 interval second 20 interval-repeat 5

  4. Controllare il risultato del test PRBS su Device A.

    [~DeviceA] display connectivity-test interface serial 0/1/0:1
    Summary:
    Start time           Side  Pattern  Phy-port   Total time (Interval*Round)
    2018-08-10 16:12:46  UNI   PRBS15   E1 0/1/0   00:01:40 (20s*5)
    Total bits     Error bits     BER   LOS      Test progress
    198400000      0              0e-0  0s       100%(00:01:40)finished
    Details:
    Round  Total bits   Error bits   BER   LOS     ES      EFS     SES     UAS
    1      39680000     0            0e-0  0s      0s      20s     0s      0s
    2      39680000     0            0e-0  0s      0s      20s     0s      0s
    3      39680000     0            0e-0  0s      0s      20s     0s      0s
    4      39680000     0            0e-0  0s      0s      20s     0s      0s
    5      39680000     0            0e-0  0s      0s      20s     0s      0s
    Error Bits Insert Record (Latest 10):
    Start time           Type        BER   Duration  Insert in round
    

  5. Al completamento del test PRBS, annullare la configurazione remota del loopback nell'interfaccia E1 di Device B.

    [~DeviceB] controller e1 0/2/0
    [~DeviceB-E1 0/2/0] undo loopback
    [*DeviceB-E1 0/2/0] commit
    [~DeviceB-E1 0/2/0] quit
    

File di configurazione
  • Device A file di configurazione

    #
    sysname DeviceA
    #
    controller E1 0/1/0
     channel-set 1 timeslot-list 1-31
    #
    interface Serial0/1/0:1
     link-protocol tdm
    #
     test connectivity interface Serial0/1/0:1 uni-direction pattern prbs15 interval second 20 interval-repeat 5
    #
    return
  • Device B file di configurazione

    #
    sysname DeviceB
    #
    controller E1 0/2/0
     channel-set 1 timeslot-list 1-31
    #
    controller E1 0/2/0
     loopback remote
    #
    controller E1 0/2/0
     undo loopback
    #
    return

Configurazione dell'interconnessione interfaccia CE1

Questa sezione fornisce un esempio su come collegare i dispositivi tramite interfacce CE1.

Prodotti e versioni applicabili

Questo esempio di configurazione si applica ai prodotti della serie NE40E/ME60 che eseguono V800R010C00 o versioni successive.

Requisiti di rete

Sulla rete mostrata in Figura 1-57, Device A and Device B devono comunicare tra loro tramite le interfacce CE1.

Figura 1-57  Interconnessione interfaccia CE1
NOTA:

In questo esempio, interface1 e interface2 si riferiscono CE1 0/1/0 e CE1 0/2/0, rispettivamente.



Roadmap di configurazione
La roadmap di configurazione è seguente:
  1. Creare interfacce seriali sincrone.
  2. Configurare gli indirizzi IP per le interfacce seriali sincrone.
  3. Riavviare tutte le interfacce per rendere effettiva la configurazione.
Preparazione dei dati

Per completare la configurazione, sono necessari i seguenti dati:

  • Numero di interfaccia CE1 di Device A

  • Numero di interfaccia CE1 di Device B

  • Indirizzo IP dell'interfaccia seriale sincrona attivata Device A

  • Indirizzo IP dell'interfaccia seriale sincrona attivata Device B

NOTA:

I canali del periodo di applicazione delle interfacce seriali su Device A devono essere uguali a quelli su Device B.

Procedura

  1. Creare interfacce seriali sincrone.

    # Configurare l'interfaccia CE1 su Device A come interfaccia seriale sincrona.

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceA
    [*HUAWEI] commit
    [~DeviceA] controller e1 0/1/0
    [~DeviceA-E1 0/1/0] channel-set 1 timeslot-list 1-15
    [*DeviceA-E1 0/1/0] commit
    [~DeviceA-E1 0/1/0] quit
    

    # Configurare l'interfaccia CE1 su Device B come interfaccia seriale sincrona.

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceB
    [*HUAWEI] commit
    [~DeviceB] controller e1 0/2/0
    [~DeviceB-E1 0/2/0] channel-set 1 timeslot-list 1-15
    [*DeviceB-E1 0/2/0] commit
    [~DeviceB-E1 0/2/0] quit
    

  2. Configurare gli indirizzi IP per le interfacce seriali sincrone.

    # Configurare un indirizzo IP per l'interfaccia seriale sincrona su Device A.

    [~DeviceA] interface serial 0/1/0:1
    [~DeviceA-Serial0/1/0:1] link-protocol ppp
    [*DeviceA-Serial0/1/0:1] ip address 10.1.1.1 255.255.255.0
    [*DeviceA-Serial0/1/0:1] shutdown
    [*DeviceA-Serial0/1/0:1] commit
    [~DeviceA-Serial0/1/0:1] quit
    

    # Configurare un indirizzo IP per l'interfaccia seriale sincrona su Device B.

    [~DeviceB] interface serial 0/2/0:1
    [~DeviceB-Serial0/2/0:1] link-protocol ppp
    [*DeviceB-Serial0/2/0:1] ip address 10.1.1.2 255.255.255.0
    [*DeviceB-Serial0/2/0:1] shutdown
    [*DeviceB-Serial0/2/0:1] commit
    [~DeviceB-Serial0/2/0:1] quit
    

  3. Riavviare tutte le interfacce per rendere effettiva la configurazione.

    # Riavviare l'interfaccia seriale sincrona Device A.

    [~DeviceA] interface serial 0/1/0:1
    [~DeviceA-Serial0/1/0:1] undo shutdown
    [*DeviceA-Serial0/1/0:1] commit
    [~DeviceA-Serial0/1/0:1] quit
    

    # Riavviare l'interfaccia seriale sincrona su Device B.

    [~DeviceB] interface serial 0/2/0:1
    [~DeviceB-Serial0/2/0:1] undo shutdown
    [*DeviceB-Serial0/2/0:1] commit
    [~DeviceB-Serial0/2/0:1] quit
    

  4. Verificare la configurazione.

    # Su Device A eseguire il ping dell'indirizzo IP dell'interfaccia seriale sincrona suDevice B. L'output del comando mostra che il ping è successo.

    [~DeviceA] ping 10.1.1.2
    PING 10.1.1.2: 56  data bytes, press CTRL_C to break
        Reply from 10.1.1.2: bytes=56 Sequence=1 ttl=255 time=29 ms
        Reply from 10.1.1.2: bytes=56 Sequence=2 ttl=255 time=31 ms
        Reply from 10.1.1.2: bytes=56 Sequence=3 ttl=255 time=29 ms
        Reply from 10.1.1.2: bytes=56 Sequence=4 ttl=255 time=30 ms
        Reply from 10.1.1.2: bytes=56 Sequence=5 ttl=255 time=30 ms
      --- 10.1.1.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 29/29/31 ms

File di configurazione
  • Device A file di configurazione

    #
    sysname DeviceA
    #
    controller E1 0/1/0
     channel-set 1 timeslot-list 1-15
    #
    interface Serial0/1/0:1
     link-protocol ppp
     ip address 10.1.1.1 255.255.255.0
     undo shutdown
    #
    return
  • Device B file di configurazione

    #
    sysname DeviceB
    #
    controller E1 0/2/0
     channel-set 1 timeslot-list 1-15
    #
    interface Serial0/2/0:1
     link-protocol ppp
     ip address 10.1.1.2 255.255.255.0
     undo shutdown
    #
    return

Esempio per la configurazione dell'interconnessione interfaccia E1

Questa sezione fornisce un esempio su come interconnettere i dispositivi tramite interfacce E1.

Prodotti e versioni applicabili

Questo esempio di configurazione si applica ai prodotti della serie NE40E/ME60 con V800R010C00 o versioni successive.

Requisiti di rete

Sulla rete mostrata in Figura 1-58, Device A eDevice B devono comunicare tra loro tramite le interfacce E1.

Figura 1-58  Interconnessione interfaccia E1
NOTA:

In questo esempio, interface1 e interface2 si riferiscono E1 0/1/0 e E1 0/2/0, rispettivamente.



Roadmap di configurazione
La roadmap di configurazione è seguente:
  1. Creare interfacce seriali sincrone.
  2. Configurare gli indirizzi IP per le interfacce seriali sincrone.
  3. Riavviare tutte le interfacce per rendere effettiva la configurazione.
Preparazione dei dati

Per completare la configurazione, sono necessari i seguenti dati:

  • E1 numero di interfaccia di Device A

  • E1 numero di interfaccia di Device B

  • Indirizzo IP dell'interfaccia seriale sincrona attivata Device A

  • Indirizzo IP dell'interfaccia seriale sincrona attivata Device B

Procedura

  1. Creare un'interfaccia seriale sincrona su Device A.

    # Configurare l'interfaccia E1 su Device A come interfaccia seriale sincrona.

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceA
    [*HUAWEI] commit
    [~DeviceA] controller e1 0/1/0
    [~DeviceA-E1 0/1/0] using e1
    [*DeviceA-E1 0/1/0] commit
    [~DeviceA-E1 0/1/0] quit
    

    # Configurare l'interfaccia E1 su Device B come interfaccia seriale sincrona.

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceB
    [*HUAWEI] commit
    [~DeviceB] controller e1 0/2/0
    [~DeviceB-E1 0/2/0] using e1
    [*DeviceB-E1 0/2/0] commit
    [~DeviceB-E1 0/2/0] quit
    

  2. Configurare gli indirizzi IP per le interfacce seriali sincrone.

    # Configurare un indirizzo IP per l'interfaccia seriale sincrona su Device A.

    [~DeviceA] interface serial 0/1/0:0
    [~DeviceA-Serial0/1/0:0] link-protocol ppp
    [*DeviceA-Serial0/1/0:0] ip address 10.1.1.1 255.255.255.0
    [*DeviceA-Serial0/1/0:0] shutdown
    [*DeviceA-Serial0/1/0:0] commit
    [~DeviceA-Serial0/1/0:0] quit
    

    # Configurare un indirizzo IP per l'interfaccia seriale sincrona su Device B.

    [~DeviceB] interface serial 0/2/0:0
    [~DeviceB-Serial0/2/0:0] link-protocol ppp
    [*DeviceB-Serial0/2/0:0] ip address 10.1.1.2 255.255.255.0
    [*DeviceB-Serial0/2/0:0] shutdown
    [*DeviceB-Serial0/2/0:0] commit
    [~DeviceB-Serial0/2/0:0] quit
    

  3. Riavviare tutte le interfacce per rendere effettiva la configurazione.

    # Riavviare l'interfaccia seriale sincrona su Device A.

    [~DeviceA] interface serial 0/1/0:0
    [~DeviceA-Serial0/1/0:0] undo shutdown
    [*DeviceA-Serial0/1/0:0] commit
    [~DeviceA-Serial0/1/0:0] quit
    

    # Riavviare l'interfaccia seriale sincrona su Device B.

    [~DeviceB] interface serial 0/2/0:0
    [~DeviceB-Serial0/2/0:0] undo shutdown
    [*DeviceB-Serial0/2/0:0] commit
    [~DeviceB-Serial0/2/0:0] quit
    

  4. Verificare la configurazione.

    # In Device A, eseguire il ping dell'indirizzo IP dell'interfaccia seriale sincrona suDevice B. L'output del comando mostra che il ping ha avuto successo.

    [~DeviceA] ping 10.1.1.2
    PING 10.1.1.2: 56  data bytes, press CTRL_C to break
        Reply from 10.1.1.2: bytes=56 Sequence=1 ttl=255 time=29 ms
        Reply from 10.1.1.2: bytes=56 Sequence=2 ttl=255 time=31 ms
        Reply from 10.1.1.2: bytes=56 Sequence=3 ttl=255 time=29 ms
        Reply from 10.1.1.2: bytes=56 Sequence=4 ttl=255 time=30 ms
        Reply from 10.1.1.2: bytes=56 Sequence=5 ttl=255 time=30 ms
      --- 10.1.1.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 29/29/31 ms

File di configurazione
  • Device A file di configurazione

    #
    sysname DeviceA
    #
    controller E1 0/1/0
     using e1
     undo shutdown
    #
    interface Serial0/1/0:0
     link-protocol ppp
     ip address 10.1.1.1 255.255.255.0
     undo shutdown
    #
    return
  • Device B file di configurazione

    #
    sysname DeviceB
    #
    controller E1 0/2/0
     using e1
     undo shutdown
    #
    interface Serial0/2/0:0
     link-protocol ppp
     ip address 10.1.1.2 255.255.255.0
     undo shutdown
    #
    return

Esempio per la configurazione di MP-group

Quando due dispositivi si connettono tra loro attraverso interfacce E1, queste interfacce E1 possono essere aggiunte ai gruppi MP per aumentare la larghezza di banda disponibile. Questa sezione fornisce un esempio su come configurare MP-group.

Prodotti e versioni applicabili

Questo esempio di configurazione si applica ai prodotti della serie NE40E/ME60 con V800R010C00 o versioni successive.

Requisiti di rete

Sulla rete mostrata in Figura 1-59, Device A e Device B si connettono tra loro tramite due coppie di interfacce E1

A volte un singolo collegamento non può supportare la trasmissione dei dati quando i servizi sono occupati. Per aumentare rapidamente, in modo efficiente e sicuro la larghezza di banda disponibile per la trasmissione dei dati, è possibile utilizzare MP-group.

Figura 1-59  Aggiungere le interfacce E1 a MP-group
NOTA:

In questo esempio, interface1, interface2, interface3, e interface4 rappresentano E1 0/1/0, E1 0/1/1, E1 0/2/0, e E1 0/2/1 rispettivamente.



Roadmap di configurazione
La roadmap di configurazione è seguente:
  1. Creare interfacce di MP-group.
  2. Creare interfacce seriali sincrone e aggiungere le interfacce alle interfacce di MP-group
  3. Riavviare tutte le interfacce per rendere effettiva la configurazione.
Preparazione dei dati

Per completare la configurazione, sono necessari i seguenti dati:

  • Indirizzo IP dell'interfaccia di MP-group su Device A

  • Indirizzo IP dell'interfaccia di MP-group su Device B

  • Numeri di interfaccia E1 di Device A

  • Numeri di interfaccia E1 di Device B

NOTA:

L'interfaccia da aggiungere all'interfaccia di MP-group deve avere lo stesso numero di slot e il numero di scheda dell'interfaccia di MP-group.

I canali del periodo di applicazione delle interfacce seriali su Device A devono essere uguali a quelli suDevice B.

Procedura

  1. Creare interfacce di MP-group.

    # Creare un'interfaccia MP-group e configurare un indirizzo IP per esso su Device A.

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceA
    [*HUAWEI] commit
    [~DeviceA] interface mp-group 0/1/1
    [*DeviceA-Mp-group0/1/1] ip address 10.1.1.1 255.255.255.0
    [*DeviceA-Mp-group0/1/1] shutdown
    [*DeviceA-Mp-group0/1/1] commit
    [~DeviceA-Mp-group0/1/1] quit

    # Creare un'interfaccia MP-group e configurare un indirizzo IP per esso su Device B.

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceB
    [*HUAWEI] commit
    [~DeviceB] interface mp-group 0/2/1
    [*DeviceB-Mp-group0/2/1] ip address 10.1.1.2 255.255.255.0
    [*DeviceB-Mp-group0/2/1] shutdown
    [*DeviceB-Mp-group0/2/1] commit
    [~DeviceB-Mp-group0/2/1] quit

  2. Creare interfacce seriali sincrone e aggiungere le interfacce alle interfacce di MP-group

    # Configurare le interfacce E1 di Device A come interfacce seriali sincrone e aggiungerle all'interfaccia di MP-group.

    [~DeviceA] controller e1 0/1/0
    [~DeviceA-E1 0/1/0] channel-set 1 timeslot-list 1-15
    [*DeviceA-E1 0/1/0] commit
    [~DeviceA-E1 0/1/0] quit
    [~DeviceA] controller e1 0/1/1
    [~DeviceA-E1 0/1/1] channel-set 1 timeslot-list 16-31
    [*DeviceA-E1 0/1/1] commit
    [~DeviceA-E1 0/1/1] quit
    [~DeviceA] interface serial 0/1/0:1
    [~DeviceA-Serial0/1/0:1] link-protocol ppp
    [*DeviceA-Serial0/1/0:1] ppp mp mp-group 0/1/1
    [*DeviceA-Serial0/1/0:1] commit
    [~DeviceA-Serial0/1/0:1] quit
    [~DeviceA] interface serial 0/1/1:1
    [~DeviceA-Serial0/1/1:1] link-protocol ppp
    [*DeviceA-Serial0/1/1:1] ppp mp mp-group 0/1/1
    [*DeviceA-Serial0/1/1:1] commit
    [~DeviceA-Serial0/1/1:1] quit

    # Configurare le interfacce E1 di Device B come interfacce seriali sincrone e aggiungerle all'interfaccia di MP-group.

    [~DeviceB] controller e1 0/2/0
    [~DeviceB-E1 0/2/0] channel-set 1 timeslot-list 1-15
    [*DeviceB-E1 0/2/0] commit
    [~DeviceB-E1 0/2/0] quit
    [~DeviceB] controller e1 0/2/1
    [~DeviceB-E1 0/2/1] channel-set 1 timeslot-list 16-31
    [*DeviceB-E1 0/2/1] commit
    [~DeviceB-E1 0/2/1] quit
    [~DeviceB] interface serial 0/2/0:1
    [~DeviceB-Serial0/2/0:1] link-protocol ppp
    [*DeviceB-Serial0/2/0:1] ppp mp mp-group 0/2/1
    [*DeviceB-Serial0/2/0:1] commit
    [~DeviceB-Serial0/2/0:1] quit
    [~DeviceB] interface serial 0/2/1:1
    [~DeviceB-Serial0/2/1:1] link-protocol ppp
    [*DeviceB-Serial0/2/1:1] ppp mp mp-group 0/2/1
    [*DeviceB-Serial0/2/1:1] commit
    [~DeviceB-Serial0/2/1:1] quit

  3. Riavviare tutte le interfacce per rendere effettiva la configurazione.

    # Riavviare le interfacce sincrona seriale e MP-group su Device A.

    [~DeviceA] interface serial 0/1/0:1
    [~DeviceA-Serial0/1/0:1] undo shutdown
    [*DeviceA-Serial0/1/0:1] commit
    [~DeviceA-Serial0/1/0:1] quit
    [~DeviceA] interface serial 0/1/1:1
    [~DeviceA-Serial0/1/1:1] undo shutdown
    [*DeviceA-Serial0/1/1:1] commit
    [~DeviceA-Serial0/1/1:1] quit
    [~DeviceA] interface mp-group 0/1/1
    [~DeviceA-Mp-group0/1/1] undo shutdown
    [*DeviceA-Mp-group0/1/1] commit
    [~DeviceA-Mp-group0/1/1] quit

    # Riavviare le interfacce sincrona seriale e MP-group Device B.

    [~DeviceB] interface serial 0/2/0:1
    [~DeviceB-Serial0/2/0:1] undo shutdown
    [*DeviceB-Serial0/2/0:1] commit
    [~DeviceB-Serial0/2/0:1] quit
    [~DeviceB] interface serial 0/2/1:1
    [~DeviceB-Serial0/2/1:1] undo shutdown
    [*DeviceB-Serial0/2/1:1] commit
    [~DeviceB-Serial0/2/1:1] quit
    [~DeviceB] interface mp-group 0/2/1
    [~DeviceB-Mp-group0/2/1] undo shutdown
    [*DeviceB-Mp-group0/2/1] commit
    [~DeviceB-Mp-group0/2/1] quit

  4. Verificare la configurazione.

    # Su Device A, controllare le informazioni sull'interfaccia del gruppo MP e le statistiche sui pacchetti inviati e ricevuti dall'interfaccia di MP-group.

    [~DeviceA] display ppp mp interface mp-group 0/1/1
    Mp-group is Mp-group0/1/1
     ===========Sublinks status begin======
     Serial0/1/0:1 physical UP,protocol UP
     Serial0/1/1:1 physical UP,protocol UP
     ===========Sublinks status end========
     Bundle Multilink, 2 member, slot 1, Master link is Mp-group0/1/1
      0 lost fragments, 0 reordered, 0 unassigned, 0 interleaved,
     sequence 0/0 rcvd/sent
     The bundled son channels are:
          Serial0/1/0:1
          Serial0/1/1:1 

    # Su Device B, controllare le informazioni sull'interfaccia del gruppo MP e le statistiche sui pacchetti inviati e ricevuti dall'interfaccia di MP-group.

    [~DeviceB] display ppp mp interface mp-group 0/2/1
    Mp-group is Mp-group0/2/1
     ===========Sublinks status begin======
     Serial0/2/0:1 physical UP,protocol UP
     Serial0/2/1:1 physical UP,protocol UP
     ===========Sublinks status end========
     Bundle Multilink, 2 member, slot 2, Master link is Mp-group0/2/1
      0 lost fragments, 0 reordered, 0 unassigned, 0 interleaved,
     sequence 0/0 rcvd/sent
     The bundled son channels are:
          Serial0/2/0:1
          Serial0/2/1:1 

    # Device A, eseguire il ping dell'indirizzo IP dell'interfaccia di MP-group su 0/2/1 B. L'output del comando mostra che il ping ha avuto successo.

    [~DeviceA] ping 10.1.1.2
    PING 10.1.1.2: 56  data bytes, press CTRL_C to break
        Reply from 10.1.1.2: bytes=56 Sequence=1 ttl=255 time=29 ms
        Reply from 10.1.1.2: bytes=56 Sequence=2 ttl=255 time=31 ms
        Reply from 10.1.1.2: bytes=56 Sequence=3 ttl=255 time=29 ms
        Reply from 10.1.1.2: bytes=56 Sequence=4 ttl=255 time=30 ms
        Reply from 10.1.1.2: bytes=56 Sequence=5 ttl=255 time=30 ms
      --- 10.1.1.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 29/29/31 ms

File di configurazione
  • Device A file di configurazione

    #
    sysname DeviceA
    #
    controller E1 0/1/0
     channel-set 1 timeslot-list 1-15
    #
    interface Serial0/1/0:1
     undo shutdown
     link-protocol ppp
     ppp mp Mp-group0/1/1
    #
    controller E1 0/1/1
     channel-set 1 timeslot-list 16-31
    #
    interface Serial0/1/1:1
     undo shutdown
     link-protocol ppp
     ppp mp Mp-group0/1/1  
    #
    interface Mp-group0/1/1
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
    #
    return
  • Device B file di configurazione

    #
    sysname DeviceB
    #
    controller E1 0/2/0
     channel-set 1 timeslot-list 1-15
    #
    interface Serial0/2/0:1
     undo shutdown
     link-protocol ppp
     ppp mp Mp-group0/2/1
    #
    controller E1 0/2/1
     channel-set 1 timeslot-list 16-31
    #
    interface Serial0/2/1:1
     undo shutdown
     link-protocol ppp
     ppp mp Mp-group0/2/1  
    #
    interface Mp-group0/2/1
     undo shutdown
     ip address 10.1.1.2 255.255.255.0
    #
    return
Download
Updated: 2019-05-16

N. documento: EDOC1100082601

Visualizzazioni:797

Download: 2

Average rating:
This Document Applies to these Products
Documenti correlati
Related Version
Share
Precedente Avanti