Для выбранного языка не найдены ресурсы переадресации.

Этот веб-сайт использует cookie-файлы. Продолжая просмотр, вы соглашаетесь на их использование. Ознакомьтесь с нашей политикой соблюдения конфиденциальности.>

Меню

Типичные примеры настройки WLAN

Rate and give feedback:
Информация об этом переводе
Чтобы помочь вам лучше понять содержимое этого документа, компания Huawei перевела его на разные языки, используя машинный перевод, отредактированный людьми. Примечание: даже самые передовые программы машинного перевода не могут обеспечить качество на уровне перевода, выполненного профессиональным переводчиком. Компания Huawei не несет ответственность за точность перевода и рекомендует ознакомиться с документом на английском языке (по ссылке, которая была предоставлена ранее).
Пример настройки прохождения NAT (NAT-T) между AC и AP

Пример настройки прохождения NAT (NAT-T) между AC и AP

Требования к службе

Пользователи предприятия могут получить доступ к сети через WLAN, что является основным требованием мобильного офиса. Кроме того, службы пользователей не затрагиваются во время роуминга в зоне покрытия.

АР находятся в филиале предприятия, а АС - в головном офисе. Администраторы требуют единого управления AP с помощью AC. Таким образом, NAT-T настраивается между AC и AP для сохранения общедоступных IP-адресов предприятия.

Требования к сети

  • Режим сети AC: NAT-T между AC в головном офисе и точками доступа (AP) в филиале
  • Режим развертывания DHCP: Router_1 функционирует как DHCP-сервер, чтобы назначить IP-адреса для AP и STA.
  • Режим переадресации сервисных данных: прямая переадресация
Рис. 3-20 Сеть для настройки прохождения NAT (NAT-T) между AC и AP

План данных

Табл. 3-20 План данных AC
Пункт Данные

Управляющая VLAN для AP

VLAN 200

Сервисная VLAN для STA

VLAN 101

DHCP-сервер

Router_1 функционирует как DHCP-сервер, чтобы назначить IP-адреса для AP и STA.

Пул IP-адресов для AP

10.23.100.2-10.23.100.254/24

Пул IP-адресов для STA

10.23.101.2-10.23.101.254/24

Адрес исходного интерфейса AC

VLANIF 200: 10.23.200.1/24

Группа AP

  • Имя: ap-group1

  • Ссылочные профили: Профиль VAP wlan-net и профиль регулятивного домена default

Профиль регулятивного домена

  • Имя: default
  • Код страны: CN

Профиль SSID

  • Имя: wlan-net

  • Имя SSID: wlan-net

Профиль безопасности

  • Имя: wlan-net

  • Политика безопасности: WPA-WPA2+PSK+AES

  • Пароль: a1234567

Профиль VAP

  • Имя: wlan-net

  • Режим переадресации: прямая переадресация

  • Сервисная VLAN: VLAN 101

  • Ссылочные профили: Профиль SSID wlan-net и профиль безопасности wlan-net

NAT Outbound

Router_1: переводит частные IP-адреса в сегменте сети 10.23.100.0/24 на общедоступные IP-адреса в сегменте сети 2.2.2.1.

Статический NAT

Router_2: переводит частные IP-адреса в сегменте сети 10.23.200.1 на общедоступные IP-адреса в сегменте сети 3.3.3.3.

Схема настройки

  1. Настройте сетевое взаимодействие AC, AP и других сетевых устройств.
  2. Настройте NAT для преобразования адресов.
  3. Настройте AP для входа в сеть.
    1. Создайте группу AP и добавьте AP, для которых требуется единообразная конфигурация группы для унифицированной конфигурации.
    2. Настройте системные параметры AC, включая код страны и исходный интерфейс, используемые AC для связи с AP.
    3. Настройте режим аутентификации AP и импортируйте AP в автономном режиме, чтобы позволить AP входить в сеть.
  4. Настройте параметры службы WLAN для STA в целях доступа к WLAN.

Примечания по конфигурации

  • Механизм ACK не предусмотрен для многоадресной передачи пакетов на воздушных интерфейсах. Кроме того, беспроводные каналы нестабильны. Для обеспечения стабильной передачи многоадресных пакетов они обычно отправляются по низким тарифам. Если большое количество таких многоадресных пакетов отправляется с сетевой стороны, воздушные интерфейсы могут быть перегружены. Рекомендуется настроить подавление многоадресных пакетов, чтобы уменьшить влияние большого количества низкоскоростных многоадресных пакетов на беспроводную сеть. Соблюдайте осторожность при настройке ограничения скорости; в противном случае могут быть затронуты многоадресные услуги.
    • В режиме прямой переадресации рекомендуется настроить подавление многоадресных пакетов на интерфейсах коммутатора, подключенных к точкам доступа (AP).
    • В режиме туннельной переадресации рекомендуется настроить подавление многоадресных пакетов в профилях трафика AC.
    Подробнее о том, как настроить подавление трафика, см. Подавление многоадресных пакетов не настроено, что приводит к замедлению доступа к сети STA.
  • Настройте изоляцию портов на интерфейсах устройства, напрямую подключенного к точкам доступа. Если изоляция порта не настроена и используется прямая переадресация, в VLAN может быть создано большое количество ненужных широковещательных пакетов, блокирующих сеть и ухудшающих работу пользователя.

  • В режиме туннельной переадресации управляющая VLAN и сервисная VLAN не могут быть одинаковыми. Только пакеты из управляющей VLAN передаются между AC и AP. Пакеты из сервисной VLAN не допускаются между AC и AP.

Процедура

  1. Настройте сетевые устройства.

    # На Switch добавьте GE0/0/1, GE0/0/2, GE0/0/3 к VLAN 100 и VLAN 101. VLAN 100 является VLAN по умолчанию GE0/0/1 и GE0/0/2.
    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 100 101
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type trunk
    [Switch-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [Switch-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 101
    [Switch-GigabitEthernet0/0/1] port-isolate enable
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type trunk
    [Switch-GigabitEthernet0/0/2] port trunk pvid vlan 100
    [Switch-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 101
    [Switch-GigabitEthernet0/0/2] port-isolate enable
    [Switch-GigabitEthernet0/0/2] quit
    [Switch] interface gigabitethernet 0/0/3
    [Switch-GigabitEthernet0/0/3] port link-type trunk
    [Switch-GigabitEthernet0/0/3] port trunk allow-pass vlan 100 101
    [Switch-GigabitEthernet0/0/3] quit
    
    # На Router_1 добавьте GE1/0/0 к VLAN 100 и VLAN 101. Если одноранговый конец GE0/0/1 находится в 2.2.2.2/24, установите IP-адрес GE0/0/1 на 2.2.2.1/24.
    <Huawei> system-view
    [Huawei] sysname Router_1
    [Router_1] vlan batch 100 101
    [Router_1] interface gigabitethernet1/0/0
    [Router_1-GigabitEthernet1/0/0] port link-type trunk
    [Router_1-GigabitEthernet1/0/0] port trunk allow-pass vlan 100 to 101
    [Router_1-GigabitEthernet1/0/0] quit
    [Router_1] interface gigabitethernet0/0/1
    [Router_1-GigabitEthernet0/0/1] ip address 2.2.2.1 255.255.255.0
    [Router_1-GigabitEthernet0/0/1] quit
    # Настройте маршрут по умолчанию со адресом следующего перехода 2.2.2.2 на Router_1.
    [Router_1] ip route-static 0.0.0.0 0.0.0.0 2.2.2.2
    
    # На Router_2 добавьте GE1/0/0 к VLAN 200. Если одноранговый конец GE0/0/1 находится в 3.3.3.2/24, установите IP-адрес GE0/0/1 на 3.3.3.1/24. Создайте VLANIF 200 и установите его IP-адрес на 10.23.200.2/24.
    <Huawei> system-view
    [Huawei] sysname Router_2
    [Router_2] vlan batch 200
    [Router_2] interface GigabitEthernet1/0/0
    [Router_2-GigabitEthernet1/0/0] port link-type trunk
    [Router_2-GigabitEthernet1/0/0] port trunk allow-pass vlan 200
    [Router_2-GigabitEthernet1/0/0] quit
    [Router_2] interface gigabitethernet 0/0/1
    [Router_2-GigabitEthernet0/0/1] ip address 3.3.3.1 255.255.255.0
    [Router_2-GigabitEthernet0/0/1] quit
    [Router_2] interface vlanif 200
    [Router_2-Vlanif200] ip address 10.23.200.2 24
    [Router_2-Vlanif200] quit
    
    # Настройте маршрут по умолчанию со адресом следующего перехода 3.3.3.2 на Router_2.
    [Router_2] ip route-static 0.0.0.0 0.0.0.0 3.3.3.2
    

  2. Настройте AC для связи с сетевыми устройствами.

    # На AC добавьте GE0/0/1 к VLAN 200. Создайте VLANIF 200 и установите его IP-адрес на 10.23.200.1/24.
    <AC6605> system-view
    [AC6605] sysname AC
    [AC] vlan batch 101 200
    [AC] interface gigabitethernet 0/0/1
    [AC-GigabitEthernet0/0/1] port link-type trunk
    [AC-GigabitEthernet0/0/1] port trunk allow-pass vlan 200
    [AC-GigabitEthernet0/0/1] quit
    [AC] interface vlanif 200
    [AC-Vlanif200] ip address 10.23.200.1 24
    [AC-Vlanif200] quit
    # Настройте маршрут по умолчанию со адресом следующего перехода 10.23.200.2 на AC.
    [AC] ip route-static 0.0.0.0 0.0.0.0 10.23.200.2
    

  3. Настройте DHCP-сервер для того, чтобы назначить IP-адреса для AP и STA.

    # Настройте Router_1 как DHCP-сервер, чтобы назначить IP-адреса для AP и STA. Адрес исходного интерфейса AC преобразуется в общедоступный IP-адрес 3.3.3.3 после сопоставления NAT.
    [Router_1] dhcp enable
    [Router_1] interface vlanif 100
    [Router_1-Vlanif100] ip address 10.23.100.1 255.255.255.0
    [Router_1-Vlanif100] dhcp select global
    [Router_1-Vlanif100] quit
    [Router_1] ip pool ap
    [Router_1-ip-pool-ap] gateway-list 10.23.100.1
    [Router_1-ip-pool-ap] network 10.23.100.0 mask 24
    [Router_1-ip-pool-ap] option 43 sub-option 3 ascii 3.3.3.3
    [Router_1-ip-pool-ap] quit
    [Router_1] interface vlanif 101
    [Router_1-Vlanif101] ip address 10.23.101.1 255.255.255.0
    [Router_1-Vlanif101] dhcp select interface
    [Router_1-Vlanif101] quit
    ПРИМЕЧАНИЕ:
    Настройте DNS-сервер по мере необходимости. Общие методы заключаются в следующем:
    • В сценариях пула адресов интерфейса запустите команду dhcp server dns-list ip-address &<1-8> в виде интерфейса VLANIF.
    • В сценариях пула глобального адреса запустите команду dns-list ip-address &<1-8> в виде пула IP-адресов.

  4. Настройте NAT.

    # Настройте NAT Outbound на Router_1.
    [Router_1] acl 2000
    [Router_1-acl-basic-2000] rule 5 permit source 10.23.100.0 0.0.0.255
    [Router_1-acl-basic-2000] rule 10 permit source 10.23.101.0 0.0.0.255
    [Router_1-acl-basic-2000] quit
    [Router_1] interface gigabitethernet 0/0/1
    [Router_1-GigabitEthernet0/0/1] nat outbound 2000
    [Router_1-GigabitEthernet0/0/1] quit
    
    # Настройте статический NAT на Router_2.
    [Router_2] interface gigabitethernet 0/0/1
    [Router_2-GigabitEthernet0/0/1] nat static global 3.3.3.3 inside 10.23.200.1
    [Router_2-GigabitEthernet0/0/1] quit
    

  5. Настройте AP для входа в сеть.

    # Создайте группу AP, к которой могут добавляться точки доступа с той же конфигурацией.
    [AC] wlan
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] quit
    
    # Создайте профиль регулятивного домена, настройте код страны AC в профиле и примените профиль к группе AP.
    [AC-wlan-view] regulatory-domain-profile name default
    [AC-wlan-regulate-domain-default] country-code cn
    [AC-wlan-regulate-domain-default] quit
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] regulatory-domain-profile default
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AC-wlan-ap-group-ap-group1] quit
    [AC-wlan-view] quit
    
    # Настройте исходный интерфейс AC.
    [AC] capwap source interface vlanif 200
    
    # Импортируйте AP в автономном режиме на AC и добавьте AP в группу AP ap-group1. Предположим, что MAC-адресом точки доступа является 60de-4476-e360. Настройте имя для AP на основе местоположения развертывания AP, чтобы узнать, где AP развертывается из своего имени. Например, назовите AP area_1, если она развернута в Зоне 1.
    ПРИМЕЧАНИЕ:

    Режим аутентификации AP по умолчанию - это аутентификация MAC-адреса. Если настройки по умолчанию сохранены, не нужно запускать команду ap auth-mode mac-auth.

    В этом примере используется AP5030DN и имеет два Radio: Radio 0 и Radio 1. Radio 0 и Radio 1 работают соответственно на частоте 2.4 ГГц и 5 ГГц.

    [AC] wlan
    [AC-wlan-view] ap auth-mode mac-auth
    [AC-wlan-view] ap-id 0 ap-mac 60de-4476-e360
    [AC-wlan-ap-0] ap-name area_1
    [AC-wlan-ap-0] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-0] quit
    [AC-wlan-view] ap-id 1 ap-mac 60de-4474-9640
    [AC-wlan-ap-1] ap-name area_2
    [AC-wlan-ap-1] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-1] quit
    
    # После включения AP запустите команду display ap all, чтобы проверить состояние AP. Если поле State отображается как nor, AP успешно подключается к сети.
    [AC-wlan-view] display ap all
    Total AP information:
    nor  : normal          [1]
    -------------------------------------------------------------------------------------
    ID   MAC            Name   Group     IP            Type            State STA Uptime
    -------------------------------------------------------------------------------------
    0    60de-4476-e360 area_1 ap-group1 10.23.100.254 AP5030DN        nor   0   10S
    1    60de-4474-9640 area_2 ap-group1 10.23.100.253 AP5030DN        nor   0   11S
    -------------------------------------------------------------------------------------
    Total: 2

  6. Настройте параметры службы WLAN.

    # Создайте профиль безопасности wlan-net и установите политику безопасности в профиле.
    ПРИМЕЧАНИЕ:

    В этом примере политика безопасности установлена ​​на WPA-WPA2+PSK+AES и пароль на a1234567. В реальных ситуациях политика безопасности должна быть настроена в соответствии с требованиями к службе.

    [AC-wlan-view] security-profile name wlan-net
    [AC-wlan-sec-prof-wlan-net] security wpa-wpa2 psk pass-phrase a1234567 aes
    [AC-wlan-sec-prof-wlan-net] quit
    
    # Создайте профиль SSID wlan-net и установите имя SSID на wlan-net.
    [AC-wlan-view] ssid-profile name wlan-net
    [AC-wlan-ssid-prof-wlan-net] ssid wlan-net
    [AC-wlan-ssid-prof-wlan-net] quit
    
    # Создайте профиль VAP wlan-net, установите режим переадресации данных и сервисную VLAN и примените профиль безопасности и профиль SSID к профилю VAP.
    [AC-wlan-view] vap-profile name wlan-net
    [AC-wlan-vap-prof-wlan-net] forward-mode direct-forward
    [AC-wlan-vap-prof-wlan-net] service-vlan vlan-id 101
    [AC-wlan-vap-prof-wlan-net] security-profile wlan-net
    [AC-wlan-vap-prof-wlan-net] ssid-profile wlan-net
    [AC-wlan-vap-prof-wlan-net] quit
    
    # Привяжите профиль VAP wlan-net к группе AP и примените профиль к radio 0 и radio 1 точки доступа.
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 0
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 1
    [AC-wlan-ap-group-ap-group1] quit
    

  7. Настройте канал и мощность AP.
  8. Проверьте конфигурацию.

    AC автоматически доставляет конфигурацию службы WLAN в AP. После завершения настройки запустите команду display vap ssid wlan-net. Если поле Status отображается как ON, VAP успешно созданы на AP Radio.

    [AC-wlan-view] display vap ssid wlan-net
    WID : WLAN ID
    --------------------------------------------------------------------------------
    AP ID AP name RfID WID   BSSID          Status  Auth type     STA   SSID
    --------------------------------------------------------------------------------
    0     area_1  0    1     60DE-4476-E360 ON      WPA/WPA2-PSK  0     wlan-net
    0     area_1  1    1     60DE-4476-E370 ON      WPA/WPA2-PSK  0     wlan-net
    0     area_2  0    1     60DE-4474-9640 ON      WPA/WPA2-PSK  0     wlan-net
    0     area_2  1    1     60DE-4474-9650 ON      WPA/WPA2-PSK  0     wlan-net
    -------------------------------------------------------------------------------
    Total: 4

    Подключите STA к WLAN с помощью SSID wlan-net и введите пароль a1234567. Запустите команду display station ssid wlan-net на AC. Вывод команды показывает, что STA подключены к WLAN wlan-net.

    [AC-wlan-view] display station ssid wlan-net
    Rf/WLAN: Radio ID/WLAN ID
    Rx/Tx: link receive rate/link transmit rate(Mbps)
    ---------------------------------------------------------------------------------
    STA MAC         AP ID Ap name   Rf/WLAN  Band  Type  Rx/Tx      RSSI  VLAN  IP address
    ---------------------------------------------------------------------------------
    e019-1dc7-1e08  0     area_1    1/1      5G    11n   46/59      -68   101   10.23.101.254
    ---------------------------------------------------------------------------------
    Total: 1 2.4G: 0 5G: 1

Файлы конфигурации

  • Файл конфигурации Switch
    #
    sysname Switch
    #
    vlan batch 100 to 101
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100 to 101
     port-isolate enable group 1
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100 to 101
     port-isolate enable group 1
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 100 to 101
    #
    return
  • Файл конфигурации Router_1
    #
    sysname Router_1
    #
    vlan batch 100 to 101
    #
    dhcp enable
    #
    acl number 2000  
     rule 5 permit source 10.23.100.0 0.0.0.255 
     rule 10 permit source 10.23.101.0 0.0.0.255
    #
    ip pool ap
     gateway-list 10.23.100.1
     network 10.23.100.0 mask 255.255.255.0
     option 43 sub-option 3 ascii 3.3.3.3
    #
    interface Vlanif100
     ip address 10.23.100.1 255.255.255.0
     dhcp select global
    #
    interface Vlanif101
     ip address 10.23.101.1 255.255.255.0
     dhcp select interface
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100 to 101
     port-isolate enable
    #
    interface GigabitEthernet0/0/1
     ip address 2.2.2.1 255.255.255.0
     nat outbound 2000
    #
    ip route-static 0.0.0.0 0.0.0.0 2.2.2.2
    #
    return
  • Файл конфигурации Router_2.
    #
    sysname Router_2
    #
    vlan batch 200
    #
    interface Vlanif200
     ip address 10.23.200.2 24
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface GigabitEthernet0/0/1
     ip address 3.3.3.1 255.255.255.0
     nat static global 3.3.3.3 inside 10.23.200.1
    #
    ip route-static 0.0.0.0 0.0.0.0 3.3.3.2
    #
    return
  • Файл конфигурации AC

    #
     sysname AC
    #
    vlan batch 101 200
    #
    interface Vlanif200
     ip address 10.23.200.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    ip route-static 0.0.0.0 0.0.0.0 10.23.200.2
    #
    capwap source interface vlanif200
    #
    wlan
     security-profile name wlan-net
      security wpa-wpa2 psk pass-phrase %^%#m"tz0f>~7.[`^6RWdzwCy16hJj/Mc!,}s`X*B]}A%^%# aes
     ssid-profile name wlan-net
      ssid wlan-net
     vap-profile name wlan-net
      service-vlan vlan-id 101
      ssid-profile wlan-net
      security-profile wlan-net
     regulatory-domain-profile name default
     ap-group name ap-group1
      radio 0
       vap-profile wlan-net wlan 1
      radio 1
       vap-profile wlan-net wlan 1
     ap-id 0 type-id 35 ap-mac 60de-4476-e360 ap-sn 210235554710CB000042
      ap-name area_1
      ap-group ap-group1
      radio 0
       channel 20mhz 6
       eirp 127
      radio 1
       channel 20mhz 149
       eirp 127
     ap-id 1 type-id 35 ap-mac 60de-4474-9640 ap-sn 210235554710CB002312
      ap-name area_2
      ap-group ap-group1
    #
    return
Загрузить
Updated: 2018-08-21

№ документа:EDOC1100029357

Просмотры:8971

Загрузки: 129

Average rating:
This Document Applies to these Products
Связанные документы
Related Version
Share
Назад Далее