Для выбранного языка не найдены ресурсы переадресации.

Этот веб-сайт использует cookie-файлы. Продолжая просмотр, вы соглашаетесь на их использование. Ознакомьтесь с нашей политикой соблюдения конфиденциальности.>

Типичные примеры настройки WLAN

Rate and give feedback :
Информация об этом переводе
Чтобы помочь вам лучше понять содержимое этого документа, компания Huawei перевела его на разные языки, используя машинный перевод, отредактированный людьми. Примечание: даже самые передовые программы машинного перевода не могут обеспечить качество на уровне перевода, выполненного профессиональным переводчиком. Компания Huawei не несет ответственность за точность перевода и рекомендует ознакомиться с документом на английском языке (по ссылке, которая была предоставлена ранее).
Пример подключения локальной сети к Интернету с использованием модема ADSL

Пример подключения локальной сети к Интернету с использованием модема ADSL

Требования к сети

Как показано на Рис. 3-28, AP подключается к модему ADSL, используя GE 0/0/0, а маршрутизатор подключается к DSLAM с использованием ATM1/0/0.

Частные IP-адреса хостов в локальной сети - 192.168.10.0/24. Пользователи хотят, чтобы хосты в локальной сети получали доступ к маршрутизатору с использованием точки доступа и для доступа к внешней сети. Имя пользователя user1, и пароль huawei123.

Рис. 3-28 Сетевая диаграмма для подключения локальной сети к Интернету с использованием модема ADSL

Схема настройки

Схема настройки показывается в нижеследующем:
  1. Настройте AP в качестве клиента PPPoE, чтобы хосты в локальной сети могли получить доступ к Интернету без установки программного обеспечения клиента PPPoE.
  2. Настройте маршрутизатор в качестве сервера PPPoE для обеспечения функций аутентификации и учета RADIUS.
  3. Настройте NAT, чтобы пользователи локальной сети могли получить доступ к внешней сети.

Процедура

  1. # Настройте сервер PPPoE.

    # Настройте интерфейс Dialer.

    <Huawei> system-view
    [Huawei] sysname AP
    [AP] interface dialer 1
    [AP-Dialer1] ppp chap user user1
    [AP-Dialer1] ppp chap password cipher huawei123
    [AP-Dialer1] dialer timer idle 300
    [AP-Dialer1] dialer queue-length 8
    [AP-Dialer1] ip address ppp-negotiate
    [AP-Dialer1] quit

    Создайте сеанс PPPoE.

    [AP] vlan batch 100
    [AP] interface gigabitethernet 0/0/0
    [AP-GigabitEthernet0/0/0] port link-type trunk
    [AP-GigabitEthernet0/0/0] port trunk allow-pass vlan 100
    [AP-GigabitEthernet0/0/0] port trunk pvid vlan 100
    [AP-GigabitEthernet0/0/0] quit
    [AP] interface vlanif 100
    [AP-Vlanif100] pppoe-client dial-bundle-number 1
    [AP-Vlanif100] quit

    # Настройте NAT для перевода частных адресов хостов в локальной сети на общедоступные адреса, чтобы хосты могли подключаться к Интернету.

    [AP] acl number 3002
    [AP-acl-adv-3002] rule 5 permit ip source 192.168.10.0 0.0.0.255
    [AP-acl-adv-3002] quit
    [AP] interface dialer 1
    [AP-Dialer1] nat outbound 3002
    [AP-Dialer1] quit

    # Настройте статический маршрут с клиента PPPoE на сервер PPPoE.

    [AP] ip route-static 0.0.0.0 0 dialer 1
    [AP] quit

  2. # Настройте сервер PPPoE.

    # Настройте пул глобальных IP-адресов pool1.

    <AC6605> system-view
    [AC6605] sysname Router
    [Router] ip pool pool1
    [Router-ip-pool-pool1] network 100.100.10.0 mask 255.255.255.0
    [Router-ip-pool-pool1] gateway-list 100.100.10.1
    [Router-ip-pool-pool1] quit

    # Настройте пользователь PPPoE.

    [Router] aaa
    [Router-aaa] local-user user1 password
    Please configure the login password (8-128)                                     
    It is recommended that the password consist of at least 2 types of characters, i
    ncluding lowercase letters, uppercase letters, numerals and special characters. 
    Please enter password:                                                          
    Please confirm password:                                                        
    Info: Добавьте пользователя.                                                           
    [Router-aaa] local-user user1 service-type ppp
    [Router-aaa] quit
    Настройте аутентификацию RADIUS.
    1. Настройте шаблон сервера RADIUS.

      [Router] radius-server template shiva
      [Router-radius-shiva] radius-server authentication 129.6.6.66 1812
      [Router-radius-shiva] radius-server accounting 129.6.6.66 1813
      [Router-radius-shiva] radius-server shared-key cipher hello@123
      [Router-radius-shiva] quit
    2. Настройте схемы аутентификации и учета.

      [Router] aaa
      [Router-aaa] authentication-scheme 1
      [Router-aaa-authen-1] authentication-mode radius
      [Router-aaa-authen-1] quit
      [Router-aaa] accounting-scheme 1
      [Router-aaa-accounting-1] accounting-mode radius
      [Router-aaa-accounting-1] quit
    3. Настройте домен с именем system и примените схему аутентификации 1, схему учета 1 и шаблон сервера RADIUS shiva в домен.

      [Router-aaa] domain system
      [Router-aaa-domain-system] authentication-scheme 1
      [Router-aaa-domain-system] accounting-scheme 1
      [Router-aaa-domain-system] radius-server shiva
      [Router-aaa-domain-system] quit
      [Router-aaa] quit

    # Создайте и настройте VT.

    [Router] interface virtual-template 1
    [Router-Virtual-Template1] ppp authentication-mode chap domain system
    [Router-Virtual-Template1] ip address 100.100.10.1 255.255.255.0
    [Router-Virtual-Template1] remote address pool pool1
    [Router-Virtual-Template1] quit

    # Включите функцию сервера PPPoE на виртуальном интерфейсе Ethernet.

    [Router] interface virtual-ethernet 0/0/1
    [Router-Virtual-Ethernet0/0/1] pppoe-server bind virtual-template 1
    [Router-Virtual-Ethernet0/0/1] quit

    # Настройте интерфейс ATM.

    [Router] interface atm 1/0/0
    [Router-Atm1/0/0] pvc 0/32
    [Router-atm-pvc-Atm1/0/0-0/32] map bridge virtual-ethernet 0/0/1
    [Router-atm-pvc-Atm1/0/0-0/32] quit

  3. Проверьте конфигурацию.

    # Запустите команду display pppoe-client session summary для проверки состояния и конфигурации сеанса PPPoE. Следующий вывод команды показывает, что состояние сеанса PPPoE равно Up, и конфигурация сеанса соответствует тарифному плану и сети.

    <AP> display pppoe-client session summary
    PPPoE Client Session:
    ID   Bundle  Dialer  Intf             Client-MAC    Server-MAC    State
    0    1       1       vlanif100        54899874dbc7  000000000000  PADI   

    # AP может успешно выполнить ping маршрутизатора сервера.

Файлы конфигурации

  • Файл конфигурации AP

    #
     sysname AP
    #
    vlan batch 100
    #
    acl number 3002
     rule 5 permit ip source 192.168.10.0 0.0.0.255
    #
    interface Dialer1
     link-protocol ppp
     ppp chap user user1
     ppp chap password cipher %^%#D][/manual/concept/concept/task/taskbody/example/ul/li/screen/ph/B
         {""}) ${2C"o|jLLQwm<#=FP[~\b3P!w0Vr6BLp4A%^%# (B]
     ip address ppp-negotiate
     dialer queue-length 8
     dialer timer idle 300
     nat outbound 3002
    #
    interface Vlanif100
     pppoe-client dial-bundle-number 1
    #
    interface GigabitEthernet0/0/0
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
    #
    ip route-static 0.0.0.0 0.0.0.0 Dialer1
    #
    return
    
  • Файл конфигурации маршрутизатора

    #
     sysname Router
    #
    radius-server template shiva
     radius-server shared-key cipher %^%#s2BY1Z1+yAE}!(X0JTHB64T#,K$SFIfN5D!RjIGI%^%#
     radius-server authentication 129.6.6.66 1812 weight 80
     radius-server accounting 129.6.6.66 1813 weight 80
    #
    ip pool pool1
     gateway-list 100.100.10.1
     network 100.100.10.0 mask 255.255.255.0
    #
    aaa
     authentication-scheme 1
      authentication-mode radius
     accounting-scheme 1
      accounting-mode radius
     domain system
      authentication-scheme 1
      accounting-scheme 1
      radius-server  shiva
     local-user user1 password cipher %^%#9T`|L}K(4#J3k=+I8SiJrsM:RO[iy@Uuc:LTQJ,1%^%#
     local-user user1 privilege level 0
     local-user user1 service-type ppp
    #
    interface Virtual-Template1
     ppp authentication-mode chap domain system
     remote address pool pool1
     ppp keepalive retry-times 2
     timer hold 30
     ip address 100.100.10.1 255.255.255.0
    #
    interface Atm1/0/0
     pvc 0/32
      map bridge Virtual-Ethernet0/0/1
    #
    interface Virtual-Ethernet0/0/1
     pppoe-server bind Virtual-Template 1
    #
    return
    
Загрузить
Updated: 2018-08-21

№ документа:EDOC1100029357

Просмотры:7799

Загрузки: 106

Average rating:
This Document Applies to these Products
Связанные документы
Related Version
Share
Назад Далее