Для выбранного языка не найдены ресурсы переадресации.

Этот веб-сайт использует cookie-файлы. Продолжая просмотр, вы соглашаетесь на их использование. Ознакомьтесь с нашей политикой соблюдения конфиденциальности.>

Меню

Типичные примеры настройки WLAN

Rate and give feedback:
Информация об этом переводе
Чтобы помочь вам лучше понять содержимое этого документа, компания Huawei перевела его на разные языки, используя машинный перевод, отредактированный людьми. Примечание: даже самые передовые программы машинного перевода не могут обеспечить качество на уровне перевода, выполненного профессиональным переводчиком. Компания Huawei не несет ответственность за точность перевода и рекомендует ознакомиться с документом на английском языке (по ссылке, которая была предоставлена ранее).
Пример настройки встроенной аутентификации Portal для локальных пользователей

Пример настройки встроенной аутентификации Portal для локальных пользователей

Требования к службе

Чтобы улучшить безопасность WLAN, предприятие использует режим аутентификации Portal. Чтобы снизить затраты, предприятие развертывает AC в качестве сервера Portal и использует режим локальной аутентификации, чтобы аутентификация выполнялась на AC.

Требования к сети

  • Режим сети AC: Режим обхода уровня 2
  • Режим развертывания DHCP:
    • AC функционирует как DHCP-сервер, чтобы назначить IP-адреса для AP.
    • Коммутатор агрегации (SwitchB) функционирует как DHCP-сервер, чтобы назначить IP-адреса для STA.
  • Режим переадресации сервисных данных: туннельная переадресация
  • Режим аутентификации: аутентификация встроенного Portal
  • Политика безопасности: открытая
Рис. 3-30 Сеть для настройки аутентификации встроенного Portal для локальных пользователей

План данных

Табл. 3-33 План данных AC
Пункт Данные

Управляющая VLAN для AP

VLAN 100

Сервисная VLAN для STA

VLAN 101

DHCP-сервер

AC функционирует как DHCP-сервер, чтобы назначить IP-адреса для AP.

SwitchB функционирует как DHCP-сервер, чтобы назначить IP-адреса для STA. Адрес шлюза по умолчанию для STA - 10.23.101.2.

Пул IP-адресов для AP

10.23.100.2-10.23.100.254/24

Пул IP-адресов для STA

10.23.101.3-10.23.101.254/24

Исходный интерфейс AC

VLANIF100: 10.23.100.1/24

Группа AP

  • Имя: ap-group1

  • Ссылочный профиль: Профиль VAP wlan-net и профиль регулятивного домена default

Профиль регулятивного домена

  • Имя: default
  • Код страны: CN

Профиль SSID

  • Имя: wlan-net

  • Имя SSID: wlan-net

Профиль безопасности

  • Имя: wlan-net

  • Политика безопасности: открытая

Локальный пользователь

  • Имя пользователя: гость

  • Пароль: guest@123

Схема аутентификации
  • Имя: wlan-net
  • Схема аутентификации: локальная

Профиль доступа к Portal

  • Имя: wlan-net

  • Используется сервер встроенного Portal.
    • IP сервера: 10.23.100.3/24

    • Политика SSL: default_policy

    • Номер порта: 20000

Профиль правила без аутентификации
  • Имя: default_free_rule
  • Ресурс без аутентификации: IP-адрес DNS-сервера (8.8.8.8)

Профиль аутентификации

  • Имя: wlan-net

  • Ссылочный профиль: Профиль доступа к Portal wlan-net, профиль правила без аутентификации default_free_rule, схема аутентификации wlan-net

Профиль VAP

  • Имя: wlan-net

  • Режим переадресации: туннельная переадресация

  • Сервисная VLAN: VLAN 101

  • Ссылочный профиль: Профиль SSID wlan-net, профиль безопасности wlan-net и профиль аутентификации wlan-net

Схема Настройки

  1. Настройте сетевое взаимодействие AC, AP и других сетевых устройств.
  2. Настройте AP для входа в сеть.
  3. Настройте аутентификацию встроенного Portal для локальных пользователей.
    1. Настройте параметры локальной аутентификации.
    2. Настройте профиль доступа к Portal для сервера встроенного Portal, чтобы управлять параметрами контроля доступа к Portal.
    3. Настройте профиль правил без аутентификации, чтобы AC разрешал пропускать пакеты к DNS-серверу.
    4. Настройте профиль аутентификации для управления конфигурацией аутентификации встроенного Portal.
  4. Настройте параметры службы WLAN для управления доступом от STA.

Примечания по конфигурации

  • Механизм ACK не предусмотрен для многоадресной передачи пакетов на воздушных интерфейсах. Кроме того, беспроводные каналы нестабильны. Для обеспечения стабильной передачи многоадресных пакетов они обычно отправляются по низким тарифам. Если большое количество таких многоадресных пакетов отправляется с сетевой стороны, воздушные интерфейсы могут быть перегружены. Рекомендуется настроить подавление многоадресных пакетов, чтобы уменьшить влияние большого количества низкоскоростных многоадресных пакетов на беспроводную сеть. Соблюдайте осторожность при настройке ограничения скорости; в противном случае могут быть затронуты многоадресные услуги.
    • В режиме прямой переадресации рекомендуется настроить подавление многоадресных пакетов на интерфейсах коммутатора, подключенных к точкам доступа (AP).
    • В режиме туннельной переадресации рекомендуется настроить подавление многоадресных пакетов в профилях трафика AC.
    Подробнее о том, как настроить подавление трафика, см. Подавление многоадресных пакетов не настроено, что приводит к замедлению доступа к сети STA.
  • Настройте изоляцию портов на интерфейсах устройства, напрямую подключенного к точкам доступа. Если изоляция порта не настроена и используется прямая переадресация, в VLAN может быть создано большое количество ненужных широковещательных пакетов, блокирующих сеть и ухудшающих работу пользователя.

  • В режиме туннельной переадресации управляющая VLAN и сервисная VLAN не могут быть одинаковыми. Только пакеты из управляющей VLAN передаются между AC и AP. Пакеты из сервисной VLAN не допускаются между AC и AP.

Процедура

  1. Настройте сетевые устройства.

    # Добавьте GE0/0/1 и GE0/0/2 на SwitchA к VLAN 100. VLAN по умолчанию GE0/0/1 - VLAN 100.
    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 100
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [SwitchA-GigabitEthernet0/0/1] port-isolate enable
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 100
    [SwitchA-GigabitEthernet0/0/2] quit
    
    # Добавьте GE0/0/1 и GE0/0/2 на SwitchB (коммутатор агрегации) к VLAN 100, GE0/0/2 и GE0/0/3 к VLAN 101.
    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan batch 100 101
    [SwitchB] interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] port link-type trunk
    [SwitchB-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [SwitchB-GigabitEthernet0/0/1] quit
    [SwitchB] interface gigabitethernet 0/0/2
    [SwitchB-GigabitEthernet0/0/2] port link-type trunk
    [SwitchB-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 101
    [SwitchB-GigabitEthernet0/0/2] quit
    [SwitchB] interface gigabitethernet 0/0/3
    [SwitchB-GigabitEthernet0/0/3] port link-type trunk
    [SwitchB-GigabitEthernet0/0/3] port trunk allow-pass vlan 101
    [SwitchB-GigabitEthernet0/0/3] quit
    
    # Добавьте GE1/0/0 на маршрутизаторе (Router) к VLAN 101. Создайте VLANIF 101 и установите его IP-адрес на 10.23.101.2/24.
    <Huawei> system-view
    [Huawei] sysname Router
    [Router] vlan batch 101
    [Router] interface gigabitethernet 1/0/0
    [Router-GigabitEthernet1/0/0] port link-type trunk
    [Router-GigabitEthernet1/0/0] port trunk allow-pass vlan 101
    [Router-GigabitEthernet1/0/0] quit
    [Router] interface vlanif 101
    [Router-Vlanif101] ip address 10.23.101.2 24
    [Router-Vlanif101] quit
    

  2. Настройте AC для связи с сетевыми устройствами.

    ПРИМЕЧАНИЕ:

    Если AC и AP подключены напрямую, установите VLAN по умолчанию интерфейсов, подключенных к AP, на управляющую VLAN 100.

    # Добавьте GE0/0/1 на AC к VLAN 100 и VLAN 101.
    <AC6605> system-view
    [AC6605] sysname AC
    [AC] vlan batch 100 101
    [AC] interface gigabitethernet 0/0/1
    [AC-GigabitEthernet0/0/1] port link-type trunk
    [AC-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 101
    [AC-GigabitEthernet0/0/1] quit
    

  3. Настройте DHCP-серверы для того, чтобы назначить IP-адреса для AP и STA.

    # На AC настройте VLANIF 100 для того, чтобы назначить IP-адреса для AP.
    [AC] dhcp enable
    [AC] interface vlanif 100
    [AC-Vlanif100] ip address 10.23.100.1 24
    [AC-Vlanif100] dhcp select interface
    [AC-Vlanif100] quit
    
    # На SwitchB настройте VLANIF 101 для того, чтобы назначить IP-адреса для STA и установите адрес шлюза STA по умолчанию на 10.23.101.2.
    ПРИМЕЧАНИЕ:
    Настройте DNS-сервер по мере необходимости. Общие методы заключаются в следующем:
    • В сценариях пула адресов интерфейса запустите команду dhcp server dns-list ip-address &<1-8> в виде интерфейса VLANIF.
    • В сценариях пула глобального адреса запустите команду dns-list ip-address &<1-8> в виде пула IP-адресов.
    [SwitchB] dhcp enable
    [SwitchB] interface vlanif 101
    [SwitchB-Vlanif101] ip address 10.23.101.1 24
    [SwitchB-Vlanif101] dhcp select interface
    [SwitchB-Vlanif101] dhcp server gateway-list 10.23.101.2
    [SwitchB-Vlanif101] quit
    

  4. Настройте маршрут с AC на DNS-сервер.

    [AC] ip route-static 0.0.0.0 0.0.0.0 10.23.101.2
    

  5. Настройте AP для входа в сеть.

    # Создайте группу AP, к которой могут добавляться точки доступа с той же конфигурацией.
    [AC] wlan
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] quit
    
    # Создайте профиль регулятивного домена, настройте код страны AC в профиле и примените профиль к группе AP.
    [AC-wlan-view] regulatory-domain-profile name default
    [AC-wlan-regulate-domain-default] country-code cn
    [AC-wlan-regulate-domain-default] quit
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] regulatory-domain-profile default
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AC-wlan-ap-group-ap-group1] quit
    [AC-wlan-view] quit
    
    # Настройте исходный интерфейс AC.
    [AC] capwap source interface vlanif 100
    
    # Импортируйте AP в автономном режиме на AC и добавьте AP в группу AP ap-group1. Предположим, что MAC-адресом у AP является 60de-4476-e360. Настройте имя для AP на основе местоположения развертывания AP, чтобы узнать, где AP развертывается из своего имени. Например, назовите AP area_1, если она развернута в Зоне 1.
    ПРИМЕЧАНИЕ:

    Режим аутентификации AP по умолчанию - это аутентификация MAC-адреса. Если настройки по умолчанию сохранены, не нужно запускать команду ap auth-mode mac-auth.

    В этом примере используется AP5030DN и имеет два радио: радио 0 (2.4 ГГц) и радио 1 (5 ГГц).

    [AC] wlan
    [AC-wlan-view] ap auth-mode mac-auth
    [AC-wlan-view] ap-id 0 ap-mac 60de-4476-e360
    [AC-wlan-ap-0] ap-name area_1
    [AC-wlan-ap-0] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-0] quit
    
    # После включения AP запустите команду display ap all, чтобы проверить состояние AP. Если поле State отображается как nor, AP успешно подключается к сети.
    [AC-wlan-view] display ap all
    Total AP information:
    nor  : normal          [1]
    -------------------------------------------------------------------------------------
    ID   MAC            Name   Group     IP            Type            State STA Uptime
    -------------------------------------------------------------------------------------
    0    60de-4476-e360 area_1 ap-group1 10.23.100.254 AP5030DN        nor   0   10S
    -------------------------------------------------------------------------------------
    Total: 1

  6. Настройте локальную аутентификацию.

    # Настройте локальную схему аутентификации wlan-net.

    [AC] aaa
    [AC-aaa] authentication-scheme wlan-net
    [AC-aaa-authen-wlan-net] authentication-mode local
    [AC-aaa-authen-wlan-net] quit

    # Настройте имя пользователя, пароль и тип службы локального пользователя.

    [AC-aaa] local-user guest password cipher guest@123
    [AC-aaa] local-user guest service-type web
    [AC-aaa] quit

  7. Настройте политику SSL default_policy и загрузите цифровой сертификат.

    # Загрузите сертификаты и ключевую пару RSA.

    ПРИМЕЧАНИЕ:
    Локальный сертификат abc_local.pem, сертификат CA abc_ca.pem и ключевая пара RSA privatekey.pem были запрошены, получены и загружены в носитель данных устройства. Если запрашивается несколько сертификатов CA, выполните ту же операцию для загрузки сертификатов в память устройства. Когда privatekey.pem генерируется, ключом является Huawei@123.
    [AC] pki realm abc
    [AC-pki-realm-abc] quit 
    [AC] pki import-certificate local realm abc pem filename abc_local.pem
    [AC] pki import-certificate ca realm abc pem filename abc_ca.pem
    [AC] pki import rsa-key-pair key1 pem privatekey.pem password Huawei@123
    

    # Настройте политику SSL default_policy и загрузите цифровой сертификат.

    [AC] ssl policy default_policy type server
    [AC-ssl-policy-default_policy] pki-realm abc
    [AC-ssl-policy-default_policy] version tls1.0 tls1.1 tls1.2
    [AC-ssl-policy-default_policy] ciphersuite rsa_aes_128_sha256 rsa_aes_256_sha256
    [AC-ssl-policy-default_policy] quit
    [AC] http secure-server ssl-policy default_policy
    [AC] http secure-server enable
    

    # Проверьте конфигурацию политики SSL. Статус CA и локальных сертификатов должен быть загружен.

    [AC] display ssl policy default_policy
    ------------------------------------------------------------------------------
      Policy name                            :   default_policy                             
      Policy ID                              :   2                                
      Policy type                            :   Server                            
      Cipher suite                           :   rsa_aes_128_sha256 rsa_aes_256_sha256 
      PKI realm                              :   abc
      Version                                :   tls1.0 tls1.1 tls1.2  
      Cache number                           :   32                                
      Time out(second)                       :   3600                              
      Server certificate load status         :   loaded                            
      CA certificate chain load status       :   loaded                            
      SSL renegotiation status               :   enable
      Bind number                            :   1                                 
      SSL connection number                  :   0                                 
      ------------------------------------------------------------------------------
    

  8. Настройка профиля доступа к Portal wlan-net

    # Включите функцию сервера встроенного Portal.

    [AC] interface loopback 1
    [AC-LoopBack1] ip address 10.23.100.3 24
    [AC-LoopBack1] quit
    [AC] portal local-server ip 10.23.100.3
    [AC] portal local-server https ssl-policy default_policy port 20000

    # Создайте профиль доступа к Portal wlan-net и настройте его для использования сервера встроенного Portal.

    [AC] portal-access-profile name wlan-net
    [AC-portal-access-profile-wlan-net] portal local-server enable
    [AC-portal-access-profile-wlan-net] quit

  9. Настройте профиль правил без аутентификации, чтобы пользователи могли получить доступ к DNS-серверу перед аутентификацией.

    [AC] free-rule-template name default_free_rule
    [AC-free-rule-default_free_rule] free-rule 1 destination ip 8.8.8.8 mask 32
    [AC-free-rule-default_free_rule] quit
    

  10. Настройте профиль аутентификации wlan-net.

    [AC] authentication-profile name wlan-net
    [AC-authentication-profile-wlan-net] portal-access-profile wlan-net
    [AC-authentication-profile-wlan-net] free-rule-template default_free_rule
    [AC-authentication-profile-wlan-net] authentication-scheme wlan-net
    [AC-authentication-profile-wlan-net] quit

  11. Настройте параметры службы WLAN.

    # Создайте профиль безопасности wlan-net и установите политику безопасности в профиле. По умолчанию, политика безопасности - открытая система.

    [AC] wlan
    [AC-wlan-view] security-profile name wlan-net
    [AC-wlan-sec-prof-wlan-net] quit
    

    # Создайте профиль SSID wlan-net и установите имя SSID на wlan-net.

    [AC-wlan-view] ssid-profile name wlan-net
    [AC-wlan-ssid-prof-wlan-net] ssid wlan-net
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AC-wlan-ssid-prof-wlan-net] quit
    

    # Создайте профиль VAP wlan-net, настройте режим переадресации данных и сервисные VLAN и примените профиль безопасности, профиль SSID и профиль аутентификации к профилю VAP.

    [AC-wlan-view] vap-profile name wlan-net
    [AC-wlan-vap-prof-wlan-net] forward-mode tunnel
    [AC-wlan-vap-prof-wlan-net] service-vlan vlan-id 101
    [AC-wlan-vap-prof-wlan-net] security-profile wlan-net
    [AC-wlan-vap-prof-wlan-net] ssid-profile wlan-net
    [AC-wlan-vap-prof-wlan-net] authentication-profile wlan-net
    [AC-wlan-vap-prof-wlan-net] quit
    

    # Привяжите профиль VAP wlan-net к группе AP и примените профиль к radio 0 и radio 1 точки доступа.

    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 0
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 1
    [AC-wlan-ap-group-ap-group1] quit
    [AC-wlan-view] quit
    

  12. Проверьте конфигурацию.

    • WLAN с SSID wlan-net доступна для STA после завершения конфигурации.

    • STA получают IP-адреса тогда, когда они успешно связывают с WLAN.
    • Когда пользователь открывает браузер и пытается получить доступ к сети, пользователь автоматически перенаправляется на страницу аутентификации, предоставляемую сервером Portal. После ввода правильного имени пользователя и пароля на странице пользователь может получить доступ к сети.

Файлы конфигурации

  • Файл конфигурации SwitchA

    #
    sysname SwitchA
    #
    vlan batch 100
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
     port-isolate enable group 1
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    return
  • Файл конфигурации SwitchB

    #
    sysname SwitchB
    #
    vlan batch 100 to 101
    #
    dhcp enable
    #
    interface Vlanif101
     ip address 10.23.101.1 255.255.255.0
     dhcp select interface
     dhcp server gateway-list 10.23.101.2
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 100 to 101
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 101
    #
    return
  • Файл конфигурации Router

    #
    sysname Router
    #
    vlan batch 101
    #
    interface Vlanif101
     ip address 10.23.101.2 255.255.255.0
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 101
    #
    return
    
  • Файл конфигурации AC

    #
     sysname AC
    #                                                                               
     http secure-server ssl-policy default_policy                                        
     http server enable 
    #
    portal local-server ip 10.23.100.3
    portal local-server https ssl-policy default_policy port 20000
    #
    vlan batch 100 to 101
    #
    authentication-profile name wlan-net
     portal-access-profile wlan-net
     free-rule-template default_free_rule
     authentication-scheme wlan-net
    #
    dhcp enable
    #                                                                               
    pki realm abc                                                                   
     pki import-certificate local realm abc pem filename abc_local.pem
     pki import-certificate ca realm abc pem filename abc_ca.pem
     pki import rsa-key-pair key1 pem privatekey.pem password Huawei@123
    #                                                                               
    ssl policy default_policy type server                                                
     pki-realm abc                                                                  
     version tls1.0 tls1.1 tls1.2                                                   
     ciphersuite rsa_aes_128_sha256 rsa_aes_256_sha256  
    #
    free-rule-template name default_free_rule
     free-rule 1 destination ip 8.8.8.8 mask 255.255.255.255
    #
    portal-access-profile name wlan-net
     portal local-server enable
    #
    aaa
     authentication-scheme wlan-net
     #
    interface Vlanif100
     ip address 10.23.100.1 255.255.255.0
     dhcp select interface
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 100 to 101 
    #
    interface LoopBack1
     ip address 10.23.100.3 255.255.255.0
    #
    ip route-static 0.0.0.0 0.0.0.0 10.23.101.2
    #
    capwap source interface vlanif100
    #
    wlan
     security-profile name wlan-net
     ssid-profile name wlan-net
      ssid wlan-net
     vap-profile name wlan-net
      forward-mode tunnel
      service-vlan vlan-id 101
      ssid-profile wlan-net
      security-profile wlan-net
      authentication-profile wlan-net         
     regulatory-domain-profile name default
     ap-group name ap-group1
      radio 0
       vap-profile wlan-net wlan 1            
      radio 1
       vap-profile wlan-net wlan 1
     ap-id 0 type-id 35 ap-mac 60de-4476-e360 ap-sn 210235554710CB000042
      ap-name area_1
      ap-group ap-group1
    #
    return
Загрузить
Updated: 2018-08-21

№ документа:EDOC1100029357

Просмотры:10177

Загрузки: 143

Average rating:
This Document Applies to these Products
Связанные документы
Related Version
Share
Назад Далее