Для выбранного языка не найдены ресурсы переадресации.

Этот веб-сайт использует cookie-файлы. Продолжая просмотр, вы соглашаетесь на их использование. Ознакомьтесь с нашей политикой соблюдения конфиденциальности.>

Типичные примеры настройки WLAN

Rate and give feedback :
Информация об этом переводе
Чтобы помочь вам лучше понять содержимое этого документа, компания Huawei перевела его на разные языки, используя машинный перевод, отредактированный людьми. Примечание: даже самые передовые программы машинного перевода не могут обеспечить качество на уровне перевода, выполненного профессиональным переводчиком. Компания Huawei не несет ответственность за точность перевода и рекомендует ознакомиться с документом на английском языке (по ссылке, которая была предоставлена ранее).
Пример настройки VRRP HSB

Пример настройки VRRP HSB

Требования к службе

Предприятие развертывает WLAN для предоставления пользователям служб WLAN. Предприятие требует, чтобы VRRP HSB улучшал надежность передачи данных.

Требования к сети

  • Режим сети AC: Режим обхода уровня 2
  • Режим развертывания DHCP: AC функционирует как DHCP-сервер, чтобы назначить IP-адреса для AP и STA.
  • Режим переадресации сервисных данных: прямая переадресация
  • Кластер коммутаторов: кластер настраивается с использованием платы CSS, содержащей SwitchB и SwitchC на базовом уровне. SwitchB - активный коммутатор, а SwitchC - резервный коммутатор.
Рис. 3-43 Настройка VRRP HSB (прямая переадресация)

План данных

Табл. 3-46 План данных AC

Пункт

Конфигурация

Исходный интерфейс AC1

VLANIF 100: 10.23.100.3/24

Исходный интерфейс AC2

VLANIF 100: 10.23.100.3/24

Виртуальный IP-адрес управляющей группы VRRP

10.23.100.3/24

Виртуальный IP-адрес сервисной группы VRRP

10.23.101.3/24

Профиль VAP

  • Имя: wlan-net
  • Режим переадресации: прямая переадресация
  • Сервисная VLAN: VLAN 101
  • Ссылочные профили: Профиль SSID wlan-net и профиль безопасности wlan-net

Группа AP

  • Имя: ap-group1
  • Ссылочные профили: Профиль VAP wlan-net и профиль регулятивного домена default

Профиль регулятивного домена

  • Имя: default
  • Код страны: China

Профиль SSID

  • Имя: wlan-net
  • Имя SSID: wlan-net

Профиль безопасности

  • Имя: wlan-net
  • Политика безопасности: WPA-WPA2+PSK+AES
  • Пароль: a1234567

DHCP-сервер

AC функционирует как DHCP-сервер, чтобы назначить IP-адреса для AP и STA.

Шлюз AP

VLANIF 100: 10.23.100.3/24

Пул IP-адресов для AP

10.23.100.4 to 10.23.100.254/24

Шлюз STA

VLANIF 101: 10.23.101.3/24

Пул IP-адресов для STA

10.23.101.4 to 10.23.101.254/24

IP-адреса и номера портов для активных и резервных каналов AC1

IP-адрес: VLANIF 102, 10.23.102.1/24

Номер порта: 10241

IP-адреса и номера портов для активных и резервных каналов AC2

IP-адрес: VLANIF 102, 10.23.102.2/24

Номер порта: 10241

Схема настройки

Схема настройки выглядит следующим образом:

  1. Настройте кластер между SwitchB и SwitchC через кластерные платы для повышения надежности базового уровня и настройте SwitchB в качестве главного коммутатора.
  2. Настройте соединения между AP, AC и другими сетевыми устройствами.
  3. Настройте базовые службы WLAN, чтобы пользователи могли получать доступ к Интернету через WLAN.
  4. Настройте группу VRRP на AC1 и AC2 и настройте высокий приоритет для AC1 в качестве активного устройства для пересылки трафика и низкий приоритет для AC2 в качестве резервного устройства.
  5. Настройте функцию горячего резерв (HSB), чтобы информация о службе на AC1 была скопирована к AC2 в пакетах в реальном времени, обеспечивая бесперебойное переключение службы с активного устройства на резервное устройство.
ПРИМЕЧАНИЕ:

Проверьте, происходят ли петли в проводной сети. Если возникают петли, настройте MSTP на соответствующих элементах сети (NE).

Примечания по конфигурации

  • Механизм ACK не предусмотрен для многоадресной передачи пакетов на воздушных интерфейсах. Кроме того, беспроводные каналы нестабильны. Для обеспечения стабильной передачи многоадресных пакетов они обычно отправляются по низким тарифам. Если большое количество таких многоадресных пакетов отправляется с сетевой стороны, воздушные интерфейсы могут быть перегружены. Рекомендуется настроить подавление многоадресных пакетов, чтобы уменьшить влияние большого количества низкоскоростных многоадресных пакетов на беспроводную сеть. Соблюдайте осторожность при настройке ограничения скорости; в противном случае могут быть затронуты многоадресные услуги.
    • В режиме прямой переадресации рекомендуется настроить подавление многоадресных пакетов на интерфейсах коммутатора, подключенных к точкам доступа (AP).
    • В режиме туннельной переадресации рекомендуется настроить подавление многоадресных пакетов в профилях трафика AC.
    Подробнее о том, как настроить подавление трафика, см. Подавление многоадресных пакетов не настроено, что приводит к замедлению доступа к сети STA.
  • Настройте изоляцию портов на интерфейсах устройства, напрямую подключенного к точкам доступа. Если изоляция порта не настроена и используется прямая переадресация, в VLAN может быть создано большое количество ненужных широковещательных пакетов, блокирующих сеть и ухудшающих работу пользователя.

  • В режиме туннельной переадресации управляющая VLAN и сервисная VLAN не могут быть одинаковыми. Только пакеты из управляющей VLAN передаются между AC и AP. Пакеты из сервисной VLAN не допускаются между AC и AP.

Процедура

  1. Установите кластер через кластерные платы.

    # Установите идентификатор CSS на 1, приоритет CSS на 100 и режим соединения с CSS на соединение с платой CSS для SwitchB.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] set css mode css-card
    [SwitchB] set css id 1
    [SwitchB] set css priority 100
    

    # Установите идентификатор CSS на 2, приоритет CSS на 10 и режим соединения с CSS на соединение с платой CSS для SwitchC.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchC
    [SwitchC] set css mode css-card
    [SwitchC] set css id 2
    [SwitchC] set css priority 10
    

    # Проверьте конфигурацию CSS на SwitchB.

    [SwitchB] display css status saved
    Current Id   Saved Id     CSS Enable   CSS Mode    Priority    Master force     
    ------------------------------------------------------------------------------  
    1            1            Off          CSS card    100         Off             

    # Проверьте конфигурацию CSS на SwitchC.

    [SwitchC] display css status saved
    Current Id   Saved Id     CSS Enable   CSS Mode    Priority    Master force     
    ------------------------------------------------------------------------------  
    1            2            Off          CSS card    10          Off              

    # Включите функцию CSS на SwitchB и перезапустите SwitchB.

    [SwitchB] css enable
    Warning: The CSS configuration will take effect only after the system is rebooted. T
    he next CSS mode is CSS card. Reboot now? [Y/N]:y

    # Включите функцию CSS на SwitchC и перезапустите SwitchC.

    [SwitchC] css enable
    Warning: The CSS configuration will take effect only after the system is rebooted. T
    he next CSS mode is CSS card. Reboot now? [Y/N]:y

    # Войдите в CSS через консольный порт на любом MPU, чтобы проверить, успешно ли установлен CSS.

    <SwitchB> display device
    Chassis 1 (Master Switch)
    S12708's Device status:
    Slot  Sub Type         Online    Power      Register       Status     Role  
    -------------------------------------------------------------------------------
    1     -   ET1D2SFUD000 Present   PowerOn    Registered     Normal     NA    
          1   EH1D2VS08000 Present   PowerOn    Registered     Normal     NA    
    5     -   ET1D2G48SEC0 Present   PowerOn    Registered     Normal     NA    
    7     -   ET1D2X16SSC0 Present   PowerOn    Registered     Normal     NA    
    9     -   ET1D2MPUA000 Present   PowerOn    Registered     Normal     Slave 
    10    -   ET1D2MPUA000 Present   PowerOn    Registered     Normal     Master
    12    -   ET1D2SFUD000 Present   PowerOn    Registered     Normal     NA    
          1   EH1D2VS08000 Present   PowerOn    Registered     Normal     NA    
    13    -   ET1D2SFUD000 Present   PowerOn    Registered     Normal     NA    
          1   EH1D2VS08000 Present   PowerOn    Registered     Normal     NA    
    14    -   ET1D2SFUD000 Present   PowerOn    Registered     Normal     NA    
          1   EH1D2VS08000 Present   PowerOn    Registered     Normal     NA    
    PWR1  -   -            Present   PowerOn    Registered     Normal     NA    
    PWR2  -   -            Present   PowerOn    Registered     Normal     NA    
    CMU2  -   EH1D200CMU00 Present   PowerOn    Registered     Normal     Master
    FAN1  -   -            Present   PowerOn    Registered     Normal     NA    
    FAN2  -   -            Present   PowerOn    Registered     Normal     NA    
    FAN3  -   -            Present   PowerOn    Registered     Normal     NA    
    FAN4  -   -            Present   PowerOn    Registered     Normal     NA    
    Chassis 2 (Standby Switch)
    S12708's Device status:
    Slot  Sub Type         Online    Power      Register       Status     Role  
    -------------------------------------------------------------------------------
    1     -   ET1D2SFUD000 Present   PowerOn    Registered     Normal     NA    
          1   EH1D2VS08000 Present   PowerOn    Registered     Normal     NA    
    3     -   ET1D2G48SEC0 Present   PowerOn    Registered     Normal     NA    
    4     -   ET1D2X16SSC0 Present   PowerOn    Registered     Normal     NA    
    9     -   ET1D2MPUA000 Present   PowerOn    Registered     Normal     Slave 
    10    -   ET1D2MPUA000 Present   PowerOn    Registered     Normal     Master
    12    -   ET1D2SFUD000 Present   PowerOn    Registered     Normal     NA    
          1   EH1D2VS08000 Present   PowerOn    Registered     Normal     NA    
    13    -   ET1D2SFUD000 Present   PowerOn    Registered     Normal     NA    
          1   EH1D2VS08000 Present   PowerOn    Registered     Normal     NA    
    14    -   ET1D2SFUD000 Present   PowerOn    Registered     Normal     NA    
          1   EH1D2VS08000 Present   PowerOn    Registered     Normal     NA    
    PWR1  -   -            Present   PowerOn    Registered     Normal     NA    
    PWR2  -   -            Present   PowerOn    Registered     Normal     NA    
    CMU1  -   EH1D200CMU00 Present   PowerOn    Registered     Normal     Master
    FAN1  -   -            Present   PowerOn    Registered     Normal     NA    
    FAN2  -   -            Present   PowerOn    Registered     Normal     NA    
    FAN3  -   -            Present   PowerOn    Registered     Normal     NA    
    FAN4  -   -            Present   PowerOn    Registered     Normal     NA    
    <SwitchB> display css status
    CSS Enable switch On                                                            
                                                                                    
    Chassis Id   CSS Enable   CSS Status      CSS Mode    Priority    Master Force  
    ------------------------------------------------------------------------------  
    1            On           Master          CSS card    100         Off           
    2            On           Standby         CSS card    10          Off   

    Вывод команды показывает состояние платы и состояние CSS обоих членов-коммутаторов, что указывает на успешное создание CSS.

    # Проверьте, являются ли связи кластера нормальными.

    <SwitchB> display css channel
                   Chassis 1               ||             Chassis 2                 
    --------------------------------------------------------------------------------
    Num      [Port]         [Speed]        ||        [Speed]         [Port]
     1       1/1/0/1        10G                      10G             2/1/0/1      
     2       1/1/0/2        10G                      10G             2/1/0/2      
     3       1/1/0/3        10G                      10G             2/1/0/3      
     4       1/1/0/4        10G                      10G             2/1/0/4      
     5       1/1/0/5        10G                      10G             2/1/0/5      
     6       1/1/0/6        10G                      10G             2/1/0/6      
     7       1/1/0/7        10G                      10G             2/1/0/7      
     8       1/1/0/8        10G                      10G             2/1/0/8      
     9       1/12/0/1       10G                      10G             2/12/0/1      
    10       1/12/0/2       10G                      10G             2/12/0/2      
    11       1/12/0/3       10G                      10G             2/12/0/3      
    12       1/12/0/4       10G                      10G             2/12/0/4      
    13       1/12/0/5       10G                      10G             2/12/0/5      
    14       1/12/0/6       10G                      10G             2/12/0/6      
    15       1/12/0/7       10G                      10G             2/12/0/7      
    16       1/12/0/8       10G                      10G             2/12/0/8      
    17       1/13/0/1       10G                      10G             2/13/0/1      
    18       1/13/0/2       10G                      10G             2/13/0/2      
    19       1/13/0/3       10G                      10G             2/13/0/3      
    20       1/13/0/4       10G                      10G             2/13/0/4      
    21       1/13/0/5       10G                      10G             2/13/0/5      
    22       1/13/0/6       10G                      10G             2/13/0/6      
    23       1/13/0/7       10G                      10G             2/13/0/7      
    24       1/13/0/8       10G                      10G             2/13/0/8      
    25       1/14/0/1       10G                      10G             2/14/0/1      
    26       1/14/0/2       10G                      10G             2/14/0/2      
    27       1/14/0/3       10G                      10G             2/14/0/3      
    28       1/14/0/4       10G                      10G             2/14/0/4      
    29       1/14/0/5       10G                      10G             2/14/0/5      
    30       1/14/0/6       10G                      10G             2/14/0/6      
    31       1/14/0/7       10G                      10G             2/14/0/7      
    32       1/14/0/8       10G                      10G             2/14/0/8      
    --------------------------------------------------------------------------------

    Вывод команды показывает, что все связи кластера находятся в состоянии Up, что указывает на успешное установление CSS.

  2. Настройте SwitchA, SwitchB, SwitchC, AC1 и AC2, чтобы пакеты CAPWAP могли передаваться между AP и AC.

    ПРИМЕЧАНИЕ:

    Если используется прямая переадресация, настройте выделение портов на GE0/0/1 у SwitchA (соединяющий с AP). Если изоляция порта не настроена, многие широковещательные пакеты будут передаваться в VLAN, или пользователи WLAN на разных AP могут напрямую связываться на уровне 2.

    # Установите PVID GE0/0/1 на SwitchA, подключенном к AP, на управляющую VLAN 100 и добавьте GE0/0/1 к VLAN 100 и сервисной VLAN 101. Добавьте GE0/0/2 на SwitchA, подключенный к SwitchB к VLAN 100 и VLAN 101 и GE0/0/3 на SwitchA, подключенном к SwitchC к VLAN 100 и VLAN 101.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 100 101
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [SwitchA-GigabitEthernet0/0/1] undo port trunk allow-pass vlan 1
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 101
    [SwitchA-GigabitEthernet0/0/1] port-isolate enable
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] undo port trunk allow-pass vlan 1
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 101
    [SwitchA-GigabitEthernet0/0/2] quit
    [SwitchA] interface gigabitethernet 0/0/3
    [SwitchA-GigabitEthernet0/0/3] port link-type trunk
    [SwitchA-GigabitEthernet0/0/3] undo port trunk allow-pass vlan 1
    [SwitchA-GigabitEthernet0/0/3] port trunk allow-pass vlan 100 101
    [SwitchA-GigabitEthernet0/0/3] quit
    

    # Добавьте GE1/1/0/2, который соединяет SwitchB с SwitchA к VLAN 100 и VLAN 101 (сервисная VLAN), и добавьте GE1/1/0/1, который соединяет SwitchB с AC1 к VLAN 100 и VLAN 101. Добавьте GE2/1/0/2, который соединяет SwitchC с SwitchA к VLAN 100 и VLAN 101 (сервисная VLAN) и добавьте GE2/1/0/1, который соединяет SwitchC с AC1 к VLAN 100 и VLAN 101.

    [SwitchB] sysname CSS
    [CSS] vlan batch 100 101
    [CSS] interface gigabitethernet 1/1/0/1
    [CSS-GigabitEthernet1/1/0/1] port link-type trunk
    [CSS-GigabitEthernet1/1/0/1] undo port trunk allow-pass vlan 1
    [CSS-GigabitEthernet1/1/0/1] port trunk allow-pass vlan 100 101
    [CSS-GigabitEthernet1/1/0/1] quit
    [CSS] interface gigabitethernet 1/1/0/2
    [CSS-GigabitEthernet1/1/0/2] port link-type trunk
    [CSS-GigabitEthernet1/1/0/2] undo port trunk allow-pass vlan 1
    [CSS-GigabitEthernet1/1/0/2] port trunk allow-pass vlan 100 101
    [CSS-GigabitEthernet1/1/0/2] quit
    [CSS] interface gigabitethernet 2/1/0/1
    [CSS-GigabitEthernet2/1/0/1] port link-type trunk
    [CSS-GigabitEthernet2/1/0/1] undo port trunk allow-pass vlan 1
    [CSS-GigabitEthernet2/1/0/1] port trunk allow-pass vlan 100 101
    [CSS-GigabitEthernet2/1/0/1] quit
    [CSS] interface gigabitethernet 2/1/0/2
    [CSS-GigabitEthernet2/1/0/2] port link-type trunk
    [CSS-GigabitEthernet2/1/0/2] undo port trunk allow-pass vlan 1
    [CSS-GigabitEthernet2/1/0/2] port trunk allow-pass vlan 100 101
    [CSS-GigabitEthernet2/1/0/2] quit

    # Добавьте GE0/0/1, который соединяет AC1 с SwitchB к VLAN 100 и VLAN 101, и настройте VLANIF 100 и VLANIF 101.

    <AC6605> system-view
    [AC6605] sysname AC1
    [AC1] vlan batch 100 101
    [AC1] interface gigabitethernet 0/0/1
    [AC1-GigabitEthernet0/0/1] port link-type trunk
    [AC1-GigabitEthernet0/0/1] undo port trunk allow-pass vlan 1
    [AC1-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 101
    [AC1-GigabitEthernet0/0/1] quit
    [AC1] interface vlanif 100
    [AC1-Vlanif100] ip address 10.23.100.1 24
    [AC1-Vlanif100] quit
    [AC1] interface vlanif 101
    [AC1-Vlanif101] ip address 10.23.101.1 24
    [AC1-Vlanif101] quit

    # Добавьте GE0/0/1, который соединяет AC2 с SwitchC к VLAN 100 и VLAN 101 и настройте VLANIF 100 и VLANIF 101.

    <AC6605> system-view
    [AC6605] sysname AC2
    [AC2] vlan batch 100 101
    [AC2] interface gigabitethernet 0/0/1
    [AC2-GigabitEthernet0/0/1] port link-type trunk
    [AC2-GigabitEthernet0/0/1] undo port trunk allow-pass vlan 1
    [AC2-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 101
    [AC2-GigabitEthernet0/0/1] quit
    [AC2] interface vlanif 100
    [AC2-Vlanif100] ip address 10.23.100.2 24
    [AC2-Vlanif100] quit
    [AC2] interface vlanif 101
    [AC2-Vlanif101] ip address 10.23.101.2 24
    [AC2-Vlanif101] quit

  3. Настройте AC1 для связи с AC2.

    # Добавьте GE0/0/2 на AC1 (соединяющий с AC2) к VLAN 102.

    [AC1] vlan batch 102
    [AC1] interface gigabitethernet 0/0/2
    [AC1-GigabitEthernet0/0/2] port link-type trunk
    [AC1-GigabitEthernet0/0/2] undo port trunk allow-pass vlan 1
    [AC1-GigabitEthernet0/0/2] port trunk allow-pass vlan 102
    [AC1-GigabitEthernet0/0/2] quit
    [AC1] interface vlanif 102
    [AC1-Vlanif102] ip address 10.23.102.1 24
    [AC1-Vlanif102] quit
    

    # Добавьте GE0/0/2 на AC2 (соединяющий с AC1) к VLAN 102.

    [AC2] vlan batch 102
    [AC2] interface gigabitethernet 0/0/2
    [AC2-GigabitEthernet0/0/2] port link-type trunk
    [AC2-GigabitEthernet0/0/2] undo port trunk allow-pass vlan 1
    [AC2-GigabitEthernet0/0/2] port trunk allow-pass vlan 102
    [AC2-GigabitEthernet0/0/2] quit
    [AC2] interface vlanif 102
    [AC2-Vlanif102] ip address 10.23.102.2 24
    [AC2-Vlanif102] quit
    

  4. Настройте DHCP-сервер.

    ПРИМЕЧАНИЕ:
    Настройте DNS-сервер по мере необходимости. Общие методы заключаются в следующем:
    • В сценариях пула адресов интерфейса запустите команду dhcp server dns-list ip-address &<1-8> в виде интерфейса VLANIF.
    • В сценариях пула глобального адреса запустите команду dns-list ip-address &<1-8> в виде пула IP-адресов.

    # Настройте AC1 в качестве DHCP-сервера, чтобы назначить IP-адреса для AP и STA.

    [AC1] dhcp enable
    [AC1] dhcp server database enable
    [AC1] dhcp server database recover
    [AC1] interface vlanif 100
    [AC1-Vlanif100] dhcp select interface
    [AC1-Vlanif100] dhcp server excluded-ip-address 10.23.100.2
    [AC1-Vlanif100] quit
    [AC1] interface vlanif 101
    [AC1-Vlanif101] dhcp select interface
    [AC1-Vlanif101] dhcp server excluded-ip-address 10.23.101.2
    [AC1-Vlanif101] quit
    

    Конфигурация для AC2 аналогична конфигурации для AC1 и не упоминается здесь.

  5. Настройте VRRP на AC1 для реализации горячего резерва AC.

    # Установите задержку восстановления группы VRRP на 60 секунд.

    [AC1] vrrp recover-delay 60
    

    # Создайте управляющую группу VRRP на AC1, установите приоритет VRRP AC1 на 120 и установите задержку переадресации на 1800 секунд.

    [AC1] interface vlanif 100
    [AC1-Vlanif100] vrrp vrid 1 virtual-ip 10.23.100.3
    [AC1-Vlanif100] vrrp vrid 1 priority 120
    [AC1-Vlanif100] vrrp vrid 1 preempt-mode timer delay 1800
    [AC1-Vlanif100] admin-vrrp vrid 1
    [AC1-Vlanif100] quit
    

    # Создайте сервисную группу VRRP на AC1 и установите задержку приостановки на 1800 секунд.

    [AC1] interface vlanif 101
    [AC1-Vlanif101] vrrp vrid 2 virtual-ip 10.23.101.3
    [AC1-Vlanif101] vrrp vrid 2 preempt-mode timer delay 1800
    [AC1-Vlanif101] vrrp vrid 2 track admin-vrrp interface vlanif 100 vrid 1 unflowdown
    [AC1-Vlanif101] quit

    # На AC1 создайте HSB услуги 0, настройте IP-адреса и номера портов для активных и резервных каналов и установите время повторной передачи и интервал HSB-пакетов.

    [AC1] hsb-service 0
    [AC1-hsb-service-0] service-ip-port local-ip 10.23.102.1 peer-ip 10.23.102.2 local-data-port 10241 peer-data-port 10241
    [AC1-hsb-service-0] service-keep-alive detect retransmit 3 interval 6
    [AC1-hsb-service-0] quit

    # На AC1 создайте HSB группу 0 и привяжите ее к HSB услуге 0 и управляющей группе VRRP.

    [AC1] hsb-group 0
    [AC1-hsb-group-0] bind-service 0
    [AC1-hsb-group-0] track vrrp vrid 1 interface vlanif 100
    [AC1-hsb-group-0] quit
    

    # Привяжите службу NAC к группе HSB.

    [AC1] hsb-service-type access-user hsb-group 0

    # Привяжите службу WLAN к группе HSB.

    [AC1] hsb-service-type ap hsb-group 0

    # Привяжите службу DHCP к группе HSB.

    [AC1] hsb-service-type dhcp hsb-group 0

    # Включите функцию HSB.

    [AC1] hsb-group 0
    [AC1-hsb-group-0] hsb enable
    [AC1-hsb-group-0] quit

  6. Настройте VRRP на AC2 для реализации горячего резерва AC.

    # Установите задержку восстановления группы VRRP на 60 секунд.

    [AC2] vrrp recover-delay 60
    

    # Создайте управляющую группу VRRP на AC2.

    [AC2] interface vlanif 100
    [AC2-Vlanif100] vrrp vrid 1 virtual-ip 10.23.100.3
    [AC2-Vlanif100] admin-vrrp vrid 1
    [AC2-Vlanif100] quit
    

    # Создайте сервисную группу VRRP на AC2.

    [AC2] interface vlanif 101
    [AC2-Vlanif101] vrrp vrid 2 virtual-ip 10.23.101.3
    [AC2-Vlanif101] vrrp vrid 2 track admin-vrrp interface vlanif 100 vrid 1 unflowdown
    [AC2-Vlanif101] quit

    # Создайте HSB услуги 0 на AC2, настройте IP-адреса и номера портов для активных и резервных каналов и установите время повторной передачи и интервал HSB-пакетов.

    [AC2] hsb-service 0
    [AC2-hsb-service-0] service-ip-port local-ip 10.23.102.2 peer-ip 10.23.102.1 local-data-port 10241 peer-data-port 10241
    [AC2-hsb-service-0] service-keep-alive detect retransmit 3 interval 6
    [AC2-hsb-service-0] quit

    # Создайте группу HSB 0 на AC2 и привяжите ее к HSB услуге 0 и управляющей группе VRRP.

    [AC2] hsb-group 0
    [AC2-hsb-group-0] bind-service 0
    [AC2-hsb-group-0] track vrrp vrid 1 interface vlanif 100
    [AC2-hsb-group-0] quit
    

    # Привяжите службу NAC к группе HSB.

    [AC2] hsb-service-type access-user hsb-group 0

    # Привяжите службу WLAN к группе HSB.

    [AC2] hsb-service-type ap hsb-group 0

    # Привяжите службу DHCP к группе HSB.

    [AC2] hsb-service-type dhcp hsb-group 0

    # Включите функцию HSB.

    [AC2] hsb-group 0
    [AC2-hsb-group-0] hsb enable
    [AC2-hsb-group-0] quit

  7. Настройте службы WLAN на AC1. Конфигурации на AC2 аналогичны конфигурациям на AC1. Если AP на активном AC находится в нормальном состоянии, то она на AC2 находится в резервном состоянии.
    1. Настройте системные параметры для AC1.

      [AC1] wlan
      [AC1-wlan-view] ap-group name ap-group1
      [AC1-wlan-ap-group-ap-group1] quit
      [AC1-wlan-view] regulatory-domain-profile name default
      [AC1-wlan-regulate-domain-default] country-code cn
      [AC1-wlan-regulate-domain-default] quit
      [AC1-wlan-view] ap-group name ap-group1
      [AC1-wlan-ap-group-ap-group1] regulatory-domain-profile default
      Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
      e?[Y/N]:y 
      [AC1-wlan-ap-group-ap-group1] quit
      [AC1-wlan-view] quit
      [AC1] capwap source ip-address 10.23.100.3

    2. Импортируйте AP в автономном режиме на AC1.

      [AC1] wlan
      [AC1-wlan-view] ap auth-mode mac-auth
      [AC1-wlan-view] ap-id 0 ap-mac 60de-4476-e360
      [AC1-wlan-ap-0] ap-name area_1
      [AC1-wlan-ap-0] ap-group ap-group1
      Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
      s of the radio, Whether to continue? [Y/N]:y 
      [AC1-wlan-ap-0] quit
      [AC1-wlan-view] display ap all
      Total AP information:
      nor  : normal          [1]
      -------------------------------------------------------------------------------------
      ID   MAC            Name   Group     IP              Type            State STA Uptime
      -------------------------------------------------------------------------------------
      0    60de-4476-e360 area_1 ap-group1 10.23.100.254   AP5030DN        nor   0   10S
      -------------------------------------------------------------------------------------
      Total: 1

    3. Настройте параметры службу WLAN на AC1.

      # Создайте профиль безопасности wlan-net и установите политику безопасности в профиле.
      ПРИМЕЧАНИЕ:

      В этом примере политика безопасности установлена ​​на WPA-WPA2+PSK+AES и пароль на a1234567. В реальных ситуациях политика безопасности должна быть настроена в соответствии с требованиями к службе.

      [AC1-wlan-view] security-profile name wlan-net
      [AC1-wlan-sec-prof-wlan-net] security wpa-wpa2 psk pass-phrase a1234567 aes
      [AC1-wlan-sec-prof-wlan-net] quit
      

      # Создайте профиль SSID wlan-net и установите имя SSID на wlan-net.

      [AC1-wlan-view] ssid-profile name wlan-net
      [AC1-wlan-ssid-prof-wlan-net] ssid wlan-net
      [AC1-wlan-ssid-prof-wlan-net] quit
      

      # Создайте профиль VAP wlan-net, установите режим переадресации данных и сервисную VLAN и примените профиль безопасности и профиль SSID к профилю VAP.

      [AC1-wlan-view] vap-profile name wlan-net
      [AC1-wlan-vap-prof-wlan-net] forward-mode direct-forward
      [AC1-wlan-vap-prof-wlan-net] service-vlan vlan-id 101
      [AC1-wlan-vap-prof-wlan-net] security-profile wlan-net
      [AC1-wlan-vap-prof-wlan-net] ssid-profile wlan-net
      [AC1-wlan-vap-prof-wlan-net] quit
      

      # Привяжите профиль VAP wlan-net к группе AP и примените профиль к Radio 0 и Radio 1 точки доступа.

      [AC1-wlan-view] ap-group name ap-group1
      [AC1-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 0
      [AC1-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 1
      [AC1-wlan-ap-group-ap-group1] quit
      [AC1-wlan-view] quit

  8. Проверьте конфигурацию.

    # После завершения конфигураций запустите команду display vrrp на AC1 и AC2. Вывод команды показывает, что поле State у AC1 является Master, а у AC2 - Backup.

    [AC1] display vrrp
      Vlanif100 | Virtual Router 1
        State : Master
        Virtual IP : 10.23.100.3
        Master IP : 10.23.100.1
        PriorityRun : 120
        PriorityConfig : 120
        MasterPriority : 120
        Preempt : YES   Delay Time : 1800 s
        TimerRun : 1 s
        TimerConfig : 1 s
        Auth type : NONE
        Virtual MAC : 0000-5e00-0101
        Check TTL : YES
        Config type : admin-vrrp
        Backup-forward : disabled
        Create time : 2005-07-31 01:25:55 UTC+08:00
        Last change time : 2005-07-31 02:48:22 UTC+08:00
                                                                                    
      Vlanif101 | Virtual Router 2
        State : Master
        Virtual IP : 10.23.101.3
        Master IP : 10.23.101.1
        PriorityRun : 100
        PriorityConfig : 100
        MasterPriority : 100
        Preempt : YES   Delay Time : 1800 s
        TimerRun : 1 s
        TimerConfig : 1 s
        Auth type : NONE
        Virtual MAC : 0000-5e00-0102
        Check TTL : YES
        Config type : member-vrrp
        Backup-forward : disabled
        Create time : 2005-07-30 23:45:50 UTC+08:00
        Last change time : 2005-07-31 02:48:22 UTC+08:00
    [AC2] display vrrp
      Vlanif100 | Virtual Router 1
        State : Backup
        Virtual IP : 10.23.100.3
        Master IP : 10.23.100.1
        PriorityRun : 100
        PriorityConfig : 100
        MasterPriority : 120
        Preempt : YES   Delay Time : 0 s
        TimerRun : 1 s
        TimerConfig : 1 s
        Auth type : NONE
        Virtual MAC : 0000-5e00-0101
        Check TTL : YES
        Config type : admin-vrrp
        Backup-forward : disabled
        Create time : 2005-07-31 02:11:07 UTC+08:00
        Last change time : 2005-07-31 03:40:45 UTC+08:00
    
      Vlanif101 | Virtual Router 2
        State : Backup
        Virtual IP : 10.23.101.3
        Master IP : 0.0.0.0
        PriorityRun : 100
        PriorityConfig : 100
        MasterPriority : 100
        Preempt : YES   Delay Time : 0 s
        TimerRun : 1 s
        TimerConfig : 1 s
        Auth type : NONE
        Virtual MAC : 0000-5e00-0102
        Check TTL : YES
        Config type : member-vrrp
        Backup-forward : disabled
        Create time : 2005-07-31 00:32:33 UTC+08:00
        Last change time : 2005-07-31 03:40:45 UTC+08:00

    # Запустите команду display hsb-service 0 на AC1 и AC2, чтобы проверить состояние услуги HSB. Вывод команды показывает, что поле Service State является Connected, что указывает на то, что канал HSB установлен.

    [AC1] display hsb-service 0
    Hot Standby Service Information:
    ----------------------------------------------------------
      Local IP Address       : 10.23.102.1
      Peer IP Address        : 10.23.102.2
      Source Port            : 10241
      Destination Port       : 10241
      Keep Alive Times       : 2
      Keep Alive Interval    : 1
      Service State          : Connected
      Service Batch Modules  : 
    ----------------------------------------------------------
    
    [AC2] display hsb-service 0
    Hot Standby Service Information:
    ----------------------------------------------------------
      Local IP Address       : 10.23.102.2
      Peer IP Address        : 10.23.102.1
      Source Port            : 10241
      Destination Port       : 10241
      Keep Alive Times       : 2
      Keep Alive Interval    : 1
      Service State          : Connected
      Service Batch Modules  : 
    ----------------------------------------------------------
    

    # Запустите команду display hsb-group 0 на AC1 и AC2, чтобы проверить состояние группы HSB.

    [AC1] display hsb-group 0
    Hot Standby Group Information:
    ----------------------------------------------------------
      HSB-group ID                : 0
      Vrrp Group ID               : 1
      Vrrp Interface              : Vlanif100
      Service Index               : 0
      Group Vrrp Status           : Master
      Group Status                : Active
      Group Backup Process        : Realtime
      Peer Group Device Name      : AC6605
      Peer Group Software Version : V200R007C20
      Group Backup Modules        : Access-user
                                    DHCP
                                    AP
    ----------------------------------------------------------  
    [AC2] display hsb-group 0
    Hot Standby Group Information:
    ----------------------------------------------------------
      HSB-group ID                : 0
      Vrrp Group ID               : 1
      Vrrp Interface              : Vlanif100
      Service Index               : 0
      Group Vrrp Status           : Backup
      Group Status                : Inactive
      Group Backup Process        : Realtime
      Peer Group Device Name      : AC6605
      Peer Group Software Version : V200R007C20
      Group Backup Modules        : Access-user
                                    DHCP
                                    AP
    ----------------------------------------------------------  

    WLAN с SSID wlan-net доступна для STA, подключенных к AP, и эти STA могут подключаться к WLAN.

    Когда соединения между SwitchA и SwitchB и соединения между AC1 и SwitchB отключены, AC2 переключается на активный AC. Это обеспечивает стабильность передачи службы.

Файлы конфигурации

  • Файл конфигурации SwitchA

    #
    sysname SwitchA
    #
    vlan batch 100 to 101
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk pvid vlan 100
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 100 to 101
     port-isolate enable group 1
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 100 to 101
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 100 to 101
    #
    return
  • • Файл конфигурации CSS

    #
    sysname CSS
    #
    vlan batch 100 to 101
    #  
    interface GigabitEthernet1/1/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 100 to 101
    #
    interface GigabitEthernet1/1/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 100 to 101
    #
    interface GigabitEthernet2/1/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 100 to 101
    #
    interface GigabitEthernet2/1/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 100 to 101
    #
    return
  • Файл конфигурации AC1

    #
     sysname AC1
    #
    vrrp recover-delay 60
    #
    vlan batch 100 to 102
    #
    dhcp enable
    #
    dhcp server database enable
    dhcp server database recover
    #
    interface Vlanif100
     ip address 10.23.100.1 255.255.255.0
     vrrp vrid 1 virtual-ip 10.23.100.3
     admin-vrrp vrid 1
     vrrp vrid 1 priority 120
     vrrp vrid 1 preempt-mode timer delay 1800
     dhcp select interface
     dhcp server excluded-ip-address 10.23.100.2
    #
    interface Vlanif101
     ip address 10.23.101.1 255.255.255.0
     vrrp vrid 2 virtual-ip 10.23.101.3
     vrrp vrid 2 preempt-mode timer delay 1800
     vrrp vrid 2 track admin-vrrp interface Vlanif100 vrid 1 unflowdown
     dhcp select interface
     dhcp server excluded-ip-address 10.23.101.2
    #
    interface Vlanif102
     ip address 10.23.102.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 100 to 101
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 102
    #
    capwap source ip-address 10.23.100.3
    #
    hsb-service 0
     service-ip-port local-ip 10.23.102.1 peer-ip 10.23.102.2 local-data-port 10241 peer-data-port 10241
     service-keep-alive detect retransmit 3 interval 6
    #
    hsb-group 0
     track vrrp vrid 1 interface Vlanif100
     bind-service 0
     hsb enable
    #
    hsb-service-type access-user hsb-group 0
    #
    hsb-service-type dhcp hsb-group 0
    #
    hsb-service-type ap hsb-group 0
    #
    wlan
     security-profile name wlan-net
      security wpa-wpa2 psk pass-phrase %^%#G.DGWgjG./fvyr*oM)KMgc*sR}!GUWLa"%G_E.^B%^%# aes
     ssid-profile name wlan-net
      ssid wlan-net
     vap-profile name wlan-net
      service-vlan vlan-id 101
      ssid-profile wlan-net
      security-profile wlan-net
     regulatory-domain-profile name default
     ap-group name ap-group1
      radio 0
       vap-profile wlan-net wlan 1
      radio 1
       vap-profile wlan-net wlan 1
     ap-id 0 type-id 35 ap-mac 60de-4476-e360 ap-sn 210235554710CB000042
      ap-name area_1
      ap-group ap-group1
    #
    return
  • Файл конфигурации AC2

    #
     sysname AC2
    #
    vrrp recover-delay 60
    #
    vlan batch 100 to 102
    #
    dhcp enable
    #
    dhcp server database enable
    dhcp server database recover
    #
    interface Vlanif100
     ip address 10.23.100.2 255.255.255.0
     vrrp vrid 1 virtual-ip 10.23.100.3
     admin-vrrp vrid 1
     dhcp select interface
    #
    interface Vlanif101
     ip address 10.23.101.2 255.255.255.0
     vrrp vrid 2 virtual-ip 10.23.101.3
     vrrp vrid 2 track admin-vrrp interface Vlanif100 vrid 1 unflowdown
     dhcp select interface
    #
    interface Vlanif102
     ip address 10.23.102.2 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 100 to 101
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 102
    #
    capwap source ip-address 10.23.100.3
    #
    hsb-service 0
     service-ip-port local-ip 10.23.102.2 peer-ip 10.23.102.1 local-data-port 10241 peer-data-port 10241
     service-keep-alive detect retransmit 3 interval 6
    #
    hsb-group 0
     track vrrp vrid 1 interface Vlanif100
     bind-service 0
     hsb enable
    #
    hsb-service-type access-user hsb-group 0
    #
    hsb-service-type dhcp hsb-group 0
    #
    hsb-service-type ap hsb-group 0
    #
    wlan
     security-profile name wlan-net
      security wpa-wpa2 psk pass-phrase %^%#G.DGWgjG./fvyr*oM)KMgc*sR}!GUWLa"%G_E.^B%^%# aes
     ssid-profile name wlan-net
      ssid wlan-net
     vap-profile name wlan-net
      service-vlan vlan-id 101
      ssid-profile wlan-net
      security-profile wlan-net
     regulatory-domain-profile name default
     ap-group name ap-group1
      radio 0
       vap-profile wlan-net wlan 1
      radio 1
       vap-profile wlan-net wlan 1
     ap-id 0 type-id 35 ap-mac 60de-4476-e360 ap-sn 210235554710CB000042
      ap-name area_1
      ap-group ap-group1
    #
    return
Загрузить
Updated: 2018-08-21

№ документа:EDOC1100029357

Просмотры:7612

Загрузки: 103

Average rating:
This Document Applies to these Products
Связанные документы
Related Version
Share
Назад Далее