Для выбранного языка не найдены ресурсы переадресации.

Этот веб-сайт использует cookie-файлы. Продолжая просмотр, вы соглашаетесь на их использование. Ознакомьтесь с нашей политикой соблюдения конфиденциальности.>

Типичные примеры настройки WLAN

Rate and give feedback :
Информация об этом переводе
Чтобы помочь вам лучше понять содержимое этого документа, компания Huawei перевела его на разные языки, используя машинный перевод, отредактированный людьми. Примечание: даже самые передовые программы машинного перевода не могут обеспечить качество на уровне перевода, выполненного профессиональным переводчиком. Компания Huawei не несет ответственность за точность перевода и рекомендует ознакомиться с документом на английском языке (по ссылке, которая была предоставлена ранее).
Пример настройки резервного копирования N+1

Пример настройки резервного копирования N+1

Требования к службе

У крупного предприятия есть филиалы в разных областях. В филиалах развертываются AC для управления AP и предоставления доступа к WLAN и служб e-mail. Эти службы требуют низкой надежности сети и обеспечивают временное прерывание службы. Для экономии затрат требуется AC для резервного копирования всех AC. В этом случае предприятие может развертывать высокопроизводительный AC в головном офисе в качестве резервного AC в целях предоставления служб резервного копирования для активных AC в филиалах.

Требования к сети

  • Режим сети AC: Режим обхода уровня 3
  • Режим развертывания DHCP: Router_3 функционирует как DHCP-сервер, чтобы назначить IP-адреса для AP и STA.
  • Режим переадресации сервисных данных: прямая переадресация
Рис. 3-44 Сеть для настройки резервного копирования N+1

План данных

Табл. 3-47 План данных AC
Пункт Данные

Управляющая VLAN для AP

AC_1 (активный AC): VLAN 99

AC_2 (активный AC): VLAN 100

Сервисная VLAN для STA

AC_1: VLAN 101

AC_2: VLAN 102

DHCP-сервер

Router_3 функционирует как DHCP-сервер, чтобы назначить IP-адреса для AP и STA.

Шлюз STA:
  • STA_1: 10.23.101.1/24
  • STA_2: 10.23.102.1/24

Шлюз AP:

  • AP_1: 10.23.99.1/24
  • AP_2: 10.23.100.1/24

Пул IP-адресов для AP

AP_1: 10.23.99.2-10.23.99.254/24

AP_2: 10.23.100.2-10.23.100.254/24

Пул IP-адресов для STA

STA1: 10.23.101.2-10.23.101.254/24

STA2: 10.23.102.2-10.23.102.254/24

Исходный интерфейс AC

AC_1: VLANIF 201

AC_2: VLANIF 202

AC_3: VLANIF 203

Управляющий IP-адрес AC_1

VLANIF 201: 10.23.201.1/24

Управляющий IP-адрес AC_2

VLANIF 202: 10.23.202.1/24

Управляющий IP-адрес AC_3

VLANIF 203: 10.23.203.1/24

Группа AP

AC_1: (активный AC):
  • Имя: ap-group1

  • Ссылочные профили: профиль системы AP ap-system, профиль VAP wlan-net и профиль регулятивного домена default

AC_2: (активный AC):
  • Имя: ap-group2

  • Ссылочные профили: профиль системы AP ap-system, профиль VAP wlan-net1 и профиль регулятивного домена default

AC_3 (резервный AC):
  • Имя: ap-group1
    • Ссылочные профили: профиль системы AP ap-system, профиль VAP wlan-net и профиль регулятивного домена default
  • Имя: ap-group2
    • Ссылочные профили: профиль системы AP ap-system, профиль VAP wlan-net1 и профиль регулятивного домена default

Профиль регулятивного домена

  • Имя: default
  • Код страны: China

Профиль SSID

AC_1:
  • Имя: wlan-net

  • Имя SSID: wlan-net

AC_2:
  • Имя: wlan-net1

  • Имя SSID: wlan-net1

AC_3:
  • Имя: wlan-net

  • Имя SSID: wlan-net

  • Имя: wlan-net1

  • Имя SSID: wlan-net1

Профиль безопасности

AC_1, AC_3:
  • Имя: wlan-net

  • Политика безопасности: WPA-WPA2+PSK+AES

  • Пароль: a1234567

AC_2, AC_3:
  • Имя: wlan-net1

  • Политика безопасности: WPA-WPA2+PSK+AES

  • Пароль: a1234567

Профиль системы AP

AC_3 (резервный AC): ap-system and ap-system1

Профиль VAP

AC_1:
  • Имя: wlan-net

  • Режим переадресации: прямая переадресация

  • Сервисная VLAN: VLAN 101

  • Ссылочные профили: Профиль SSID wlan-net и профиль безопасности wlan-net

AC_2:
  • Имя: wlan-net1

  • Режим переадресации: прямая переадресация

  • Сервисная VLAN: VLAN 102

  • Ссылочные профили: Профиль SSID wlan-net1 и профиль безопасности wlan-net1

AC_3:
  • Имя: wlan-net

    • Режим переадресации: прямая переадресация

    • Сервисная VLAN: VLAN 101

    • Ссылочные профили: Профиль SSID wlan-net и профиль безопасности wlan-net

  • Имя: wlan-net1

    • Режим переадресации: прямая переадресация

    • Сервисная VLAN: VLAN 102

    • Ссылочные профили: Профиль SSID wlan-net1 и профиль безопасности wlan-net1

Глобальный приоритет:

AC_1: 0

AC_2: 0

AC_3: 5

Схема настройки

  1. Настройте сетевое взаимодействие каждого AC и других сетевых устройств. Настройте Router_3 в качестве DHCP-сервера, чтобы назначить IP-адреса для AP и STA.
  2. Настройте AC_1 и AC_2 в качестве активных AC для AP_1 и AP_2 соответственно и настройте основные службы WLAN на AC_1 и AC_2.
  3. Настройте AC_3 как резервный AC и настройте основные службы WLAN на AC_3. Убедитесь, что конфигурации службы на AC_3 совпадают с конфигурациями на AC_1 и AC_2.
  4. Сначала настройте резервное копирование N+1 на активных AC, а затем на резервном AC. Когда включено резервное копирование N+1, все AP перезапускаются.

Примечания по конфигурации

  • Механизм ACK не предусмотрен для многоадресной передачи пакетов на воздушных интерфейсах. Кроме того, беспроводные каналы нестабильны. Для обеспечения стабильной передачи многоадресных пакетов они обычно отправляются по низким тарифам. Если большое количество таких многоадресных пакетов отправляется с сетевой стороны, воздушные интерфейсы могут быть перегружены. Рекомендуется настроить подавление многоадресных пакетов, чтобы уменьшить влияние большого количества низкоскоростных многоадресных пакетов на беспроводную сеть. Соблюдайте осторожность при настройке ограничения скорости; в противном случае могут быть затронуты многоадресные услуги.
    • В режиме прямой переадресации рекомендуется настроить подавление многоадресных пакетов на интерфейсах коммутатора, подключенных к точкам доступа (AP).
    • В режиме туннельной переадресации рекомендуется настроить подавление многоадресных пакетов в профилях трафика AC.
    Подробнее о том, как настроить подавление трафика, см. Подавление многоадресных пакетов не настроено, что приводит к замедлению доступа к сети STA.
  • Настройте изоляцию портов на интерфейсах устройства, напрямую подключенного к точкам доступа. Если изоляция порта не настроена и используется прямая переадресация, в VLAN может быть создано большое количество ненужных широковещательных пакетов, блокирующих сеть и ухудшающих работу пользователя.

  • В режиме туннельной переадресации управляющая VLAN и сервисная VLAN не могут быть одинаковыми. Только пакеты из управляющей VLAN передаются между AC и AP. Пакеты из сервисной VLAN не допускаются между AC и AP.

Процедура

  1. Настройте маршрутизаторы, коммутаторы и AC, чтобы обеспечить связь между ними.

    # На Router_1 создайте VLAN 99, VLAN 101 и VLAN 201. VLAN 99 используется в качестве управляющей VLAN, а VLAN 101 в качестве сервисной VLAN. Добавьте Eth2/0/0, подключенный к Switch_1, к VLAN 99 и VLAN 101, и Eth2/0/1, подключенный к AC_1, к VLAN 201. Настройте IP-адрес 10.23.99.1/24 для VLANIF 99, 10.23.101.1/24 для VLANIF 101 и 10.23.201.2/24 для VLANIF 201.
    <Huawei> system-view
    [Huawei] sysname Router_1
    [Router_1] vlan batch 99 101 201
    [Router_1] interface ethernet 2/0/0
    [Router_1-Ethernet2/0/0] port link-type trunk
    [Router_1-Ethernet2/0/0] port trunk allow-pass vlan 99 101
    [Router_1-Ethernet2/0/0] quit
    [Router_1] interface ethernet 2/0/1
    [Router_1-Ethernet2/0/1] port link-type trunk
    [Router_1-Ethernet2/0/1] port trunk allow-pass vlan 201
    [Router_1-Ethernet2/0/1] quit
    [Router_1] interface vlanif 99
    [Router_1-Vlanif99] ip address 10.23.99.1 255.255.255.0
    [Router_1-Vlanif99] quit
    [Router_1] interface vlanif 101
    [Router_1-Vlanif101] ip address 10.23.101.1 255.255.255.0
    [Router_1-Vlanif101] quit
    [Router_1] interface vlanif 201
    [Router_1-Vlanif201] ip address 10.23.201.2 255.255.255.0
    [Router_1-Vlanif201] quit
    

    # На Router_2 создайте VLAN 100, VLAN 102 и VLAN 202. VLAN 100 используется в качестве управляющей VLAN, а VLAN 102 в качестве сервисной VLAN. Добавьте Eth2/0/0, подключенный к Switch_2, к VLAN 100 и VLAN 102, а Eth2/0/1, подключенный к AC_2 к VLAN 202. Настройте IP-адрес 10.23.100.1/24 для VLANIF 100, 10.23.102.1/24 для VLANIF 102 и 10.23.202.2/24 для VLANIF 202. См. Router_1 для подробной процедуры настройки.

    # На Router_3 создайте VLAN 200, VLAN 203 и добавьте Eth2/0/0, подключенный к сети, к VLAN 200, и Eth2/0/1, подключенный к AC_3, к VLAN 203. Настройте IP-адрес 10.23.200.1/24 для VLANIF 200. Настройте IP-адрес 10.23.203.2/24 для VLANIF 203. См. Router_1 для подробной процедуры настройки.

    # На Switch_1 создайте VLAN 99 и VLAN 101. Добавьте GE0/0/2, подключенный к Router_1 и GE0/0/1, подключенные к AP_1, к VLAN 99 и VLAN 101, а PVID GE0/0/1 является VLAN 99.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch_1
    [Switch_1] vlan batch 99 101
    [Switch_1] interface gigabitethernet 0/0/1
    [Switch_1-GigabitEthernet0/0/1] port link-type trunk
    [Switch_1-GigabitEthernet0/0/1] port trunk pvid vlan 99
    [Switch_1-GigabitEthernet0/0/1] port trunk allow-pass vlan 99 101
    [Switch_1-GigabitEthernet0/0/1] port-isolate enable
    [Switch_1-GigabitEthernet0/0/1] quit
    [Switch_1] interface gigabitethernet 0/0/2
    [Switch_1-GigabitEthernet0/0/2] port link-type trunk
    [Switch_1-GigabitEthernet0/0/2] port trunk allow-pass vlan 99 101
    [Switch_1-GigabitEthernet0/0/2] quit
    

    # На Switch_2 создайте VLAN 100 и VLAN 102. Добавьте GE0/0/2, подключенный к Router_2 и GE0/0/1, подключенный к AP_2, к VLAN 100 и VLAN 102, а PVID GE0/0/1 является VLAN 100. См. Switch_1 для подробной процедуры настройки.

    # На AC_1 создайте VLAN 101 и VLAN 201 и добавьте GE0/0/1, подключенный к Router_1, к VLAN 201. Настройте IP-адрес 10.23.201.1/24 для VLANIF 201.

    <AC6605> system-view
    [AC6605] sysname AC_1
    [AC_1] vlan batch 101 201
    [AC_1] interface gigabitethernet 0/0/1
    [AC_1-GigabitEthernet0/0/1] port link-type trunk
    [AC_1-GigabitEthernet0/0/1] port trunk allow-pass vlan 201
    [AC_1-GigabitEthernet0/0/1] quit
    [AC_1] interface vlanif 201
    [AC_1-Vlanif201] ip address 10.23.201.1 255.255.255.0
    [AC_1-Vlanif201] quit
    

    # На AC_2 создайте VLAN 102 и VLAN 202 и добавьте GE0/0/1, подключенный к Router_2, к VLAN 202. Настройте IP-адрес 10.23.202.1/24 для VLANIF 202. См. AC_1 для подробной процедуры настройки.

    # На AC_3 создайте VLAN 101, VLAN 102 и VLAN 203 и добавьте GE0/0/1, подключенный к Router_3, к VLAN 203. Настройте IP-адрес 10.23.203.1/24 для VLANIF 203. Для подробной процедуры настройки см. AC_1.

    # Настройте доступные маршруты между AC_1 и AC_3, AP_1 и AC_3, AC_2 и AC_3, а также между AP_2 и AC_3. Выполните настройки в соответствии с сетевыми требованиями. Процедура настройки здесь не приводится.

    # Настройте маршрут между AC_1 и AP_1 со следующим переходом в качестве VLANIF 201 Router_1.
    [AC_1] ip route-static 10.23.99.0 24 10.23.201.2
    # Настройте маршрут между AC_2 и AP_2 со следующим переходом в качестве VLANIF 202 Router_2.
    [AC_2] ip route-static 10.23.101.0 24 10.23.202.2

  2. Настройте DHCP-сервер для того, чтобы назначить IP-адреса для AP и STA.

    # Настройте Router_1 в качестве агента DHCP-ретранслятора.

    [Router_1] dhcp enable
    [Router_1] interface vlanif 99
    [Router_1-Vlanif99] dhcp select relay
    [Router_1-Vlanif99] dhcp relay server-ip 10.23.200.1
    [Router_1-Vlanif99] quit
    [Router_1] interface vlanif 101
    [Router_1-Vlanif101] dhcp select relay
    [Router_1-Vlanif101] dhcp relay server-ip 10.23.200.1
    [Router_1-Vlanif101] quit
    

    # Настройте Router_2 в качестве агента DHCP-ретранслятора.

    [Router_2] dhcp enable
    [Router_2] interface vlanif 100
    [Router_2-Vlanif100] dhcp select relay
    [Router_2-Vlanif100] dhcp relay server-ip 10.23.200.1
    [Router_2-Vlanif100] quit
    [Router_2] interface vlanif 102
    [Router_2-Vlanif102] dhcp select relay
    [Router_2-Vlanif102] dhcp relay server-ip 10.23.200.1
    [Router_2-Vlanif102] quit
    

    # Настройте Router_3 в качестве DHCP-сервера в целях назначения IP-адресов для AP и STA, настройте поле Option 43 для объявления AP_1 о IP-адресах AC_1 и AC_3, и объявления AP_2 о IP-адресах AC_2 и AC_3. Настройте сервер-DHCP, чтобы назначить IP-адрес для AP_1 из пула IP-адресов ap_1_pool, для AP_2 из ap_2_pool, для STA1 из sta_1_pool и для STA2 из sta_2_pool.

    ПРИМЕЧАНИЕ:

    В этом примере AP_1 и AP_2 не могут совместно использовать пул IP-адресов; в противном случае AP_1 может обнаружить AC_2, и AP_2 может обнаружить AC_1, что приведет к тому, что AP не смогут подключиться к правильному AC на основе приоритета AC.

    Настройте DNS-сервер по мере необходимости. Общие методы заключаются в следующем:
    • В сценариях пула адресов интерфейса запустите команду dhcp server dns-list ip-address &<1-8> в виде интерфейса VLANIF.
    • В сценариях пула глобального адреса запустите команду dns-list ip-address &<1-8> в виде пула IP-адресов.
    [Router_3] dhcp enable
    [Router_3] ip pool ap_1_pool
    [Router_3-ip-pool-ap_1_pool] network 10.23.99.0 mask 24
    [Router_3-ip-pool-ap_1_pool] gateway-list 10.23.99.1
    [Router_3-ip-pool-ap_1_pool] option 43 sub-option 2 ip-address 10.23.201.1 10.23.203.1
    [Router_3-ip-pool-ap_1_pool] quit
    [Router_3] ip pool ap_2_pool
    [Router_3-ip-pool-ap_2_pool] network 10.23.100.0 mask 24
    [Router_3-ip-pool-ap_2_pool] gateway-list 10.23.100.1
    [Router_3-ip-pool-ap_2_pool] option 43 sub-option 2 ip-address 10.23.202.1 10.23.203.1
    [Router_3-ip-pool-ap_2_pool] quit
    [Router_3] ip pool sta_1_pool
    [Router_3-ip-pool-sta_1_pool] network 10.23.101.0 mask 24
    [Router_3-ip-pool-sta_1_pool] gateway-list 10.23.101.1
    [Router_3-ip-pool-sta_1_pool] quit
    [Router_3] ip pool sta_2_pool
    [Router_3-ip-pool-sta_2_pool] network 10.23.102.0 mask 24
    [Router_3-ip-pool-sta_2_pool] gateway-list 10.23.102.1
    [Router_3-ip-pool-sta_2_pool] quit
    

  3. Настройте базовые службы WLAN на AC_1.
    1. Настройте AP для входа в сеть.

      # Создайте группу AP, к которой могут добавляться точки доступа с той же конфигурацией.

      [AC_1] wlan
      [AC_1-wlan-view] ap-group name ap-group1
      [AC_1-wlan-ap-group-ap-group1] quit
      

      # Создайте профиль регулятивного домена, настройте код страны AC в профиле и примените профиль к группе AP.

      [AC_1-wlan-view] regulatory-domain-profile name default
      [AC_1-wlan-regulate-domain-default] country-code cn
      [AC_1-wlan-regulate-domain-default] quit
      [AC_1-wlan-view] ap-group name ap-group1
      [AC_1-wlan-ap-group-ap-group1] regulatory-domain-profile default
      Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
      e?[Y/N]:y 
      [AC_1-wlan-ap-group-ap-group1] quit
      [AC_1-wlan-view] quit
      

      # Настройте исходный интерфейс AC_1.

      [AC_1] capwap source interface vlanif 201
      
      # Импортируйте AP в автономном режиме на AC и добавьте AP в группу AP ap-group1. В этом примере MAC-адрес AP равен 60de-4476-e360. Настройте имя для AP на основе местоположения развертывания AP, чтобы узнать, где находится AP. Например, если AP с MAC-адресом 60de-4476-e360 развернута в зоне 1, назовите AP area_1.
      ПРИМЕЧАНИЕ:

      Режим аутентификации AP по умолчанию - это аутентификация MAC-адреса. Если настройки по умолчанию сохранены, не нужно запускать команду ap auth-mode mac-auth.

      В данном примере используется AP5030DN и имеет два Radio: Radio 0 и Radio 1.

      [AC_1] wlan
      [AC_1-wlan-view] ap auth-mode mac-auth
      [AC_1-wlan-view] ap-id 0 ap-mac 60de-4476-e360
      [AC_1-wlan-ap-0] ap-name area_1
      [AC_1-wlan-ap-0] ap-group ap-group1
      Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configurati
      ons of the radio, Whether to continue? [Y/N]:y
      [AC_1-wlan-ap-0] quit
      

      # После включения AP запустите команду display ap all, чтобы проверить состояние AP. Если поле State показано как nor, AP вошли в сеть.

      [AC_1-wlan-view] display ap all
      Total AP information:
      nor  : normal          [1]
      --------------------------------------------------------------------------------
      ID   MAC            Name   Group     IP            Type            State STA Uptime
      --------------------------------------------------------------------------------
      0    60de-4476-e360 area_1 ap-group1 10.23.99.254  AP5030DN        nor   0   10S
      --------------------------------------------------------------------------------
      Total: 1

    2. Настройте параметры службы WLAN.

      # Создайте профиль безопасности wlan-net и установите политику безопасности в профиле.
      ПРИМЕЧАНИЕ:

      В этом примере политика безопасности установлена ​​на WPA-WPA2+PSK+AES и пароль на a1234567. В реальных ситуациях политика безопасности должна быть настроена в соответствии с требованиями к службе.

      [AC_1-wlan-view] security-profile name wlan-net
      [AC_1-wlan-sec-prof-wlan-net] security wpa-wpa2 psk pass-phrase a1234567 aes
      [AC_1-wlan-sec-prof-wlan-net] quit
      

      # Создайте профиль SSID wlan-net и установите имя SSID на wlan-net.

      [AC_1-wlan-view] ssid-profile name wlan-net
      [AC_1-wlan-ssid-prof-wlan-net] ssid wlan-net
      [AC_1-wlan-ssid-prof-wlan-net] quit
      

      # Создайте профиль VAP wlan-net, установите режим переадресации данных и сервисную VLAN и примените профиль безопасности и профиль SSID к профилю VAP.

      [AC_1-wlan-view] vap-profile name wlan-net
      [AC_1-wlan-vap-prof-wlan-net] forward-mode direct-forward
      [AC_1-wlan-vap-prof-wlan-net] service-vlan vlan-id 101
      [AC_1-wlan-vap-prof-wlan-net] security-profile wlan-net
      [AC_1-wlan-vap-prof-wlan-net] ssid-profile wlan-net
      [AC_1-wlan-vap-prof-wlan-net] quit
      

      # Привяжите профиль VAP к группе AP и примените профиль VAP wlan-net к Radio 0 и Radio 1 AP.

      [AC_1-wlan-view] ap-group name ap-group1
      [AC_1-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 0
      [AC_1-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 1
      [AC_1-wlan-ap-group-ap-group1] quit
      

  4. Настройте базовые службы WLAN на AC_2.

    # Настройте основные параметры для AC_2 в соответствии с конфигурациями AC_1.

    # Настройте исходный интерфейс AC_2.

    [AC_2] capwap source interface vlanif 202
    

    # Создайте группу AP ap-group2.

    [AC_2] wlan
    [AC_2-wlan-view] ap-group name ap-group2
    [AC_2-wlan-ap-group-ap-group2] quit
    

    # Импортируйте AP в автономном режиме на AC и добавьте AP в группу AP ap-group2. В этом примере MAC-адрес AP равен 60de-4474-9640. Настройте имя для AP на основе местоположения развертывания AP, чтобы узнать, где находится AP. Например, если AP с MAC-адресом 60de-4474-9640 развернута в зоне 2, назовите AP area_2.

    [AC_2] wlan
    [AC_2-wlan-view] ap auth-mode mac-auth
    [AC_2-wlan-view] ap-id 1 ap-mac 60de-4474-9640
    [AC_2-wlan-ap-1] ap-name area_2
    [AC_2-wlan-ap-1] ap-group ap-group2
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configurati
    ons of the radio, Whether to continue? [Y/N]:y
    [AC_2-wlan-ap-1] quit
    
    # Создайте профиль безопасности wlan-net1 и установите политику безопасности в профиле.
    ПРИМЕЧАНИЕ:

    В этом примере политика безопасности установлена ​​на WPA-WPA2+PSK+AES и пароль на a1234567. В реальных ситуациях политика безопасности должна быть настроена в соответствии с требованиями к службе.

    [AC_2-wlan-view] security-profile name wlan-net1
    [AC_2-wlan-sec-prof-wlan-net1] security wpa-wpa2 psk pass-phrase a1234567 aes
    [AC_2-wlan-sec-prof-wlan-net1] quit
    

    # Создайте профиль SSID и установите имя SSID на wlan-net1.

    [AC_2-wlan-view] ssid-profile name wlan-net1
    [AC_2-wlan-ssid-prof-wlan-net1] ssid wlan-net1
    [AC_2-wlan-ssid-prof-wlan-net1] quit
    

    # Создайте профиль VAP wlan-net1, установите режим переадресации данных и сервисную VLAN и примените профиль безопасности и профиль SSID к профилю VAP.

    [AC_2-wlan-view] vap-profile name wlan-net1
    [AC_2-wlan-vap-prof-wlan-net1] forward-mode direct-forward
    [AC_2-wlan-vap-prof-wlan-net1] service-vlan vlan-id 102
    [AC_2-wlan-vap-prof-wlan-net1] security-profile wlan-net1
    [AC_2-wlan-vap-prof-wlan-net1] ssid-profile wlan-net1
    [AC_2-wlan-vap-prof-wlan-net1] quit
    

    # Привяжите профиль VAP к группе AP и примените профиль VAP wlan-net1 к Radio 0 и Radio 1 AP.

    [AC_2-wlan-view] ap-group name ap-group2
    [AC_2-wlan-ap-group-ap-group2] vap-profile wlan-net1 wlan 1 radio 0
    [AC_2-wlan-ap-group-ap-group2] vap-profile wlan-net1 wlan 1 radio 1
    [AC_2-wlan-ap-group-ap-group2] quit
    

    # Установите другие параметры, аналогичные параметрам AC_1.

  5. Настройте основные службы WLAN на AC_3.
    1. Настройте AP для входа в сеть.

      # Создайте группу AP, к которой могут добавляться точки доступа с той же конфигурацией.

      [AC_3] wlan
      [AC_3-wlan-view] ap-group name ap-group1
      [AC_3-wlan-ap-group-ap-group1] quit
      [AC_3-wlan-view] ap-group name ap-group2
      [AC_3-wlan-ap-group-ap-group2] quit
      

      # Создайте профиль регулятивного домена, настройте код страны AC в профиле и примените профиль к группе AP.

      [AC_3-wlan-view] regulatory-domain-profile name default
      [AC_3-wlan-regulate-domain-default] country-code cn
      [AC_3-wlan-regulate-domain-default] quit
      [AC_3-wlan-view] ap-group name ap-group1
      [AC_3-wlan-ap-group-ap-group1] regulatory-domain-profile default
      Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
      e?[Y/N]:y 
      [AC_3-wlan-ap-group-ap-group1] quit
      [AC_3-wlan-view] ap-group name ap-group2
      [AC_3-wlan-ap-group-ap-group2] regulatory-domain-profile default
      Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
      e?[Y/N]:y 
      [AC_3-wlan-ap-group-ap-group2] quit
      [AC_3-wlan-view] quit
      

      # Настройте исходный интерфейс AC_3.

      [AC_3] capwap source interface Vlanif 203
      
      ПРИМЕЧАНИЕ:

      Режим аутентификации AP по умолчанию - это аутентификация MAC-адреса. Если настройки по умолчанию сохранены, не нужно запускать команду ap auth-mode mac-auth.

      [AC_3] wlan
      [AC_3-wlan-view] ap auth-mode mac-auth
      [AC_3-wlan-view] ap-id 0 ap-mac 60de-4476-e360
      [AC_3-wlan-ap-0] ap-name area_1
      [AC_3-wlan-ap-0] ap-group ap-group1
      Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
      s of the radio, Whether to continue? [Y/N]:y 
      [AC_3-wlan-ap-0] quit
      [AC_3-wlan-view] ap-id 1 ap-mac 60de-4474-9640
      [AC_3-wlan-ap-1] ap-name area_2
      [AC_3-wlan-ap-1] ap-group ap-group2
      Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
      s of the radio, Whether to continue? [Y/N]:y 
      [AC_3-wlan-ap-1] quit
      

      # Запустите команду display ap all на AC, чтобы проверить состояние работы AP. Вывод команды показывает, что состояние area_1 и area_2 одновременно является fault.

      [AC_3-wlan-view] display ap all
      Total AP information:
      idle : idle            [2]
      ------------------------------------------------------------------------
      ID   MAC            Name   Group     IP Type            State STA Uptime
      ------------------------------------------------------------------------
      0    60de-4476-e360 area_1 ap-group1 -  -               fault 0   -
      1    60de-4474-9640 area_2 ap-group2 -  -               fault 0   -
      ------------------------------------------------------------------------
      Total: 2

    2. Настройте параметры службы WLAN.

      # Создайте профили безопасности wlan-net и wlan-net1 и настройте политики безопасности.

      [AC_3-wlan-view] security-profile name wlan-net
      [AC_3-wlan-sec-prof-wlan-net] security wpa-wpa2 psk pass-phrase a1234567 aes
      [AC_3-wlan-sec-prof-wlan-net] quit
      [AC_3-wlan-view] security-profile name wlan-net1
      [AC_3-wlan-sec-prof-wlan-net1] security wpa-wpa2 psk pass-phrase a1234567 aes
      [AC_3-wlan-sec-prof-wlan-net1] quit
      

      # Создайте профиль SSID wlan-net и установите имя SSID на wlan-net.

      [AC_3-wlan-view] ssid-profile name wlan-net
      [AC_3-wlan-ssid-prof-wlan-net] ssid wlan-net
      [AC_3-wlan-ssid-prof-wlan-net] quit
      

      # Создайте профиль SSID wlan-net1 и установите имя SSID на wlan-net1.

      [AC_3-wlan-view] ssid-profile name wlan-net1
      [AC_3-wlan-ssid-prof-wlan-net1] ssid wlan-net1
      [AC_3-wlan-ssid-prof-wlan-net1] quit
      

      # Создайте профиль системы AP ap-system и настройте IP-адрес резервного AC.

      [AC_3-wlan-view] ap-system-profile name ap-system
      [AC_3-wlan-ap-system-prof-ap-system] protect-ac ip-address 10.23.201.1
      Warning: This action will take effect after resetting AP.
      [AC_3-wlan-ap-system-prof-ap-system] quit
      

      # Создайте профиль системы AP ap-system1 и настройте IP-адрес резервного AC.

      [AC_3-wlan-view] ap-system-profile name ap-system1
      [AC_3-wlan-ap-system-prof-ap-system1] protect-ac ip-address 10.23.202.1
      Warning: This action will take effect after resetting AP.
      [AC_3-wlan-ap-system-prof-ap-system1] quit
      

      # Создайте профиль VAP wlan-net, установите режим переадресации данных и сервисную VLAN и примените профиль безопасности и профиль SSID к профилю VAP.

      [AC_3-wlan-view] vap-profile name wlan-net
      [AC_3-wlan-vap-prof-wlan-net] forward-mode direct-forward
      [AC_3-wlan-vap-prof-wlan-net] service-vlan vlan-id 101
      [AC_3-wlan-vap-prof-wlan-net] security-profile wlan-net
      [AC_3-wlan-vap-prof-wlan-net] ssid-profile wlan-net
      [AC_3-wlan-vap-prof-wlan-net] quit
      

      # Создайте профиль VAP wlan-net1, установите режим переадресации данных и сервисную VLAN и примените профиль безопасности и профиль SSID к профилю VAP.

      [AC_3-wlan-view] vap-profile name wlan-net1
      [AC_3-wlan-vap-prof-wlan-net1] forward-mode direct-forward
      [AC_3-wlan-vap-prof-wlan-net1] service-vlan vlan-id 102
      [AC_3-wlan-vap-prof-wlan-net1] security-profile wlan-net1
      [AC_3-wlan-vap-prof-wlan-net1] ssid-profile wlan-net1
      [AC_3-wlan-vap-prof-wlan-net1] quit
      

      # Привяжите профиль VAP и профиль системы AP к группе AP и примените профиль VAP к Radio 0 и Radio 1 AP.

      [AC_3-wlan-view] ap-group name ap-group1
      [AC_3-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 0
      [AC_3-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 1
      [AC_3-wlan-ap-group-ap-group1] ap-system-profile ap-system
      [AC_3-wlan-ap-group-ap-group1] quit
      [AC_3-wlan-view] ap-group name ap-group2
      [AC_3-wlan-ap-group-ap-group2] vap-profile wlan-net1 wlan 1 radio 0
      [AC_3-wlan-ap-group-ap-group2] vap-profile wlan-net1 wlan 1 radio 1
      [AC_3-wlan-ap-group-ap-group2] ap-system-profile ap-system1
      [AC_3-wlan-ap-group-ap-group2] quit
      

  6. Включите резервное копирование N+1 на AC_1, AC_2 и AC_3.

    # На AC_1 настройте глобальный приоритет AC и IP-адрес AC_3.
    ПРИМЕЧАНИЕ:
    Приоритеты AC определяют роли AC. AC с более высоким приоритетом - активный AC, и AC с более низким приоритетом - резервный AC. Меньшее значение указывает на более высокий приоритет. Если приоритеты AC одинаковы, AC, который подключается к большему количеству AP, является активным AC. Если AC подключаются к одному и тому же количеству AP, AC, который подключается к большему количеству STA, является активным AC. Если AC подключаются к одному и тому же количеству STA, AC с меньшим IP-адресом является активным AC.
    [AC_1-wlan-view] ac protect priority 0 protect-ac 10.23.203.1
    
    # На AC_2 настройте глобальный приоритет AC и IP-адрес AC_3.
    [AC_2-wlan-view] ac protect priority 0 protect-ac 10.23.203.1
    
    # Настройте глобальный приоритет AC_3.
    [AC_3-wlan-view] ac protect priority 5
    
    # На AC_1 включите резервное копирование N+1 и перезапустите все AP, чтобы функция начинала действовать.
    ПРИМЕЧАНИЕ:
    По умолчанию включено резервное копирование N+1. Система выводит информационное сообщение, если вы запустите команду undo ac protect enable. Нужно запустить команду ap-reset all, чтобы перезапустить все AP. После перезапуска AP резервное копирование N+1 начинает действовать.
    [AC_1-wlan-view] undo ac protect enable
    Info: Backup function has already disabled. 
    [AC_1-wlan-view] ap-reset all
    Warning: Reset AP(s), continue?[Y/N]:y
    # На AC_2 включите резервное копирование N+1 и перезапустите все AP, чтобы функция начинала действовать.
    [AC_2-wlan-view] undo ac protect enable
    Info: Backup function has already disabled. 
    [AC_2-wlan-view] ap-reset all
    Warning: Reset AP(s), continue?[Y/N]:y
    # Включите реверсивное переключение и резервное копирование N+1 на AC_3.
    ПРИМЕЧАНИЕ:
    По умолчанию включено глобальное реверсивное переключение. Система выводит информационное сообщение, если вы запустите команду undo ac protect restore disable.
    [AC_3-wlan-view] undo ac protect restore disable
    Info: Protect restore has already enabled.
    [AC_3-wlan-view] undo ac protect enable
    Info: Backup function has already disabled. 
    [AC_3-wlan-view] ap-reset all
    Warning: Reset AP(s), continue?[Y/N]:y

  7. Проверьте конфигурацию.

    # Запустите команду display ac protect на AC_1, чтобы проверить информацию о резервном копировании N+1.

    [AC_1-wlan-view] display ac protect
    ------------------------------------------------------------
    Protect state             : disable
    Protect AC                : 10.23.203.1
    Priority                  : 0
    Protect restore           : enable
    ...
    ------------------------------------------------------------
    

    # Запустите команду display ac protect на AC_2, чтобы проверить информацию о резервном копировании N+1.

    [AC_2-wlan-view] display ac protect
    ------------------------------------------------------------
    Protect state             : disable
    Protect AC                : 10.23.203.1
    Priority                  : 0
    Protect restore           : enable
    ...
    ------------------------------------------------------------
    

    # Запустите команду display ac protect и display ap-system-profile на AC_3, чтобы проверить информацию о резервном копировании N+1.

    [AC_3-wlan-view] display ac protect
    ------------------------------------------------------------
    Protect state             : disable
    Protect AC                : -
    Priority                  : 5
    Protect restore           : enable
    ...
    ------------------------------------------------------------
    [AC_3-wlan-view] display ap-system-profile name ap-system
    ------------------------------------------------------------------------------
    AC priority                                    : -
    Protect AC IP address                          : 10.23.201.1
    Primary AC                                     : -
    Backup AC                                      : -
    ...
    ------------------------------------------------------------------------------
    [AC_3-wlan-view] display ap-system-profile name ap-system1
    ------------------------------------------------------------------------------
    AC priority                                    : -
    Protect AC IP address                          : 10.23.202.1
    Primary AC                                     : -
    Backup AC                                      : -
    ...
    ------------------------------------------------------------------------------
    

    WLAN с SSID wlan-net или wlan-net1 доступна для STA, подключенных к AP, и эти STA могут подключаться к WLAN и нормально входить в сеть.

    Когда связь между AP и AC_1 или AC_2 неисправна, AC_3 берет на себя активную роль. Это обеспечивает ускоренное восстановление системы.

Файлы конфигурации

  • Файл конфигурации Switch_1

    #
    sysname Switch_1
    #
    vlan batch 99 101
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk pvid vlan 99
     port trunk allow-pass vlan 99 101
     port-isolate enable group 1
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 99 101
    #
    return
  • Файл конфигурации Switch_2

    #
    sysname Switch_2
    #
    vlan batch 100 102
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100 102
     port-isolate enable group 1
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 100 102
    #
    return
  • Файл конфигурации AC_1

    #
     sysname AC_1
    #
    vlan batch 101 201
    #
    interface Vlanif201
     ip address 10.23.201.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 201
    #
    ip route-static 10.23.99.0 255.255.255.0 10.23.201.2
    #
    capwap source interface vlanif201
    #
    wlan
     ac protect protect-ac 10.23.203.1
     security-profile name wlan-net
      security wpa-wpa2 psk pass-phrase %^%#m"tz0f>~7.[`^6RWdzwCy16hJj/Mc!,}s`X*B]}A%^%# aes
     ssid-profile name wlan-net
      ssid wlan-net
     vap-profile name wlan-net
      service-vlan vlan-id 101
      ssid-profile wlan-net
      security-profile wlan-net
     regulatory-domain-profile name default
     ap-group name ap-group1
      radio 0
       vap-profile wlan-net wlan 1
      radio 1
       vap-profile wlan-net wlan 1
     ap-id 0 type-id 35 ap-mac 60de-4476-e360 ap-sn 210235554710CB000042
      ap-name area_1
      ap-group ap-group1
    #
    return
  • Файл конфигурации AC_2

    #
     sysname AC_2
    #
    vlan batch 102 202
    #
    interface Vlanif202
     ip address 10.23.202.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 202
    #
    ip route-static 10.23.101.0 255.255.255.0 10.23.202.2
    #
    capwap source interface vlanif202
    #
    wlan
     ac protect protect-ac 10.23.203.1
     security-profile name wlan-net1
      security wpa-wpa2 psk pass-phrase %^%#m"tz0f>~7.[`^6RWdzwCy16hJj/Mc!,}s`X*B]}A%^%# aes
     ssid-profile name wlan-net1
      ssid wlan-net1
     vap-profile name wlan-net1
      service-vlan vlan-id 102
      ssid-profile wlan-net1
      security-profile wlan-net1
     regulatory-domain-profile name default
     ap-group name ap-group2
      radio 0
       vap-profile wlan-net1 wlan 1
      radio 1
       vap-profile wlan-net1 wlan 1
     ap-id 1 type-id 35 ap-mac 60de-4474-9640 ap-sn 210235419610D2000097
      ap-name area_2
      ap-group ap-group2
    #
    return                       
  • Файл конфигурации AC_3

    #
     sysname AC_3
    #
    vlan batch 101 to 102 203
    #
    interface Vlanif203
     ip address 10.23.203.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 203
    #
    capwap source interface vlanif203
    #
    wlan
     ac protect priority 5
     security-profile name wlan-net
      security wpa-wpa2 psk pass-phrase %^%#m"tz0f>~7.[`^6RWdzwCy16hJj/Mc!,}s`X*B]}A%^%# aes
     security-profile name wlan-net1
      security wpa-wpa2 psk pass-phrase %^%#m"tz0f>~7.[`^6RWdzwCy16hJj/Mc!,}s`X*B]}A%^%# aes
     ssid-profile name wlan-net
      ssid wlan-net
     ssid-profile name wlan-net1
      ssid wlan-net1
     vap-profile name wlan-net
      service-vlan vlan-id 101
      ssid-profile wlan-net
      security-profile wlan-net
     vap-profile name wlan-net1
      service-vlan vlan-id 102
      ssid-profile wlan-net1
      security-profile wlan-net1
     regulatory-domain-profile name default
     ap-system-profile name ap-system
      protect-ac ip-address 10.23.201.1
     ap-system-profile name ap-system1
      protect-ac ip-address 10.23.202.1
     ap-group name ap-group1
      ap-system-profile ap-system
      radio 0
       vap-profile wlan-net wlan 1
      radio 1
       vap-profile wlan-net wlan 1
     ap-group name ap-group2
      ap-system-profile ap-system1
      radio 0
       vap-profile wlan-net1 wlan 1
      radio 1
       vap-profile wlan-net1 wlan 1
     ap-id 0 type-id 35 ap-mac 60de-4476-e360 ap-sn 210235554710CB000042
      ap-name area_1
      ap-group ap-group1
     ap-id 1 type-id 35 ap-mac 60de-4474-9640 ap-sn 210235419610D2000097
      ap-name area_2
      ap-group ap-group2
    #
    return
  • Файл конфигурации Router_1

    #
     sysname Router_1
    #
    vlan batch 99 101 201
    #
    dhcp enable
    #
    interface Vlanif99
     ip address 10.23.99.1 255.255.255.0
     dhcp select relay
     dhcp relay server-ip 10.23.200.1
    #
    interface Vlanif101
     ip address 10.23.101.1 255.255.255.0
     dhcp select relay
     dhcp relay server-ip 10.23.200.1
    #
    interface Vlanif201
     ip address 10.23.201.2 255.255.255.0
    #
    interface Ethernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 99 101
    #
    interface Ethernet2/0/1
     port link-type trunk
     port trunk allow-pass vlan 201
    #
    return 
  • Файл конфигурации Router_2

    #
     sysname Router_2
    #
    vlan batch 100 102 202
    #
    dhcp enable
    #
    interface Vlanif100
     ip address 10.23.100.1 255.255.255.0
     dhcp select relay
     dhcp relay server-ip 10.23.200.1
    #
    interface Vlanif102
     ip address 10.23.102.1 255.255.255.0
     dhcp select relay
     dhcp relay server-ip 10.23.200.1
    #
    interface Vlanif202
     ip address 10.23.202.2 255.255.255.0
    #
    interface Ethernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 100 102
    #
    interface Ethernet2/0/1
     port link-type trunk
     port trunk allow-pass vlan 202
    #
    return 
  • Файл конфигурации Router_3

    #
     sysname Router_3
    #
    vlan batch 200 203
    #
    dhcp enable
    #
    ip pool ap_1_pool
     gateway-list 10.23.99.1
     network 10.23.99.0 mask 255.255.255.0
     option 43 sub-option 2 ip-address 10.23.201.1 10.23.203.1
    #
    ip pool ap_2_pool
     gateway-list 10.23.100.1
     network 10.23.100.0 mask 255.255.255.0
     option 43 sub-option 2 ip-address 10.23.202.1 10.23.203.1
    #
    ip pool sta_1_pool
     gateway-list 10.23.101.1
     network 10.23.101.0 mask 255.255.255.0
    #
    ip pool sta_2_pool
     gateway-list 10.23.102.1
     network 10.23.102.0 mask 255.255.255.0
    #
    interface Vlanif200
     ip address 10.23.200.1 255.255.255.0
    #
    interface Vlanif203
     ip address 10.23.203.2 255.255.255.0
    #
    interface Ethernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface Ethernet2/0/1
     port link-type trunk
     port trunk allow-pass vlan 203
    #
    return 
Загрузить
Updated: 2018-08-21

№ документа:EDOC1100029357

Просмотры:6762

Загрузки: 86

Average rating:
This Document Applies to these Products
Связанные документы
Related Version
Share
Назад Далее