Для выбранного языка не найдены ресурсы переадресации.

Этот веб-сайт использует cookie-файлы. Продолжая просмотр, вы соглашаетесь на их использование. Ознакомьтесь с нашей политикой соблюдения конфиденциальности.>

Типичные примеры настройки WLAN

Rate and give feedback :
Информация об этом переводе
Чтобы помочь вам лучше понять содержимое этого документа, компания Huawei перевела его на разные языки, используя машинный перевод, отредактированный людьми. Примечание: даже самые передовые программы машинного перевода не могут обеспечить качество на уровне перевода, выполненного профессиональным переводчиком. Компания Huawei не несет ответственность за точность перевода и рекомендует ознакомиться с документом на английском языке (по ссылке, которая была предоставлена ранее).
Пример настройки переключения каналов без прерывания службы

Пример настройки переключения каналов без прерывания службы

Требования к службе

Пользователи предприятия могут получить доступ к сети через WLAN, что является основным требованием мобильного офиса. Кроме того, службы пользователей не затрагиваются во время роуминга в зоне покрытия.

Предприятие требует, чтобы службы WLAN не прерывались, даже когда AP меняли свои рабочие каналы.

Требования к сети

  • Режим сети AC: Сеть уровня 2 в режиме обхода
  • Режим развертывания DHCP: Коммутатор функционирует как DHCP-сервер, чтобы назначить IP-адреса для AP и STA.
  • Режим переадресации сервисных данных: прямая переадресация
Рис. 3-71 Сеть для настройки переключения каналов без прерывания услуги

План данных

Табл. 3-77 План данных AC

Пункт

Данные

Управляющая VLAN для AP

VLAN 100

Сервисная VLAN для STA

VLAN 101

DHCP-сервер

Коммутатор функционирует как DHCP-сервер, чтобы назначить IP-адреса для AP и STA.

Пул IP-адресов для AP

10.1.1.3-10.1.1.254/24

Пул IP-адресов для STA

10.1.2.3-10.1.2.254/24

Адрес шлюза для AP

10.1.1.1/24

Адрес шлюза для STA

10.1.2.1/24

Адрес исходного интерфейса AC

VLANIF 100: 10.1.1.2/24

Группа AP
  • Имя: ap-group1
  • Ссылочные профили: профиль 2G Radio wlan-radio2g, профиль 5G Radio wlan-radio5g, профиль VAP wlan-net и профиль регулятивного домена default
Профиль регулятивного домена
  • Имя: default
  • Код страны: CN
Профиль SSID
  • Имя: wlan-net
  • Имя SSID: wlan-net
Профиль безопасности
  • Имя: wlan-net
  • Политика безопасности: WPA-WPA2+PSK+AES
  • Пароль: a1234567
Профиль VAP
  • Имя: wlan-net
  • Режим переадресации: прямая переадресация
  • Сервисная VLAN: VLAN 101
  • Ссылочные профили: Профиль SSID wlan-net и профиль безопасности wlan-net

Профиль 2G Radio

  • Имя: wlan-radio2g
  • Объявление переключения канала: включено
  • Режим объявления переключения канала: continue-transmitting

Профиль 5G Radio

  • Имя: wlan-radio5g
  • Объявление переключения канала: включено
  • Режим объявления переключения канала: continue-transmitting

Схема настройки

  1. Настройте сетевое взаимодействие AC, AP и других сетевых устройств.
  2. Настройте AP для входа в сеть.
    1. Создайте группу AP и добавьте AP, для которых требуется единообразная конфигурация группы для унифицированной конфигурации.
    2. Настройте системные параметры AC, включая код страны и исходный интерфейс, используемые AC для связи с AP.
    3. Настройте режим аутентификации AP и импортируйте AP в автономном режиме, чтобы позволить AP входить в сеть.
  3. Настройте параметры службы WLAN для STA в целях доступа к WLAN.
  4. Настройте переключение каналов без прерывания услуги для повышения надежности службы WLAN, чтобы службы не прерывались, даже когда AP меняли свои рабочие каналы.

Примечания по конфигурации

  • Механизм ACK не предусмотрен для многоадресной передачи пакетов на воздушных интерфейсах. Кроме того, беспроводные каналы нестабильны. Для обеспечения стабильной передачи многоадресных пакетов они обычно отправляются по низким тарифам. Если большое количество таких многоадресных пакетов отправляется с сетевой стороны, воздушные интерфейсы могут быть перегружены. Рекомендуется настроить подавление многоадресных пакетов, чтобы уменьшить влияние большого количества низкоскоростных многоадресных пакетов на беспроводную сеть. Соблюдайте осторожность при настройке ограничения скорости; в противном случае могут быть затронуты многоадресные услуги.
    • В режиме прямой переадресации рекомендуется настроить подавление многоадресных пакетов на интерфейсах коммутатора, подключенных к точкам доступа (AP).
    • В режиме туннельной переадресации рекомендуется настроить подавление многоадресных пакетов в профилях трафика AC.
    Подробнее о том, как настроить подавление трафика, см. Подавление многоадресных пакетов не настроено, что приводит к замедлению доступа к сети STA.
  • Настройте изоляцию портов на интерфейсах устройства, напрямую подключенного к точкам доступа. Если изоляция порта не настроена и используется прямая переадресация, в VLAN может быть создано большое количество ненужных широковещательных пакетов, блокирующих сеть и ухудшающих работу пользователя.

  • В режиме туннельной переадресации управляющая VLAN и сервисная VLAN не могут быть одинаковыми. Только пакеты из управляющей VLAN передаются между AC и AP. Пакеты из сервисной VLAN не допускаются между AC и AP.

Процедура

  1. Настройте сетевые устройства.

    # Добавьте GE0/0/1 и GE0/0/2 на Switch к VLAN 100 и VLAN 101, и GE0/0/3 к VLAN 100. VLAN 100 является VLAN по умолчанию GE0/0/1 и GE0/0/2.
    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 100 101
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type trunk
    [Switch-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [Switch-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 to 101
    [Switch-GigabitEthernet0/0/1] port-isolate enable
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type trunk
    [Switch-GigabitEthernet0/0/2] port trunk pvid vlan 100
    [Switch-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 to 101
    [Switch-GigabitEthernet0/0/2] port-isolate enable
    [Switch-GigabitEthernet0/0/2] quit
    [Switch] interface gigabitethernet 0/0/3
    [Switch-GigabitEthernet0/0/3] port link-type trunk
    [Switch-GigabitEthernet0/0/3] port trunk allow-pass vlan 100
    [Switch-GigabitEthernet0/0/3] quit
    
    # Добавьте GE1/0/0 на маршрутизаторе (Router) к VLAN 101. Создайте VLANIF 101 и установите его IP-адрес на 10.23.101.2/24.
    <Huawei> system-view
    [Huawei] sysname Router
    [Router] vlan batch 101
    [Router] interface gigabitethernet 1/0/0
    [Router-GigabitEthernet1/0/0] port link-type trunk
    [Router-GigabitEthernet1/0/0] port trunk allow-pass vlan 101
    [Router-GigabitEthernet1/0/0] quit
    [Router] interface vlanif 101
    [Router-Vlanif101] ip address 10.23.101.2 24
    [Router-Vlanif101] quit
    

  2. Настройте AC для связи с сетевыми устройствами.

    ПРИМЕЧАНИЕ:

    Если AC и точки доступа (AP) подключены напрямую, установите VLAN по умолчанию интерфейсов, подключенных к AP, на управляющую VLAN 100.

    # На AC добавьте GE0/0/1 к VLAN 100. Создайте VLANIF 100 и установите его IP-адрес на 10.23.101.2/24.
    <AC6605> system-view
    [AC6605] sysname AC
    [AC] vlan batch 100 101
    [AC] interface gigabitethernet 0/0/1
    [AC-GigabitEthernet0/0/1] port link-type trunk
    [AC-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [AC-GigabitEthernet0/0/1] quit
    [AC] interface vlanif 100
    [AC-Vlanif100] ip address 10.1.1.2 24
    [AC-Vlanif100] quit

  3. Настройте DHCP-серверы для того, чтобы назначить IP-адреса для AP и STA.

    # На Switch настройте VLANIF 100 для назначения IP-адресов точкам доступа.

    [Switch] dhcp enable
    [Switch] interface vlanif 100
    [Switch-Vlanif100] ip address 10.1.1.1 255.255.255.0
    [Switch-Vlanif100] dhcp select interface
    [Switch-Vlanif100] dhcp server excluded-ip-address 10.1.1.2
    [Switch-Vlanif100] quit
    

    # На Switch настройте VLANIF 101 для назначения IP-адресов STA.

    ПРИМЕЧАНИЕ:
    Настройте DNS-сервер по мере необходимости. Общие методы заключаются в следующем:
    • В сценариях пула адресов интерфейса запустите команду dhcp server dns-list ip-address &<1-8> в виде интерфейса VLANIF.
    • В сценариях пула глобального адреса запустите команду dns-list ip-address &<1-8> в виде пула IP-адресов.
    [Switch] interface vlanif 101
    [Switch-Vlanif101] ip address 10.1.2.1 255.255.255.0
    [Switch-Vlanif101] dhcp select interface
    [Switch-Vlanif101] quit
    

  4. Настройте AP для входа в сеть.

    # Создайте группу AP, к которой могут добавляться точки доступа с той же конфигурацией.
    [AC] wlan
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] quit
    
    # Создайте профиль регулятивного домена, настройте код страны AC в профиле и примените профиль к группе AP.
    [AC-wlan-view] regulatory-domain-profile name default
    [AC-wlan-regulate-domain-default] country-code cn
    [AC-wlan-regulate-domain-default] quit
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] regulatory-domain-profile default
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AC-wlan-ap-group-ap-group1] quit
    [AC-wlan-view] quit
    
    # Настройте исходный интерфейс AC.
    [AC] capwap source interface vlanif 100
    
    # Импортируйте AP в автономном режиме на AC и добавьте AP в группу AP ap-group1. Предположим, что MAC-адреса AP1 и AP2 соответственно являются 60de-4476-e360 и dcd2-fc04-b500. Настройте имена для AP на основе местоположений развертывания AP, чтобы узнать, где AP развертываются из их имен. Например, назовите AP1 area_1, если она развернута в Зоне 1.
    ПРИМЕЧАНИЕ:

    Режим аутентификации AP по умолчанию - это аутентификация MAC-адреса. Если настройки по умолчанию сохранены, не нужно запускать команду ap auth-mode mac-auth.

    В этом примере используется AP5030DN и имеет два Radio: Radio 0 (2.4 ГГц) и Radio 1 (5 ГГц).

    [AC] wlan
    [AC-wlan-view] ap auth-mode mac-auth
    [AC-wlan-view] ap-id 0 ap-mac 60de-4476-e360
    [AC-wlan-ap-0] ap-name area_1
    [AC-wlan-ap-0] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-0] quit
    [AC-wlan-view] ap-id 1 ap-mac dcd2-fc04-b500
    [AC-wlan-ap-1] ap-name area_2
    [AC-wlan-ap-1] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-1] quit
    

    # После включения AP запустите команду display ap all, чтобы проверить состояние AP. Если поле State отображается как nor, AP успешно подключается к сети.

    [AC-wlan-view] display ap all
    Total AP information:
    nor  : normal          [2]
    -------------------------------------------------------------------------------------
    ID   MAC            Name   Group     IP            Type            State STA Uptime
    -------------------------------------------------------------------------------------
    0    60de-4476-e360 area_1 ap-group1 10.1.1.253    AP5030DN        nor   0   10S
    1    dcd2-fc04-b500 area_2 ap-group1 10.1.1.254    AP5030DN        nor   0   10S
    -------------------------------------------------------------------------------------
    Total: 2

  5. Настройте параметры службы WLAN.

    # Создайте профиль безопасности wlan-net и установите политику безопасности в профиле.
    ПРИМЕЧАНИЕ:

    В этом примере политика безопасности установлена ​​на WPA-WPA2+PSK+AES и пароль на a1234567. В реальных ситуациях политика безопасности должна быть настроена в соответствии с требованиями к службе.

    [AC-wlan-view] security-profile name wlan-net
    [AC-wlan-sec-prof-wlan-net] security wpa-wpa2 psk pass-phrase a1234567 aes
    [AC-wlan-sec-prof-wlan-net] quit
    
    # Создайте профиль SSID wlan-net и установите имя SSID на wlan-net.
    [AC-wlan-view] ssid-profile name wlan-net
    [AC-wlan-ssid-prof-wlan-net] ssid wlan-net
    [AC-wlan-ssid-prof-wlan-net] quit
    
    # Создайте профиль 2G Radio wlan-radio2g и профиль 5G Radio wlan-radio5g. Настройте переключение каналов без прерывания службы.
    ПРИМЕЧАНИЕ:

    Следующий пример настраивает профиль 2G Radio. Конфигурация профиля 5G Radio аналогична конфигурации профиля 2G Radio.

    [AC-wlan-view] radio-2g-profile name wlan-radio2g
    [AC-wlan-radio-2g-prof-wlan-radio2g] undo channel-switch announcement disable
    [AC-wlan-radio-2g-prof-wlan-radio2g] channel-switch mode continue-transmitting
    [AC-wlan-radio-2g-prof-wlan-radio2g] quit
    [AC-wlan-view] radio-5g-profile name wlan-radio5g
    [AC-wlan-radio-5g-prof-wlan-radio5g] undo channel-switch announcement disable
    [AC-wlan-radio-5g-prof-wlan-radio5g] channel-switch mode continue-transmitting
    [AC-wlan-radio-5g-prof-wlan-radio5g] quit
    
    # Создайте профиль VAP wlan-net, установите режим переадресации данных и сервисную VLAN и примените профиль безопасности и профиль SSID к профилю VAP.
    [AC-wlan-view] vap-profile name wlan-net
    [AC-wlan-vap-prof-wlan-net] forward-mode direct-forward
    [AC-wlan-vap-prof-wlan-net] service-vlan vlan-id 101
    [AC-wlan-vap-prof-wlan-net] security-profile wlan-net
    [AC-wlan-vap-prof-wlan-net] ssid-profile wlan-net
    [AC-wlan-vap-prof-wlan-net] quit
    

    # Свяжите профиль 2G Radio, профиль 5G Radio и профиль VAP с группой AP и примените профиль VAP к Radio 0 и Radio 1 точки доступа.

    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] radio-2g-profile wlan-radio2g radio 0
    [AC-wlan-ap-group-ap-group1] radio-5g-profile wlan-radio5g radio 1
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 0
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 1
    [AC-wlan-ap-group-ap-group1] quit
    

  6. Проверьте конфигурацию.

    WLAN с SSID huawei доступна для STA, подключенных к AP1 и AP2, и эти STA могут подключаться к WLAN. Когда калибровка радио для AP1 или AP2 реализована в целях изменения канала AP1 или AP2, переадресация сервисных данных для пользователей беспроводной сети в Зоне A не затрагивается. Запустите команду display radio all, чтобы просмотреть рабочие каналы всех точек доступа (AP).

    [AC-wlan-view] display radio all
    

Файлы конфигурации

  • Файл конфигурации коммутатора

    #
     sysname Switch
    #
     vlan batch 100 to 101
    #
     dhcp enable
    #
    interface Vlanif100
     ip address 10.1.1.1 255.255.255.0
     dhcp select interface
     dhcp server excluded-ip-address 10.1.1.2
    #
    interface Vlanif101
     ip address 10.1.2.1 255.255.255.0
     dhcp select interface
    # 
     interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100 to 101
     port-isolate enable group 1 
    # 
     interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100 to 101
     port-isolate enable group 1
    #
     interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    return
  • Файл конфигурации AC

    #
    sysname AC
    #
    vlan batch 100 to 101
    #
    interface Vlanif100
     ip address 10.1.1.2 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    capwap source interface vlanif100
    #
    wlan
     security-profile name wlan-net
      security wpa-wpa2 psk pass-phrase %^%#m"tz0f>~7.[`^6RWdzwCy16hJj/Mc!,}s`X*B]}A%^%# aes
     ssid-profile name wlan-net
      ssid wlan-net
     vap-profile name wlan-net
      service-vlan vlan-id 101
      ssid-profile wlan-net
      security-profile wlan-net
     regulatory-domain-profile name default
     radio-2g-profile name wlan-radio2g
     radio-5g-profile name wlan-radio5g
     ap-group name ap-group1
      radio 0
       radio-2g-profile wlan-radio2g
       vap-profile wlan-net wlan 1
      radio 1
       radio-5g-profile wlan-radio5g
       vap-profile wlan-net wlan 1
     ap-id 0 type-id 35 ap-mac 60de-4476-e360 ap-sn 210235554710CB000042
      ap-name area_1
      ap-group ap-group1
     ap-id 1 type-id 35 ap-mac dcd2-fc04-b500 ap-sn 210235419610D2000097
      ap-name area_2
      ap-group ap-group1
    #
    return
Загрузить
Updated: 2018-08-21

№ документа:EDOC1100029357

Просмотры:7525

Загрузки: 101

Average rating:
This Document Applies to these Products
Связанные документы
Related Version
Share
Назад Далее