Для выбранного языка не найдены ресурсы переадресации.

Этот веб-сайт использует cookie-файлы. Продолжая просмотр, вы соглашаетесь на их использование. Ознакомьтесь с нашей политикой соблюдения конфиденциальности.>

Типичные примеры настройки WLAN

Rate and give feedback :
Информация об этом переводе
Чтобы помочь вам лучше понять содержимое этого документа, компания Huawei перевела его на разные языки, используя машинный перевод, отредактированный людьми. Примечание: даже самые передовые программы машинного перевода не могут обеспечить качество на уровне перевода, выполненного профессиональным переводчиком. Компания Huawei не несет ответственность за точность перевода и рекомендует ознакомиться с документом на английском языке (по ссылке, которая была предоставлена ранее).
Пример настройки службы Soft GRE

Пример настройки службы Soft GRE

Требования к службе

Пользователи предприятия могут получить доступ к сети через WLAN, что является основным требованием мобильного офиса. Кроме того, службы пользователей не затрагиваются во время роуминга в зоне покрытия. Проводная сеть была развернута в зоне. Чтобы обеспечить более удобные услуги доступа к сети, администраторы должны развернуть беспроводную сеть в этой зоне. Для облегчения унифицированного управления проводными и беспроводными пользователями администраторы также должны использовать существующий шлюз ME60 для проводного доступа в целях аутентификации и учета пользователей беспроводной сети.

Требования к сети

  • Режим сети AC: Сеть уровня 2 в режиме обхода
  • Режим развертывания DHCP:
    • ME60 функционирует как DHCP-сервер для того, чтобы назначить IP-адреса для STA.
    • Коммутатор выполняет функции DHCP-сервера для назначения IP-адресов точкам доступа.
  • Режим переадресации сервисных данных: переадресация soft GRE
Рис. 3-73 Сеть для настройки службы и soft GRE

План данных

Табл. 3-79 План данных AC

Пункт

Данные

План данных коммутатора

DHCP-сервер Коммутатор выполняет функции DHCP-сервера для назначения IP-адресов точкам доступа.
Пул IP-адресов для AP 10.23.100.3-10.23.100.254/24
План данных AC
Адрес исходного интерфейса AC VLANIF 100: 10.23.100.1/24
Группа AP
  • Имя: ap-group1
  • Ссылочные профили: Профиль VAP wlan-net и профиль регулятивного домена default
Профиль регулятивного домена
  • Имя: default
  • Код страны: CN
Профиль SSID
  • Имя: wlan-net
  • Имя SSID: wlan-net
Профиль безопасности
  • Имя: wlan-net
  • Политика безопасности: открытая
Профиль Soft GRE
  • Имя: wlan-soft
  • Адрес назначения туннеля soft GRE: 10.23.200.1
Профиль VAP
  • Имя: wlan-net
  • Режим переадресации: переадресация soft GRE
  • Сервисная VLAN: VLAN 101
  • Ссылочные профили: Профиль SSID wlan-net, профиль безопасности wlan-net и профиль soft GRE wlan-soft
План данных ME60
DHCP-сервер ME60 функционирует как DHCP-сервер для того, чтобы назначить IP-адреса для STA.
Пул IP-адресов для STA 10.23.101.2-10.23.101.254/24
Интерфейс VE для soft GRE Virtual-Ethernet2/0/0
Группа Soft GRE
  • Имя: group1
  • Применен Virtual-Ethernet2/0/0.
Адрес назначения туннеля soft GRE
  • Имя: Loopback 1
  • IP-адрес: 10.23.200.1/24
  • Применена группа soft GRE group1.
Параметры сервера RADIUS
  • Группа серверов: radius1
  • IP-адрес серверов: 172.168.20.1
  • № порта аутентификации: 1812
  • № порта учета: 1813
  • Общий ключ: 123456
  • Схема учета RADIUS: radius
  • Схема аутентификации RADIUS: radius
  • Домен: aaadomain1

Схема настройки

  1. Настройте сетевое взаимодействие AP, AC, Switch и ME60.
  2. Настройте Switch и ME60 для работы в качестве DHCP-серверов, чтобы назначить IP-адресов соответственно для AP и STA.
  3. Настройте ME60, туннель soft GRE, а также функции аутентификации и учета.
  4. Настройте AP для входа в сеть.
    1. Создайте группу AP и добавьте AP, для которых требуется единообразная конфигурация группы для унифицированной конфигурации.
    2. Настройте системные параметры AC, включая код страны и исходный интерфейс, используемые AC для связи с AP.
    3. Настройте режим аутентификации AP и импортируйте AP в автономном режиме, чтобы позволить AP входить в сеть.
  5. Настройте параметры службы WLAN.

Примечания по конфигурации

  • Механизм ACK не предусмотрен для многоадресной передачи пакетов на воздушных интерфейсах. Кроме того, беспроводные каналы нестабильны. Для обеспечения стабильной передачи многоадресных пакетов они обычно отправляются по низким тарифам. Если большое количество таких многоадресных пакетов отправляется с сетевой стороны, воздушные интерфейсы могут быть перегружены. Рекомендуется настроить подавление многоадресных пакетов, чтобы уменьшить влияние большого количества низкоскоростных многоадресных пакетов на беспроводную сеть. Соблюдайте осторожность при настройке ограничения скорости; в противном случае могут быть затронуты многоадресные услуги.
    • В режиме прямой переадресации рекомендуется настроить подавление многоадресных пакетов на интерфейсах коммутатора, подключенных к точкам доступа (AP).
    • В режиме туннельной переадресации рекомендуется настроить подавление многоадресных пакетов в профилях трафика AC.
    Подробнее о том, как настроить подавление трафика, см. Подавление многоадресных пакетов не настроено, что приводит к замедлению доступа к сети STA.
  • Настройте изоляцию портов на интерфейсах устройства, напрямую подключенного к точкам доступа. Если изоляция порта не настроена и используется прямая переадресация, в VLAN может быть создано большое количество ненужных широковещательных пакетов, блокирующих сеть и ухудшающих работу пользователя.

  • В режиме туннельной переадресации управляющая VLAN и сервисная VLAN не могут быть одинаковыми. Только пакеты из управляющей VLAN передаются между AC и AP. Пакеты из сервисной VLAN не допускаются между AC и AP.

Процедура

  1. Настройте сетевые устройства.

    # На Switch добавьте GE0/0/1 к VLAN 100 и VLAN 101, GE0/0/2 к VLAN 100, и GE0/0/3 к VLAN 199. Установите PVID GE0/0/1 на VLAN 100 и GE0/0/3 на VLAN 199. Создайте VLANIF 199 и установите его IP-адрес на 10.23.199.2/24.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 100 101 199
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type trunk
    [Switch-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 101
    [Switch-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [Switch-GigabitEthernet0/0/1] port-isolate enable
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type trunk
    [Switch-GigabitEthernet0/0/2] port trunk allow-pass vlan 100
    [Switch-GigabitEthernet0/0/2] quit
    [Switch] interface gigabitethernet 0/0/3
    [Switch-GigabitEthernet0/0/3] port link-type trunk
    [Switch-GigabitEthernet0/0/3] port trunk allow-pass vlan 199
    [Switch-GigabitEthernet0/0/3] port trunk pvid vlan 199
    [Switch-GigabitEthernet0/0/3] quit
    [Switch] interface vlanif 199
    [Switch-Vlanif199] ip address 10.23.199.2 24
    [Switch-Vlanif199] quit
    

    # На ME60 установите IP-адрес GE2/0/0 на 10.23.199.1/24 и настройте маршрут до 10.23.100.0/24.

    <HUAWEI> system-view
    [HUAWEI] sysname ME60
    [ME60] interface gigabitethernet 2/0/0
    [ME60-GigabitEthernet2/0/0] ip address 10.23.199.1 24
    [ME60-GigabitEthernet2/0/0] quit
    [ME60] ip route-static 10.23.100.0 24 10.23.199.2
    

  2. Настройте AC для связи с сетевыми устройствами.

    # На AC добавьте GE0/0/1 к VLAN 100 (управляющая VLAN). Создайте VLANIF 100 и установите его IP-адрес на 10.23.100.1/24.
    <AC6605> system-view
    [AC6605] sysname AC
    [AC] vlan batch 100 101
    [AC] interface gigabitethernet 0/0/1
    [AC-GigabitEthernet0/0/1] port link-type trunk
    [AC-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [AC-GigabitEthernet0/0/1] quit
    [AC] interface vlanif 100
    [AC-Vlanif100] ip address 10.23.100.1 24
    [AC-Vlanif100] quit
    

  3. Настройте DHCP-серверы для того, чтобы назначить IP-адреса для AP и STA.

    # Настройте коммутатор как DHCP-сервер для назначения IP-адресов точкам доступа и настройте маршрут до 10.23.200.0/24.

    [Switch] dhcp enable
    [Switch] interface vlanif 100
    [Switch-Vlanif100] ip address 10.23.100.2 24
    [Switch-Vlanif100] dhcp select interface
    [Switch-Vlanif100] dhcp server excluded-ip-address 10.23.100.1
    [Switch-Vlanif100] quit
    [Switch] ip route-static 10.23.200.0 24 10.23.199.1
    

    # Настройте ME60 как DHCP-сервер, чтобы назначить IP-адреса для STA.

    ПРИМЕЧАНИЕ:
    Настройте DNS-сервер по мере необходимости. Общие методы заключаются в следующем:
    • В сценариях пула адресов интерфейса запустите команду dhcp server dns-list ip-address &<1-8> в виде интерфейса VLANIF.
    • В сценариях пула глобального адреса запустите команду dns-list ip-address &<1-8> в виде пула IP-адресов.
    [ME60] dhcp enable
    [ME60] ip pool sta-pool bas local
    [ME60-ip-pool-sta-pool] gateway 10.23.101.1 24
    [ME60-ip-pool-sta-pool] section 1 10.23.101.3 10.23.101.254
    [ME60-ip-pool-sta-pool] option 43 ip 10.23.101.1
    [ME60-ip-pool-sta-pool] quit
    

  4. Настройте туннель soft GRE на ME60.

    # Создайте интерфейс VE для поддержки soft GRE.

    [ME60] interface virtual-ethernet 2/0/0
    [ME60-Virtual-Ethernet2/0/0] soft-gre enable
    [ME60-Virtual-Ethernet2/0/0] quit
    

    # Создайте группу soft GRE.

    [ME60] soft-gre group group1
    [ME60-softgre-group-group1] master virtual-ethernet 2/0/0
    [ME60-softgre-group-group1] quit
    

    # Настройте IP-адрес для интерфейса loopback и привяжите к нему группу soft GRE.

    [ME60] interface loopback 1
    [ME60-LoopBack1] ip address 10.23.200.1 255.255.255.0
    [ME60-LoopBack1] binding soft-gre group group1
    [ME60-LoopBack1] quit
    

  5. Настройте аутентификацию и учет RADIUS на ME60.

    # Настройте профиль сервера RADIUS, схему аутентификации AAA, схему учета AAA и информацию о домене.

    [ME60] radius-server group radius1
    [ME60-radius-radius1] radius-server authentication 172.168.20.1 1812
    [ME60-radius-radius1] radius-server accounting 172.168.20.1 1813
    [ME60-radius-radius1] radius-server shared-key 123456
    [ME60-radius-radius1] quit
    [ME60] aaa
    [ME60-aaa] authentication-scheme radius
    [ME60-aaa-authen-radius] authentication-mode radius
    [ME60-aaa-authen-radius] quit
    [ME60-aaa] accounting-scheme radius
    [ME60-aaa-accounting-radius] accounting-mode radius
    [ME60-aaa-accounting-radius] quit
    [ME60-aaa] domain aaadomain1
    [ME60-aaa-domain-aaadomain1] ip-pool sta-pool
    [ME60-aaa-domain-aaadomain1] authentication-scheme radius
    [ME60-aaa-domain-aaadomain1] accounting-scheme radius
    [ME60-aaa-domain-aaadomain1] radius-server group radius1
    [ME60-aaa-domain-aaadomain1] quit
    [ME60-aaa] quit
    

  6. Настройте интерфейс BAS (Маршрутизатор Широкополосного Доступа) на ME60.

    # Создайте интерфейс BAS, настройте тип интерфейса BAS и режим аутентификации. Настройте пользовательскую VLAN и сервисную VLAN как одну и ту же VLAN.

    [ME60] interface virtual-ethernet 2/0/0.1
    [ME60-Virtual-Ethernet2/0/0.1] user-vlan 101
    [ME60-Virtual-Ethernet2/0/0.1-vlan-101-101] bas
    [ME60-Virtual-Ethernet2/0/0.1-bas] access-type layer2-subscriber default-domain authentication aaadomain1
    [ME60-Virtual-Ethernet2/0/0.1-bas] authentication-method bind
    

  7. Настройте AP для входа в сеть.

    # Создайте группу AP, к которой могут добавляться точки доступа с той же конфигурацией.
    [AC] wlan
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] quit
    
    # Создайте профиль регулятивного домена, настройте код страны AC в профиле и примените профиль к группе AP.
    [AC-wlan-view] regulatory-domain-profile name default
    [AC-wlan-regulate-domain-default] country-code cn
    [AC-wlan-regulate-domain-default] quit
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] regulatory-domain-profile default
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AC-wlan-ap-group-ap-group1] quit
    [AC-wlan-view] quit
    
    # Настройте исходный интерфейс AC.
    [AC] capwap source interface vlanif 100
    
    # Импортируйте AP в автономном режиме на AC и добавьте AP в группу AP ap-group1. Предположим, что MAC-адресом у AP является 60de-4476-e360. Настройте имя для AP на основе местоположения развертывания AP, чтобы узнать, где AP развертывается из своего имени. Например, назовите AP area_1, если она развернута в Зоне 1.
    ПРИМЕЧАНИЕ:

    Режим аутентификации AP по умолчанию - это аутентификация MAC-адреса. Если настройки по умолчанию сохранены, не нужно запускать команду ap auth-mode mac-auth.

    В этом примере используется AP5030DN и имеет два радио: радио 0 (2.4 ГГц) и радио 1 (5 ГГц).

    [AC] wlan
    [AC-wlan-view] ap auth-mode mac-auth
    [AC-wlan-view] ap-id 0 ap-mac 60de-4476-e360
    [AC-wlan-ap-0] ap-name area_1
    [AC-wlan-ap-0] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-0] quit
    
    # После включения AP запустите команду display ap all, чтобы проверить состояние AP. Если поле State отображается как nor, AP успешно подключается к сети.
    [AC-wlan-view] display ap all
    Total AP information:
    nor  : normal          [1]
    -------------------------------------------------------------------------------------
    ID   MAC            Name   Group     IP            Type            State STA Uptime
    -------------------------------------------------------------------------------------
    0    60de-4476-e360 area_1 ap-group1 10.23.100.254 AP5030DN        nor   0   10S
    -------------------------------------------------------------------------------------
    Total: 1

  8. Настройте параметры службы WLAN.

    # Создайте профиль безопасности wlan-net и используйте политику безопасности по умолчанию в профиле.

    [AC-wlan-view] security-profile name wlan-net
    [AC-wlan-sec-prof-wlan-net] quit
    
    # Создайте профиль SSID wlan-net и установите имя SSID на wlan-net.
    [AC-wlan-view] ssid-profile name wlan-net
    [AC-wlan-ssid-prof-wlan-net] ssid wlan-net
    [AC-wlan-ssid-prof-wlan-net] quit
    

    # Создайте профиль soft GRE wlan-soft и установите параметры профиля soft GRE.

    [AC-wlan-view] softgre-profile name wlan-soft
    [AC-wlan-softgre-prof-wlan-soft] destination ip-address 10.23.200.1
    [AC-wlan-softgre-prof-wlan-soft] quit
    

    # Создайте профиль VAP wlan-net, установите режим переадресации данных и сервисную VLAN и примените профиль безопасности и профиль SSID к профилю VAP.

    [AC-wlan-view] vap-profile name wlan-net
    [AC-wlan-vap-prof-wlan-net] forward-mode softgre wlan-soft
    [AC-wlan-vap-prof-wlan-net] service-vlan vlan-id 101
    [AC-wlan-vap-prof-wlan-net] security-profile wlan-net
    [AC-wlan-vap-prof-wlan-net] ssid-profile wlan-net
    [AC-wlan-vap-prof-wlan-net] quit
    
    # Привяжите профиль VAP wlan-net к группе AP и примените профиль к radio 0 и radio 1 точки доступа.
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 0
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 1
    [AC-wlan-ap-group-ap-group1] quit
    

  9. Настройте канал и мощность AP.
  10. Проверьте конфигурацию.

    AC автоматически доставляет конфигурацию службы WLAN в AP. После завершения настройки запустите команду display vap ssid wlan-net. Если поле Status отображается как ON, VAP успешно созданы на AP Radio.

    [AC-wlan-view] display vap ssid wlan-net
    WID : WLAN ID
    --------------------------------------------------------------------------------
    AP ID AP name RfID WID   BSSID          Status  Auth type     STA   SSID
    --------------------------------------------------------------------------------
    0     area_1  0    1     60DE-4476-E360 ON      open          0     wlan-net
    0     area_1  1    1     60DE-4476-E370 ON      open          0     wlan-net
    -------------------------------------------------------------------------------
    Total: 2

    Подключите STA к WLAN с помощью SSID wlan-net. Запустите команду display station ssid wlan-net на AC. Вывод команды показывает, что STA подключены к WLAN wlan-net.

    [AC-wlan-view] display station ssid wlan-net
    Rf/WLAN: Radio ID/WLAN ID
    Rx/Tx: link receive rate/link transmit rate(Mbps)
    ---------------------------------------------------------------------------------
    STA MAC         AP ID Ap name   Rf/WLAN  Band  Type  Rx/Tx      RSSI  VLAN  IP address
    ---------------------------------------------------------------------------------
    e019-1dc7-1e08  0     area_1    1/1      5G    11n   46/59      -68   101   10.23.101.254
    ---------------------------------------------------------------------------------
    Total: 1 2.4G: 0 5G: 1

Файлы конфигурации

  • Файл конфигурации коммутатора

    #
    sysname Switch
    #
    vlan batch 100 to 101 199
    #
    dhcp enable
    #
    interface Vlanif100
     ip address 10.23.100.2 255.255.255.0
     dhcp select interface
     dhcp server excluded-ip-address 10.23.100.1
    #
    interface Vlanif199
     ip address 10.23.199.2 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100 to 101
     port-isolate enable group 1
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk pvid vlan 199
     port trunk allow-pass vlan 199
    #
    ip route-static 10.23.200.0 0.0.0.0 10.23.199.2
    #
    return
  • Файл конфигурации AC

    #
     sysname AC
    #
    vlan batch 100 to 101
    #
    interface Vlanif100
     ip address 10.23.100.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    capwap source interface vlanif100
    #
    wlan
     security-profile name wlan-net
     ssid-profile name wlan-net
      ssid wlan-net
     softgre-profile name wlan-soft
      destination ip-address 10.23.200.1
     vap-profile name wlan-net
      forward-mode softgre wlan-soft
      service-vlan vlan-id 101
      ssid-profile wlan-net
      security-profile wlan-net
     regulatory-domain-profile name default
     ap-group name ap-group1
      radio 0
       vap-profile wlan-net wlan 1
      radio 1
       vap-profile wlan-net wlan 1
     ap-id 0 type-id 35 ap-mac 60de-4476-e360 ap-sn 210235554710CB000042
      ap-name area_1
      ap-group ap-group1
      radio 0
       channel 20mhz 6
       eirp 127
      radio 1
       channel 20mhz 149
       eirp 127
    #
    return
  • Файл конфигурации ME60

    #
    sysname ME60
    #
    vlan batch 101
    #
    radius-server group radius1
     radius-server authentication 172.168.20.1 1812 weight 0
     radius-server accounting 172.168.20.1 1813 weight 0
     radius-server shared-key 123456
    #
    ip pool sta-pool bas local
     gateway 10.23.101.1 255.255.255.0
     section 1 10.23.101.3 10.23.101.254
     option 43 ip 10.23.101.1
    #
    aaa
     authentication-scheme radius
     #
     accounting-scheme radius
     #
     domain aaadomain1
      authentication-scheme radius
      accounting-scheme radius
      ip-pool sta-pool
      radius-server group radius1
     #
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 10.23.199.1 255.255.255.0
    #
    interface Virtual-Ethernet2/0/0
     soft-gre enable
    #
    interface Virtual-Ethernet2/0/0.1
     user-vlan 101
     bas
     #
      access-type layer2-subscriber default-domain authentication aaadomain1
      authentication-method bind
     #
    #
    interface LoopBack1
     ip address 10.23.200.1 255.255.255.0
     binding soft-gre group group1
    #
    soft-gre group group1
     master Virtual-Ethernet2/0/0
    #
    ip route-static 10.23.100.0 255.255.255.0 10.23.199.2
    #
    return
Загрузить
Updated: 2018-08-21

№ документа:EDOC1100029357

Просмотры:7541

Загрузки: 101

Average rating:
This Document Applies to these Products
Связанные документы
Related Version
Share
Назад Далее