所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

FusionServer Pro 刀片服务器 升级指导书 16

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
升级前检查

升级前检查

操作场景

该操作指导维护工程师,在升级IB交换平面前,检查固件版本和端口的连接状态。

必备事项

前提条件

  • 交换模块已经上电。
  • 计算节点已经上电。
  • 保证网卡与交换模块物理链路连通。

数据

需要准备的数据请参见局点信息

操作步骤

安装IB Mezz网卡驱动

  • 本章节操作都是在redhat6.5下进行,其他linux系统操作类似。
  • 如果已经安装驱动包请跳过本步骤,运行命令ofed_info -s查看是否安装驱动,如果无此命令就未装驱动,如果返回版本说明已经安装驱动。
  • 本指导使用的驱动包OSCA-connectx3_vpi-rhel6.5-x86_64-xx.xx.xx.xx.gz为示例,其他OS下软件包请参见软件包
  • 此步以SCP工具举例进行文件上传,可以根据实际情况改变。
  • 如果安装过程中报错,会提示缺少的库文件名称,如libnl-devel、libgfortran43、tcl、tk等,可以通过挂载系统iso找到缺少的rpm包并进行安装。
  1. 下载IB Mezz网卡驱动包,解压后获取对应操作系统的驱动包。

    以redhat6.5系统为例介绍,其他操作系统操作相同。

    IB Mezz网卡驱动包格式为:

    CHxxx-RHEL-MZ61x(ConnectX-3)_Drivers-Vxxx.zip

    解压zip包后获取redhat6.5系统的驱动包格式为:OSCA-connectx3_vpi-rhel6.5-x86_64-xx.xx.xx.xx.gz

  2. 通过SCP把OSCA-connectx3_vpi-rhel6.5-x86_64-xx.xx.xx.xx.gz驱动包上传到rhel6.5x86_64系统下。
  3. 通过tar命令解压驱动包,进入解压后的文件夹运行./mlnxofedinstall进行安装。

    运行命令:

    #tar -zxf OSCA-connectx3_vpi-rhel6.5-x86_64-xx.xx.xx.xx.gz

    #cd MLNX_OFED_LINUX-x.x-x.x.x-rhel6.5-x86_64

    #./mlnxofedinstall

    安装完成后重启系统生效。

检查连接状态

  1. 登录计算节点,在CLI执行以下命令,开启子网管理器激活IB网络。

    # /etc/init.d/opensmd start

    显示如下信息,表示已经开启子网管理器激活IB网络。

  2. 检查IB Mezz扣卡和交换模块的连接状态。

    ibstat

    显示如下信息:

    “State”表示目前的端口状态,由上面信息可知,Port1端口状态为Active,表示连接正常。

查询IB交换平面的当前版本

  1. 将网络中IB设备映射到计算节点本地。

    mst ib add

    显示类似如下信息:

  2. 查询交换设备的设备信息。

    mst status

    显示如下信息:

    参数说明:

    “/dev/mst/SW_MT51000_20f17c030013d8a6_lid-0x0003”和“/dev/mst/SW_MT51000_54511b0300aadbd7_lid-0x0004”都为交换芯片的设备名称,根据实际情况有所不同。

  3. 查询并记录IB交换平面固件的当前版本。

    flint -d /dev/mst/SW_MT51000_20f17c030013d8a6_lid-0x0003 q

    显示如下信息:

    参数说明:

    • -d后面参数“/dev/mst/SW_MT51000_20f17c030013d8a6_lid-0x0003”为交换芯片的设备名称,根据实际情况有所不同。
    • “FW Version”表示该交换芯片的固件版本号。

确认需要升级的固件

  1. 根据最新的版本配套表,确认需要升级的软件,如表8-6所示。

    表8-6 确认需要升级的软件

    模块名称

    是否需要升级

    IB交换平面固件

    是□ 否□

翻译
下载文档
更新时间:2019-11-11

文档编号:EDOC1000081367

浏览量:74806

下载量:11448

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页