所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

OceanStor 9000 V300R005C00 故障处理 05

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
告警不能上报

告警不能上报

告警不能上报,将导致用户无法在DeviceManager中查看到告警信息。

现象描述

告警不能上报,导致在DeviceManager中查看不到告警的信息。

可能原因

  • 原因1:CM进程异常。
  • 原因2:DeviceManager与CM通信异常。

定位思路

图5-7   告警无法上报处理流程

处理步骤

  • 原因1:CM故障。
    1. 使用omuser用户通过PuTTY工具登录OceanStor 9000管理IP地址,使用su命令并输入root用户密码切换到root用户。
    2. 执行命令ps -ef|grep snas_cm,查看CM进程是否正常。

      若显示有记录,说明进程正常。否则进程不正常。

    3. 重新启动CM。

      • 执行命令ps -ef|grep cm,查看CM进程号,CM进程号为带有snas_cm字样的那条进程。
      • 执行命令kill -9 进程号,关闭CM进程后,守护进程会自动启动CM,实现重启。

    4. 重新启动DeviceManager

      在命令行模式下,执行命令cd /opt/deviceManager/bin,进入该目录下,执行命令sh restart.sh

    5. 查看告警信息是否能正常上报。

      • 是 => 故障排除。
      • 否 => 原因2

  • 原因2:DeviceManager与CM通信异常。
    1. 登录服务器。
    2. 在命令行模式下,运行cd /var/ISM/deviceManager/logs,进入该目录下。
    3. 运行命令less currentindex,获取当前日志索引,之后运行命令less ibase_N.dbg(其中N为当前日志索引),查看是否有“connect to 127.0.0.1:8080, failed, resource temporarily unavailable”输出表示通信异常。

      • 是 => 参见原因134,重启CM和DeviceManager
      • 否 => 请联系技术服务工程师。

    4. 查看告警是否能成功上报。

      • 是 => 故障排除。
      • 否 => 请联系技术服务工程师。

翻译
下载文档
更新时间:2018-10-27

文档编号:EDOC1000095849

浏览量:7178

下载量:799

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页