所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

OceanStor 9000 V300R005C00 故障处理 05

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
创建后台任务失败

创建后台任务失败

创建后台任务失败,将会导致此次失败的任务类型对应的业务不能正常运行。

现象描述

用户在创建一次性后台任务时,提示失败。如图4-24所示。

图4-24  启动后台任务失败

可能原因

  • 原因1:snas_bjm_manager进程未运行。
  • 原因2:集群中没有主snas_bjm_manager。
  • 原因3:主snas_bjm_manager所在节点的CA文件系统未挂载。

定位思路

图4-25  创建后台任务失败故障处理流程图

处理步骤

  1. 原因1:snas_bjm_manager进程未运行。
    1. 使用“omuser”身份登录到所有节点。
    2. 执行ps -ef|grep snas_bjm_ma|grep -v grep命令,查看snas_bjm_manager进程是否运行。

      说明:

      如果命令有输出,说明snas_bjm_manager进程在运行;否则,说明snas_bjm_manager进程未运行。

    3. 执行/opt/product/deploy/bin/daemon /opt/product/snas/bin/snas_bjm_manager启动snas_bjm_manager进程。

      说明:

      参见1.b判断进程是否启动成功。

      • 启动成功=>1.d
      • 启动失败=>请联系技术服务工程师。

    4. 执行创建后台任务的操作,是否能成功。

      • 是=>故障排除。
      • 否=>2

  2. 原因2:集群中没有主snas_bjm_manager。
    1. 使用“omuser”身份登录到集群所有节点。
    2. 执行cat /proc/monc_jmmap命令,检查各节点snas_bjm_manager的map信息是否正常。

      说明:

      如果map信息中有全0的map信息(如下所示),或集群内多个节点上的map信息不一致,则说明map信息异常,集群未选举产生主snas_bjm_manager。

      active manager id (0)

    3. 请联络网络管理员进行网络故障的排查。
    4. 再次执行2.b,检查map信息是否恢复正常。

      • 是=>2.e
      • 否=>请联系技术服务工程师。

    5. 执行创建后台任务的操作,查看是否成功。

      • 是=>故障排除。
      • 否=>3

  3. 原因3:主snas_bjm_manager所在节点的CA文件系统未挂载。
    1. 请参见2的方法查看主snas_bjm_manager所在节点的IP地址。
    2. 使用“omuser”身份登录主snas_bjm_manager所在的节点,使用su -切换到“root”用户。
    3. 执行mount -t cafs命令,查看主snas_bjm_manager的CA文件系统是否正常挂载。

      说明:

      如果命令执行结果如下,说明正常挂载了CA文件系统。否则,说明未正常挂载CA文件系统

      / on /mnt/fs type cafs (rw,relatime)
      • 是=>请联系技术服务工程师。
      • 否=>3.d

    4. 执行mount -t cafs / /mnt/fs/命令,挂载CA文件系统。

      • 挂载成功=>3.e
      • 挂载失败=>请联系技术服务工程师。

    5. 执行创建后台任务的操作,查看是否成功。

      • 是=>故障排除。
      • 否=>请联系技术服务工程师。

参考信息

无。

翻译
下载文档
更新时间:2018-10-27

文档编号:EDOC1000095849

浏览量:7385

下载量:801

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页