所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

OceanStor 9000 V300R005C00 故障处理 05

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
删除快照失败

删除快照失败

删除快照失败,导致管理员无法删除已存在的快照,对文件系统本身不会产生损害。

现象描述

登录DeviceManager选择数据保护 > 快照 > 快照勾选需要查看的快照,单击“删除”,确认风险后,单击“确定”,弹出错误提示,提示信息有“快照Id不存在”,“通信异常或系统繁忙”,删除快照失败。

可能原因

  • 原因1:CM进程异常。
  • 原因2:CCDB进程异常。
  • 原因3:文件系统运行状态异常。

定位思路

图4-30   删除快照失败处理流程图

处理步骤

  • 原因1:CM进程异常。
    1. 使用omuser身份通过PuTTY工具登录OceanStor 9000管理IP地址,使用su命令并输入root用户的登录密码切换到root用户,在命令行模式下,运行ps -ef |grep snas_cm,查看CM进程是否异常。

    2. 重新启动CM进程。

      在命令行模式下,输入kill -9 `ps -ef|grep snas_cm|grep -v grep|awk '{print $2}'`命令,即可重启CM进程。

    3. 重新删除快照,查看是否成功。

      • 是 => 故障排除。
      • 否 => 原因2

  • 原因2:CCDB进程异常。
    1. 使用omuser身份通过PuTTY工具登录OceanStor 9000管理IP地址,使用su命令并输入root用户的登录密码切换到root用户,在命令行模式下,运行MmlBatch 4004 "mon ccdbmap 0",查询CCDB主节点ID。

      其中Master Ccdb Id : 1表示ccdb主节点ID为1。

      *****************CCDB MAP Start***************
      Epoch : 6
      Master Ccdb Id : 1
      RackName : h1
      Node Id : 2
      Role : 1
      State : 1
      RackName : h1
      Node Id : 1
      Role : 0
      State : 1
      RackName : h1
      Node Id : 3
      Role : 1
      State : 1
      *****************CCDB MAP End***************

    2. 执行cat /proc/monc_nodemap,查询CCDB主节点IP地址。

      根据1中查询的CCDB主节点ID,可知CCDB主节点IP地址。下面的例子中CCDB主节点IP地址为192.168.100.14。

      NODE14:~ # cat /proc/monc_nodemap 
      ***************** Node Map *****************
      Node: NodeID(3), BackIp(0x61ca640f), BirthTime(6148640756791479442), DevName(192.168.100.15), ClusterID(snassnap11431590979863), NodeType(1), RegStatus(1), FaultTime(0), DelTime(0)
      Node: NodeID(2), BackIp(0x61ca6410), BirthTime(6148640610762061891), DevName(192.168.100.16), ClusterID(snassnap11431590979863), NodeType(1), RegStatus(1), FaultTime(0), DelTime(0)
      Node: NodeID(1), BackIp(0x61ca640e), BirthTime(6148640606467511425), DevName(192.168.100.14), ClusterID(snassnap11431590979863), NodeType(1), RegStatus(1), FaultTime(0), DelTime(0)
      ************** Local Node Info *************
      Node RegStat: 1, NodeId: 1, BirthTime: 6148640606467511425, ClusterId: snassnap11431590979863, DevName: 192.168.100.14, NodeType: 1, FaultTime: 0, DelTime: 0
      NIDStat: 1(1:normal), HbStop: 0(1:stop), Ntf: 0(0:done), NIDFlg: 0(0:normal 1:map_fault 2:detect_fault)

    3. 使用omuser身份通过PuTTY工具登录CCDB主节点,使用su命令并输入root用户的登录密码切换到root用户,在命令行模式下,执行cat /proc/ccdb_statemap,查看CCDB进程的状态是否正常。

      若回显信息中result为0,且status为2,则说明CCDB进程的状态正常。

      NODE15:/home/omuser # cat /proc/ccdb_statemap 
      result:0,status:2

    4. 执行ps -ef |grep ccdb_server,查看CCDB进程。
    5. 重新启动CCDB进程。

      1. 执行以下命令,停止CCDB进程。

        /opt/huawei/deploy/bin/daemon -s /opt/huawei/snas_cluster/bin/ccdb_server

      2. 执行以下命令,重新启动CCDB进程。

        /opt/huawei/deploy/bin/daemon /opt/huawei/snas_cluster/bin/ccdb_server

    6. 重新删除快照,查看是否成功。

      • 是 => 故障排除。
      • 否 => 原因3

  • 原因3:文件系统运行状态异常。
    1. 参见“查询文件系统运行状态失败或错误”进行处理,排除故障。
    2. 重新删除快照,查看是否成功。

      • 是 => 故障排除。
      • 否 => 请联系技术服务工程师。

翻译
下载文档
更新时间:2018-10-27

文档编号:EDOC1000095849

浏览量:7276

下载量:801

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页