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OceanStor 9000 V300R005C00 故障处理 05

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备份服务器连接NDMP服务器失败

备份服务器连接NDMP服务器失败

备份服务器(NDMP客户端)连接NDMP服务器(OceanStor 9000)失败。

现象描述

备份服务器连接NDMP服务器失败,显示如图4-111所示。

图4-111  备份服务器连接NDMP服务器失败处理流程

可能原因

  • 原因1:NDMP服务异常。
  • 原因2:指定端口未启用。
  • 原因3:备份服务器未添加NDMP服务器DNS。
  • 原因4:用户名与密码输入错误。

定位思路

图4-112  备份服务器连接NDMP主机失败故障定位流程

处理步骤

  • 原因1:NDMP服务异常。
    1. 登录DeviceManager
    2. 选择设置 > 存储设置 > 文件存储服务 > NDMP设置
    3. 查看“启用”前的复选框是否为勾选状态。

      如果未勾选,表明NDMP服务异常,请勾选后,单击“保存”;否则,请继续定位其他原因。

  • 原因2:指定端口未启用。
    1. 在备份服务器中,执行telnet命令查看指定端口能否访问。

      例如,在设置 > 存储设置 > 文件存储服务 > NDMP设置页面中设置的“监控端口”“10000”,则执行命令telnet xx.xx.xx.xx 10000

      • 如果显示“Connected to”,表明能正常访问,请继续定位其他原因 => 原因3

      • 否则 => 2

    2. 登录DeviceManager
    3. 选择设置 > 存储设置 > 文件存储服务 > NDMP设置
    4. 去勾选“启用”并单击“保存”
    5. 重新勾选“启用”,在“监控端口”输入指定端口号,然后单击“保存”

      检查功能是否正常。

      • 是 => 故障排除。
      • 否 => 原因3

  • 原因3:备份服务器未添加NDMP服务器DNS。

    检查备份服务器的配置文件/etc/resolv.conf中是否添加DNS,如果没有,请添加NDMP主机DNS。配置项为“nameserver DNSIP”,DNSIP为集群DNS IP,在DeviceManager设置 > 集群设置 > InfoEqualizer > 网络设置中可以查看DNS IP地址。设置好后再检测是否可以访问OceanStor 9000动态域名,用nslookup dynamicname命令检测,其中dynamicnameOceanStor 9000动态域名。

    • 是 => 故障排除。
    • 否 => 请联系技术服务工程师。

  • 原因4:用户名与密码输入错误。

    请在如图4-111所示的操作界面,重新输入用户名与密码,再次尝试连接。

    • 是 => 故障排除。
    • 否 => 请联系技术服务工程师。

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更新时间:2018-10-27

文档编号:EDOC1000095849

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