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OceanStor 9000 V300R005C00 故障处理 05

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认证执行失败(FTP)

认证执行失败(FTP)

FTP认证执行失败,将导致用户无法登录FTP服务器,进而无法使用FTP服务。

现象描述

当使用FTP客户端登录服务器时,服务器返回响应“530 Login authentication failed”

可能原因

  • 用于FTP登录的用户不存在或密码不正确。
  • FTP用户共享数据信息丢失。

定位思路

图4-60  认证执行失败(FTP)处理流程

处理步骤

  1. 原因1:用于FTP登录的用户不存在或密码不正确。
    1. 登录DeviceManager
    2. 选择资源分配 > 共享 > FTP,查看FTP共享信息中是否存在该用户信息。

      • 是 => 1.c
      • 否 => 请创建用户并创建相应的FTP共享,然后再登录。

    3. 重新输入正确的用户密码,检查是否可以正常登录。

      • 是 => 故障排除。
      • 否 => 2

  2. 原因2:FTP用户共享数据信息丢失。
    1. 使用omuser身份通过PuTTY工具登录OceanStor 9000管理IP地址,使用su命令并输入root用户密码切换到root用户。
    2. 执行service nasftp status命令查询FTP服务状态,检查FTP服务状态是否为“running”

      • 是 => 2.c
      • 否 => 执行service nasftp start命令启动FTP服务,并重新登录。

    3. 执行iptables -L | grep ftp命令,检查系统“21”端口是否被防火墙策略屏蔽。

      返回类似如下回显,表示端口已被屏蔽。
      node1:~ # iptables -L | grep ftp
      ACCEPT     tcp  --  anywhere             anywhere            tcp dpt:ftp state NEW,ESTABLISHED 
      REJECT     tcp  --  anywhere             anywhere            tcp dpt:ftp state NEW,ESTABLISHED
      • 是 => 执行iptables -I INPUT 1 -p tcp --dport 21 -m state --state NEW,ESTABLISHED -j ACCEPT命令,开启“21”端口,并重新登录。
      • 否 => 请联系技术服务工程师。

参考信息

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更新时间:2018-10-27

文档编号:EDOC1000095849

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