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OceanStor 9000 V300R005C00 故障处理 05

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设置用户信息失败

设置用户信息失败

设置用户信息失败,将会导致认证失败,CIFS共享设置用户权限失败。

现象描述

在设置用户信息过程中,提示出错。

可能原因

  • 原因1:产品提供的共享存储异常。
  • 原因2:InfoEqualizer进程退出。
  • 原因3:cmr_store进程退出。

定位思路

图4-82  设置用户信息失败故障处理流程

处理步骤

  • 原因1:文件系统提供的共享存储异常。
    1. 使用omuser身份通过PuTTY工具登录OceanStor 9000管理IP地址,使用su命令并输入root用户密码切换到root用户。
    2. 执行cat /proc/monc_pipmap获取到主节点IP。
    3. 使用omuser身份通过ssh命令登录到该主节点,使用su命令并输入root用户密码切换到root用户。
    4. 登录DeviceManager在基本信息的“健康状态”一栏,显示的是集群运行状态为非“正常”状态。
    5. 单击设备图标,进入“设备视图”,进入节点列表来查看各个节点健康状态的详情,存在一个或几个节点的健康状态为非“正常”状态。
    6. 单击健康状态为非“正常”状态的节点,单击位置如图4-83所示。进入节点基本信息,查看其“文件系统服务运行状态”为非“运行”状态。

      图4-83   DeviceManager查询节点状态

  • 原因2:InfoEqualizer进程退出。
    1. 使用omuser身份通过PuTTY工具登录OceanStor 9000管理IP地址,使用su命令并输入root用户密码切换到root用户。
    2. 执行cat /proc/monc_pipmap获取到主节点IP。
    3. 使用omuser身份通过ssh命令登录到该主节点,使用su命令并输入root用户密码切换到root用户。
    4. 执行ps -ef|grep InfoEqualizer命令,查看InfoEqualizer进程是否退出。

      如果系统显示如下,表明InfoEqualizer进程存在。

      root     11759     1  0 14:06 ?        00:00:03 /usr/local/bin/InfoEqualizer

    5. 执行InfoEqualizer,重新启动InfoEqualizer进程后设置用户信息是否成功。

      • 是 => 故障排除。
      • 否 => 原因3

  • 原因3:cmr_store进程退出。
    1. 使用omuser身份通过PuTTY工具登录OceanStor 9000管理IP地址,使用su命令并输入root用户密码切换到root用户。
    2. 执行cat /proc/monc_pipmap获取到主节点IP。
    3. 使用omuser身份通过ssh命令登录到该主节点,使用su命令并输入root用户密码切换到root用户。
    4. 执行ps -ef|grep cmr_store命令,查看cmr_store进程是否退出。

      如果系统显示如下,表明cmr_store进程存在。

      root     11766     1  0 Mar04 ?        00:00:00 cmr_store
      • 是 => 5
      • 否 => 请联系技术服务工程师。

    5. 执行killproc cmr_store命令,重新启动cmr_store进程后设置用户信息是否成功。

      • 是 => 故障排除。
      • 否 => 请联系技术服务工程师。

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更新时间:2018-10-27

文档编号:EDOC1000095849

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