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OceanStor 9000 V300R005C00 故障处理 05

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创建复制区域通道失败

创建复制区域通道失败

创建复制区域通道失败,会导致无法创建远程复制Pair,进而无法正常使用远程复制功能。

现象描述

登录DeviceManager选择右侧功能导航数据保护 > 远程复制 > 复制区域通道,单击“创建”进行创建复制区域通道,返回错误,创建复制区域通道失败。

可能原因

  • 原因1:与相同远端集群间已经存在一个复制区域通道。
  • 原因2:本端或远端复制区域通道数目超过规格。
  • 原因3:本端或远端复制区域内无可用IP地址。
  • 原因4:指定的远端复制区域名称不存在。
  • 原因5:输入的通道鉴权IP地址不可用。
  • 原因6:输入的通道鉴权密码错误。
  • 原因7:远端复制区域通道ID已存在。
  • 原因8:CM进程异常。
  • 原因9:CCDB进程异常。
  • 原因10:本端与远端的软件版本不一致。

定位思路

图4-75  创建复制区域通道失败处理流程

处理步骤

  • 原因1:与相同远端集群间已经存在一个复制区域通道。
    1. 查看错误提示信息是否为“复制通道已存在”

    2. 在复制区域通道管理界面,查看是否存在一个到相同远端集群的复制区域通道。

      • 是 => 两个集群间仅允许建立一个复制区域通道,故障排除。
      • 否 => 请联系技术支持工程师。

  • 原因2:本端或远端复制区域通道数目超过规格。
    1. 查看错误提示信息是否为“本端复制通道数目已达最大规格”“远端复制通道数目已达最大规格”

    2. 根据提示,在本端或远端集群复制区域通道管理界面,查看复制区域通道数量是否达到上限(32个)。

      • 是 => 3
      • 否 => 请联系技术支持工程师。

    3. 与管理员确认后,删除本端或远端集群内多余的复制区域通道。
    4. 重新创建复制区域通道,查看是否成功。

      • 是 => 故障排除。
      • 否 => 请联系技术支持工程师。

  • 原因3:本端或远端复制区域内无可用IP地址。
    1. 查看错误提示信息是否为“本端复制区域内无工作的复制节点IP地址”“远端复制区域内无工作的复制节点IP地址”

    2. 根据提示,登录本端或远端DeviceManager,选择右侧功能导航数据保护 > 远程复制 > 复制区域,选中复制区域,查看是否包含可用IP地址。

      • 是 => 请联系技术支持工程师。
      • 否 => 3

    3. 修改复制区域包含IP地址段,确保已至少包含一个节点的前端业务IP地址。
    4. 重新创建复制区域通道,查看是否成功。

      • 是 => 故障排除。
      • 否 => 请联系技术支持工程师。

  • 原因4:指定的远端复制区域名称不存在。
    1. 查看错误提示信息是否为“指定的远端复制区域名称不存在”

    2. 修改创建复制区域通道时指定的远端复制区域名称为正确的名称。
    3. 重新创建复制区域通道,查看是否成功。

      • 是 => 故障排除。
      • 否 => 请联系技术支持工程师。

  • 原因5:输入的通道鉴权IP地址不可用。
    1. 查看错误提示信息是否为“输入的远端IP地址不允许为本端集群IP地址”“连接远端IP失败”

    2. 使用正确的远端集群任一节点的前端业务IP地址重新创建复制区域通道,查看是否成功。

      • 是 => 故障排除。
      • 否 => 请联系技术支持工程师。

  • 原因6:输入的通道鉴权密码错误。
    1. 查看错误提示信息是否为“密码错误”

    2. 使用正确的密码,重新创建复制区域通道,查看是否成功。

      • 是 => 故障排除。
      • 否 => 请联系技术支持工程师。

  • 原因7:远端复制区域通道ID已存在。
    1. 查看错误提示信息是否为“远端复制通道ID已存在”

    2. 分别登录本端与远端DeviceManager,选择右侧功能导航数据保护 > 远程复制 > 复制区域通道,查看是否有仅在本端DeviceManager存在而远端不存在的复制区域通道。

      • 是 => 3
      • 否 => 请联系技术支持工程师。

    3. 在本端DeviceManager删除2所述的复制区域通道。
    4. 重新创建复制区域通道,查看是否成功。

      • 是 => 故障排除。
      • 否 => 原因8

  • 原因8:CM进程异常。
    1. 使用“omuser”身份通过PuTTY工具登录OceanStor 9000管理IP地址,使用su命令,并输入“root”用户的登录密码切换到“root”用户,在命令行模式下,运行ps -ef |grep snas_cm,查看CM进程是否异常。

    2. 重新启动CM进程。

      在命令行模式下,执行kill -9 `ps -ef|grep snas_cm|grep -v grep|awk '{print $2}'`命令,即可重启CM进程。

    3. 重新创建复制区域通道,查看是否成功。

      • 是 => 故障排除。
      • 否 => 原因9

  • 原因9:CCDB进程异常。
    1. 使用“omuser”身份通过PuTTY工具登录OceanStor 9000管理IP地址,使用su命令,并输入“root”用户的登录密码切换到“root”用户,在命令行模式下,运行ps -ef |grep ccdb_server,查看CCDB进程是否异常。

      • 是 => 2
      • 否 => 请联系技术支持工程师。

    2. 重新启动CCDB进程。

      1. 在命令行模式下,执行/opt/huawei/deploy/bin/daemon -s /opt/huawei/snas_cluster/bin/ccdb_server命令,终止CCDB进程。
      2. 执行命令/opt/huawei/deploy/bin/daemon /opt/huawei/snas_cluster/bin/ccdb_server,重新启动CCDB进程。

    3. 重新创建复制区域通道,查看是否成功。

      • 是 => 故障排除。
      • 否 => 原因10

  • 原因10:本端与远端的软件版本不一致。
    1. 请与系统管理员确认,老版本的集群是否可升级到新版本。

      • 是 => 2
      • 否 => 3

    2. 将老版本的集群升级为新版本,确保本端集群与远端集群的软件版本一致后,重新创建复制区域通道,查看是否创建成功。

      • 是 => 故障排除。
      • 否 => 请联系技术支持工程师。

    3. 在新版本的集群中,确认网络环境安全后,参见《远程复制可测试性与维护性手册》,将复制链路鉴权开关关闭。然后重新创建复制区域通道,查看是否创建成功。

      • 是 => 故障排除。
      • 否 => 请联系技术支持工程师。

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更新时间:2018-10-27

文档编号:EDOC1000095849

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