所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

E600 V200R010C00 配置指南-IP组播

本文档介绍如何配置IP组播功能,主要包括IGMP/MLD Snooping配置、静态组播MAC地址配置、组播VLAN配置、可控组播配置、组播网管配置。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置MLD Snooping示例

配置MLD Snooping示例

组网需求

图2-6所示为一个IPv6组播网络,路由器Router通过二层设备Switch连接用户网络。组播源Source向组播组FF16::1~FF16::5发送数据,网络中有HostA、HostB、HostC三个接收者,他们只对FF16::1~FF16::3的数据感兴趣。

图2-6  配置MLD Snooping组网图

配置思路

在二层设备上配置MLD Snooping基本功能以及组播组过滤策略,可以实现此需求。

  1. Switch上创建VLAN并将接口加入VLAN。
  2. 使能全局和VLAN的MLD Snooping功能。
  3. 配置组播组过滤策略,并在VLAN内应用此策略。

操作步骤

  1. 创建VLAN,配置接口加入VLAN。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan 10
    [Switch-vlan10] quit
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type hybrid
    [Switch-GigabitEthernet0/0/1] port hybrid pvid vlan 10
    [Switch-GigabitEthernet0/0/1] port hybrid untagged vlan 10
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type hybrid
    [Switch-GigabitEthernet0/0/2] port hybrid pvid vlan 10
    [Switch-GigabitEthernet0/0/2] port hybrid untagged vlan 10
    [Switch-GigabitEthernet0/0/2] quit
    [Switch] interface gigabitethernet 0/0/3
    [Switch-GigabitEthernet0/0/3] port link-type hybrid
    [Switch-GigabitEthernet0/0/3] port hybrid pvid vlan 10
    [Switch-GigabitEthernet0/0/3] port hybrid untagged vlan 10
    [Switch-GigabitEthernet0/0/3] quit

  2. 使能MLD Snooping功能。

    # 使能全局的MLD Snooping功能。

    [Switch] mld-snooping enable

    # 使能VLAN10的MLD Snooping功能。

    [Switch] vlan 10
    [Switch-vlan10] mld-snooping enable
    [Switch-vlan10] quit
    说明:

    配置完成后,Switch就可以通过侦听MLD协议报文生成二层组播转发表项。确保Switch与上游三层设备Router的普遍组查询间隔保持一致,以防止Switch的二层组播转发表项被错误老化,导致组播流量不通。如果Switch默认的普遍组查询间隔与Router不一致,可在VLAN10内执行命令mld-snooping query-interval query-interval进行调整。

  3. 配置并应用组播组过滤策略。

    # 配置组播组过滤策略。

    [Switch] acl ipv6 2000
    [Switch-acl6-basic-2000] rule permit source ff16::1 128
    [Switch-acl6-basic-2000] rule permit source ff16::2 128
    [Switch-acl6-basic-2000] rule permit source ff16::3 128
    [Switch-acl6-basic-2000] quit

    # 在VLAN10内应用组播组过滤策略。

    [Switch] vlan 10
    [Switch-vlan10] mld-snooping group-policy 2000
    [Switch-vlan10] quit

  4. 验证配置结果。

    # 查看Switch上的端口信息。

    [Switch] display mld-snooping port-info vlan 10
    --------------------------------------------------------------------------------
                                 (Source, Group)  Port                          Flag
                                 Flag: S:Static    D:Dynamic
    --------------------------------------------------------------------------------
    VLAN 10, 3 Entry(s)                                                           
                         (*, ff16:0:0:0:0:0:0:1)  GE0/0/1                      -D-
                                                  GE0/0/2                      -D-
                                                              2 port(s)
                         (*, ff16:0:0:0:0:0:0:2)  GE0/0/1                      -D-
                                                  GE0/0/2                      -D-
                                                              2 port(s)
                         (*, ff16:0:0:0:0:0:0:3)  GE0/0/1                      -D-
                                                  GE0/0/2                      -D-
                                                              2 port(s)
    --------------------------------------------------------------------------------

    由显示信息可知,组FF16::1~FF16::3已在Switch上动态生成的成员端口为GE0/0/1和GE0/0/2。

    # 查看Switch上二层组播转发表。

    [Switch] display mld-snooping forwarding-table vlan 10
    VLAN ID : 10, Forwarding Mode : IP                                      
    ------------------------------------------------------------------------
                         (Source, Group)    Interface               Out-Vlan
    ----------------------------------------------------------------------     
                             Router-port    GigabitEthernet0/0/3       10
                   (*, ff16:0:0:0:0:0:0:1)  GigabitEthernet0/0/3       10
                                            GigabitEthernet0/0/1       10
                                            GigabitEthernet0/0/2       10
                   (*, ff16:0:0:0:0:0:0:2)  GigabitEthernet0/0/3       10
                                            GigabitEthernet0/0/1       10
                                            GigabitEthernet0/0/2       10
                   (*, ff16:0:0:0:0:0:0:3)  GigabitEthernet0/0/3       10
                                            GigabitEthernet0/0/1       10
                                            GigabitEthernet0/0/2       10
    ------------------------------------------------------------------------
    Total Group(s) : 3

    由显示信息可知,转发表中只有FF16::1~FF16::3的组播数据。FF16::4~FF16::5的数据不会转发给Host。

配置文件

  • Switch的配置文件

    #
    sysname Switch
    #
    vlan batch 10
    #
    mld-snooping enable
    #
    acl ipv6 number 2000
     rule 0 permit source FF16::1/128 
     rule 1 permit source FF16::2/128  
     rule 2 permit source FF16::3/128  
    #
    vlan 10
     mld-snooping enable
     mld-snooping group-policy 2000
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet0/0/3
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    return
下载文档
更新时间:2018-10-24

文档编号:EDOC1000141355

浏览量:7033

下载量:31

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页