所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

E600 V200R010C00 配置指南-IP组播

本文档介绍如何配置IP组播功能,主要包括IGMP/MLD Snooping配置、静态组播MAC地址配置、组播VLAN配置、可控组播配置、组播网管配置。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置可控组播示例

配置可控组播示例

组网需求

图5-3所示,路由器连接的网络上有组播组G1(225.0.0.1)、G2(225.0.0.2)、G3(225.0.0.3)和G4(225.0.0.4)。现在控制VlAN10和VLAN20的用户只能观看G1和G2;VlAN30和VlAN40的用户可观看所有的组播组。

说明:

这里介绍IPv4网络中可控组播的配置示例。IPv6网络的配置示例和IPv4的配置示例类似,只需将配置IGMP Snooping换成配置MLD Snooping即可。

图5-3  可控组播组网图

配置思路

在Switch上配置可控组播,可实现此需求。配置思路如下:

  1. 配置IGMP Snooping。
  2. 配置可控组播。
    • 配置两个组播列表L1(G1, G2)和L2(G3,G4)。
    • 配置两个模板P1和P2。

操作步骤

  1. 配置用户VLAN,并将接口加入用户VLAN。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 10 20 30 40
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type hybrid
    [Switch-GigabitEthernet0/0/1] port hybrid untagged vlan 10
    [Switch-GigabitEthernet0/0/1] port hybrid pvid vlan 10
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type hybrid
    [Switch-GigabitEthernet0/0/2] port hybrid untagged vlan 20
    [Switch-GigabitEthernet0/0/2] port hybrid pvid vlan 20
    [Switch-GigabitEthernet0/0/2] quit
    [Switch] interface gigabitethernet 0/0/3
    [Switch-GigabitEthernet0/0/3] port link-type hybrid
    [Switch-GigabitEthernet0/0/3] port hybrid untagged vlan 30
    [Switch-GigabitEthernet0/0/3] port hybrid pvid vlan 30
    [Switch-GigabitEthernet0/0/3] quit
    [Switch] interface gigabitethernet 0/0/4
    [Switch-GigabitEthernet0/0/4] port link-type hybrid
    [Switch-GigabitEthernet0/0/4] port hybrid untagged vlan 40
    [Switch-GigabitEthernet0/0/4] port hybrid pvid vlan 40
    [Switch-GigabitEthernet0/0/4] quit
    

  2. 配置IGMP Snooping。

    [Switch] igmp-snooping enable
    [Switch] vlan 10
    [Switch-vlan10] igmp-snooping enable
    [Switch-vlan10] quit
    [Switch] vlan 20
    [Switch-vlan20] igmp-snooping enable
    [Switch-vlan20] quit
    [Switch] vlan 30
    [Switch-vlan30] igmp-snooping enable
    [Switch-vlan30] quit
    [Switch] vlan 40
    [Switch-vlan40] igmp-snooping enable
    [Switch-vlan40] quit
    

  3. 配置可控组播。

    # 配置组播组。

    [Switch] btv
    [Switch-btv] multicast-group g1 ip-address 225.0.0.1
    [Switch-btv] multicast-group g2 ip-address 225.0.0.2
    [Switch-btv] multicast-group g3 ip-address 225.0.0.3
    [Switch-btv] multicast-group g4 ip-address 225.0.0.4

    # 配置组播组列表。

    [Switch-btv] multicast-list l1
    [Switch-btv-list-l1] add multicast-group name g1
    [Switch-btv-list-l1] add multicast-group name g2
    [Switch-btv-list-l1] quit
    [Switch-btv] multicast-list l2
    [Switch-btv-list-l2] add multicast-group name g3
    [Switch-btv-list-l2] add multicast-group name g4
    [Switch-btv-list-l2] quit

    # 配置组播模板。

    [Switch-btv] multicast-profile p1
    [Switch-btv-profile-p1] add multicast-list name l1 watch
    [Switch-btv-profile-p1] quit
    [Switch-btv] multicast-profile p2
    [Switch-btv-profile-p2] add multicast-list name l1 watch
    [Switch-btv-profile-p2] add multicast-list name l2 watch
    [Switch-btv-profile-p2] quit
    [Switch-btv] quit

    # 在VLAN下应用组播模板。

    [Switch] vlan 10
    [Switch-vlan10] attach multicast-profile p1
    [Switch-vlan10] quit
    [Switch] vlan 20
    [Switch-vlan20] attach multicast-profile p1
    [Switch-vlan20] quit
    [Switch] vlan 30
    [Switch-vlan30] attach multicast-profile p2
    [Switch-vlan30] quit
    [Switch] vlan 40
    [Switch-vlan40] attach multicast-profile p2
    [Switch-vlan40] quit

  4. 验证配置结果。

    [Switch] display multicast-profile-apply
    ------------------------------------------------------------------------------- 
      Vlan-id  Port                      SMAC                            Max-Users
                           Index               Profile-name
    ------------------------------------------------------------------------------- 
      Vlan10    --                        --                                 8       
                             1                   p1
      Vlan20    --                        --                                 8       
                             1                   p1
      Vlan30    --                        --                                 8       
                             2                   p2
      Vlan40    --                        --                                 8       
                             2                   p2
    
      Total: 4
    
    [Switch] display multicast-profile
     -----------------------------------------------------------------------------  
     Index        Profile-Name                    Multicast-list  Attach-User       
     -----------------------------------------------------------------------------  
      1              p1                               1               2
      2              p2                               2               2
    
     Total: 2  
    
    [Switch] display multicast-list
     -------------------------------------------------------------------------      
     Index        Multicast-list-name             Multicast-group                   
     -------------------------------------------------------------------------      
      1             l1                                     2                        
      2             l2                                     2                        
    
     Total: 2
    
    [Switch] display multicast-group 
    -------------------------------------------------------------------------      
     Index        Multicast-group-name              Address                         
     -------------------------------------------------------------------------      
      1           g1                               225.0.0.1              
      2           g2                               225.0.0.2              
      3           g3                               225.0.0.3              
      4           g4                               225.0.0.4              
    
     Total: 4

配置文件

  • Switch的配置文件

    #
    sysname Switch
    # 
    vlan batch 10 20 30 40
    #
    igmp-snooping enable
    #
    btv
     multicast-group g1 ip-address 225.0.0.1
     multicast-group g2 ip-address 225.0.0.2
     multicast-group g3 ip-address 225.0.0.3
     multicast-group g4 ip-address 225.0.0.4
     multicast-list l1
      add multicast-group name g2
      add multicast-group name g1
     multicast-list l2
      add multicast-group name g4
      add multicast-group name g3
     multicast-profile p1
      add multicast-list name l1 watch
     multicast-profile p2
      add multicast-list name l1 watch
      add multicast-list name l2 watch
    #
    vlan 10
     igmp-snooping enable 
     attach multicast-profile p1
    vlan 20
     igmp-snooping enable 
     attach multicast-profile p1
    vlan 30
     igmp-snooping enable 
     attach multicast-profile p2
    vlan 40
     igmp-snooping enable 
     attach multicast-profile p2 
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid pvid vlan 20
     port hybrid untagged vlan 20
    #
    interface GigabitEthernet0/0/3
     port link-type hybrid
     port hybrid pvid vlan 30
     port hybrid untagged vlan 30
    #
    interface GigabitEthernet0/0/4
     port link-type hybrid
     port hybrid pvid vlan 40
     port hybrid untagged vlan 40
    #
    return
下载文档
更新时间:2018-10-24

文档编号:EDOC1000141355

浏览量:6883

下载量:31

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页