所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

E600 V200R010C00 配置指南-IP组播

本文档介绍如何配置IP组播功能,主要包括IGMP/MLD Snooping配置、静态组播MAC地址配置、组播VLAN配置、可控组播配置、组播网管配置。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置IGMP Snooping SSM Mapping功能示例

配置IGMP Snooping SSM Mapping功能示例

组网需求

图1-11所示组播网络中,路由器Router通过二层设备Switch连接用户网络。Router上运行IGMPv3版本,同时采用ASM和SSM模式提供组播服务。网络中用户主机HostA、HostB、HostC的IGMP版本为IGMPv2,不能升级到IGMPv3。组播源Source1和Source2同时往组播组225.1.1.1发送组播数据,用户主机只想接收Source1发送的数据。

图1-11  配置IGMP Snooping SSM Mapping功能组网图

配置思路

Switch上配置IGMP Snooping SSM Mapping功能,可以实现此需求。

  1. Switch上创建VLAN,配置接口加入VLAN。

  2. 使能全局和VLAN的IGMP Snooping功能,实现用户接收组播数据。

  3. 配置IGMP Snooping的SSM组策略,实现用户所在的ASM类型组播组地址加入到SSM组地址范围内。

  4. 配置IGMP Snooping SSM Mapping功能,实现用户接收指定组播源数据。

操作步骤

  1. 创建VLAN,配置接口加入VLAN。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan 10
    [Switch-vlan10] quit
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type hybrid
    [Switch-GigabitEthernet0/0/1] port hybrid pvid vlan 10
    [Switch-GigabitEthernet0/0/1] port hybrid untagged vlan 10
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/3
    [Switch-GigabitEthernet0/0/3] port link-type hybrid
    [Switch-GigabitEthernet0/0/3] port hybrid pvid vlan 10
    [Switch-GigabitEthernet0/0/3] port hybrid untagged vlan 10
    [Switch-GigabitEthernet0/0/3] quit

  2. 使能IGMP Snooping功能。

    # 使能全局的IGMP Snooping功能。

    [Switch] igmp-snooping enable

    # 使能VLAN10的IGMP Snooping功能。

    [Switch] vlan 10
    [Switch-vlan10] igmp-snooping enable
    [Switch-vlan10] quit

  3. 配置IGMP Snooping的SSM组策略。

    # 创建ACL,配置其规则为允许组225.1.1.1的数据通过。

    [Switch] acl number 2008
    [Switch-acl-basic-2008] rule 5 permit source 225.1.1.1 0
    [Switch-acl-basic-2008] quit
    

    # 在VLAN下应用SSM Mapping策略,将组225.1.1.1作为SSM范围的组地址对待。

    [Switch] vlan 10 
    [Switch-vlan10] igmp-snooping ssm-policy 2008
    

  4. 配置SSM Mapping功能。

    # 配置Switch上运行IGMPv3版本,使能SSM Mapping功能,并配置映射关系为组225.1.1.1对应的源地址为10.10.1.1。

    [Switch-vlan10] igmp-snooping version 3
    [Switch-vlan10] igmp-snooping ssm-mapping enable 
    [Switch-vlan10] igmp-snooping ssm-mapping 225.1.1.1 32 10.10.1.1
    [Switch-vlan10] quit

  5. 验证配置结果。

    # 查看VLAN内IGMP Snooping的配置情况。

    [Switch] display igmp-snooping vlan configuration
     IGMP Snooping Configuration for VLAN 10
         igmp-snooping enable
         igmp-snooping version 3
         igmp-snooping ssm-mapping enable
         igmp-snooping ssm-policy 2008
         igmp-snooping ssm-mapping 225.1.1.1 255.255.255.255 10.10.1.1

    可见VLAN10内已配置了SSM Mapping策略。

    # 查看二层组播转发表。

    [Switch] display l2-multicast forwarding-table vlan 10 
    VLAN ID : 10, Forwarding Mode : IP  
    Total Group(s) : 1                                        
    ----------------------------------------------------------------------------
                         (Source, Group)    Interface                   Out-Vlan
    ----------------------------------------------------------------------------
                            Router-port     GigabitEthernet0/0/3           10
                 (10.10.1.1, 225.1.1.1)     GigabitEthernet0/0/1           10
                                            GigabitEthernet0/0/3           10
    ----------------------------------------------------------------------------
    

    由显示信息可知,Switch上生成(10.10.1.1, 225.1.1.1)表项,是Source1发送的数据。

配置文件

  • Switch的配置文件

    #
    sysname Switch
    #
    vlan batch 10
    #
    igmp-snooping enable
    #
    acl number 2008
     rule 5 permit source 225.1.1.1 0
    #
    vlan 10
     igmp-snooping enable
     igmp-snooping ssm-mapping enable
     igmp-snooping version 3
     igmp-snooping ssm-policy 2008
     igmp-snooping ssm-mapping 225.1.1.1 255.255.255.255 10.10.1.1
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet0/0/3
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10 
    #
    return 
下载文档
更新时间:2018-10-24

文档编号:EDOC1000141355

浏览量:7024

下载量:31

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页