所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

E600 V200R010C00 配置指南-IP组播

本文档介绍如何配置IP组播功能,主要包括IGMP/MLD Snooping配置、静态组播MAC地址配置、组播VLAN配置、可控组播配置、组播网管配置。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置基于用户VLAN的组播VLAN一对多功能示例

配置基于用户VLAN的组播VLAN一对多功能示例

组网需求

图4-4所示,RouterA和SwitchA之间用于传输组播数据的业务VLAN为VLAN 10,而下游用户主机HostA、HostB和HostC分别属于VLAN 100、VLAN 200和VLAN 300,并且都需要接收组播Source的组播数据。

要求通过配置基于用户VLAN的组播VLAN一对多功能,对于不同用户主机多份相同的组播需求,RouterA只需要向VLAN 10发送一份组播数据,减少RouterA与SwitchA之间的带宽浪费。

图4-4  配置基于用户VLAN的组播VLAN一对多功能组网图

配置思路

采用如下的思路配置基于用户VLAN的组播VLAN一对多功能:

  1. 在系统视图下使能IGMP Snooping。
  2. 创建用户VLAN,并在用户VLAN下使能IGMP Snooping。
  3. 创建组播VLAN,并在组播VLAN下使能IGMP Snooping。
  4. 在组播VLAN下面绑定用户VLAN。
  5. 将接口分别以Hybrid方式加入VLAN。

操作步骤

  1. 在系统视图下使能IGMP Snooping。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] igmp-snooping enable
    

  2. 创建用户VLAN,并在用户VLAN下使能IGMP Snooping功能。

    [SwitchA] vlan 100
    [SwitchA-vlan100] igmp-snooping enable
    [SwitchA-vlan100] quit
    [SwitchA] vlan 200
    [SwitchA-vlan200] igmp-snooping enable
    [SwitchA-vlan200] quit
    [SwitchA] vlan 300
    [SwitchA-vlan300] igmp-snooping enable
    [SwitchA-vlan300] quit
    

  3. 创建组播VLAN,并在组播VLAN下使能IGMP Snooping功能和IGMP Snooping查询器功能。

    说明:
    建议在组播VLAN视图下配置igmp-snooping querier enable。如果上游RouterA作为网关,使能了IGMP功能,就可以不用配置igmp-snooping querier enable命令。
    [SwitchA] vlan 10
    [SwitchA-vlan10] igmp-snooping enable
    [SwitchA-vlan10] igmp-snooping querier enable
    [SwitchA-vlan10] multicast-vlan enable
    

  4. 在组播VLAN10下面绑定用户VLAN 100、VLAN 200和VLAN 300。

    [SwitchA-vlan10] multicast-vlan user-vlan 100 200 300
    [SwitchA-vlan10] quit

  5. 把接口以Hybrid方式加入VLAN。

    # 把GE0/0/1接口加入组播VLAN 10。

    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type hybrid
    [SwitchA-GigabitEthernet0/0/1] port hybrid pvid vlan 10
    [SwitchA-GigabitEthernet0/0/1] port hybrid untagged vlan 10 
    [SwitchA-GigabitEthernet0/0/1] quit

    # 把GE0/0/2GE0/0/3GE0/0/4接口分别加入用户VLAN 100、VLAN 200、VLAN 300。

    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type hybrid
    [SwitchA-GigabitEthernet0/0/2] port hybrid pvid vlan 100
    [SwitchA-GigabitEthernet0/0/2] port hybrid untagged vlan 100
    [SwitchA-GigabitEthernet0/0/2] quit
    [SwitchA] interface gigabitethernet 0/0/3
    [SwitchA-GigabitEthernet0/0/3] port link-type hybrid
    [SwitchA-GigabitEthernet0/0/3] port hybrid pvid vlan 200
    [SwitchA-GigabitEthernet0/0/3] port hybrid untagged vlan 200
    [SwitchA-GigabitEthernet0/0/3] quit
    [SwitchA] interface gigabitethernet 0/0/4
    [SwitchA-GigabitEthernet0/0/4] port link-type hybrid
    [SwitchA-GigabitEthernet0/0/4] port hybrid pvid vlan 300
    [SwitchA-GigabitEthernet0/0/4] port hybrid untagged vlan 300
    [SwitchA-GigabitEthernet0/0/4] quit

  6. 验证配置结果,在SwitchA可以查看到组播VLAN和用户VLAN的信息。

    [SwitchA] display multicast-vlan vlan
    Total multicast vlan   1                                                       
     multicast-vlan     user-vlan number     snooping-state                         
     ----------------------------------------------------------------               
     10                 3                    IGMP Enable/MLD Disable 
    [SwitchA] display user-vlan vlan                                       
     Total user vlan   3                                                            
     user-vlan  snooping-state            multicast-vlan  snooping-state            
     -----------------------------------------------------------------------------  
     100        IGMP Enable/MLD Disable  10               IGMP Enable/MLD Disable
     200        IGMP Enable/MLD Disable  10               IGMP Enable/MLD Disable
     300        IGMP Enable/MLD Disable  10               IGMP Enable/MLD Disable

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10 100 200 300
    #
    igmp-snooping enable
    #
    vlan 10
     igmp-snooping enable
     igmp-snooping querier enable
     multicast-vlan enable
     multicast-vlan user-vlan 100 200 300 
    vlan 100
     igmp-snooping enable
    vlan 200
     igmp-snooping enable
    vlan 300
     igmp-snooping enable
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    interface GigabitEthernet0/0/3
     port link-type hybrid
     port hybrid pvid vlan 200
     port hybrid untagged vlan 200
    #
    interface GigabitEthernet0/0/4
     port link-type hybrid
     port hybrid pvid vlan 300
     port hybrid untagged vlan 300
    #
    return
    
下载文档
更新时间:2018-10-24

文档编号:EDOC1000141355

浏览量:6917

下载量:31

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页