所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

E600 V200R010C00 配置指南-IP组播

本文档介绍如何配置IP组播功能,主要包括IGMP/MLD Snooping配置、静态组播MAC地址配置、组播VLAN配置、可控组播配置、组播网管配置。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置基于接口的组播VLAN功能示例

配置基于接口的组播VLAN功能示例

组网需求

在如图4-6所示的网络中,SwitchA上的GE0/0/1接口连接路由器,GE0/0/2GE0/0/3接口下的业务分别批发给ISP1和ISP2,ISP1和ISP2分别通过组播VLAN 2和组播VLAN 3传输组播数据。GE0/0/2GE0/0/3接口下用户VLAN重复,都为VLAN 10。

为了防止不同ISP的组播报文会发送到不属于此ISP的用户,影响到ISP的利益,要求通过基于接口的组播VLAN功能,指定属于本ISP的组播数据只转发到连接本ISP用户的接口。

图4-6  配置基于接口的组播VLAN功能组网图

配置思路

采用如下的思路配置基于接口组播VLAN功能:

  1. 在系统视图下使能IGMP Snooping功能。
  2. 创建用户VLAN 10。
  3. 创建组播VLAN 2和组播VLAN 3,并在组播VLAN下使能IGMP Snooping。
  4. GE0/0/2接口和GE0/0/3接口下对组播VLAN和用户VLAN分别进行绑定。
  5. 将接口分别以Hybrid方式加入VLAN。

操作步骤

  1. 创建用户VLAN 10。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10

  2. 配置组播VLAN 2和组播VLAN 3,并在组播VLAN下使能IGMP Snooping功能和IGMP Snooping查询器功能。

    说明:
    建议在组播VLAN视图下配置igmp-snooping querier enable。如果上游Router作为网关,使能了IGMP功能,就可以不用配置igmp-snooping querier enable命令。
    [SwitchA] igmp-snooping enable
    [SwitchA] vlan 2
    [SwitchA-vlan2] igmp-snooping enable
    [SwitchA-vlan2] igmp-snooping querier enable
    [SwitchA-vlan2] quit
    [SwitchA] vlan 3
    [SwitchA-vlan3] igmp-snooping enable
    [SwitchA-vlan3] igmp-snooping querier enable
    [SwitchA-vlan3] quit

  3. GE0/0/2接口和GE0/0/3接口下分别对组播VLAN和用户VLAN进行绑定。

    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] l2-multicast-bind vlan 10 mvlan 2
    [SwitchA-GigabitEthernet0/0/2] quit
    [SwitchA] interface gigabitethernet 0/0/3
    [SwitchA-GigabitEthernet0/0/3] l2-multicast-bind vlan 10 mvlan 3
    [SwitchA-GigabitEthernet0/0/3] quit

  4. GE0/0/1接口加入组播VLAN,将GE0/0/2GE0/0/3加入用户VLAN。

    # 以Trunk方式把GE0/0/1加入组播VLAN 2和组播VLAN 3。

    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 2 3 
    [SwitchA-GigabitEthernet0/0/1] quit

    # 把GE0/0/2GE0/0/3接口分别以Hybrid方式加入用户VLAN 10。

    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type hybrid
    [SwitchA-GigabitEthernet0/0/2] port hybrid pvid vlan 10
    [SwitchA-GigabitEthernet0/0/2] port hybrid untagged vlan 10 
    [SwitchA-GigabitEthernet0/0/2] quit
    [SwitchA] interface gigabitethernet 0/0/3
    [SwitchA-GigabitEthernet0/0/3] port link-type hybrid
    [SwitchA-GigabitEthernet0/0/3] port hybrid pvid vlan 10
    [SwitchA-GigabitEthernet0/0/3] port hybrid untagged vlan 10 
    [SwitchA-GigabitEthernet0/0/3] quit

  5. 验证配置结果。

    SwitchA上是使用display l2-multicast-bind命令查看接口下用户VLAN与组播VLAN的绑定信息。

    [SwitchA] display l2-multicast-bind
     -------------------------------------------------------------------            
     Port                          Startvlan        Endvlan        Mvlan            
     -------------------------------------------------------------------            
     GigabitEthernet0/0/2                 10             --            2            
     GigabitEthernet0/0/3                 10             --            3            
     -------------------------------------------------------------------            
     Total Table(s) : 2

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 2 to 3 10
    #
    igmp-snooping enable
    #
    vlan 2
     igmp-snooping enable
     igmp-snooping querier enable
    vlan 3
     igmp-snooping enable
     igmp-snooping querier enable
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 3
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
     l2-multicast-bind vlan 10 mvlan 2
    #
    interface GigabitEthernet0/0/3
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
     l2-multicast-bind vlan 10 mvlan 3
    #
    return
    
下载文档
更新时间:2018-10-24

文档编号:EDOC1000141355

浏览量:6938

下载量:31

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页