所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

E600 V200R010C00 配置指南-IP组播

本文档介绍如何配置IP组播功能,主要包括IGMP/MLD Snooping配置、静态组播MAC地址配置、组播VLAN配置、可控组播配置、组播网管配置。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置基于用户VLAN的组播VLAN多对多功能示例

配置基于用户VLAN的组播VLAN多对多功能示例

组网需求

图4-5所示,交换机通过GE0/0/1接口和RouterA相连,通过GE0/0/2接口和RouterB相连,通过GE0/0/3连接用户主机;组播源S1、S2为不同ISP提供的组播源。

要求通过配置基于用户VLAN的组播VLAN多对多功能,用不同的组播VLAN标识不同的ISP,并且用户主机能够同时接收S1发往组播组225.1.1.1、S2发往组播组225.1.2.1的组播数据。

图4-5  配置基于用户VLAN的组播VLAN多对多组网图

配置思路

采用如下的思路配置基于用户VLAN的组播VLAN多对多:

  1. 在系统视图下使能IGMP Snooping。
  2. 创建用户VLAN,并在用户VLAN下使能IGMP Snooping,并在用户VLAN下使能组播流触发功能。
  3. 创建组播VLAN,并在组播VLAN下使能IGMP Snooping。
  4. 用户VLAN加入多个组播VLAN,并且在组播VLAN下配置静态组播流。
  5. 将接口分别以Hybrid方式加入VLAN。

操作步骤

  1. 在系统视图下使能IGMP Snooping。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] igmp-snooping enable
    

  2. 创建用户VLAN100,在用户VLAN下使能IGMP Snooping功能,并在用户VLAN下使能组播流触发功能。

    [Switch] vlan 100
    [Switch-vlan100] igmp-snooping enable
    [Switch-vlan100] multicast flow-trigger enable
    [Switch-vlan100] quit

  3. 创建组播VLAN10和组播VLAN20,并在组播VLAN下使能IGMP Snooping功能和IGMP Snooping查询器功能。

    说明:
    建议在组播VLAN视图下配置igmp-snooping querier enable。如果上游RouterA和RouterB作为网关,都使能了IGMP功能,就可以不用配置igmp-snooping querier enable命令。
    [Switch] vlan 10
    [Switch-vlan10] igmp-snooping enable
    [Switch-vlan10] igmp-snooping querier enable
    [Switch-vlan10] multicast-vlan enable
    [Switch-vlan10] quit
    [Switch] vlan 20
    [Switch-vlan20] igmp-snooping enable
    [Switch-vlan20] igmp-snooping querier enable
    [Switch-vlan20] multicast-vlan enable
    [Switch-vlan20] quit

  4. 用户VLAN100加入组播VLAN10和组播VLAN20,并且在组播VLAN下配置静态组播流。

    [Switch] vlan 10
    [Switch-vlan10] multicast-vlan user-vlan 100
    [Switch-vlan10] multicast static-flow 225.1.1.1
    [Switch-vlan10] quit
    [Switch] vlan 20
    [Switch-vlan20] multicast-vlan user-vlan 100
    [Switch-vlan20] multicast static-flow 225.1.2.1
    [Switch-vlan20] quit

  5. 把接口以Hybrid方式加入VLAN。

    # 把GE0/0/1接口加入组播VLAN10,GE0/0/2接口加入组播VLAN20。

    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type hybrid
    [Switch-GigabitEthernet0/0/1] port hybrid pvid vlan 10
    [Switch-GigabitEthernet0/0/1] port hybrid untagged vlan 10 
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type hybrid
    [Switch-GigabitEthernet0/0/2] port hybrid pvid vlan 20
    [Switch-GigabitEthernet0/0/2] port hybrid untagged vlan 20 
    [Switch-GigabitEthernet0/0/2] quit

    # 把GE0/0/3接口加入用户VLAN100。

    [Switch] interface gigabitethernet 0/0/3
    [Switch-GigabitEthernet0/0/3] port link-type hybrid
    [Switch-GigabitEthernet0/0/3] port hybrid pvid vlan 100
    [Switch-GigabitEthernet0/0/3] port hybrid untagged vlan 100 
    [Switch-GigabitEthernet0/0/3] quit

  6. 验证配置结果

    # 在Switch使用display user-vlan vlan命令可以查看到用户VLAN同时就加入到了组播VLAN10和组播VLAN20。

    [Switch] display user-vlan vlan                                       
     Total user vlan   2                                                            
     user-vlan  snooping-state            multicast-vlan  snooping-state            
     -----------------------------------------------------------------------------  
     100        IGMP Enable/MLD Disable   10              IGMP Enable/MLD Disable  
     100        IGMP Enable/MLD Disable   20              IGMP Enable/MLD Disable 

    # 使用display multicast static-flow命令可以查看到组播VLAN下面配置的组播静态流信息,说明用户VLAN下用户可以加入指定的组播组。

    [Switch] display multicast static-flow                                       
     -------------------------------------------------------------------            
     Vlan                                        (Source, Group)                    
     -------------------------------------------------------------------            
      10                                          (*, 225.1.1.1)                    
      20                                          (*, 225.1.2.1)                    
     -------------------------------------------------------------------            
     Total Table(s) : 2                                                  

配置文件

  • Switch的配置文件

    #
    sysname Switch
    #
    vlan batch 10 20 100
    #
    igmp-snooping enable
    #
    vlan 10
     igmp-snooping enable
     igmp-snooping querier enable
     multicast-vlan enable
     multicast static-flow 225.1.1.1
     multicast-vlan user-vlan 100 
    vlan 20
     igmp-snooping enable
     igmp-snooping querier enable
     multicast-vlan enable
     multicast static-flow 225.1.2.1
     multicast-vlan user-vlan 100 
    vlan 100
     multicast flow-trigger enable
     igmp-snooping enable
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid pvid vlan 20
     port hybrid untagged vlan 20
    #
    interface GigabitEthernet0/0/3
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    return
    
下载文档
更新时间:2018-10-24

文档编号:EDOC1000141355

浏览量:6951

下载量:31

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页