所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

E600 V200R010C00 配置指南-IP组播

本文档介绍如何配置IP组播功能,主要包括IGMP/MLD Snooping配置、静态组播MAC地址配置、组播VLAN配置、可控组播配置、组播网管配置。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置MLD Snooping响应网络拓扑变化示例

配置MLD Snooping响应网络拓扑变化示例

组网需求

在如图2-11所示的IPv6组播网络中,为提高网络可靠性,4台交换机依次连接成环网。为消除环路,在4台交换机上运行STP。HostA和HostB需要接收组播源发出的组播数据。

图2-11  配置MLD Snooping响应二层网络拓扑变化事件示例组网图

配置思路

Switch上启用MLD Snooping,并配置MLD Snooping响应二层网络拓扑变化事件。
  1. 在所有Switch上配置STP。
  2. 在所有Switch上创建VLAN10,并配置接口加入VLAN10。
  3. 使能所有Switch全局和VLAN的MLD Snooping功能。
  4. 配置SwitchA的MLD Snooping响应二层网络拓扑变化事件。

操作步骤

  1. 在所有Switch上配置STP。

    # 配置SwitchA的STP。SwitchB、SwitchC和SwitchD的配置与SwitchA类似,配置过程略。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] stp enable
    

  2. 在所有Switch上创建VLAN10,并配置接口加入VLAN10。

    # 配置SwitchA的接口加入VLAN10。SwitchB、SwitchC和SwitchD的配置与SwitchA类似,配置过程略。

    [SwitchA] vlan 10
    [SwitchA-vlan10] quit
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type hybrid
    [SwitchA-GigabitEthernet0/0/1] port hybrid pvid vlan 10
    [SwitchA-GigabitEthernet0/0/1] port hybrid untagged vlan 10
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type hybrid
    [SwitchA-GigabitEthernet0/0/2] port hybrid pvid vlan 10
    [SwitchA-GigabitEthernet0/0/2] port hybrid untagged vlan 10
    [SwitchA-GigabitEthernet0/0/2] quit
    [SwitchA] interface gigabitethernet 0/0/3
    [SwitchA-GigabitEthernet0/0/3] port link-type hybrid
    [SwitchA-GigabitEthernet0/0/3] port hybrid pvid vlan 10
    [SwitchA-GigabitEthernet0/0/3] port hybrid untagged vlan 10
    [SwitchA-GigabitEthernet0/0/3] quit

  3. 在所有Switch上使能MLD Snooping功能

    # 使能SwitchA的全局和VLAN10内MLD Snooping功能。SwitchB、SwitchC和SwitchD的配置与SwitchA类似,配置过程略。

    [SwitchA] mld-snooping enable
    [SwitchA] vlan 10
    [SwitchA-vlan10] mld-snooping enable
    [SwitchA-vlan10] quit

  4. 配置SwitchA的MLD Snooping响应二层网络拓扑变化事件。

    [SwitchA] mld-snooping send-query enable
    [SwitchA] mld-snooping send-query source-address fe80::1
    

  5. 验证配置结果。

    1. 检查组播数据转发是否正常。

      SwitchB和SwitchD上查看转发表项。
      [SwitchB] display mld-snooping forwarding-table vlan 10
      VLAN ID : 10, Forwarding Mode : IP                                      
      ------------------------------------------------------------------------
                           (Source, Group)    Interface               Out-Vlan
      ----------------------------------------------------------------------     
                               Router-port    GigabitEthernet0/0/2       10
                     (*, ff16:0:0:0:0:0:0:2)  GigabitEthernet0/0/2       10
                                              GigabitEthernet0/0/3       10
                     (*, ff16:0:0:0:0:0:0:3)  GigabitEthernet0/0/2       10
                                              GigabitEthernet0/0/3       10
                     (*, ff16:0:0:0:0:0:0:6)  GigabitEthernet0/0/2       10
                                              GigabitEthernet0/0/3       10
      ------------------------------------------------------------------------
      Total Group(s) : 3
      [SwitchD] display mld-snooping forwarding-table vlan 10
      VLAN ID : 10, Forwarding Mode : IP                                      
      ------------------------------------------------------------------------
                           (Source, Group)    Interface               Out-Vlan
      ----------------------------------------------------------------------     
                               Router-port    GigabitEthernet0/0/2       10
                     (*, ff16:0:0:0:0:0:0:2)  GigabitEthernet0/0/2       10
                                              GigabitEthernet0/0/3       10
                     (*, ff16:0:0:0:0:0:0:3)  GigabitEthernet0/0/2       10
                                              GigabitEthernet0/0/3       10
                     (*, ff16:0:0:0:0:0:0:6)  GigabitEthernet0/0/2       10
                                              GigabitEthernet0/0/3       10
      ------------------------------------------------------------------------
      Total Group(s) : 3

      可见SwitchB和SwitchD的路由器端口都是GE0/0/2。

      查看SwitchA上的MLD报文统计信息。

      [SwitchA] display mld-snooping statistics
       MLD Snooping Events Counter
           Recv VLAN Up Event Times      0
           Recv VLAN Down Event Times    0
           Recv VLAN Del Event Times     0
           Recv Port Up Event Times      0
           Recv Port Down Event Times    0
           Recv Port Del Event Times     0
           Recv Port Inc Event Times     0
           Recv Port Exc Event Times     0
           Recv MSTP Block Event Times   0
           Recv MSTP Forward Event Times 0
           Recv LINK Change Event Times  0
       MLD Snooping Packets Counter
         Statistics for VLAN 10
           Recv V1 Report  12
           Recv V2 Report  0
           Recv V1 Query   15
           Recv V2 Query   0
           Recv Done       0
           Recv Pim Hello  3
           Send Query(S=0) 0
           Send Query(S!=0)0
           Send General Query               0
           Send Group-Specific Query        0
           Send Group-Source-Specific Query 0

      可见SwitchA没有发送查询报文。

    2. 在所有Switch上使用display stp brief命令,查看哪个接口被阻塞,从而判断组播数据的传送路径。

      发现观察结果是SwitchB的GE0/0/1接口被阻塞。
      [SwitchB] display stp brief
       MSTID  Port                        Role  STP State     Protection              
         0    GigabitEthernet0/0/1        ALTE  DISCARDING    NONE
         0    GigabitEthernet0/0/2        ROOT  FORWARDING      NONE
         0    GigabitEthernet0/0/3        DESI  FORWARDING      NONE
      

      可以判断出,组播数据沿SwitchA→SwitchC→SwitchB到达HostA,沿SwitchA→SwitchD到达HostB。

    3. SwitchC的接口GE0/0/1上执行shutdown命令关闭该接口,使STP网络拓扑发生变化。
    4. 观察网络拓扑发生变化后,HostA和HostB是否仍然能够收到组播数据。

      SwitchB和SwitchD上查看转发表项。
      [SwitchB] display mld-snooping forwarding-table vlan 10
      VLAN ID : 10, Forwarding Mode : IP                                      
      ------------------------------------------------------------------------
                           (Source, Group)    Interface               Out-Vlan
      ----------------------------------------------------------------------     
                               Router-port    GigabitEthernet0/0/1       10
                     (*, ff16:0:0:0:0:0:0:2)  GigabitEthernet0/0/1       10
                                              GigabitEthernet0/0/3       10
                     (*, ff16:0:0:0:0:0:0:3)  GigabitEthernet0/0/1       10
                                              GigabitEthernet0/0/3       10
                     (*, ff16:0:0:0:0:0:0:6)  GigabitEthernet0/0/1       10
                                              GigabitEthernet0/0/3       10
      ------------------------------------------------------------------------
      Total Group(s) : 3
      [SwitchD] display mld-snooping forwarding-table vlan 10
      VLAN ID : 10, Forwarding Mode : IP                                      
      ------------------------------------------------------------------------
                           (Source, Group)    Interface               Out-Vlan
      ----------------------------------------------------------------------     
                               Router-port    GigabitEthernet0/0/2       10
                     (*, ff16:0:0:0:0:0:0:2)  GigabitEthernet0/0/2       10
                                              GigabitEthernet0/0/3       10
                     (*, ff16:0:0:0:0:0:0:3)  GigabitEthernet0/0/2       10
                                              GigabitEthernet0/0/3       10
                     (*, ff16:0:0:0:0:0:0:6)  GigabitEthernet0/0/2       10
                                              GigabitEthernet0/0/3       10
      ------------------------------------------------------------------------
      Total Group(s) : 3

      可见SwitchB的路由器端口已变化为GE0/0/1。

      查看SwitchA的MLD报文统计信息。

      [SwitchA] display mld-snooping statistics
       MLD Snooping Events Counter
           Recv VLAN Up Event Times      0
           Recv VLAN Down Event Times    0
           Recv VLAN Del Event Times     0
           Recv Port Up Event Times      0
           Recv Port Down Event Times    1
           Recv Port Del Event Times     0
           Recv Port Inc Event Times     1
           Recv Port Exc Event Times     2
           Recv MSTP Block Event Times   0
           Recv MSTP Forward Event Times 1
           Recv LINK Change Event Times  70
       MLD Snooping Packets Counter
         Statistics for VLAN 10
           Recv V1 Report 18
           Recv V2 Report 0
           Recv V1 Query  15
           Recv V2 Query  0
           Recv Done      0
           Recv Pim Hello 38
           Send Query(S=0) 8
           Send Query(S!=0)0
           Send General Query               0
           Send Group-Specific Query        0
           Send Group-Source-Specific Query 0

      可见SwitchA已发送源地址为0的查询报文。

配置文件

  • SwitchA的配置文件。

    #
    sysname SwitchA
    #
    vlan batch 10
    #
    stp enable
    #
    mld-snooping enable
    mld-snooping send-query enable
    mld-snooping send-query source-address fe80:0:0:0:0:0:0:1
    #
    vlan 10
     mld-snooping enable
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet0/0/3
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    return
    
  • SwitchB的配置文件。

    #
    sysname SwitchB
    #
    vlan batch 10
    #
    stp enable
    #
    mld-snooping enable
    #
    vlan 10
     mld-snooping enable
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet0/0/3
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    return
    
  • SwitchC的配置文件。

    #
    sysname SwitchC
    #
    vlan batch 10
    #
    stp enable
    #
    mld-snooping enable
    #
    vlan 10
     mld-snooping enable
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    return
    
  • SwitchD的配置文件。

    #
    sysname SwitchD
    #
    vlan batch 10
    #
    stp enable
    #
    mld-snooping enable
    #
    vlan 10
     mld-snooping enable
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet0/0/3
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    return
    
下载文档
更新时间:2018-10-24

文档编号:EDOC1000141355

浏览量:7058

下载量:31

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页